none
How can I set lync 2010 client presence to ignore pc lock?

    Question

  • our users like to set lync presence status to custom at lunch or at court. The problem is that the pc lock/screensaver kicks in after 10 minutes and the presence is set to away. When the user returns the pc becomes active and lync goes back to at lunch or at court. Pretty useless really. The idle, 60 minutes and 360 minutes away settings are superfluous. Does anyone know how to stop the pc lock changing the presence status?
    Monday, June 06, 2011 10:50 AM

Answers

  • You could modify the 'Show me as Away after' setting in the Lync client's Status options to a value greater than these schedule meetings, but then uses will never be marked as away during normal away periods.

    A locked workstation is supposed to indicate that the persons is 'away' as they cannot be reached during that time.  Presence is intended to advertise the user's ability to be contacted on that specific client/device.   It's not meant to show where people currently are located at the time (Lunch, Conference Room, etc).  For that information the users' should just add a comment to their 'What's happening Today' line and then delete it when they return.


    Jeff Schertz, Microsoft Solutions Architect - Polycom | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Monday, June 06, 2011 12:03 PM

All replies

  • You could modify the 'Show me as Away after' setting in the Lync client's Status options to a value greater than these schedule meetings, but then uses will never be marked as away during normal away periods.

    A locked workstation is supposed to indicate that the persons is 'away' as they cannot be reached during that time.  Presence is intended to advertise the user's ability to be contacted on that specific client/device.   It's not meant to show where people currently are located at the time (Lunch, Conference Room, etc).  For that information the users' should just add a comment to their 'What's happening Today' line and then delete it when they return.


    Jeff Schertz, Microsoft Solutions Architect - Polycom | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Monday, June 06, 2011 12:03 PM
  • Hi, Damien,

       Custom presence states can be configured with the Available, Busy, and Do Not Disturb presence indicators. And your status also changes to Away if your screen saver comes on or you lock your computer. As Jeff’s suggestion, at the top of the Lync main window, you can type or paste any kind of note you want, which will appear with your contact card.


    Please remember to click “Mark As Answer” on the post that helps you, and to click “Unmark As Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, June 08, 2011 3:22 AM


  •  

    You could modify the 'Show me as Away after' setting in the Lync client's Status options to a value greater than these schedule meetings, but then uses will never be marked as away during normal away periods.

    A locked workstation is supposed to indicate that the persons is 'away' as they cannot be reached during that time.  Presence is intended to advertise the user's ability to be contacted on that specific client/device.   It's not meant to show where people currently are located at the time (Lunch, Conference Room, etc).  For that information the users' should just add a comment to their 'What's happening Today' line and then delete it when they return.


    Jeff Schertz, Microsoft Solutions Architect - Polycom | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    This doesn't really fit the question or offer a solution. A user should be able to set whether or not the client goes into away mode. I use 3 machine when I am remote. I only use Lync on one of them, if my screen saver kicks in on it, I don't want it to show that I'm away because I'm not, I'm just not at that terminal. And the solution of run it on all 3 systems doesn't make sense either because Lync does not connection share therefore you can have 3 conversations with the same user and they have 3 open windows on their desktop to talk to you. Is there a registry key to disable or change this setting?
    Friday, August 05, 2011 6:41 PM
  • same problem here, different workstations only one lync configured.

    screen lock does not mean you "are away". seems like a major design flaw to me. i hope it is quicly fixed ..

    It's not because there is no mouse or keyboard activity that you cannot answer the phone ...or be notified for incomming messages, etc ... 

    It is realy,realy annoying

    Monday, October 24, 2011 12:30 PM
  • I agree with rudy. It is Design flaw, A solution should not force a behaviour on USER, rather it should embrace and adapt to USER's behaviour. How can Microsoft assumes, when a PC or Laptop is locked, then the USER won't be available to answer?. All it means that Workstation or PC or Laptop is locked. The solution should allow to set any Status that USER prefers to show up when a PC is locked. It is a Design oversight!!!.
    Wednesday, April 11, 2012 5:10 PM
  • I also agree with the posters above.  I see that the moderators have yet to reply since April.  Is there a reason?
    Monday, August 06, 2012 2:42 PM
  • Noya, can you please help with this situation?

    Thanks

    Monday, August 06, 2012 2:43 PM
  • I think you'll find you will be waiting a long time...

    It's been like this in OCS for a while and I've seen threads from years back where users are asking for this capability. The answer is always the same.

    Microsoft has decided (I don't know how) that the app should work this way. They don't see a reason to allow flexibility in the way it can work for different organisations/people.

    To my mind, since it integrates with Exchange it should do more than just display your ooo. The busy and in a meeting status should persist through locking - but they don't and they won't - because Microsoft has decided it will be that way.

    • Proposed as answer by FoaRyan Friday, January 04, 2013 3:49 PM
    Thursday, September 13, 2012 1:26 PM
  • I agree with everyone above.  I use a different machine for Lync so that I can keep working while I am in a video call or something, and my Lync machine constantly shows me as Away, even though I am sitting right there.  Microsoft, please take note!  This is a totally valid use case that many people are using.  A great feature would be a way to force a specific status.
    Friday, October 12, 2012 5:58 PM
  • Typical Microsoft attitude and answer. The "we know best" answer. I dread the fact that we are moving from Lotus Sametime to Lync.
    Wednesday, December 19, 2012 9:01 PM
  • It doesn't work if You put Your custom presence as an "Away"-presence (i.e. Yellow)? It still changes when You lock the computer?

    Haven't tried this myself so I can't swear by it.

    • Proposed as answer by rlbonner Wednesday, March 20, 2013 3:10 PM
    • Unproposed as answer by rlbonner Wednesday, March 20, 2013 3:10 PM
    Thursday, February 21, 2013 10:38 AM
  • Save the following code as a .vbs file and doubleclick it on the box you’re trying to keep alive. Once this script is running, then RDP to another box into a session were the LYNC is opened. This will keep alive. 

    It has no confirmation, so just verify the wscript.exe command is running after you run it.

    It sends an F15 command every few seconds to the box.  There is no "F15", so it does no harm.  It loops around forever so you’ll need to perform an endtask  (the wscript.exe process) when you’re done. This is how i have been able to keep lync from showing "away" when the system is locked.

    Dim WshShell

    Set WshShell = WScript.CreateObject("WScript.Shell")

    Do While True

    WshShell.SendKeys("{F15}")

    WScript.Sleep(55000)

    Loop


    • Edited by rlbonner Wednesday, March 20, 2013 3:22 PM
    • Proposed as answer by rlbonner Wednesday, March 20, 2013 3:25 PM
    Wednesday, March 20, 2013 3:21 PM
  • Did you ever find a solution to this?

    The Scenario at my Company is that we have integration with Exchange/Outlook. Presence is automatically set to Busy (In a Meeting) when they have entries in their calendar. But when the screen lock comes on, the presence is set to Away. Is it possible to avoid this, so that the presence stays at "Busy - In a Meeting" when the screen Lock is activated?

    Thursday, May 16, 2013 12:41 PM
  • Agreed. This is idiotic. I have call center users that fold and file paper between answering calls. And I have an IT security policy required by an auditor that PCs lock in 1 minute of inactivity.

    You can see the obvious issue here, right?

    Wednesday, July 24, 2013 7:44 PM
  • I have a slightly different problem and came here looking for an answer.. *sigh*.. My office is a bit behind the times. We just got Windows 7 and Office 2010.  Since then, everytime I lock my screen, Lync shows me as "out of office" although I currently have no OOO message set in Outlook.  Meetings show correctly, and if I don't use my pc for 5 minutes, it shows away but as soon as I hit the 10 minute mark and my screen locks, or I hit the Windows+L combo to lock it, I'm suddenly Out of the Office.  This causes several problems as people will then call my supervisor and ask things like "when will Sam be back?" when I'm sitting right there, or just ran to the restroom.  HOW can I stop it? "Away" I can deal with "out of office" is NOT cool.
    Tuesday, September 03, 2013 12:30 PM
  • Hi,

    Can you please tell me the steps, I have created the vbs file.

    What do you mean by "doubleclick it on the box you’re trying to keep alive. Once this script is running, then RDP to another box into a session were the LYNC is opened.".

    Would be really helpful

    Thanks

    anish.gupta86@gmail.com

    Tuesday, December 10, 2013 9:48 AM