none
Lync RT app: We're having trouble connecting to exchange or we can't find a calendar for you

    Question

  • I'm having a minor issue with the Lync RT App and was hoping that someone may be able to point me in the right direction to get it fixed.

    We have Lync 2010 Server installed and we are running Exchange 2010 SP2. Outlook Anywhere is published via TMG 2010 and our Outlook clients can connect.

    We have Lync Mobile deployed and also remote users can connect to Lync OK as well although the full Lync client does give an error about not being able to connect to Exchange if they don't have Outlook installed and connected before hand.

    Is this to do with how the EWS is published and how do I fix it if it is?

    Thanks in advance for any pointers.


    Darren

    Wednesday, October 31, 2012 9:15 AM

All replies

  • Could you see if the EWS autodiscovery service is configured to require authentication? If yes, could you allow anonymous access to EWS autodiscovery service and see if that helps?

    Thursday, November 01, 2012 2:04 AM
  • Hi,

    I suggest referring to the following tips to check the issue.

    In this user's Lync, please holding down CTRL and right-clicking the Lync icon located in the System Tray and click Configuration Information .  Please check if the status of EWS information is ok. Please also check if Value of EWS Internal URL and EWS External URL is correct.

    On user's client, please go to HKCU\Software\Microsoft\Communicator\[User SMTP Address]\Autodiscovery, please check if the URL of the

    following items are correct:

    ExternalEwsUrl

    InternalEwsUrl


    Regards, Kent Huang TechNet Community Support ************************************************************************************************************************ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.

    Thursday, November 01, 2012 2:12 AM
  • Thanks for your input. Unfortunately there is no tray icon for the Lync RT App BUT...

    I setup a Lync 2010 client on a Windows 7 PC as an external user and although it auto-detected and connected OK it reported problems connecting to Exchange.

    I cancelled out of the MAPI login as I wanted to rely on EWS as the Lync RT App has no Outlook client to fall back on.

    I then did as you suggested and got the Configuration Information. The output from the Configuration Information is at the bottom of my reply.

    There was no ExternalEwsUrl or InternalEwsUrl.

    I looked at the reg keys and there were urls listed. I browsed to the exteral url and got prompted for  a username and password by a TMG form (similar to the one we get when using OWA). When I entered my username(using a UPN which matches the sip account and password) I got an XML page (same as when I browse to it internally and everything works fine for internal users).

    I tested Outlook Anywhere access and it works fine and Autodiscover configures Outlook 2010 OK.

    I have been to www.testocsconnectivity.com and got passes all the way.

    What do I need to do as the EWS virtual directories are configured to use Basic Authentication as seems to be recommended and Outlook Anywhere is published via TMG.

    Thanks again for responding.

    Lync Configuration Information Output:

    DG URL Internal;https://lyncFEserver.mydomain.local:443/groupexpansion/service.svc;--;

    DG URL External;https://lsrp.mydomain.co.uk:443/groupexpansion/service.svc;--;

    Quality Metrics URI;;--;

    URL Internal From Server;https:// lyncFEserver.mydomain.local:443/abs/handler;--;

    URL External From Server;https://lsrp.mydomain.co.uk:443/abs/handler;--;

    Voice mail URI;sip:darrenthorley@mydomain.co.uk;opaque=app:voicemail;--;

    Exum Enabled;FALSE;--;

    Exum URL;;--;

    MRAS Server;sip:lyncedgeserver.mydomain.local@mydomain.co.uk;gruu;opaque=srvr:MRAS:8lq_UHU4hlyvLBjUectwFAAA;Enabled;

    GAL Status;https:// lyncFEserver.mydomain.local:443/abs/handler;--;

    Controlled Phones;TRUE;--;

    PC to PC AV Encryption;AV Encryption Supported;--;

    Focus Factory;sip:username@mydomain.co.uk;gruu;opaque=app:conf:focusfactory;--;

    Telephony Mode;Telephony Mode UC Enabled;--;

    Line;tel:+1301;ext=301;--;

    Line Configured From;Auto Line Configuration;--;

    Location Profile;DefaultProfile;--;

    Call Park Server URI;sip: lyncFEserver.mydomain.local@mydomain.co.uk;gruu;opaque=srvr:Microsoft.Rtc.Applications.Cps:-XMhgGSg81CFae8DmFIe-wAA;--;

    UCS Mode;Lync Server Mode;--;

    Configuration Mode;Auto Configuration;--;

    Server Address Internal;--;--;

    Server Address External;--;--;

    Server SIP URI;username@mydomain.co.uk;--;

    GAL or Server Based Search;GAL search;--;

    Local Log Folder;F:\Users\Darren\tracing;--;

    MAPI Information;A separate sign in was required to connect to Outlook, but the sign-in dialog box was canceled or closed, or your Exchange server may be unavailable. To establish the connection, sign out and then sign back in to Lync.;MAPI unavailable;

    EWS Information;--;EWS not deployed;

    Inside User Status;FALSE;--;

    Auto Update Download Started;--;--;

    Auto Update Download Completed;--;--;

    Last Auto Update Request;--;--;

    Pairing State;Lync cannot connect to your desk phone because the USB cable is not plugged in. Make sure that you connect the cable.;Enabled;

    Contact List Provider;Lync Server;--;

    UCS Connectivity State;Exchange connection Down;--;

    Connected Lync Server;lync.mydomain.co.uk;--;

    Skill Search URL;;--;

    SharePoint Search Center URL;;--;

    EWS Internal URL;;--;

    EWS External URL;;--;


    Darren

    Thursday, November 01, 2012 5:24 PM
  • I notice that you are using TMG. I have noticed on my TMG server that the Lync client only appears to be attempting connections anonymously. Since my Exchange rules require authentication, it is failing. I see similar behavior with the other Lync clients, but they eventually fallback and authenticate.

    The only way I have gotten it to work so far is to remove all authentication from my listener and rules. Then the client will talk to the server. Otherwise, TMG blocks it since the communication is anonymous.

    I hope you find something different, because this sort of defeats one of the reasons for having TMG.

    Tuesday, November 06, 2012 12:36 AM