none
Lync Emoticon Text

    Question

  • If you type into Lync:

    "Here are our options: (a) buy a car (b) buy a bus (c) buy a plane"

    The (b) turns into an emoticon for a Beer and the (c) turned into an emoticon for a cup of coffee, not what I wanted to send to my boss...

    I was then curious which letters mapped to which emoticons so I typed up some letters into Notepad like this:

    (a)
    (b)
    (c)
    (d)
    (e)
    (f)

    Copied them from Notepad into Lync (Ctrl+C, Ctrl+V)...and guess what? There are no emoticons this time, just the text as seen above.

    What is going on here? Is there a character encoding issue?

    Just curious.

    Monday, February 13, 2012 10:04 PM

All replies

  • it probably won't change the text into an emoticon when copied/pasted because it will not parse the characters individually...if that makes sense.
    Monday, February 13, 2012 10:34 PM
  • I see what you mean, that is a good point. However, I tried a new test today to test the individual parsing theory:

    Type in "(c)" into Lync and then highlight "(c)" with the mouse and [Ctrl+C] to copy.

    Now [Ctrl+V] and paste the copied text...it shows up as a Coffee Cup icon each time you paste. This should not be parsing the characters individually, so why does it still show the Coffee Cup?

    Tuesday, February 14, 2012 4:19 PM
  • The only way around this is to turn off emoticons using a Client Policy. You can't change the way the characters are made into emoticons.

    Check out this TechNet article for more info on how to set a client policy for this - http://technet.microsoft.com/en-us/library/gg398300.aspx


    Justin Morris | Consultant | Modality Systems
    Lync Blog - www.justin-morris.net
    Twitter: @jm_deluxe
    If this post has been useful please click the green arrow to the left or click "Propose as answer"

    Tuesday, February 14, 2012 4:27 PM
  • Thanks Justin, that is good to know, but I am not asking how to turn off emoticons. To be more clear my question is:

    For emoticon text like "(c)":

    Copy from Notepad --> Paste into Lync

    has different behaviour from :

    Copy within Lync --> Paste within Lync.

    Why?
    Tuesday, February 14, 2012 4:50 PM
  • I can't answer that question, but what business task are you looking to achieve here?

    Justin Morris | Consultant | Modality Systems
    Lync Blog - www.justin-morris.net
    Twitter: @jm_deluxe
    If this post has been useful please click the green arrow to the left or click "Propose as answer"

    Tuesday, February 14, 2012 4:53 PM
  • ...but what business task are you looking to achieve here?

    Justin Morris | Consultant | Modality Systems
    Lync Blog - www.justin-morris.net
    Twitter: @jm_deluxe
    If this post has been useful please click the green arrow to the left or click "Propose as answer"

    No specific business task. I just don't understand how Lync is behaving and what is the cause of that behaviour.
    Tuesday, February 14, 2012 5:39 PM
  • This is an artifact of RTF encoding in the Lync client, AFAIK Lync Client treats any text copy/pasted from another location as RTF text. So when you are copy/pasting the text from notepad it preserves the text as-is and shows you the list. It does the same when you cut/paste text from Lync IM text box, it tries to preserve the formatting related information and when you paste it back in it retains the formatting information and recognizes the character combo "(C)" as a coffee cup or the "(B)" as a beer mug. Hope this makes sense.

    PS: Did you know that if you sent "(B)" as a text message(SMS) from one Windows Phone 7 device to another, it shows up as a Beer Mug? See: http://windowsteamblog.com/windows_phone/b/windowsphone/archive/2011/12/06/tip-tuesday-more-fun-with-emoticons.aspx for more.



    • Edited by Akshat N Tuesday, February 21, 2012 5:03 AM Fixed more typos
    • Proposed as answer by JasonBurns Tuesday, March 06, 2012 4:27 PM
    Tuesday, February 21, 2012 4:57 AM