none
Lync Mediation Server Errors - Event ID 19254, 30509, 46009

    Question

  • Hi,

    Users are complaining about poor audio quality during phone calls (voice skipping) using lync especially inbound calls coming from PSTN.

    These are users from a branch site where we have an SBA + audiocodes mediant 1000 gateway connected to an ISDN 1.5 PSTN.

    Then problem seems to be random.

    When I checked the server logs: I noticed the following persistent errors:

    LS QoE Monitoring Agent (Event ID: 19254)

    LS Archiving Agent (Event ID: 30509) 

    LS Outbound Routing (Event ID: 46009)

    Are these errors causing the poor audio quality during phone calls? I'm suspecting that the Outbound Routing Error is caused by a bad cable or bad cable connection between the Gateway and the PBX or the Gateway and the SBA. Is this correct?

    Thursday, September 06, 2012 8:51 AM

Answers

  • Hi

    Install message queing on the server with AD integration and the Archiving and monitoring "errors" will go away, if that install goes ok. Otherwise you may have to reinstall that component.

    It's not in the pre req to install the Message queing but I do that anyway just to avoid theese errors in the log. The errors aren't realy errors since you probably don't use either of te Monitoring server or Archiving in your network.


    /Tim

    • Marked as answer by Kent-Huang Tuesday, September 25, 2012 1:20 AM
    Friday, September 07, 2012 4:14 AM
  • Hi,

    you must install Message Queuing with Active Directory Domain Services Integration enabled. For details:

    http://technet.microsoft.com/en-us/library/gg398383.aspx

    The Archiving and Monitoring components should be working after installing Message Queuing properly.

    Regarding the event ID46009, this may occur if the call could not route to Gateway correct. You can try to check the listening port for gateway.


    Regards,

    Kent Huang

    TechNet Community Support ************************************************************************************************************************ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.


    • Edited by Kent-Huang Friday, September 07, 2012 6:07 AM
    • Marked as answer by Kent-Huang Tuesday, September 25, 2012 1:22 AM
    Friday, September 07, 2012 6:06 AM

All replies

  • I don't recognize the first two.  What is the text of the Events?
    Thursday, September 06, 2012 11:22 PM
  • hi john,

    thank you for the reply.

    the description for the first two event id's are as follows:

    Log Name:               Lync Server
    Source:                    LS QoE Monitoring Agent
    Date:                       MM/DD/YYYY HH:MM:SS
    Event ID:                 19254
    Task Category:        (1920)
    Level:                       Error
    Keywords:               Classic
    User:           N/A
    Computer:       XXXXXXXXXXXXXXXXXXXXXXX
    Description:  The Quality of Experience (QoE) monitoring agent cannot operate on Message Queuing object.
    Cause:   This can occur if Message Queuing is not installed with Active Directory integration on this server.
    Resolution: Verify that Message Queuing is installed with Active Directory integration on this server. If it is not, reinstall Message Queuing with Active Directory integration and restart Message Queuing.

    Log Name:              Lync Server
    Source:                   LS Archiving Agent
    Date:                      MM/DD/YYYY HH:MM:SS
    Event ID:               30509
    Task Category:      (1011)
    Level:                     Error
    Keywords:              Classic
    User:                       N/A
    Computer:               XXXXXXXXXXXXXXXXXXXXXXX
    Description: Lync Server Archiving Agent failed to create a local administration queue for acknowledgements.
    Cause:   This can happen if Message Queuing is unavailable or not installed with Active Directory integration.
    Resolution: Verify that Message Queuing is installed with Active Directory integration and operating correctly. If it is not, re-install the Message Queuing service with Active Directory integration and restart Message Queuing.

    Will reinstalling the MSMQ solve these two errors? what are the possible risks of reinstalling the MSMQ component of the lync server?

    thanks,

    ron

    Friday, September 07, 2012 1:24 AM
  • Hi

    Install message queing on the server with AD integration and the Archiving and monitoring "errors" will go away, if that install goes ok. Otherwise you may have to reinstall that component.

    It's not in the pre req to install the Message queing but I do that anyway just to avoid theese errors in the log. The errors aren't realy errors since you probably don't use either of te Monitoring server or Archiving in your network.


    /Tim

    • Marked as answer by Kent-Huang Tuesday, September 25, 2012 1:20 AM
    Friday, September 07, 2012 4:14 AM
  • Hi Tim,

    Thank you for your reply.

    We do actually have a Monitoring server located in the central site. But I noticed that cannot find reports (e.g. Server Performance Report) for this specific server located in the branchsite while i'm seeing other servers from other branchsites.

    Are these issues (missing reports, archiving/monitoring errors) related? I mean if I am able to repair/reinstall the MSMQ with AD integration component, the errors will go away and I'd be able to see reports for this specific branchsite server?

    Thanks,

    ron

    Friday, September 07, 2012 5:01 AM
  • Hi

    If you have a monitoring server and you have the Message queing installed but it doesn't work from that site, yes I'w try and reinstall that component. Bare in mind that you need to reboot the server if you remove that component before you may add any other component to the server.

    Any errors on the monitoring server that could be related to the not getting the statistics from the faulty FE?


    /Tim

    Friday, September 07, 2012 5:16 AM
  • Hi,

    you must install Message Queuing with Active Directory Domain Services Integration enabled. For details:

    http://technet.microsoft.com/en-us/library/gg398383.aspx

    The Archiving and Monitoring components should be working after installing Message Queuing properly.

    Regarding the event ID46009, this may occur if the call could not route to Gateway correct. You can try to check the listening port for gateway.


    Regards,

    Kent Huang

    TechNet Community Support ************************************************************************************************************************ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.


    • Edited by Kent-Huang Friday, September 07, 2012 6:07 AM
    • Marked as answer by Kent-Huang Tuesday, September 25, 2012 1:22 AM
    Friday, September 07, 2012 6:06 AM