none
"View Conversation History" is grayed out

    Question

  •  

    I just installed Lync 2010 and it's working great except for viewing Conversation History.  In the Lync Client the "View Conversation History" is grayed out


    so I went to tools/options and made sure that "save im in my email conversation history" folder was enabled

    I verified that I do have a Conversation History folder in Outlook

    And I verified that the add-in was installed.

     

    I thought perhaps it was because there was no archiving server so I setup an archive server using topology and the whole thing.  Services are working fine and shows up in the control panel fine under topology.

    I thought perhaps archiving policy needed to be made so I created archiving policies and applied them.

    We use Win 7 64 bit, Office 2010,  Google Apps Business Sync in lieu of an exchange server.  The server is a Lync 2010 server in a standard configuration - Edge server, archive server.

    Oh, I've read some posts about a reg key
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Communicator 1 and changing ImAutoArchivingPolicy from 0 to 1.  I didn't have this reg key so I figured what the heck I would create it in hopes that it would work, but it did not.

    ***edit

    After some checking and testing, nothing is being sent to the archive server or to users Conversation History folder in Outlook.  Everything appears to be enabled and all policies are committed and applied.  I'm not sure where to look.

    jeudi 16 juin 2011 16:51

Réponses

  • I'm afraid you went through a lot of trouble to no avail. The archive server is not required for conversation history - your issue with no IMs being archived is separate. According to the Exchange UM Integration chapter of the Resource Kit book (sample chapters available) Conversation History uses Exchange Web Services interface to Exchange 2007/2010. Google Apps is the gotcha in your environment.

    Mike


    If a post is helpful, please take a second to hit the green arrow on the left, or mark as answer, thanks

    MCITP: Lync, Exchange 2010 & Server Administrator

    Blog
    jeudi 16 juin 2011 19:15

Toutes les réponses

  • I'm afraid you went through a lot of trouble to no avail. The archive server is not required for conversation history - your issue with no IMs being archived is separate. According to the Exchange UM Integration chapter of the Resource Kit book (sample chapters available) Conversation History uses Exchange Web Services interface to Exchange 2007/2010. Google Apps is the gotcha in your environment.

    Mike


    If a post is helpful, please take a second to hit the green arrow on the left, or mark as answer, thanks

    MCITP: Lync, Exchange 2010 & Server Administrator

    Blog
    jeudi 16 juin 2011 19:15
  • LOL dang.
    jeudi 16 juin 2011 19:38
  • Michael, if i am using Lync 2010 in Office365 but using on site Exchange, is there any way to utilize the conversation history?

    lundi 4 juin 2012 17:02
  • Hi Steve,

    Conversation history will work no problem in your scenario.

    I have done it multile times.

    But has Michael mentionned, your Exchange Web Service needs to be configured correctly....either on=premise or in the Cloud.

    Cheers


    If a post is helpful, please take a second to hit the green arrow on the left, or mark as answer, thanks.


    Jean-Philippe Breton | Senior Microsoft Consultant | MCTS, MCITP, MCT, Lync MVP

    lundi 4 juin 2012 17:07