none
Lync Server 2010 DNS for Certificates

    Question

  • Hello, I am having a problem with Lync clients being able to access the address book.

     

    I think I've determined the problem to be certificates.  In the "Subject Alternative Names", my FQDN is named, but not the hostname, and I have a feeling that client machines are connecting to the address book via the hostname instead of the FQDN.

     

    How can I adjust these within the topology builder, and then re-publish it?  I can't find any place where Subject Alternative Names are mentioned and configurable.

    vendredi 22 juillet 2011 18:33

Toutes les réponses

  • How did you request the certificate? If you used the Certificate Wizard, CN and SAN's should be properly configured because the wizard is intuitive.

     

    Drago


    http://www.lynclog.com
    vendredi 22 juillet 2011 19:09
  • I used the Wizard to request it, but the Wizard did not have the right "Subject Alternative Name" listed, and the help button suggested if I need to change these, to back out and re-run the topology builder.

     

    vendredi 22 juillet 2011 20:51
  • It is very strange that the wizard will not populate the CN with the host name. You are not by any chance having Enterprise Pool with single server, don't' you?

     

    Drago


    http://www.lynclog.com
    vendredi 22 juillet 2011 21:53
  • Hi do you have any update regarding this ?

    regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread
    lundi 25 juillet 2011 06:24
  • Hi,Shuhari00,

    Could you elaborate more on your topology?Is it enterprise edition or standard edition?

    What do you mean " my FQDN is named, but not the hostname"?Could you post your certificate SN/SAN and state what is your FQDN and hostname?(You can anonymizes the real name and use other words replace it)

    If you can provide more information it will be more useful to troublshoot your issue,thanks!

    Regards,

    Sharon


    mercredi 27 juillet 2011 01:39
    Modérateur
  • Hi Shuhari00,

    First open the "Configuration Information" window in Lync client for the exact URL the clients use to connect to download the address book. You should look at "URL Internal From Server" in case you have troubles with internal clients.

    Now that you know the exact URL you can do two things:

    1. Modify the certificate on the Lync server so it includes this FQDN or Netbios name
    2. Modify the Address book URL for your internal deployment using Topology Builder. This is only possible if you have an enterprise edition deployment. This option will not be available if you have a standard edition deployment. In a standard edition environment this should be the server FQDN by default

    Technical Specialist Microsoft OCS/Lync & UC Voice Specialisation - http://www.uwictpartner.be
    If you think my post is the answer to your question, please mark it as answer so future visitors can easily find it.
    mercredi 27 juillet 2011 08:00
  • Hi,Shuhari00,

    Any updates?

    If you have got some more progress on your issue please do let us know.Thanks!

    Regards,

    Sharon

    vendredi 29 juillet 2011 10:34
    Modérateur