none
Allow Blackberry connections to Lync with no prior messaging environment...

    問題

  • I do not have any version of OCS/LCS/Lync currently installed. I want to put Lync 2010 in place. We have some blackberry users which I would like to be able to use IM/presence from their phones.

    http://docs.blackberry.com/en/admin/deliverables/25747/Preparing_to_host_BCS_for_use_with_LS_2010_1403597_11.jsp

    It talks about "Unified Communications Managed API 2.0 Core Redist 64-bit (ucmaredist.msi)" and "Office Communications Server 2007 R2, Core Components (ocscore.msi)".

    Getting those packages is not a problem, but I'm not clear on how to actually proceed. I am about to do schema extensions for my test environment in order to be able to install Lync, but it sounds like I have to do the OCS 2007 R2 portion first. I can extract the schema.ldf out of OcsCoreWebdownloadX64.msi and run a commandlet to install it, but...

    1) What type of system would I install the core components to? (my Front End Lync server?)
    2) all the documentation I've seen about the core components of OCS 2007 R2 don't seem to talk about an environment that does/did not have a prior LCS/OCS presence. Is the OCS 2007 R2 Core Components sufficient to allow the Unified Communications Managed API 2.0 to be able to talk to my future Lync 2010 enterprise environment?

    Any links to discussions/articles/videos where people are talking about a virgin Lync 2010 and Blackberry connectivity would be appreciated as well. I'm not having a whole lot of luck finding those.

    2012年3月5日 下午 07:25

解答

所有回覆

  • Hi,

    Have a look in to this it answers all your questions http://msexchangeanywhere.wordpress.com/2011/08/24/how-to-integrate-lync-2010-with-blackberry-5-0-sp3/ 

    Hope above helps.


    If answer is helpful, please hit the green arrow on the left, or mark as answer. Salahuddin | Blogs:http://salahuddinkhatri.wordpress.com | MCITP Microsoft Lync

    2012年3月5日 下午 08:31
  • Thank you for the quick reply. I had found that one a while back but forgot to bookmark it and it has a lot of good information.

    • Lync integration with the BES requires the the UCAPI 2.0 (package 1, package 2) SQL Native Client, and OCS Core components (Available in OCS 2007 R2 Setup package in i386, do not install Lync 2010 core component which will not work) to be installed.

    The UCAPI package 1 references that it needs to be installed on servers running OCS 2007 R2. I have no Office Communication Server environment at all. The only IM solution that will be in our system once I get it set up, is Lync. To allow blackberry users to be able to access Lync, does OCS have to be set up and installed? I was just hoping it was a connection/API that could negotiate with Lync.

    If these do not have to be installed on an existing OCS environment, what type of system would they be installed on? I seem to be out of luck from the way I read that article.

    2012年3月5日 下午 09:20
  • Hi,

    You would require another system where prerequisites and Black berry collaboration service will be installed.

    for system requirements have a look in to this http://docs.blackberry.com/en/admin/deliverables/25805/SR_BB_Collaboration_Service_1280298_11.jsp for more information have a look in to this

    http://docs.blackberry.com/en/admin/deliverables/25805/Preparing_to_host_BCS_for_use_with_LS_2010_1403597_11.jsp 


    If answer is helpful, please hit the green arrow on the left, or mark as answer. Salahuddin | Blogs:http://salahuddinkhatri.wordpress.com | MCITP Microsoft Lync

    • 已標示為解答 DC McKinney 2012年3月7日 下午 03:37
    2012年3月5日 下午 09:51
  • Hi,there,

    To supplement SKHATRI,here is another more information about provisioning the BlackBerry Collaboration Service as a trusted application of Lync for your reference.

    http://docs.blackberry.com/en/admin/deliverables/25807/Provisioning_BCS_as_a_trusted_application_1396931_11.jsp

    B/R

    Sharon


    Sharon Shen

    TechNet Community Support

    ********************************************************************************************************************************************************************* Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.

    2012年3月7日 上午 09:37
    版主
  • If I'm understanding you clearly, it sounds like since UCAPI 2.0 package 1 has a requirement of being installed on a system running OCS 2007 R2, I will be unable to do this without standing up an OCS 2007 environment.

    Thank you and Sharon both for your replies and information.

    2012年3月7日 下午 03:37