none
Strange Header in Sequence Diagram

    Frage

  • I've got a strange thing happening in Visio 2010.  Luckily it's repeatable...

    1. Create a new UML Model Diagram
    2. Drag a single sequence object onto the page
    3. Save As, Web page, click Publish
    4. On the advanced tab, under output format choose XAML
    5. The results are displayed in IE (you may have to allow the ActiveX to run)

    The word "Sequence" appears on the result.  It also shows up on the page above the diagram.  How do I get rid of this?  I know it's a Sequence diagram.  Interestingly, it doesn't show up if you save as JPG or PNG in the publish options.

    Thanks!!
    -Jeff

    Dienstag, 2. April 2013 18:10

Antworten

  • Good, thought that should be the case as the toggle acts to actually delete the shape containing the text., so maybe something has been done to affect the shape to prevent it being deleted.

    Another way round it is to find the shape within the document explorer, open its shapesheet, overwrite the shape's delete protection, then delete it. Ah, that then turns it into a background page, then the background page can be deleted manually. What a kerfuffle.


    Paul Herber, Sandrila Ltd. Engineering and software shapes for Visio
    Sandrila Ltd

    Mittwoch, 3. April 2013 15:15

Alle Antworten

  • Hi,

    Based on my test, there is no such characters in the page, see the picture below:

    What's the version of your IE? I used IE 10.

    First make sure your IE update to the latest version, if the issue occurs, then update to IE 10 to check the issue.


    Jaynet Zhang
    TechNet Community Support

    Mittwoch, 3. April 2013 08:39
  • The text you are talking about is a watermark built into the page, and it is visible on the Visio page but difficult to see. It's easy to turn it off though, ribbon -> UML -> Drawing Options -> Create Watermark on Drawing page (untick)


    Paul Herber, Sandrila Ltd. Engineering and software shapes for Visio
    Sandrila Ltd

    Mittwoch, 3. April 2013 10:56
  • Hey Jaynet,

    Thanks for replying.  I am using IE 10, but in order to see the issue, you need to enable the ActiveX control that comes with the Visio viewer.  You should be prompted for it when you open it in IE.

    -Jeff

    Mittwoch, 3. April 2013 14:46
  • Paul,

    Thanks for your reply.  I have toggled the "Create Watermark on Drawing page" and am still getting the same result.

    Thanks,
    -Jeff

    Mittwoch, 3. April 2013 14:47
  • And what happens when you click the OK button?

    "Sequence" shouldn't normally have that background.  How have you done that?


    Paul Herber, Sandrila Ltd. Engineering and software shapes for Visio
    Sandrila Ltd

    Mittwoch, 3. April 2013 15:00
  • Hey Paul,

    That's the problem.  I have no idea where it came from and how to get rid of it.  It happens on all of my UML Sequence diagrams, and shows up when I create the web page.  Clicking OK has no effect.  The reason it is to noticeable is I have a Black color scheme on Visio.  It doesn't do this for other types of Visio diagrams.

    -Jeff

    Mittwoch, 3. April 2013 15:04
  • UPDATE...

    Paul, you hit it right, turning off the watermark got rid of it, but only for new pages.  I can't seem to turn it off for existing pages.  Not a big deal as there are not many of them, so I can copy paste.

    Appreciated!

    -Jeff

    Mittwoch, 3. April 2013 15:09
  • Good, thought that should be the case as the toggle acts to actually delete the shape containing the text., so maybe something has been done to affect the shape to prevent it being deleted.

    Another way round it is to find the shape within the document explorer, open its shapesheet, overwrite the shape's delete protection, then delete it. Ah, that then turns it into a background page, then the background page can be deleted manually. What a kerfuffle.


    Paul Herber, Sandrila Ltd. Engineering and software shapes for Visio
    Sandrila Ltd

    Mittwoch, 3. April 2013 15:15