none
Lost xlsx file association with Office 2010 starter

    Question

  • I use "Open With" option to a xlsx file in file explorer and now I lost the file association to Excel 2010 starter.

    I tried to do the same trick in "Open With" but I don't find Excel starter in the application list, and when I used 'browse', I can't find the exact Excel executable as it is hidden in Q: drive (the one with Click-to-Run).

    What should I do to restore the file association?

     

    Thursday, November 18, 2010 7:39 PM

Answers

  • Hi,

    Try this method to find excel.exe in Q:

    1. Make sure that the Show hidden files and folders option is enabled in your folder options. To check this option, follow these steps:
    2. Click Start, and then click Computer.
    3. Click Organize, and then click Folder and search options.
    4. Click the View tab.
    5. Under Hidden files and folders, make sure that the Show hidden files, folders, and drives option is selected, and then click OK .
    6. Open the Click-to-Run version of Microsoft Excel 2010.
    7. On the File menu, and then click Open.
    8. Browse to App Virt (Q:) drive to open the folder ending in "<var>xxxxxx</var>-enu".
    9. Open the Office14 folder and then you can see Excel.exe.

    Also check this setting:

    In Excel 2010, go into your File->Options, then Advanced, then in the “General” section, remove the tick from “Ignore other applications that use Dynamic Data Exchange (DDE)“.

     

    Friday, November 19, 2010 6:01 AM
    Moderator

All replies

  • Hi,

    Try this method to find excel.exe in Q:

    1. Make sure that the Show hidden files and folders option is enabled in your folder options. To check this option, follow these steps:
    2. Click Start, and then click Computer.
    3. Click Organize, and then click Folder and search options.
    4. Click the View tab.
    5. Under Hidden files and folders, make sure that the Show hidden files, folders, and drives option is selected, and then click OK .
    6. Open the Click-to-Run version of Microsoft Excel 2010.
    7. On the File menu, and then click Open.
    8. Browse to App Virt (Q:) drive to open the folder ending in "<var>xxxxxx</var>-enu".
    9. Open the Office14 folder and then you can see Excel.exe.

    Also check this setting:

    In Excel 2010, go into your File->Options, then Advanced, then in the “General” section, remove the tick from “Ignore other applications that use Dynamic Data Exchange (DDE)“.

     

    Friday, November 19, 2010 6:01 AM
    Moderator
  • I have this same issue and I don't see how the above answer works. So I can find the Q: drive in the Open dialog box from Excel Starter, but I can't ever see it from a regular explorer window with my .xls files. I even tried to right-click on the .xls file within the Open dialog box and choose the "Open With" option so that I could choose the Q: drive (because you can see it there since it is now within the Virtual Machine) but I get an error message that says that it is not allowed from there.

    HELP PLEASE

    -----

    Solved my own issue:

    I found that some file types were associated with Microsoft Office Client Virtualization Handler while others were associated with Microsoft Application Virtualization DDE Launcher.

    So I switched the .xls file to be associated with the later and VIOLA! fixed...

    • Proposed as answer by GrizzlyMan12 Friday, December 28, 2012 7:48 AM
    • Unproposed as answer by GrizzlyMan12 Friday, December 28, 2012 7:48 AM
    • Edited by GrizzlyMan12 Friday, December 28, 2012 7:52 AM solved the problem
    Friday, December 28, 2012 7:22 AM