none
Excel very slow to open files

    Question

  • Recently installed Microsoft office 2010 pro and certain excel files are very slow to open. Every other program opens just fine, however when I open certain documents they can take up to 2-3 minutes to open. If I try to open multiple excel documents at the same time my computer freezes. I disabled all of the add-ons, however it did not do anything. Does anyone have any ideas on how to fix this issue?

     

    System information: Intel i5- 6GB Ram, Windows ultimate edition

    Saturday, February 04, 2012 6:31 PM

All replies

  • Hi

    If you are using IE 8.0, and you are opening files available on a network drive, there could be a reaon for this issue.

    Try this option:

    Go to tools> internet option> security> local intranet> sites and uncheck the box that says 'automatically detect intranet network'.

    Please try this and check if it helps.


    Hope this helps. Cheers, P.K.Hari
    Sunday, February 05, 2012 6:21 AM
  • Hi,

    The formulas would be recalculated when you open the previous files first time. The issue should not occur next time after you save the files in Excel 2010.

    Best regards,


    Rex Zhang

    TechNet Community Support


    Wednesday, February 22, 2012 2:00 AM
  • I am experiencing very slow Excel and Word opening, but not related to the data file or file storage location.  The PROGRAM is very slow opening.  Once the program is open, double clicking on a file opens the file instantly regardless of where it is stored.

    Monday, March 26, 2012 2:40 PM
  • I have a user with a similar issue where Excel 2010 itself opens fast but certain files open slowly. We already went thru the usual steps of safe mode, checking for add-ins to disable (none installed), uncheck the autodetect intranet setting. etc.

    We basically narrowed it down to when the user applies "Format as Table" to a spreadsheet and saves it locally. Then on next open the file takes a full minute or longer depending on the size. Once the file is open there doesn't seem to be any performance issues in navigating Excel features, etc.

    PC specs: Core i5, 4 GB, Win7 Pro 32-bit, Office 2010 Pro

    Tuesday, April 17, 2012 8:34 PM
  • Long shot, but could this be the issue with the Office File Validation? It happened to us here and we reloved Office File Validation and all was well!
    Tuesday, April 17, 2012 8:49 PM
  • Long shot, but could this be the issue with the Office File Validation? It happened to us here and we reloved Office File Validation and all was well!

    Actually we checked for that hotfix and PC already had what's supposedly the latest version based on http://support.microsoft.com/kb/2553065. If I understood that article correctly, the updated version should eliminate the need to remove the file validation feature.

    Update:

    So the user found that the issue was they had applied Format as Table to the entire spreadsheet, rather than just a select # of cells. I guess considering how many rows/columns are the max, formatting the whole spreasheet would add some time to read/render the file. 

    Tuesday, April 17, 2012 8:59 PM
  • This was my problem too: format as a table applied to an entire worksheet and spreadsheets taking forever to load. Thanks for the pointer as I wouldn't have made the connection otherwise.
    Wednesday, October 31, 2012 8:51 AM
  • hi,

    Before my few days i solve from my network.

    please completely read before do something.

    actualy user apply some formating, instructions, color, font, fontstyle and color for whole row or column by pressing Alt+Space or Ctrl+Space. In this case or similer case your excel sheet look like you want but actualy they consume all over sheets 1000+ rows 1000+column.

    for remove: focus your working area. then after last row of your working area press Ctrl+Space to select these row and press "Shift+Ctrl+Down" Keys now you have select all rows from your end of working area to Down and delet it and save it. and do it for column also, of all sheets then save it.

    once you finish this please re open and check its magicaly responce.

    Note: please backup your file for your safety

    is your file need this operation not : please see below image

    http://www.shariqdon.com/thread/excelslow.png


    www.shariqdon.com

    Wednesday, November 07, 2012 10:40 AM
  • Try this :

      Go to a folder in Windows Explorer, then Tools -> Folder Options, then the File Types tab. For each of XLS, XLSM, XLSB, XLSX, etcetera, select it, then click Advanced, (if Advanced doesnt show, click Restore first, then Advanced) select Open in the Actions list, then click Edit

    Adjust the settings to:

    Application used to perform action: - "C:...\EXCEL.EXE" "%1"

    Use DDE - Checked

    DDE Message *LEAVE BLANK*

    Application - Excel

    Topic - System

    This is meant to open a new instance of Excel each time you double click on an Excel file.  I had /DDE at the end of the command string and other garbage in the DDE area below.

    But the above worked for me.

    Thursday, February 14, 2013 10:01 PM
  • I have had the same issue in the past and I've found that if I have a large file listed in the recent files shown in Excel, then Excel opens very slowly.

    What I did to correct this was:

    open Excel, then go to File --> Recent. 

    Wait for the files to load.

    Find the very large file, right click, and delete.

    Monday, November 04, 2013 3:41 PM
  • Delete everything from - %appdata%\Microsoft\Excel location. Worked for me!!! :)
    Tuesday, April 01, 2014 3:34 PM