none
Outlook 2010 Unable to open Word, Excel and Power Point Attachments from an email.

    Question

  • I am using Windows XP and I just upgrade to Outlook 2010 from Outlook 2007.  Now I cannot open any Word, Excel or Power Point documents as email attachments.  It gives me an error stating that "File is Corrupted" or "Word has experienced an error trying to open file".  I can open documents that were previously saved on my computer, but cannot open email attachments with Word, Excel or Power Point documents.
    Friday, July 09, 2010 5:26 PM

All replies

  • Hi,

     

    Thank you for using Outlook IT Pro Discussions forum. 

     

    From your description, I understand that after upgrading from Outlook 2007 to Outlook 2010, you are unable to open Word, Excel or PowerPoint attachment from an email, and receive an error: "File is corrupted" or "Word has experienced an error trying to open file".  . If there is any misunderstanding, please feel free to let me know.

     

    First, I would like to confirm if you have a virus scanner installed which integrates itself with Outlook. If you have, please uninstall this integration part of your virus scanner and try again. You will still be sufficiently protected by your on-access scanner part of the virus scanner. For more details see:
    http://www.msoutlook.info/question/20

     

    If the problem persists after this, you can try to empty your Outlook Temp folder and try again. For the detailed steps on how to do this, you can refer to this article:

    http://www.howto-outlook.com/faq/securetemp.htm

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Best Regards,

     

    Sally Tang

    • Marked as answer by Sally Tang Tuesday, July 13, 2010 6:06 AM
    • Unmarked as answer by Sally Tang Thursday, July 29, 2010 1:22 AM
    Saturday, July 10, 2010 5:35 AM
  • Does anyone have any other ideas on this?

    I have complete removed Office, including weeding out the registry entries orphaned from a typical office install/remove.

    I have uninstalled Symantec Endpoint email/Internet Scanning and removed Symantec all together....

     

    I am still having the same issue opening ANY attachment within outlook.

    If I drag and drop or otherwise save the attachment(s) to the desktop or documents, anywhere other than Outlook, the attachments open as they should.

    This is a brand new install of Office 2010 as an upgrade to 2007, Windows 7 PC 32 Bit.

    There were no files in the temp folder to empty either.  This PC is in a store that has yet to open and everything is brand new.

    Other Ideas?  I have tried the Registry level1add and level2add thinking it might have been a security issue, it's not.  I have 25+ clients using the same OS and Symantec Product without issues.

     

     

    Friday, July 16, 2010 3:07 PM
  • I am having the same issue with windows mail.  I have upgraded to office 2010 and now I can't open any .doc, .docx, .xls, etc.  If I save it out, it will open fine.  word does try and open...gets into the app and then says that there was an error with the file...check security, permissions, etc.  I have verified this...even opened up a .doc from the same mail director where "store" is located. 

    Any ideas?

    Thursday, August 05, 2010 2:58 PM
  • We just did a clean install of server 2008 Enterprise running as terminal server for remote desktop services, and Office 2010. We are having the same issue, attachments say they are corrupt when you try to open or save from outlook. However you can do a quickprint fine or copy paste to another folder and open's fine.

    Has ANYONE found a fix for this?

    Saturday, August 07, 2010 1:11 AM
  • Hi,

     

    We can try to check if this is only a Protected View issue. To check this, we can place the file in another location where Protected View will also be triggered (besides Outlook). Or put the same files on an Internet location that’s not trusted, etc.

     

    If opening the files using that method also fails, the issue may be with the files, the underlying Protected Mode architecture, or a hardware limitation.

     

    For more information about protect view, you can refer to this blog:

    http://blogs.technet.com/office2010/archive/2009/08/13/protected-view-in-office-2010.aspx

     

    Hope it helps.

     

    Best Regards,

     

    Sally Tang

     

    Tuesday, August 10, 2010 8:02 AM
  • Hi,


    Same issue here with Windows Server 2008 R2 running in VMWare Workstation 7.1 and Office 2010.

     

    I can create a new .docx, save it, and it opens fine in Word.

    If I then send it as an attachment to another machine (Win7/Office2010), I can preview and open it with no problems.

    If I then try to preview it back in the Outlook sent items on the 2008 machine, it comes back "This file cannot be previewed because there is no previewer installed for it".  If I try to launch it from the sent email, Word comes back "Word experienced an error trying to open the file.  Try these suggestions. * Check the file permissions for the document or drive. * Maker sure there is sufficient free memory and disk space. * Open the file with the Text Recovery converter.  If I save the attachment from my sent items, and try to open it I get the same error. It's exactly the same file size as the original document I created, and if I copy it to my other machine, it opens fine.

    Trying it the other way - I send a new .docx from the Win7 machine to the 2008 machine, but can't either preview it or open it in Word (same errors) as above.


    Don't know whether it makes any difference, but I'm using a Gmail account on the 2008 machine (it's for testing purposes) and an Exchange account on the Win7 machine.

    Have read the blog about protected view, but it didn't seem to offer any help.


    Thanks.

     

    EDIT - just tried with a Hotmail account and get the same errors.

    EDIT2 - just tried disabling the three Protected View options in Word (File, Options, Trust Centre, Trust Centre Settings, Protected View).  I can now open the attachment in Word, but still can't preview it in Outlook.

    Wednesday, August 11, 2010 3:47 PM
  • I am having exactly the same issue, now on two machines that have been upgraded from xp to vista to win7 and from office xp to office 2010, but not on two other machines that had the same upgrade path. Here's another interesting wrinkle. if the email containing the attachment is opened from a webmail application using Internet Explorer, it give the same "file is corrupt" message, but if the attachment is opened using Firefox as the browser it will open perfectly in word, excel, etc.
    Thursday, August 12, 2010 1:42 AM
  • I too am having the same issues. I am unable to open .doc, .xls, .docx...... etc.  I have narrowed it down to a security issue that I don't know how to fix. If you save the attachment to the desktop and go to its properties you get a security warning saying :"This file came from another computer and might be blocked to help protect this computer." You then have to click the unblock button to view the document. This is what is preventing anyone from viewing the document as a direct attachment.

    I have gone into gpedit.msc and enabled the attachment policy to Do not preserve zone information in file attachments, but that hasn't worked either.

    Friday, August 13, 2010 1:21 PM
  • I've encountered what sounds like the same issue on 2 computers which I recently upgraded to Office 2010.

    PC 1: Running Windows XP SP3, upgraded from Office 2003 and appeared to have this problem from the beginning.

    PC2: Running Windows XP SP3, new Office 2010 install, definitely could open some Excel attachments however this issue arose out of the blue.

    Double clicking an Office document which is attached to an email in outlook caused the appropriate Office program to launch, attempt to open the file and then report it as corrupt.

    Saving the Office document from an email to the hard drive and then opening it (either by double clicking or first launch the appropriate program and manually opening it) also caused a report of a corrupt file.

    Viewing the file properties after it was saved to the hard drive and clicking the "Unblock" button next to "This file came from another computer and might be blocked to help protect this computer" allowed me to open the document without problem.

    This workaround, however, of saving every attachment, viewing the properties, unblocking it and finally opening it, was not gonna fly with my users for long. The "solution" I found however was to open Word, Excel and Power Point, go into the Trust Center settings and disable the Protected View for Outlook attachments. I assume I'm losing some security by doing this but it allows users to simply open the attachment by double clicking on it.

    Interestingly, I've upgraded a number of computers and only 2 of them have run into this problem... I'd love to know why or what's "wrong" with the install that's causing this... but that's probably just dreaming.

    Tuesday, August 17, 2010 10:53 PM
  • Someone in my office solved this problem for office 2010 on windows 7. In word and excel, under File, Options, select Trust Center, then Protected View, Uncheck the Box for Outlook attachments and the problem of not bring able to open outlook attachments in Word and Excel, goes away. My question is that I'm not sure this is the optimum way to solve the problem. Are we creating significant exposure issues with this setting turned off?

     

    Dave

    • Proposed as answer by dave72 Wednesday, August 18, 2010 5:54 PM
    Wednesday, August 18, 2010 5:53 PM
  • I am seeing this same problem but only PPT files.  I followed the suggestion and unchecked the box for Outlook attachment.  This allowed opening the file directly from Outlook.  I noticed though if I first saved the attachments to another location that they would not open.  To resolve I had to also unchecked the box for files originating from the Internet.  

    BTW, I am experiencing this problem on Server 2008 r2 with Office 2010.  On another computer running Windows 7 32 bit with Office 2010, these same files in Outlook cause no problem.  I notice that on that computer the file opens with the message that it is in protected view.  That doesn't happen on the Server 2008 r2--it just came up with an error message, never show the protected view with PPT files.  Looking back now at the Word files, those do open with the protected view message.

    So it looks like the problem is specifically with PPT protected view.

    Ed

    • Proposed as answer by Biker Spock Thursday, August 19, 2010 6:31 PM
    Thursday, August 19, 2010 4:43 PM
  • I just decided to try the repair option for Office 2010 through Control Panel.  That worked out very well, now those PPT files are able to open in Protected View with the Trust Center setting all checked for Protected View.  This allows me to open the files in protected view and then decide to enable for editing if I chose to do so.  This way I am utilizing the security available and can still open the files.

    I definitely suggest trying the repair option to fix the problem of not being able to open in protected view.

    • Proposed as answer by Biker Spock Thursday, August 19, 2010 6:38 PM
    Thursday, August 19, 2010 6:37 PM
  • I have cleared the Outlook Temp folder, run Repair on the Office 2010 installation, and still cannot open .doc file attachments.  Protected View does not activate on my XP SP3 computer, in spite of checking all Trust Center settings to be sure Enable Protected View for Outlook attachments is checked.  When trying to open a .doc file attachment, the error message reads:  "Word experienced an error trying to open the file.  Try these suggestions: check file permissions......., make sure there is sufficient free memory & disk space, open the file with the Text Recovery Converter." 

    BTW, Protected View does activate on another XP SP3 computer, as well as a second machine running Windows 7.  There has to be some setting on this one computer that's responsible for Protected View not working.  HELP!!

    Other wrinkles discovered:

    (1) If I open MS Word first, then go to Outlook and open the attachment, Protected View does work.  If I try to open the attachment from Outlook without first opening Word, I get the message quoted above!?!?

    (2) I can open Excel attachments, so the problem seems restricted to Word (.doc) files.

     

    Thursday, September 23, 2010 6:37 PM
  • Hi All,

    I have the same issue. Now I found the problem that creates this problem!

    If you save the document on your hard disk. Then open the properties of this file.

    In the main tab you see below a button 'Unblock'. I'm using a dutch version of XP and there it says: 'Blokkering opheffen'.

    If you click the button 'Unblock' and then click 'OK' or 'Apply' it is possible to open the document again.

    So it looks like that all documents that Outlook received will be blocked by the Windows, because they come from an untrusted site.

    The question is: How can I tell Outlook or Windows not to block those files?

    Cheers,

    Arco

     

    • Edited by Vosje Thursday, October 28, 2010 7:03 AM Added a question
    Thursday, October 28, 2010 7:01 AM
  • Hello,

    I finally found out what the issue is with this and the solution!!!!.  It actually isn't a "Protected view" issue, but a DCOM issue.

    Somehow the DCOM permission got changed with an application or something installed, so it wouldn't allow certain applications access to simple things like Preview mode on Outlook 2010 / 2007, or opening up attachments without it saying file corrupt.  I also was having an issue with Pop ups in IE8, where javascript messages about security tokens were not authenticated.

    The solution is as follows, and then you can turn on your protected mode back on in word, excel, and your "Preview mode" in outlook will start working again.

    Go to start, then run.  Type dcomcnfg and push o.k. Component Services should come up.

    Expand Component Services, click on Computers, then "Right click" on My Computer and go to "properties".

    Click on Default Properties tab, and make sure the following is set:

    Default Authentication Level: Should say Connect, not "None"

    And Default Impersonation Level: Should say Identify.

    When those are set properly, hit o.k and turn on your protected mode back on your Office applications.  Everything works, and your attachments will load up in protected mode as normal.

    Cheers :)

    • Proposed as answer by Fattony007 Thursday, December 16, 2010 8:02 PM
    Tuesday, November 30, 2010 12:39 AM
  • Actually, it's best to set your Default Authenticaion Level to Default.  This still works.  Just make sure it doesn't say None.
    • Proposed as answer by Fattony007 Thursday, December 16, 2010 8:01 PM
    Tuesday, November 30, 2010 1:00 AM
  • DCOM was the cause of my problems, however for me it turned out that DCOM was not running.  The service was crashing with this error:

    • When you attempt to start the MSDTC (Microsoft Distributed Transaction Coordinator) service in Windows XP, or Windows Server 2003, you receive:
    • Windows could not start the Distributed Transaction Coordinator on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code -1073737712.

    • The Application
    • event log records:
    • Event Type: Error
    • Event Source: MSDTC
    • Event Category: LOG
    • Event ID: 4163
    • Description: MS DTC log file not found. After ensuring that all Resource Managers coordinated by MS DTC have no indoubt transactions, please run msdtc -resetlog to create the log file.

    To resolve the DCOM issue, which in turn fixes the protected view issue I had to do this:
    01. Open a CMD.EXE window.

    02. Type msdtc -resetlog and press Enter, making sure that you DO NOT have any pending pending transactions before you run the command.

    03. Type net start msdtc and press Enter.
    Thursday, December 16, 2010 8:09 PM
  • I did not have the exact same problems you are having but the solution to your problem may be the same as what I had to do.  I am pasting a copy of my reply to my own question as it has taken three days for me to get things working.  Here goes:

    COPIED FROM: Can't Open Outlook 2010

    In response to my own question and several hours of ridiculous stress I found out that "you can remove all previous versions of Java" but that does not remove the old Java .CRV files.  I had to manually find all the .CRV files and remove them one by one.  As a kicker, Webroot, my total security anti-virus-spam etc software collided with Outlook 2010 and so did Corel Paint Shop Pro 2X.  Also on start up, OUTLOOK was in logging mode and would not run until I stopped it.  For any of you who are out there and end up in the same situation I did you will also need to go to you regedit and take out all instances of old Microsoft Office one at a time. Do not remove anything that says 14 as this is the 2010 file.  You also need to go to your programs file and remove all instances of Microsoft Office (older versions)  Then you need to defragment your computer ... after I did all of this my computer had 20 percent fragmented files.  With a computer that has 60 GB of hard drive space one one drive and 60 GB on a second drive this was a lot of fragmented files.  Office now works fine except for a few glitches that I read almost every place I have gone ... things like "can't open my files in outlook" when this happens I have to close outlook and restart it.  I am now considering if all this work was worth the effort except that the satisfaction of finding out the problems was a bit uplifting, I would still like to smack someone because a lot of what I went through was absolutely stupid.  They could have just stated that all Microsoft products need to be removed, all Java needs to be removed including all .CRV and JVM.DLL files  CRV Files are connected to Corel Software and JVM files are connected to all older forms of Java.  I have never been told to delete/remove old Java, I only get a notice that Java is being updated do I want to download the updates.  Well the updates are stand alone which means all the old Java is just hanging around in there and causing software problems throughout the system.  I am not a computer geek or guru I am just a person who has been working on them for my business and had to learn a lot about what goes wrong in order to keep tech people from charging me an arm and a leg to fix idiot problems.  I know some people are not computer literate and I do feel sorry for you.  I am glad there are places like this that people can hopefully get an answer to problems they have.


    Melony Vasho
    Wednesday, January 26, 2011 7:53 PM
  • I had the same problem and this SOLVED IT!  Thanks!
    Wednesday, April 13, 2011 2:36 PM
  • Please Make sure before starting the Trouble shooting please close all Other the  MS Office Documents.

    1)      Launch a new WORD/POWER POINT /EXCEL / document.

    Click on File> Options.
    Friday, August 05, 2011 2:09 PM
  • I am getting the same problem.

    Windows Server 2008 R2 EE + Office 2010

     

    Checked the DCOM settings, these were set per mka101's recommendations already (Comment + Identify), so this was not the cause.

    Going to the Word/Excel options, Trust Center, Protected View, and disabling Protected View for Outlook attachments does provide a workaround, however this is certainly not ideal. This thing really smells like some sort of bug to me, and MS should make sure this gets fixed.

    Wednesday, September 07, 2011 9:03 AM
  • I believe I found one possible cause for this behaviour. Initially I had windows search installed and working to maximize the search functionality within Outlook however due to system resources on some of the PCs I removed Windows Search after the Office installation. This reduced memory usage however I believe it also introduced this problem. A reinstall/repair of office after the Windows Search uninstall resolved the problem.
    Wednesday, October 26, 2011 9:33 PM
  • I had the same problem with Windows 7 and Outlook 2010.  The problem finally fixed itself after uninstalling and then re-installing Office 2010 in its entirety.  

    Sunday, December 25, 2011 1:57 PM
  • I can recommend to you a small application Outlook attach unblocker

    Oskar Shon, Office System MVP

    Press if Helpful

    Sunday, December 25, 2011 3:39 PM
  • retricted permissions in help follow directions
    MVD
    Wednesday, January 04, 2012 8:50 PM
  • Having the same problem on several Windows 2008 R2 Remote Desktop Host servers running Office 2010 in both x86 and x64.

    The KB article mentioned above (http://support.microsoft.com/kb/2387587) did not fix it.

    As a workaround I had to disable Protected View, which I'm not a big fan of (turning off security features is never good), so I'm hoping that a fix will be provided.


    Regards,
    Anders

    Thursday, January 19, 2012 6:45 PM
  • Hi,
    I have a slightly different problem...I had archived my outlook 2010 emails at work in the "archive" file. I copied this file onto my external portable hard drive. I bought Outlook 2010 (as a part of Office 2010-Home and Business) for my home laptop. I linked the archive file to the Outlook on my home PC.  When I tried to open the files with attachment, all I see is the file listed but no attachment (see the example below)! This only happens to the files older than Dec 31, 2011...All the newer emails (newer than Jan 01, 2012) with attachment are perfectly fine!

    E.g. of the messed up email with word attachment (from Dec 15, 2011):
    ....It will be great if you can send me your feedback by noon tomorrow. I will then quickly incorporate your thoughts then we can circulate the finalized version.

    Many thanks
    xxxx
            <<
                   Important.doc       (39.0KB)

                   (39.0KB)
             >>
    -----------------------------------------------------

    Thanks in advance for your help!

    I have tried all the suggestions that are given above but nothing has worked. Also, the Outlook tech (from Microsoft) tried SCANPST to repair the archive file. That didn't work either!

    -KRSN1

    krsn1@yahoo.com

    Friday, March 16, 2012 4:17 AM
  • I found if the userid was in the local Administrators group, but _NOT_ in the local Users group, then Protected View would not run properly.  Add this to another of the items to check on when this problem happens...
    Tuesday, April 10, 2012 8:24 PM
  • In Word....

    Click on File --> Then Options --> Then Trust Center --> Then Trust Center Settings --> Then Trusted Locations

    Then Click ..Add New Location--> Then browse to the to the locations where the documented is saved or downloaded....

    Click Ok....

    You should have this issue with permissions anymore, this usually happens in Server 2008 and Window 7 that I have experienced thus far.

    Saturday, April 14, 2012 1:18 AM
  • Hello everyone,

    We were having te same issue after migrating to office 365 and windows 7.

    The issue sounded random, as this was happening only time to time on XLS (not XLSX) files received by email.

    In fact after deep investigation we found a bug between Office security (not enabling edition to email attachment) and old XLS files containing... COMMENTS !

    It sound like Office have to change the comments in the old version file, but as editing is not enable it can't perform the changes... Corrupted file !

    So far users do the trick: save as, then Unblock manually to open those files.

    I post the exact bug and test files to microsoft right now.

    Regards, Yannick.

    Monday, May 07, 2012 9:53 AM
  • There are 3 ways to see an attached file: (1) preview in Outlook 2010, (2) open it from within Outlook or (3) save the attachment and then open it from that location. Let's consider them one at a time.

    (1) When trying to preview an attached, say .docx, file you receive the message, "This file cannot be previewed because there is no previewer installed for it." You cannot now preview the attached file in Outlook 2010.

    (2) If you try to open it from within Outlook (by double-clicking on the attachment) then an installation routine begins but does not complete; there is a very brief message about "protected [something]" and finally an error box which begins: "Word experienced an error trying to open the file"... etc., etc.

    (3) The successful method is the following: Save all attachments; then right-click them (one at a time), select "Properties" and then further select "Unblock", and OK your way out. Only then will each open normally.

    This difficulty began from about 4 to 6 months ago. Before then, Outlook 2010 would have no problem with attached files. Let's look at #2 again. There appears that extremely brief message about "protected...". I think that this may be the key toward solving this problem. Also, there is this business about having to unblock something if method #3 is used. Evidently, this is in an effort to protect people that are thoughtless openers of attachments, as some of them can take over a computer. (!)

    There should be some way to turn off this behavior and give control back to the user.


    • Edited by LittleMac Friday, June 22, 2012 10:55 AM
    Friday, June 22, 2012 10:54 AM
  • I had problem with opening PPT files from outlook attachments. This solution worked for me. Thanks !
    Friday, August 24, 2012 5:47 PM