none
Microsoft Office 2010 encountered an error during setup: With No error codes/

    Question

  • Hello Everybody.

    I am trying to deploy Office 2010 on a windows 7 Machine.. This machine has more then what it needs for hardware to run the software so I know it is not hardware related. At the end of the Install the installers hestiates and begins rolling back and finally providing "Microsoft Office 2010 encountered an error during setup:" but does not provide any error codes what so ever.

    I have tried upgrading, Fresh installs, side by side installs, Safe mode, Clean boot, Local admin accounts and other domain accounts. I have also tried numerous so called "fixes" but still get nothing. Sadly after the 2010 install fails 2007 no longer works so each attempt is abit time consuming.  Any Ideas out there that might solve issue ?

    Thursday, December 09, 2010 5:31 PM

Answers

  • Thanks for the response guys... This is what I did and passed it along to my colleagues and we are installing with out any failures now.. Customize the install and "run all from computer" but disable "Buisness Connectivity Services" under "Office Shared Features". We have been upgrading thousands of machines and none are failing.
    • Marked as answer by H3W3Y Tuesday, December 28, 2010 4:48 PM
    Tuesday, December 28, 2010 4:48 PM

All replies

  •  

    Hi,

     

     

    First try uninstalling all your Addins include connector to test the result.

     

    If not help, try the following steps:

    1) Create a new administrator account.

    2) Log on and launch the installer.

    If things don't quite work perfectly now:

    3) If you receive errors accessing your ProgramData folder, use the TakeOwnership registry hack to take control of the entire ProgramData folder, and if needed, create a "Microsoft Office" folder with "Microsoft Office 2010 Tools" inside it under %programdata%\Microsoft\Windows\Start Menu.

    4) Your error may return at the end of the installation, but don't worry, it's finished and Office is now installed. Switch user (don't log off!) and go back to your own user. Double-check that everything works. Now, to turn off your computer, press and hold the power button for five seconds. This will force the computer to shut down instantly, which will close the installer with the error without giving it the opportunity to roll back its changes.

     

    Sincerely,

     

    Harry 

     

    • Marked as answer by Harry Yuan Sunday, December 12, 2010 9:31 AM
    • Unmarked as answer by David Wolters Monday, December 13, 2010 2:29 PM
    Sunday, December 12, 2010 9:31 AM
  • Hi,

    Try the following three steps:

    Step 1) Run command msiexec /unregister

                Run command msiexec /regserver

    Step 2) Give full permissions to the folders c:/windows/installer

               Give Full permission to folder c:/windows/temp

    Step 3) Boot the computer in Clean boot.

    Best Regards,

    Harry

    • Marked as answer by Harry Yuan Thursday, December 23, 2010 8:43 AM
    • Unmarked as answer by David Wolters Thursday, December 23, 2010 2:19 PM
    Thursday, December 23, 2010 8:43 AM
  • Thanks for the response guys... This is what I did and passed it along to my colleagues and we are installing with out any failures now.. Customize the install and "run all from computer" but disable "Buisness Connectivity Services" under "Office Shared Features". We have been upgrading thousands of machines and none are failing.
    • Marked as answer by H3W3Y Tuesday, December 28, 2010 4:48 PM
    Tuesday, December 28, 2010 4:48 PM
  • I had to disable my user account controls.    Once I did this it installed with no problems. 
    Sunday, February 27, 2011 9:26 PM
  • Thanks for your tweak

    Monday, March 14, 2011 6:15 PM
  • Thanks for the response guys... This is what I did and passed it along to my colleagues and we are installing with out any failures now.. Customize the install and "run all from computer" but disable "Buisness Connectivity Services" under "Office Shared Features". We have been upgrading thousands of machines and none are failing.

    It works! Thanks!
    Saturday, April 30, 2011 1:05 PM
  • Hi,

     

    I had the same problem with a windows XP SP3 unit and here's a workaround that worked for me.

    1. Downloaded the Fixit for MS Office 2010(50450), run it but prompted with an error.

    2. Checked the installed .Net Framework, Version 2.0 is the one currently installed.

    3. Downloaded .Net Version 4.0 then installed it in the XP machine.

    4. After installation of .Net 4.0 and restart of the unit, run the Fixit (50450). Fixit run properly and ended with no errors.

    5. Installed the Ms Office 2010. Installation successful.

     

    Thanks!

     

    Monday, August 08, 2011 9:38 AM
  • Hi! I am having the same problem except I dont have an office cd, I have the office product key card- I was wondering if anyone can help me install it on my 64-bit Windows 7 computer? I have been trying to install since OCTOBER but i get "encountered error during setup" and nothing works! Whenever someone gets a solution, its by doing some complicated techy stuff that I dont understand! if you could please explain to me set by set what I have to do!! Please :) Im not so technological
    Thursday, March 28, 2013 1:09 AM