none
How can we make the Birthday field default value as empty rather than the Birthday string How can we make the Birthday field default value as empty rather than the Birthday string

    Question

  • Hi All,

    How can we make the Birthday field default value as empty rather than the Birthday string in the Edit Profile.aspx which is SharePoint Application page.When the user is trying to edit the profile and update the details,the birthday field has validation that we have to enter the Birthday in a specific format...

    when I didn't enter anything in the birthday field and trying to "save and close" I got the error specified by the below screen shot.  


    Help is appreciated.

    Thanks,

    Krishna      


    Krishnasandeep

    Sunday, March 04, 2012 5:52 PM

Answers

  • Hi sanny521,

    The user profile property Birthday by default doesn’t has a default value like “birthday”, and it seems difficult to set default value for it, even set birthday value for user profile, it should not be format as “bithday”, for your issue, it seems related with the profile page you use, would you please check whether the application page you use is the default profile page? Or do you have any modifications on it?

    Thanks,
    Qiao


    Qiao Wei

    TechNet Community Support

    Monday, March 12, 2012 10:38 AM
  • Hey,

    Why dont you add A CEWP with some jquery in it which will set the default value as empty.

    I think you can acheieve it this way

    Let me know if you have any queries :)


    "The Only Way To Get Smarter Is By Playing A Smarter Opponent"

    Monday, March 12, 2012 11:59 AM

All replies

  • Looks like the Birthday user property is configured as required. Assign a privacy policy to make that user property optional.

    Boris Velikovich

    Sunday, March 04, 2012 11:12 PM
  • Hi Boris,

    Thanks for your quick response.It is out of the box functionality.How can we make this as optional?

    One more information, it is not required field(optional only) still it is taking default value when I am not entering anything.

    Waiting for your response..

    Thanks,

    Krishna 


    Krishnasandeep

    Monday, March 05, 2012 3:12 AM
  • Krishna,

    This is how you want to configure your Birthday user property:

    Policy Setting: Optional

    Default Privacy Setting: Everyone

    User Can Override: Yes

    Display Settings: All three checkboxes are checked

    Source Data Connection: Windows to AD

    Attribute: createTimeStamp

    Direction: Import

    Please let me know whether this is the case with you.


    Boris Velikovich

    Monday, March 05, 2012 3:33 PM
  • Boris,

    how to configure all the above settings what you have mentioned?

    Thanks,

    Krishna


    Krishnasandeep

    Tuesday, March 06, 2012 12:27 PM
  • Krishna,

    1) Go to your User Profile Service Application.

    2) Follow the Manage User Properties link.

    3) Find and edit the Birthday user property.

    4) Make sure the settings are configured exactly as I indicated in my previous post.


    Boris Velikovich

    Tuesday, March 06, 2012 2:03 PM
  • Thank you Boris..

    But I did above mentioned settings but I dont find any default value update property there for birthday field

    when we edit the properties for birthday field in Manage user profile properties link.....


    Krishnasandeep

    Wednesday, March 07, 2012 6:17 PM
  • Hi sanny521,

    The user profile property Birthday by default doesn’t has a default value like “birthday”, and it seems difficult to set default value for it, even set birthday value for user profile, it should not be format as “bithday”, for your issue, it seems related with the profile page you use, would you please check whether the application page you use is the default profile page? Or do you have any modifications on it?

    Thanks,
    Qiao


    Qiao Wei

    TechNet Community Support

    Monday, March 12, 2012 10:38 AM
  • Hey,

    Why dont you add A CEWP with some jquery in it which will set the default value as empty.

    I think you can acheieve it this way

    Let me know if you have any queries :)


    "The Only Way To Get Smarter Is By Playing A Smarter Opponent"

    Monday, March 12, 2012 11:59 AM