none
"The language of this installation package is not supported by your system" Error Message when installing Office 2010

    Question

  • Hello, I am having a very hard time attempting to install Office 2010 Pro Plus on a system.  The error message that I receive is as follows:

    The language of this installation package is not supported by your system.

    I have tried running the Microsoft FixIt tool to remove any traces of Office 2007 and Office 2010.  Also, I have followed the instructions in KB928218 to manually uninstall any traces of Office 2007.

    I believe the user had both Office 2007 and Office 2010 installed previously.  There is no article to remove all traces of Office 2010.

    Here is some additional output from the Setup log:

    Parsing setup.xml file: F:\Access.en-us\setup.xml
    Error: Installation of this product requires operating system supplemental language support. Type: 54::NoSupportedCulture.

    Error: Installation of this product requires operating system supplemental language support. Type: 54::NoSupportedCulture.

    Error: Installation of this product requires operating system supplemental language support. Type: 54::NoSupportedCulture.

    Showing parent-less message Title: 'Setup Error', Message: 'The language of this installation package is not supported by your system.

    I have tried both running setup from a disc and a network share.  I am completely stumped and have been trying to get this to load for hours now.  Thanks in advance for any advice!

    Wednesday, June 30, 2010 3:12 PM

All replies

  • An attempt at installing Office 2007 installation also failed.  Setup log gave reference to CoCreateInstance error.

    What are the OS dependencies for Office 2007/2010 installation?  What .NET versions are required, if any?

    Thanks again for the support forum on this issue.

    Wednesday, June 30, 2010 8:33 PM
  • Hi,

     

    Thank you for contacting Excel IT Pro Discussions Services. 

     

    From your description, I understand that you encountered the following error when trying to install Office 2010:

    "The language of this installation package is not supported by your system"

     

    If there is any misunderstanding, please feel free to let me know.

     

    Please check if this blog helps:

    http://blogs.technet.com/b/jks/archive/2009/04/23/how-to-fix-the-error-the-language-of-this-installation-package-is-not-supported-by-your-system-during-office-products-installation.aspx

     

    If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Best Regards,

     

    Sally Tang

    Thursday, July 01, 2010 7:54 AM
  • I have already tried the tips recommended on this blog.  This error shows up in the setup log:

    Error: CoCreateInstance failed HResult: 0x80040154.

    Thursday, July 01, 2010 1:16 PM
  • Hi,

     

    Thank you for taking the time to reply. I am sorry to hear that the problem persists.

     

    Based on the current situation, this issue might be related to some language settings when deploying the Office program. Please check the use OCT tool to open the .msp file in the Updates folder, and the configure.xml file in the core product folder to see the language settings.

     

    For more information on how to customize the language settings when deploying Office 2010, you can refer to the following article:

    http://technet.microsoft.com/en-us/library/dd162397.aspx#BKMK_CustomizeLanguageSettings

     

    Best Regards,

     

    Sally Tang

    Monday, July 05, 2010 8:22 AM
  • Thanks Sally for the response.  To make clearer what is happening, I have one machine that is not processing installation attempts for Office 2010 (and Office 2007) correctly.

    I have a number of other machines that are processing the same installations just fine.  You are correct in your last post about customizations being made to Office 2010.  However, I have tried 2 additional troubleshooting steps to further narrow down the issue.

    First, I have verified that the same installation package works correctly on other machines and it does.  It is actually installed successfully on 2 machines of mine, among others.  Second, I have backed away from the customized installation for the purpose of testing with this problematic machine and have just tried doing a vanilla installation from a brand new CD that I cut myself from the MVLS website.

    I have followed the same troubleshooting steps for Office 2007 as well and the same error that I referenced in my last post persists.  I have tried running the Microsoft FixIt tools for Office 2007 and Office 2010 over this machine and I have gone through the manual uninstallation steps for Office 2007 (no manual steps are drafted for 2010 that I can find).

    Therefore, I wanted to make clear that I'm not trying to correct (directly, at least) a symptom with the installation package but rather a symptom on this one specific machine.  That's why I asked the question about OS prerequisites or dependencies.  It appears from this end that there is something underlying here on this machine that I just can't catch.

    Do you have any advice as to additional troubleshooting steps that I can take on this machine to pin down what is preventing Office 2010 (or Office 2007) from installing correctly?  My apologies if I was not being clear earlier regarding what I am trying to get out of this thread.  It would take a long time to rebuild this machine as the user has lots of specialized software.

    Wednesday, July 07, 2010 4:59 AM
  • Any additional ideas here?  Thanks again.
    Thursday, July 08, 2010 7:44 PM
  • Any of protection tools may cause to this error message..

    like McAfee try to disable on access scan option :)

    this was my solution...

    Turhan

    Friday, January 24, 2014 12:49 PM