none
Fields do not update in Word 2010

    Question

  • How do you get fields to update automatically in Word 2010?  They should be updating when the document is opened but almost every one I've tried is not.

    An example is the "filename" field.  If it is added to a document, and the document is saved and closed, but then the filename is changed, when the document is re-opened it still shows the old field value.  You have to right click on the field value and choose "Update field" to get it to update which defeats the purpose for our needs.

    It should be noted that the "date" field does not have this problem.  It auto-updates and also auto-highlights when it is hovered over.  Additionally, when it is single-clicked on, a nice "update" tab appears over the field.  Why aren't all the field codes working like this?

    Monday, August 02, 2010 1:15 PM

Answers

  • Most fields do not update automatically. This is by design - notable exceptions are Date fields and Styleref fields.
    You can force an update with a macro. The sample update macro at http://www.gmayor.com/installing_macro.htm will do the job most of the time. Add it to a button on the QAT or Ribbon.

    <jpennin2> wrote in message news:0fdae375-5942-4d0b-a6dc-ae87f22d5e13@communitybridge.codeplex.com...

    How do you get fields to update automatically in Word 2010?  They should be updating when the document is opened but almost every one I've tried is not.

    An example is the "filename" field.  If it is added to a document, and the document is saved and closed, but then the filename is changed, when the document is re-opened it still shows the old field value.  You have to right click on the field value and choose "Update field" to get it to update which defeats the purpose for our needs.

    It should be noted that the "date" field does not have this problem.  It auto-updates and also auto-highlights when it is hovered over. Additionally, when it is single-clicked on, a nice "update" tab appears over the field.  Why aren't all the field codes working like this?


    Graham Mayor - Word MVP
    www.gmayor.com
    Posted via the Communities Bridge
    http://communitybridge.codeplex.com/
    • Marked as answer by Sally Tang Tuesday, August 03, 2010 7:23 AM
    Monday, August 02, 2010 2:35 PM
  • Specifically regarding the Filename field, MS changed it starting in
    Word 2002 so it wouldn't automatically update, according to
    http://support.microsoft.com/?kbid=832897

    The "reason" cited in the article is not believable. I don't know what
    the real reason could have been.

    --
    Jay


    Jay Freedman MS Word MVP
    • Marked as answer by Sally Tang Tuesday, August 03, 2010 7:23 AM
    Tuesday, August 03, 2010 2:02 AM

All replies

  • Most fields do not update automatically. This is by design - notable exceptions are Date fields and Styleref fields.
    You can force an update with a macro. The sample update macro at http://www.gmayor.com/installing_macro.htm will do the job most of the time. Add it to a button on the QAT or Ribbon.

    <jpennin2> wrote in message news:0fdae375-5942-4d0b-a6dc-ae87f22d5e13@communitybridge.codeplex.com...

    How do you get fields to update automatically in Word 2010?  They should be updating when the document is opened but almost every one I've tried is not.

    An example is the "filename" field.  If it is added to a document, and the document is saved and closed, but then the filename is changed, when the document is re-opened it still shows the old field value.  You have to right click on the field value and choose "Update field" to get it to update which defeats the purpose for our needs.

    It should be noted that the "date" field does not have this problem.  It auto-updates and also auto-highlights when it is hovered over. Additionally, when it is single-clicked on, a nice "update" tab appears over the field.  Why aren't all the field codes working like this?


    Graham Mayor - Word MVP
    www.gmayor.com
    Posted via the Communities Bridge
    http://communitybridge.codeplex.com/
    • Marked as answer by Sally Tang Tuesday, August 03, 2010 7:23 AM
    Monday, August 02, 2010 2:35 PM
  • Specifically regarding the Filename field, MS changed it starting in
    Word 2002 so it wouldn't automatically update, according to
    http://support.microsoft.com/?kbid=832897

    The "reason" cited in the article is not believable. I don't know what
    the real reason could have been.

    --
    Jay


    Jay Freedman MS Word MVP
    • Marked as answer by Sally Tang Tuesday, August 03, 2010 7:23 AM
    Tuesday, August 03, 2010 2:02 AM
  • i, too, wish there was a way to get fields to update in documents by default, or at least without resorting to macros (which are disabled and difficult). 

    The "filename" field in particular is my pain point. Goddamn how many documents have I printed with the wrong "filename" due to me forgetting to manually update the filed EVERY TIME I save?  please help!

    Friday, May 04, 2012 2:25 AM
  • i, too, wish there was a way to get fields to update in documents by default, or at least without resorting to macros (which are disabled and difficult).

    The "filename" field in particular is my pain point. Goddamn how many documents have I printed with the wrong "filename" due to me forgetting to manually update the filed EVERY TIME I save? please help!


      
      
    Actually, using a macro is the easiest solution. Note, however, that for a FILENAME field in the header or footer, switching to Print Preview (called the Backstage view in Word 2010) and back to your previous view does the job (you can use Ctrl+F2 followed by ESC).

    Stefan Blom, Microsoft Word MVP
    Friday, May 04, 2012 4:29 PM
  • What about this:

    Ctrl-A (selecting all)

    Right click anywhere in the documet

    Click "Update Field" from the drop down menu.

    This will update all of the fields in the document.

    Thanks to Park Bramhall for this idea.

    Thursday, May 10, 2012 12:21 PM
  • Of course, if you checked Word's option to 'update fields before printing', this wouldn't be an issue.

    Cheers
    Paul Edstein
    [MS MVP - Word]

    Thursday, May 10, 2012 12:43 PM
  • What about this:

    Ctrl-A (selecting all)

    Right click anywhere in the documet

    Click "Update Field" from the drop down menu.


           

    Note that if you rely on the selection, you'd have to select header and footer content separately (the same thing applies to text boxes).


    Stefan Blom, Microsoft Word MVP
    Thursday, May 10, 2012 6:48 PM
  • In previous versions of Word (at least up to 2003), Selecting the whole document in Normal view and clicking F9, or Update field, would update the whole document, including the Headers and Footers.

    For some reason you've changed this good behavior.

    Now, it is necessary to update each header and each footer individually. This is a pain in a long document, with multiple headers / footers, as well as defeating the purpose of using fields.

    <Flame>Sigh. Really. 2007 / 2010 updates to UI and other 'features' do not seem well thought through or to enhance usability. They do no more than require us to spend money on unnecessary program updates.</Flame>

    Monday, July 30, 2012 9:36 AM
  • Ctrl-A (to select the whole document), F9 has never updated fields anywhere other than the body of the document. So you'll be glad to know the functionality hasn't been reduced. A Print Preview is usually sufficient to update all header/footer fields.

    Cheers
    Paul Edstein
    [MS MVP - Word]

    Monday, July 30, 2012 10:14 AM
  • What's the point of adding the field if it doesn't update?

    For our more advanced users they know and they do what they need to do, BUT we want everyone in our shop to participate and that results in some, who are less familiar with the idiosyncratic nature of Word, with incorrect data in their file.

    Bad info is worst than no info, or at least more embarrassing.

    Has anyone tried the new Office for improvements?

    Thursday, August 16, 2012 3:36 PM
  • What's the point of adding the field if it doesn't update?


               

    The only explanation that I know of is the one offered in the article that Jay linked to: http://support.microsoft.com/kb/832897/en-us/. As Jay points out, it isn't much of an explanation, though.


    Stefan Blom, Microsoft Word MVP


    Thursday, August 16, 2012 5:36 PM
  • Except the link is out dated, perhaps their response was found to be lacking?

    Thursday, August 16, 2012 6:02 PM
  • "GDodman" wrote in message news:4ae9822e-40a8-4a27-adda-68d85647d464@communitybridge.codeplex.com...
    Except the link is out dated, perhaps their response was found to be lacking?

     
    I have now updated the link in my reply.

    Stefan Blom, Microsoft Word MVP
    Thursday, August 16, 2012 6:06 PM
  • Please mark solution which worked for you.
    Friday, August 17, 2012 10:05 AM
  • hey there, thanks.... I used to be an expert user from Word version 3 to Office 2007 - just back to uni so having to almost relearn...  this was Exactly the answer I was trying to jog my memory for... cheers tj
    Tuesday, February 05, 2013 1:29 AM
  • Go to File > Options > Advanced, under "Show Document Content" check the box for "Show field codes instead of their values". Click OK.

    Now go back and uncheck the same box. Click OK

    You'll have updated fields.

    Tuesday, April 23, 2013 6:45 PM
  • Toggling Print Preview (Ctrl-Alt-I, Esc) involves a lot less circumlocution ...

    Cheers
    Paul Edstein
    [MS MVP - Word]

    Tuesday, April 23, 2013 6:54 PM
  • Thanks Paul,

    that's the most effective solution yet.

    Garry

    Tuesday, April 23, 2013 8:57 PM
  • Thanks Paul,

    that's the most effective solution yet.

    Garry





    But note that switching to Print Preview and back is also mentioned in the KB article linked to last year...

    Stefan Blom, Microsoft Word MVP

    Tuesday, April 23, 2013 9:36 PM
  • Graham Mayor's macro rules.  Selecting all then updating fields (which I had on my QAT) only worked if I opened the header/footer first-too many steps, and I would forget.  The print preview workaround was too many steps.  This is workable.  Thanks Graham!
    Thursday, July 18, 2013 8:51 PM