none
Spell Check Not working in Office 2013

    Question

  • It appears that the Main Dictionary my be missing on this evaluation using a Licencing Software Assurance Key for Office 2013 (Issued automatically with my Office 2010 Licence)

    Has anybody had the same problem and knows a fix?

    Office 2013 x86

    Windows 8 Pro (Enterprise Edition) x64

    Wednesday, November 21, 2012 8:01 PM

Answers

  • Hi,

    Is there any .DIC or .dic file reserved in the following path?

    %appdata%\Microsoft\UProof

    If so, back up all these files. Add the custom dictionaries via:

    • Click the File tab.
    • Click Options.
    • Click Proofing.
    • Make sure the Suggest from main dictionary only check box is cleared.
    • Click Custom Dictionaries.
    • Click Add.
    • Locate the folder containing the custom dictionary you want, and then double-click the dictionary file.

    Best regards,


    Rex Zhang
    TechNet Community Support
    A new Office has arrived, try it now.
    A beautiful Start. It begins here. Windows 8 and Windows RT.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, November 22, 2012 1:50 AM

All replies

  • Hi,

    Is there any .DIC or .dic file reserved in the following path?

    %appdata%\Microsoft\UProof

    If so, back up all these files. Add the custom dictionaries via:

    • Click the File tab.
    • Click Options.
    • Click Proofing.
    • Make sure the Suggest from main dictionary only check box is cleared.
    • Click Custom Dictionaries.
    • Click Add.
    • Locate the folder containing the custom dictionary you want, and then double-click the dictionary file.

    Best regards,


    Rex Zhang
    TechNet Community Support
    A new Office has arrived, try it now.
    A beautiful Start. It begins here. Windows 8 and Windows RT.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, November 22, 2012 1:50 AM
  • Hi,
     
    As I have not heard from you for several days. I will go ahead and close this thread. If you have any questions, please feel free to reply to us and this thread will be re-opened.

    Best Regards,


    Rex Zhang
    TechNet Community Support

    Friday, November 30, 2012 9:20 AM
  • I am having the same problem
    Wednesday, February 13, 2013 5:40 PM
  • I have never used this site before, but yes i am having the same problem. Words that are blatanly spelled incorrectly are not being changed. When I hit the spell check it says spelling check done.
    Wednesday, February 13, 2013 5:42 PM
  • I just noticed this tonight on my Windows 7 Enterprise system.  Word was catching grammar mistakes but missing some obvious misspelled words.  Just for the heck of it, I set the proofing options to only use the main dictionary.  Viola, spellcheck started working normally.  So I cleared the option for only using the main dictionary to see if that setting mattered, and spellcheck continued to work.  Not sure what happened behind the scenes, but maybe this does a form of reboot on the spellcheck function =)
    Thursday, February 14, 2013 6:14 AM
  • I have never used this site before, but yes i am having the same problem. Words that are blatanly spelled incorrectly are not being changed. When I hit the spell check it says spelling check done.

     

    Stefan Blom, Microsoft Word MVP
    Thursday, February 14, 2013 12:31 PM
  • My problem seems to be unique. Half of my document spell checks and the other half doesn't. I don't know how to fix it I have tried everything suggested here and I have tried other things suggested else where. If anyone knows anything it would be appreciated :)

     
    Friday, March 01, 2013 12:55 AM
  • My problem seems to be unique. Half of my document spell checks and the other half doesn't. I don't know how to fix it I have tried everything suggested here and I have tried other things suggested else where. If anyone knows anything it would be appreciated :)





    That definitely sounds like a language formatting issue. What have you tried so far, specifically? In particular, the article at http://wordfaqs.mvps.org/MasterSpellCheck.htm should be useful.

    Stefan Blom, Microsoft Word MVP

    Friday, March 01, 2013 2:33 PM
  • Rex, I appreciate your response and I followed your suggestion. However, my spell check in Word 2013 is still ignoring all misspelled words. Your suggestion made me think that I might be able to copy a dictionary from another app. So I grabbed a dictionary from EverNote and I was able to add it after I converted it to Unicode. I made this new dictionary the default and I made sure the Suggest From Main Dictionary Only was not checked. Sounds like a great plan, right? Didn't work. I still have a spell checker that will lose to my 5 year old granddaughter.

    Tuesday, April 09, 2013 7:12 PM
  • I am upgrading an organization from Office 2003 (with Outlook 2007 installed on top) to Office 2013. Many users are reporting Spell Check issues. For some Spell Check works fine in Word but not in Outlook. In all cases if I blow away their current profile and have them login as a new user, the problem is completely solved.

    So I am guessing that existing profiles have something in the registry, or elsewhere that is leftover from the previous Office installation and this is causing problems.

    I am doing a full uninstall of the previous Office before installing the new Office 2013. But obviously this would not touch the registry hive in their profile.
    Tuesday, April 16, 2013 3:04 PM
  • I am having the same problem as others here. Spellcheck will slowly highlight some words but not flag or change most misspellings.

    I have a file named CUSTOM.DIC at the following path:

    C:\Users\xxxx\AppData\Roaming\Microsoft\UProof

    It is already selected as my custom dictionary. Deselecting and reselecting it does not fix the problem, neither does selecting and then deselecting 'suggest from main dictionary only'.

    EDIT: I have also tried signing in and out of my account. No joy there either.


    • Edited by xCFGx Monday, April 29, 2013 12:56 AM
    Monday, April 29, 2013 12:54 AM
  • Try the following, this worked for me after moving from 2010 to 2013.  A portion of my document was not getting spell checked.  That portion (which was what I typed into my document after the upgrade).  Anyway after I read much of the answers what I did was go to languages.  I removed all editing languages besides English.  I also set English to be the default on both the display language, and help language.  I restarted word and it seems to have worked.
    Friday, June 14, 2013 4:35 AM
  • I have the exact sme proglem.  Maybe I should go back to 2010 version of Worod.  Spell Check works in 2013 Excell
    Monday, June 17, 2013 12:56 AM
  • I'm not sure which post you would like a response to... this one or the other you posted 4 minutes earlier. Obviously I have chosen this one but in the future please don't double post.

    If you have a document open and it contains multiple language each paragraph must be marked with the designated language. Go to the Review tab and choose Set Language. Make sure your default language is set properly and if not correct it and click OK.

    Now select paragraphs of text that in the other language, open the Language dialog again and set the language that the selected paragraph of text is. Click OK.

    Now go to Word > File > Options > Proofing and Click the Custom Dictionaries button. Make sure "All Languages" is the setting for dictionaries. Click OK.

    Make sure on the Word Options dialog that neither of the Exceptions boxes are marked. Also note that if your alternate language is still selected in your document that the Grammar settings for that language can now be made.

    After you are done, click the Recheck Document button. Hopefully it now shows any spelling/grammar errors in all designated languages. If it does not... save the file, close and quit Word completely and reopen the document.

    Hopefully this helps


    Kind Regards, Rich ... http://greatcirclelearning.com


    Monday, June 17, 2013 2:03 AM
  • This exact thing happened to me and I realized I was using a document my teacher created as a template. This seems to be happening in the middle of the document. Very odd. You did not expect MS to release Office without some bugs did you?
    • Proposed as answer by Jester8947 Friday, December 13, 2013 3:51 PM
    • Unproposed as answer by Jester8947 Friday, December 13, 2013 3:51 PM
    • Proposed as answer by Jester8947 Friday, December 13, 2013 3:51 PM
    Wednesday, September 04, 2013 11:28 PM
  • I have found in our Academy that this appears to happen when text formatting is applied, if you copy the content of the document to a new document and paste just the text with no formatting Spell check works. This has worked for me not ideal but maybe get some other ideas bouncing off the wall.
    Friday, December 13, 2013 3:54 PM
  • I am having the same problem in Word 2013.

    I think I may have tracked down the source of the problem, or perhaps a contributing factor, but am unable to fix it:

    File > Options > Language

    In the "Choose Editing Languages" box I see on a single entry

    Editing Language: English (Australia) <default>
    Keyboard Layout: Enabled
    Proofing (Spelling, Grammar...): Not installed

    The "Not installed" text is a hyperlink to this page: http://office.microsoft.com/en-au/language-packs/?LpArch=x64

    So then I choose 'English' from the "Select a language" drop-down box, and go through the motions of downloading and installing the file "proofingtools_en-us-x64.exe". When installing, I get the message "Almost there - just restart Word and you're good to go".

    So I restart Windows, type some badly spelled words into a blank document - but spell checking still isn't working. When I select

    Review > Spelling & Grammar

    I still get the message: "Spell check complete. You're good to go!".

    So I go back to File > Options > Language and nothing has changed! I'm still seeing the "Not installed" message. I've tried restarting my PC several times in between attempts to install the Proofing Tool software - but still no luck.

    Frustrated! :-/


    • Edited by ItomicSpaceman Friday, January 10, 2014 5:31 AM inserted a screen shot
    Friday, January 10, 2014 5:12 AM
  • fyi: for me, I believe I've found the answer over here thanks to Doug Robbins:

    http://answers.microsoft.com/en-us/office/forum/office_2013_release-word/cant-install-default-editing-language-in-word-2013/b6c67738-956d-48ca-810c-869135ece1fc

    In summary - the proofing tools were DISABLED for MS Office Pro 2013, so I had to set them to "Run from my computer".

    Thanks again Doug.

    • Proposed as answer by alexarchitect Wednesday, January 29, 2014 9:45 AM
    Monday, January 13, 2014 12:11 AM
  • I have a similar problem... Word and Powerpoint cannot spell check.  I am using Office Standard 2013 on Windows 7 and when I am in word and I type "Todai is Fryday and it shold be an weakend souner thin nows." and press F7 it tells me "Spelling and grammar check complete.  You're good to go!"   I think my 4 year old can do better than this.   I have tried a number of the suggestions about but none seem to make any difference.  What should I try now.   If I cannot get this resolved soon,  I am almost to the point of uninstalling 2013 and going back to my 2003 version.  At least it works.
    Monday, January 20, 2014 7:47 PM
  • I have a similar problem... Word and Powerpoint cannot spell check.  I am using Office Standard 2013 on Windows 7 and when I am in word and I type "Todai is Fryday and it shold be an weakend souner thin nows." and press F7 it tells me "Spelling and grammar check complete.  You're good to go!"   I think my 4 year old can do better than this.   I have tried a number of the suggestions about but none seem to make any difference.


    What have you tried, specifically?


    Stefan Blom, Microsoft Word MVP

    Monday, January 20, 2014 7:50 PM
  • hi Please help I also have the same issue. i tried everything already.
    Wednesday, February 05, 2014 4:16 AM
  • This worked for me:

    Go to registry -  HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\Proofing Tools and remove any language that is in there, only (Default) should be here.

    Thursday, March 06, 2014 1:24 PM
  • I have found in our Academy that this appears to happen when text formatting is applied, if you copy the content of the document to a new document and paste just the text with no formatting Spell check works. This has worked for me not ideal but maybe get some other ideas bouncing off the wall.

    This was the simplest and most effective answer.

    It worked beautifully, thank you.

    Wednesday, May 14, 2014 3:20 PM