none
Outlook auto-refresh of subscribed ICS calendar.

    Question

  • Greetings,

    I realize I am mentioning Exchange 2010 in this post, but I believe this to be an Outlook issue.

    I recently tested the Exchange 2010 feature of being to publish one's calendar to the Internet as either an ICS or URL. The URL opens the calendar up just fine in a web interface, and one can then subscribe to the calendar either using the subscribe button on the web interface, or by using the ICS extension directly.

    The issue is once the calendar is displayed in Outlook, it never seems to update, even after 24 hours. The only way I have found to update the ICS is by removing the calendar and re-subscribing to it. Is there some way to get Outlook to periodicaly auto-refresh the external ICS calendar? Otherwise it seems like you aren't really "subscribed" to it, but rather took a point in time snapshot of it which will not be clear at all to our outside user base.

    Thanks!

    Friday, March 18, 2011 1:18 PM

All replies

  • Hi,

     

    The auto-refresh settings can be configured when you add the ics calendar. But not all the ics calendars can be configured how to auto-refresh.

     

    For example, you can see:

    http://mcb.berkeley.edu/academic-programs/seminars/ical-feed-instructions/

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    Best Regards,

     

    Sally Tang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com

     

    Monday, March 21, 2011 5:06 AM
  •  

    Hi,

     

    I am writing to see how everything is going with this issue. Is the problem resolved? If there is anything I can do for you, please feel free to let me know.

     

    Best Regards,

     

    Sally Tang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com   

    Wednesday, March 23, 2011 7:40 AM
  • My apologies for not responding sooner. For someon reason I never got an email notification that you responded on the 21st. I did get the one above so thank you for posting a follow up.

    Is it possible to configure Outlook to launch the Internet Calendar subscription process in the link you provided above when someone clicks on the "Subscribe" button on an Exchange 2010 OWA based ICS calendar? It currently looks like the ICS is just downloaded locally and added which means it will never get updated.

    Thanks!

    Wednesday, March 23, 2011 8:04 PM
  • Hi

    What happens if you go to File > Account Settings and then the Internet Calendars Tab, then click New and enter the path/address to the calendar?  Does it update that way - especially after hitting F9?

    Thanks!



    Larry - MSFT
    Tuesday, March 29, 2011 12:33 AM
    Answerer
  • @Larry - if you set up the ICS subscription in Outlook manually the way you described, it does seem to update periodically.

    The issue I see is that a normal user is going to click the Exchange 2010 published calendar "Subscribe" button, see the calendar show up in Outlook, and think they have a subscription to the calendar as opposed to a point-in-time snapshot of the calendar.

    So does anyone know of a way to force Outlook into a full "subscription" mode when someone clicks on an .ICS file? Otherwise the ICS file appears to be downloaded and added like a static file.

    Tuesday, March 29, 2011 4:29 PM
  • Hi

    I do not believe there is way to configure Outlook to handle ICS files this way.  What version of Outlook are you using?  2007 or 2010?

     


    Larry - MSFT
    Monday, April 11, 2011 5:32 PM
    Answerer
  • @Larry - Thank you for responding!

    My team has tested this with both Outlook 2007 and Outlook 2010, and both exhibit the same behavior of only activating the point-in-time download of the calendar. After thinking about it some, I'm not sure there is much we can do at the client level since Outlook is just reacting to the .ICS file extension file AFTER the web browser has already downloaded it.

    About the only thing my team and I came up with was rewording the button on the Exchange 2010 published calendar page to say "Download" instead of Subscribe. That is unless Microsoft can change the link on the file somehow to be something more than a file download.

    Thanks!

    Tuesday, April 12, 2011 4:43 PM
  • Hi

    Sorry my reply took so long...
    First of all, this is by design when you open a .ICS file via hyperlink (take a look at the Q&A on the second link below)
    However, if you have access to the webserver hosting the ICS files, iyou can change how Outlook handles opening ICS files.
    If you create a link (ie.. on a webpage) to the .ICS file that uses webcal, then when you click on it via a browser, Outlook will add it as an Internet Calendar.
    For example, create a link to the ICS Calendar file like this:
    webcal://www.myserver.com/calendars/mycalendar.ics

    When a user clicks on the file, they should be prompted to "Add this Internet Calendar to Outlook and subscribe to updates"
    After clicking Yes, the Calendar should be added to Outlook
    In my testing (I was using Outlook 2007 in my testing), hitting F9 forced a refresh of the Calendar after it was updated
    It should also be added as an Internet Calendar in Tools > Accounts Settings > Internet Calendars

    See also
    http://blogs.msdn.com/b/michael_affronti/archive/2006/05/10/594986.aspx
    http://blogs.msdn.com/b/michael_affronti/archive/2006/05/18/601505.aspx

    Thanks!


    Larry - MSFT
    Wednesday, April 20, 2011 11:25 PM
    Answerer
  • I apologize for this massive delay in response, somehow I never got notified that you had responded to me and I went searching on the Internet again and found your response.

    I guess my first question would be if someone could ping the Exchange product group and see if they can update the link they are providing with the "subscribe" button to be a webcal://filename.ICS versus http://mail.company.com/owa/calendar/user@company.com/Calendar/calendar.html# which in turn downloads the ICS file locally.

    Thanks!

    Friday, June 24, 2011 7:07 AM
  • Anyone figure out how to get the Outlook client to not download the one time copy of the publishing user's ICS calendar when they click the "Subscribe" link?
    Friday, February 03, 2012 9:35 PM
  • I agree - I've spend literally days working on this thinking there was an issue with my Exchange server, but it turns out that it's likely that this is by design!

    Quite difficult to think that no one is complaining about this.

    Come on guys - right now internet sharing for Calendars via Exchange server is unusable.

    Saturday, December 29, 2012 1:41 AM
  • <label style="font-size:13px;font-family:'Segoe UI', Helvetica, Arial, sans-serif;line-height:normal;">Wording from within OWA "Link for subscribing to this calendar" option:</label>

    "Subscribe Link Send this link if you want to allow people to see your calendar and get automatic updates."

    Sounds like it's supposed to automatically update to me???

    Can someone from MS please respond?

    Saturday, December 29, 2012 3:01 AM
  • Hey guys, sorry, but has anyone found a solution yet? No matter how much i try, exchange calendars will not update once subscribed to them. Need to re-subscribe to view calendar, but that's not efficient. I have tried sharing a google calendar, hotmail calendar and they both do the same. Exchange will not update :/
    Thursday, January 03, 2013 11:08 AM
  • To my knowledge this has not changed and won't change until Microsoft either changes the behavior of the "Subscribe" button in OWA (RE: the WebCal reference above), or changes Outlook to prompt the user if they want to download a local copy of the ICS file (the current behavior) or reference it from a web URL.

    Essentially we are stuck with a Subscribe button that isn't actually a subscription until Microsoft changes something either in Oultook or Exchange.

    Thursday, January 03, 2013 3:19 PM
  • :/, I'd like to test out Exchange 2013 and see if it works on there.
    Thursday, January 03, 2013 4:08 PM
  • Hi Dean and HotFix,

    I've struggled with this same issue for a while too.  I basically wanted to have an auto-updating subscription to a public google calendar using Outlook 2007.  While I don't have a fix, I've done two things that have greatly helped my situation and perhaps they will help you and trigger some additional discussion:

    1) I updated the link to the google calendar from https://..../basic.ics to webcal://.../basic.ics on my webpage.  Thus, when selected in the web browser, the web browser no longer asks to download the file and instead offers to launch my calendar client...which in my case is Outlook 2007.  I verified that the calendar is indeed an "Internet Calendar" by going to Tools->Account Settings and selecting the "Internet Calendars" tab.  Unless the calendar is listed there, Outlook is not subscribed.  I understand Internet Calendars are not supported before Outlook 2007.  Upon clicking on the webcal link, Outlook with throw a prompt reading "Add this Internet Calendar to Outlook and subscribe to updates?", at which point selecting "Yes" gets things working as desired.  I believe the functional equivalent would be to copy the https://.../basic.ics link to the clipboard and manually configure a New Internet Calendar.

    2)  To force Outlook to update the calendar without unsubscribing and re-subscribing, choosing Tools->Send/Receive->Send/Receive All would refresh the calendar for me.  I suppose that's the same as hitting F9.

    I know this is basically just a rehashing of the previous discussions.  I suppose I'm just saying that for me, it basically works.  I've now been able to subscribe to a public google calendar using a Mac (OS 10.8), an iPhone (iOS 6.1.3) , and a PC (Win 7, Outlook 2007).  Also, the initial question seems to be geared towards sharing an Exchange calendar, which I alas have not attempted, but I'm happy that I at least got some part of the Internet Calendar functionality in Outlook to work.

    Wednesday, March 27, 2013 4:01 AM
  • If Microsoft could recode their Exchange 2010 web interface to provde the link with "webcal://..." versus "https://...", then I think that would solve the issue based upon my research. Until they do though I think we are stuck with the subscription not working as users would anticipate it would.

    The Exchange product group is heavily focused on Exchange 2013 at this point so even if they "fixed" this issue, they probably would only do so in Exchange 2013.

    Wednesday, March 27, 2013 3:57 PM
  • Subscribing to an Internet calendar via Outlook desktop works great thanks for the post, anyone know how to do the same on OWA?  I get the calendar to sync once, then it never refreshes.

    John

    Monday, June 10, 2013 4:54 PM
  • Even if the site providing the calendar is still using http:// rather than webcal://, I've found a quick and dirty cheat.  Rather than clicking on the ical link, right click and select copy hyperlink.  Then, in a new browswer tab, paste the hyperlink, BUT DO NOT HIT ENTER.  Edit the http, changing it to webcal. Then hit enter.

    Fredrik V Coulter MOS (SharePoint 2010, Excel 2007), MOCMI (2003), MOCE (Acess, PowerPoint, Word, Excel 97), MCP (2.0)


    • Edited by Fredrik.Coulter Friday, March 21, 2014 1:19 PM got my left and right mixed up
    Friday, March 21, 2014 1:17 PM
  • I think this is being overcomplicated...   Go to Tools > Account Settings > Internet Calendars, then change the settings for the internet calendar.  There is a checkbox for "Update Limit."  If you uncheck this box then the calendar will refresh everytime you hit Send/Receive.  If you leave it checked, then it will use the publisher's recommendation for intervals to refresh.  Google calendars don't have a published recommendation, so unless this box is unchecked the calendar will never refresh.

    I use OWA with exchange, and it seems that if I add an internet calendar to my Outlook 2007 client, then it shows up in OWA as well.  This could be an Exchange server setting, but I am not the Admin to assist with what setting that may be...

    Monday, April 07, 2014 1:03 PM
  • I think this is being overcomplicated...   Go to Tools > Account Settings > Internet Calendars, then change the settings for the internet calendar.  There is a checkbox for "Update Limit."  If you uncheck this box then the calendar will refresh everytime you hit Send/Receive.  If you leave it checked, then it will use the publisher's recommendation for intervals to refresh.  Google calendars don't have a published recommendation, so unless this box is unchecked the calendar will never refresh.

    I use OWA with exchange, and it seems that if I add an internet calendar to my Outlook 2007 client, then it shows up in OWA as well.  This could be an Exchange server setting, but I am not the Admin to assist with what setting that may be...


    I think you are misunderstanding the scenario that is described here. Following the steps we discussed of clicking the link provided by a CAS, the ICS file is downloaded and referenced locally, and the source calendar is never referenced.
    Monday, April 14, 2014 6:32 PM