none
Adding Web folders as trusted locations using Office 2010 OCT

    Question

  • I am unable to add a Web folder (that is, http://paths) as a trusted locations using Office 2010 OCT. Is this behavior by design or do I need to set additional settings to allow me to add Web folders as trusted locations?

    I am attempting to add by doing the following:

    1. In the navigation pane of the OCT, click Office security settings.

    2. Change the default security setting 'Microsoft Word - Allowed trusted locations options' to "Allow trusted locations that are NOT on user's computer"

    3. In the 'Add the following paths to the Trusted Locations list:' section I click 'Add'

    4. For Application, I select 'Microsoft Word'

    5. For Path I enter, http://mypath.intranet.com

    6. Click 'OK'

    I get an error that the specified folder is invalid. UNC paths work, but I need to specify http:// locations for all users. Is this possible with OCT?


    Thursday, April 07, 2011 8:05 PM

Answers

  • Hi,

     

    Sorry, it is like what you said, I failed to add the web folder as the trust location, too.

     

    So let's add the web folder by adding registry in the OCT, or do the setting with GPO.

     The registry is like this:

    Windows Registry Editor Version 5.00

     

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy Objects\{F62B4452-37B4-4EF7-BB20-E561C5687539}User\software\policies\microsoft\office\14.0\word\security\trusted locations\location1]

    "Path"=hex(2):45,00,3a,00,5c,00,54,00,45,00,53,00,54,00,54,00,45,00,4d,00,50,\

      00,30,00,31,00,00,00

    "Date"=""

    "Description"=""

    "AllowSubFolders"=dword:00000000

     

     

     

    Sincerely,

    Max Meng

    Wednesday, April 13, 2011 9:22 AM

All replies

  • Hi,

    Thanks for using Microsoft Office for IT Professionals Forums.

    You can specify Web folders (that is, http:// paths) as trusted locations, but not all Web folders are recognized as trusted locations.

    Specifying Web folders as trusted locations:

    You can specify Web folders (that is, http:// paths) as trusted locations, however, only those Web folders that support Web Distributed Authoring and Versioning (WebDAV) or FrontPage Server Extensions Remote Procedure Call (FPRPC) protocols will be recognized as trusted locations. Use the following guidelines if you are not sure whether a Web folder supports the WebDAV or FPRPC protocols:

    If an application is opened by Internet Explorer, check the most recently used files list. If the most recently used files list indicates that the file is located on a remote server, rather than in the Temporary Internet Files folder, it is likely that the Web folder supports WebDAV in some form. For example, if you click a document while browsing in Internet Explorer, and the document opens in Office Word 2007, the most recently used files list should show that the document is located on the remote server and not in the local Temporary Internet Files folder.

    Try to use the Open dialog box to browse to the Web folder. If the path supports WebDAV, you should be able to browse to the Web folder or you should get prompted for credentials. If the Web folder does not support WebDAV, navigation fails and the dialog box closes.

    For more information about using environment variables to specify trusted locations and specifying Web folders as trusted locations, see Plan trusted locations and trusted publishers settings for the 2007 Office system.

    http://technet.microsoft.com/en-us/library/cc179039(office.12).aspx

    Sincerely,
    Max Meng




    Monday, April 11, 2011 1:55 AM
  • Hi Max,

    Thanks for the response. The http:// locations I am trying to add are to our internal sharepoint site. I also verified that WebDAV is supported because they appear in my recent documents the location of the documents is on the remote server (http://). So according to the above this should work, but it doesn't accept the location.

    Is adding trusted http:// locations supported in the OCT? Or does this have to be accomplished via another means?

     

    Thanks

    Monday, April 11, 2011 10:04 PM
  • Hi,

     

    Sorry, it is like what you said, I failed to add the web folder as the trust location, too.

     

    So let's add the web folder by adding registry in the OCT, or do the setting with GPO.

     The registry is like this:

    Windows Registry Editor Version 5.00

     

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy Objects\{F62B4452-37B4-4EF7-BB20-E561C5687539}User\software\policies\microsoft\office\14.0\word\security\trusted locations\location1]

    "Path"=hex(2):45,00,3a,00,5c,00,54,00,45,00,53,00,54,00,54,00,45,00,4d,00,50,\

      00,30,00,31,00,00,00

    "Date"=""

    "Description"=""

    "AllowSubFolders"=dword:00000000

     

     

     

    Sincerely,

    Max Meng

    Wednesday, April 13, 2011 9:22 AM
  • Thanks for the information. It was very hekpful. I will add via a GPO as you suggested.

    Thursday, April 14, 2011 6:21 PM
  • Glad to be helpful.
    Friday, April 15, 2011 9:27 AM