none
Outlook 2010 messages stuck in outbox, due to sending as another user

    Question

  • I've read all of the other "stuck in Outbox" issues and as far as I can tell, ours is not related to that.

    The issue is that we have messages autogenerated into the Drafts folder of an external sending account (call it "outmsgs@domain.com") and we send special emails out via that account. Multiple users have both Send As and Full Access permissions on that account. Nobody logs in as that account, but it has a mailbox, and those users with access see it in their Outlook as an additional mailbox in the side folder menu.

    They can then go into the Drafts folder of outmsgs@domain.com and send those messages.

    This worked for years via Citrix and Outlook 2000. We recently switched to Outlook 2010, and now they see everything the same, but when they send it, it just sits there in the Outbox. The visual behavior of it varies (sometimes bold, sometimes italic, sometimes none of the above), but it always stays in the Outbox (it can be manually moved).

    BUT - sometimes it actually sends in the background (nearly always), unless you move it before it has sent. There is no way of knowing if it has sent or not, from any visual state. For a single user of 60, theirs never sends when they do this (so I am guessing user behavior).

    We very much want this to go back to what it was doing before - the user sends, it works, the end.

    Additional data points:

    * Exchange 2007 (and Outlook is not using a pst, it is just right off of Exchange - but there is an OST file)
    * If you login via webmail as that user (outmsgs@domain.com) then it works fine.
    * This happens regardless of whether Outlook is run as normal, or with the "/noextensions" switch (so it is not caused by an add-on).
    * Outlook 2010 is not running in cached mode
    * It is set to sent immediately, pressing send/receive does nothing (or rather, does nothing help this case)
    * If the user is not sending as someone else, regardless of how they create the message, it works fine. But if they add the From field and then change to one of their Full Access users, it will send, but the message stays in the Outbox.
    * It being in Citrix doesn't matter - it won't work from any Outlook 2010 instance, but it will work via webmail (Exchange 2007)

    *One additional point, not sure this would cause it or not, when we open Outlook 2010, we get two (of the same) error messages regarding our SSL cert on the server (it is a self signed one that shows up for webmail - so the error message is along the lines of what you would expect on a self signed cert.)

     

    We very much want to get this resolved, as it makes it extremely difficult to know if/when things have been sent for that account.

    • Edited by stenz_bda Monday, January 10, 2011 6:38 PM self signed cert on server
    Monday, January 10, 2011 5:04 PM

Answers

  • The issue here, if not clear in the original message (and I suspect it must not be clear, given no matter who I ask this, they tell me to delete the profile, which if you think about it, is not going to work - and hey, doesn't), is that on the server (Exchange 2007 in this case), we go into a mailbox ABC and assign Full Access (with some adjustments in Security that MS has published so that a user can do a Send As, but it will not show as "Sent on Behalf"). This seems to mean the "Send As" option on the mailbox that you see next to Full Access is irrelevant in this context.

    We then have those users who have that access go into their Mail Profile, Change, and then More Settings, and then Advanced - in there they add the ABC mailbox and it shows up in their Outlook. They used to then be able to Send As that user, out of the Drafts folder. There was a known issue in Outlook 2007 and MS went to far as to patch the issue, where you would send from the Drafts of ABC, but the messages would show up in your own Sent Items.

    But we are running into an issue where they are not getting moved to Sent Items at all. They sit in the Outbox (and in the background still get sent). This was completely blowing the minds of users and it was all they could do to find their way home after a day of seeing things like this. They were completely incapable of dealing with this, so we absolutely had to fix this.

    Two Workarounds

    First workaround:

    1) Drag the email from the ABC Draft folder into your own Draft folder, it would retain the From field you want, click Send, it then goes into your Outbox, sends, and then goes into your Sent Items. 

    2) Drag the item from your Sent Items into the Sent Items of ABC

    This was too complicated for our users, and they always screwed it up.

    Second workaround:

    1) login to webmail (using IE and the "I'm not on a shared machine", other settings mileage may vary)

    2) in the upper right corner will be your name with an arrow next to it - click on that, a little window comes up with a text field. Enter in the first part of the email on the mailbox you want to connect to - so "ABC" in this case - if you have permissions, it switches you over - no passwords needed

    3) use it as you normally would, everything works

    This too was too complicated for our users, aaaand they always screwed it up.

     

    So we really needed a proper setup, but I couldn't find any sign of what we were doing wrong.

    I deleted the email profiles, I deleted user profiles (both of which I knew wouldn't do anything, since their regularly email accounts worked totally fine), and given that everything was fine in webmail we knew it was not an Exchange issue. Something specific to Outlook 2010, and given there was no patch yet, figured we were not going to get help.

    Then I noticed that originally the Mail Profile -> Change -> More Settings -> Advanced -> Mailboxes workaround was due to back in the day you were not allowed to map to multiple Exchange accounts in Outlook.

    But now you can.

    So it is as easy as that.

    If you have users who are easily confused and distracted by things like extra accounts and/or shiny bits of tin foil near their desk, I recommend you go in and remove all of the extra mailbox mappings that are in there, and then simply add the other email to their Outlook as another Exchange account.

    Perhaps I missed something, but I never saw mention of this in any documentation and only happened to stumble onto it as a side note on a forum post related to something else while spending hours trying to track this down.

     

    Hopefully this helps someone else trying to do the same thing, and saves them the many frustrating hours I've spent on this.

     

    • Marked as answer by stenz_bda Tuesday, January 25, 2011 5:39 PM
    Tuesday, January 25, 2011 5:39 PM
  • I found the answer.

    Outlook has to be on cached mode to work well.

    Thursday, June 30, 2011 2:53 PM

All replies

  • Hi,

     

     

    Try referring to the article:

     

    How to troubleshoot e-mail messages that are stuck in your Outbox

     

    http://support.microsoft.com/kb/262052

     

    Sincerely,

     

    Harry 

    Wednesday, January 12, 2011 5:55 AM
    Moderator
  • Going through those (basically they are not applicable, in that we already checked them):

    0) These appear to be for Outlook Express, and we are using Outlook 2010 (as in Office 2010)

    1) It doesn't matter what you do to the items in the Outbox, they won't send - they occasionally will change from bold to not bold, or italic or not, but they always stay there if you are sending as another user (they likely still send, but they don't leave the Outbox - you can delete or move them from the Outbox manually - but the issue is that we don't know if they have actually sent yet, and have run into issues of users)

    2) We are not working offline

    3) The Send item is configured correctly (instant and on the correct network)

    4) The new identity doesn't work (I didn't expect it to, as every single user has this issue, in areas where a new identity will work, it is usual when only a handful of users or fewer have the issue)

    Wednesday, January 12, 2011 5:41 PM
  • I also see an email from you that appears to be a different response than what I see here:

    ------------

     

    Hi,

    Based on the current situation, this issue can be caused by several factors. We can try the following methods to see if the problem can be resolved.

    Method 1:

    ====================

    Click the “Send/Receive” tab, then click “Send all”.

     

    Method 2: New Outlook profile

    ==============

    1.            Exit Outlook.

    2.            Go to Start > Control Panel, click or double-click Mail. 

     

    Mail appears in different Control Panel locations depending upon the version of the Microsoft Windows operating system, Control Panel view selected, and whether a 32- or 64-bit operating system or version of Outlook is installed.

    The easiest way to locate Mail is to open Control Panel in Windows, and then in the Search box at the top of window, type Mail. In Control Panel for Windows XP, type Mail in the Address box.

    Note    The Mail icon appears after Outlook starts for the first time.

    The title bar of the Mail Setup dialog box contains the name of the current profile. To select a different existing profile, click Show Profiles, select the profile name, and then click Properties.

    3.            Click Show Profiles. Choose Prompt for a profile to be used.

    4.            Click Add.

    5.            Type a name for the profile, and then click OK.

    6.            Start Outlook, and choose this new profile. 

    ------------

     

    We have tried both of those methods early on, neither of those methods work.

    Wednesday, January 12, 2011 5:44 PM
  • Going through those (basically they are not applicable, in that we already checked them):

    0) These appear to be for Outlook Express, and we are using Outlook 2010 (as in Office 2010)

    1) It doesn't matter what you do to the items in the Outbox, they won't send - they occasionally will change from bold to not bold, or italic or not, but they always stay there if you are sending as another user (they likely still send, but they don't leave the Outbox - you can delete or move them from the Outbox manually - but the issue is that we don't know if they have actually sent yet, and have run into issues of users)

    2) We are not working offline

    3) The Send item is configured correctly (instant and on the correct network)

    4) The new identity doesn't work (I didn't expect it to, as every single user has this issue, in areas where a new identity will work, it is usual when only a handful of users or fewer have the issue)

    I have the same issues as above. A message that is written and sent goes fine. But if I have to go into the outbox to modify the email the Sent column changes to "None". This also happens if I go into the outbox and do not open the message but simply highlight it in the outbox. As soon as you move the highlighter on to the email the sent info changes from date/time to "None". Can anyone help as this is a real problem as I mail merge emails and then add attachments when they are in the outbox. This problem has only occurred for me in the past 2 days and is stopping me from working.

     

    Richard

    Saturday, January 22, 2011 1:45 AM
  • Did you create a new mail profile for the user and it still failed? (or "identity" if you are in Outlook Express)

    The behavior you are describing (internal to the same user, and touching the messages in the Outbox - which if you are adding attachments, I would think should really be done at the Drafts level and not at the Outbox level) I've seen resolved in the past when creating a new Profile/Identity.

    For the issue we are having here, where the user is sending as another user, in that instance it doesn't matter who creates a new profile, it is moot - doesn't impact it.

    Additionally, on yours - have you checked any changes in anti-virus (in that you have it now when you did not before, or any new patches). If something was previously working, but then stopped - especially in that case, it can mean some external program is doing it - and many times it is anti-virus. We ruled that out in our own case, but I have seen similar things in the past from a few different vendors. Unfortunately, if that is the case, the solution is either to get the vendor to fix it, use a different mail program, or don't use the av at that level (we have an additional layer external to the mailserver that everything routes through in/out).

    Saturday, January 22, 2011 5:04 PM
  • The issue here, if not clear in the original message (and I suspect it must not be clear, given no matter who I ask this, they tell me to delete the profile, which if you think about it, is not going to work - and hey, doesn't), is that on the server (Exchange 2007 in this case), we go into a mailbox ABC and assign Full Access (with some adjustments in Security that MS has published so that a user can do a Send As, but it will not show as "Sent on Behalf"). This seems to mean the "Send As" option on the mailbox that you see next to Full Access is irrelevant in this context.

    We then have those users who have that access go into their Mail Profile, Change, and then More Settings, and then Advanced - in there they add the ABC mailbox and it shows up in their Outlook. They used to then be able to Send As that user, out of the Drafts folder. There was a known issue in Outlook 2007 and MS went to far as to patch the issue, where you would send from the Drafts of ABC, but the messages would show up in your own Sent Items.

    But we are running into an issue where they are not getting moved to Sent Items at all. They sit in the Outbox (and in the background still get sent). This was completely blowing the minds of users and it was all they could do to find their way home after a day of seeing things like this. They were completely incapable of dealing with this, so we absolutely had to fix this.

    Two Workarounds

    First workaround:

    1) Drag the email from the ABC Draft folder into your own Draft folder, it would retain the From field you want, click Send, it then goes into your Outbox, sends, and then goes into your Sent Items. 

    2) Drag the item from your Sent Items into the Sent Items of ABC

    This was too complicated for our users, and they always screwed it up.

    Second workaround:

    1) login to webmail (using IE and the "I'm not on a shared machine", other settings mileage may vary)

    2) in the upper right corner will be your name with an arrow next to it - click on that, a little window comes up with a text field. Enter in the first part of the email on the mailbox you want to connect to - so "ABC" in this case - if you have permissions, it switches you over - no passwords needed

    3) use it as you normally would, everything works

    This too was too complicated for our users, aaaand they always screwed it up.

     

    So we really needed a proper setup, but I couldn't find any sign of what we were doing wrong.

    I deleted the email profiles, I deleted user profiles (both of which I knew wouldn't do anything, since their regularly email accounts worked totally fine), and given that everything was fine in webmail we knew it was not an Exchange issue. Something specific to Outlook 2010, and given there was no patch yet, figured we were not going to get help.

    Then I noticed that originally the Mail Profile -> Change -> More Settings -> Advanced -> Mailboxes workaround was due to back in the day you were not allowed to map to multiple Exchange accounts in Outlook.

    But now you can.

    So it is as easy as that.

    If you have users who are easily confused and distracted by things like extra accounts and/or shiny bits of tin foil near their desk, I recommend you go in and remove all of the extra mailbox mappings that are in there, and then simply add the other email to their Outlook as another Exchange account.

    Perhaps I missed something, but I never saw mention of this in any documentation and only happened to stumble onto it as a side note on a forum post related to something else while spending hours trying to track this down.

     

    Hopefully this helps someone else trying to do the same thing, and saves them the many frustrating hours I've spent on this.

     

    • Marked as answer by stenz_bda Tuesday, January 25, 2011 5:39 PM
    Tuesday, January 25, 2011 5:39 PM
  • I have here quite the same problem but with Outlook 2007.

    Was the only solution there to configure another profile for the shared mailbox?

    Monday, June 27, 2011 2:55 PM
  • For Outlook 2007, check to see that you have every patch available (and you may need to approach MS for a hotfix if it is not in the public patches), as I am sure I ran across that this was a "known issue" in Outlook 2007 and patched, but a "totally ignored" issue in Outlook 2010.

    (that is if you are having the issue I was describing, vs some of the other expected issues of a corrupt mail profile which is much easier to fix)

    Monday, June 27, 2011 3:08 PM
  • Yeah... I have here the issue you were describing and I haven't found a solution across the web through the forums...

    It is not a problem of corrupt mail profile... I wish it could be...

    Tuesday, June 28, 2011 12:01 PM
  • I found the answer.

    Outlook has to be on cached mode to work well.

    Thursday, June 30, 2011 2:53 PM
  • I had this same problem. New profile did not correct. Redirecting accounts to new .pst files (for the additional accounts) did not correct. Outlook 2010 creates empty .pst files that reflect to an old profile each time they are deleted even though they have nothing to do with the profile in use. I'm sure there is something in the registry or an .inf/.xml file causing this, but I haven't had time to sort through.

    Relatively quick resolution (after loads of searching and testing the above and then some...) reached as follows.

    1.) Put Outlook into offline mode. Empty your outboxes.

    2.) Close Outlook.

    3.) Rename the .pst and .ost files associated with the profile. Move to a folder if you have more than a few accounts.

    4.) Configure the Exchange account not to use cached mode (even if you are not on the LAN. If RPC over HTTP is configured, it will connect, though more slowly.

    5.) The Exchange account is probably the default account to send from. In my case, at one point it appeared that all POP accounts were using this outbox. I made one of the POP accounts the default instead. Some users may find this confusing, but in my case it works.

    6.) Launch Outlook.

    7.) Close Outlook.

    8.) Verify that new .pst and .ost files were created.

    9.) If the above were not created. Manually create through account config in the Control Panel settings.

    10.) Launch Outlook and put it online.

    11.) As long as there are no errors on send/receive at this point, send test messages from each account and verify delivery.

    12.) If the tests above were successful, close Outlook. There should be no send/receive errors.

    13.) Re-enable cached-mode on the Exchange profile.

    I did not test making the Exchange account the default again. I may give that a try down the road--it's just not tested yet.

    I hope these steps help someone else getting calouses on their forehead!

     


    Sharon Peralta
    Thursday, September 15, 2011 4:37 PM
  • Actually, I've not yet found that there is one "always works" fix, especially for the "stuck in outbox" issue, not even as stenz_bda explains what worked for him. 

    I've been dealing with this issue of shared mailboxes in Outlook 2010, and Outlook 2010 SP1 (Office 2010 SP1) for quite some time.  A lot of this was manifest while making registry changes and installing Office SP1 so that the sent items and deleted items would go to the correct shared mailbox folders instead of the primary user's profile folders.  The stuck in outbox issue was experienced with shared mailboxes for both Office SP1 and before.

    Yes, we'll add the shared mailbox accounts to the profile in the account settings (requires you to do this outside of the client), and it's almost never enough.  Sometimes changing the shared account to "non-cache" will allow it to work.  I did this on one shared account, it worked, did the same for another shared mailbox, and that one still had the problem (all on the same user profile).  Creating new profiles.. rarely helped if ever.  Creating new ost files... tried this a couple of times, never helped.  Sometimes clearing out the auto-complete cache and selecting the mailbox name again would help.  Sometimes removing the user's name from a delegation link on the shared mailbox may have assisted in getting the problem fixed.  It's just baffling as to what type of event is actually triggering the product to handle the shared mailbox properly... as it is I have one example right now with 2 shared mailboxes all setup in the same manner, where one stopped having the issue, and the other still does.  Then there have been times where the problem seems fixed, and it comes back again.. almost as if sometimes the Outlook session is just corrupt and you have to restart it... a management nightmare trying to resolve all the different instances amongst the plethora of users having the problem with their shared mailbox accounts. 

    - Jerry

    Friday, November 18, 2011 6:32 PM
  • I am at the point of total despair with this problem.

    In my case I have mixed Outlook 2003 and 2010 clients running from an Exchange 2010 server. Since the install of 2010 we have been plagued with random problems, most of them were attributed to inconsistent Auto Discovery and certificate problems. These were finally resolved by re installing Exchange onto a new server and manually exporting/importing the 100+ clients via pst’s to the new Database. Having completed that exercise Auto Discovery works as it should allowing shared calendars and out of office to function correctly.

    The problem I am now stuck with is related to Outlook 2010 clients that have dual account mailboxes. For example, secretaries have access to their seniors mail account and need to send on behalf of and as the other user. Outlook 2003 users don’t have a problem as they have the second account associated to their mail profile, then logout and back in again to the other profile to send as the other user.

    When the option to use multiple accounts on Outlook 2010 became available it looked to be so simple. How wrong can you be!

    If you create a new message and select the other user with the ‘from’ option, 9 times out of 10 it will just sit in the outbox of the second user.

    I have tried the method of opening the second users sent items and pasting the stuck message into the drafts folder of the primary user and this sometimes works, but is not consistent. Likewise a restart of the machine sometimes works. In all cases if I go to the Outlook icon in the system tray and run a Connection or Auto configuration test, all appears to be ok. Deleting the profile again sometimes works, but nothing is consistent. I have even tried setting delegate rights and allowing the primary user full access to the secondary users mail.

    If I try and use a second profile for 2010 users as with 2003 it gives an error relating to .ost privileges. The general consensus is that this is not the correct way to add a second account, but to add it as a second account to the master profile  as I have done.

    If I use the same accounts on a 2003 client machine it all works without problem.

    Logic dictates that this is a 2010 client problem but for the life of me I cant find a solution!

    Anyone got any ideas, please!

    Tuesday, April 24, 2012 2:57 PM
  • Great now how do I set it in Cache Mode I have the same problem in Outlook 2007.

    Snoopy

    • Proposed as answer by dommie001 Friday, November 16, 2012 11:03 AM
    • Unproposed as answer by dommie001 Friday, November 16, 2012 11:03 AM
    Sunday, June 17, 2012 2:56 AM
  • FYI I've had the exact same problem and I solved with the following.

    In Outlook 2010 I had a profile with 2 separate accounts attached.

    Within the default account -> Change -> More Settings -> Advanced -> Mailboxes -> Remove the second account.

    Also you must remove automapping with the backend of the account using powershell; e.g. Add-MailboxPermission -Identity JeroenC -User 'Mark Steele' -AccessRight FullAccess -Automapping $false

    Now the user can send as either user, and when in the second mailbox, creating new emails appear automatically from that account.

    • Proposed as answer by dommie001 Friday, November 16, 2012 11:07 AM
    • Edited by dommie001 Friday, November 16, 2012 5:15 PM additional resolution for automapping feature
    Friday, November 16, 2012 11:07 AM