none
Outlook 2010 cannot provide form scripting support

    Question

  • I have followed two workarounds and fixes for Office 2010 in  a terminal services environment.  One was to copy a .dll file to the terminal server and the other was to remove a registry entry.  Both workarounds fixed the problem temporarily, but it continues to show up.  When a user opens some email messages they receive a warning that "Microsoft Outlook cannot provide form scripting support. This feature is not available.  For more information, contact your system administrator."
    A+, MCP, MCSA, MCSE, Security+
    Monday, August 23, 2010 6:16 PM

All replies

  • There is a KB http://support.microsoft.com/?id=302003 (http://support.microsoft.com/?id=302003) which gives us 2 workarounds.
  • This KB will not help if they have installed using Citrix Installation Wizard.
  • Delete the following registry Key
    HKEY_CLASSES_ROOT\Installer\Features\9040210900063D11C8EF00054038389C "OutlookVBScript"

    Hope it helps.

  • Proposed as answer by Jun LOU Thursday, September 01, 2011 3:09 PM
Tuesday, August 24, 2010 2:47 AM
Moderator
  • Already did that twice, that's what I am talking about when I say I did the workarounds and the problem continues to come back.
    A+, MCP, MCSA, MCSE, Security+
    Tuesday, August 24, 2010 7:18 PM
  • I have verified and performed the workarounds in KB 302003 and then the delete registry key, this does not correct my issue.  Anyone have any other suggestions?
    A+, MCP, MCSA, MCSE, Security+
    Friday, August 27, 2010 5:42 PM
  • Just in case you're still looking for an answer or any other ppl like me land on this with the same question :

     

    You should install the vbs scripting component with the following command:

    msiexec /i {90140000-0011-0000-1000-0000000FF1CE} ADDLOCAL=OutlookVBScript /qb



    Note that this command is only valid for 2008 R2 with Office 2010 pro plus, if you have a different office version, like 2010 standard or any version difference, you should look up the GUID that you need in one of the following registry keys :

    *[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products*

    or

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\14.0\Common\InstalledPackages (the first one)



    • Proposed as answer by Ziv Rivkis Friday, June 20, 2014 3:15 PM
    Tuesday, February 01, 2011 12:56 PM
  • Hi,

    Delete the following registry Key
    HKEY_CLASSES_ROOT\Installer\Features\9040210900063D11C8EF00054038389C "OutlookVBScript" doesn't work for me, because I can not find the path of the key.

    But I found the solution by myself. Maybe you can also try it.

    On the terminal server witch I met the same message error, under C:\Users\UserLogin\AppData\Roaming\Microsoft,

    I renamed the folder "Outlook" to "Outlook.old" for example.

    Then, I launched Outlook again, the folder "Outlook" is created again automatically.

    I did not have this error message any more.

    Hoping it's a good suggestion for you

     


    Jun LOU
    Tuesday, July 19, 2011 3:49 PM
  • I confirm Jennifer has proposed the best solution. The procedure is to delete (or renaming in this case) this registry key : [HKEY_CLASSES_ROOT\Installer\Features\00004109110000000000000000F01FEC] "OutlookVBScript"="OUTLOOKFiles" The procedure to copy OUTLVBS.DLL has been useless. Regards
    Jun LOU
    Thursday, September 01, 2011 3:13 PM
  • Allthough in my case the key was HKEY_CLASSES_ROOT\Installer\Features\00004109210000000000000000F01FEC instead of yours i allso fixed the problem by deleting the key "OutlookVBScript"="OUTLOOKFiles".

     

    Cheers.


    Regards, Marco Scholten
    Thursday, September 15, 2011 2:05 PM
  • Here is what I did to enable VB scripting for Outlook 2010.

    1.      Determine the GUID for Office 2010.

     

    In the Registry, go to HKEY_CLASSES_ROOT\Installer\Features. Search for “OutlookVBScript”. I found it at:

     

    HKEY_CLASSES_ROOT\Installer\Features\00004109110000000000000000F01FEC.

     

    In the Registry, for an x86 server go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products,
    or for an x64 server, go to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\14.0\Common\InstalledPackages (the first one)
    and select the key where you located “OutlookVBScript”.

     

    On my server, it is:

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\00004109110000000000000000F01FEC

     

    When I select it, this is what I see:

    DisplayName “Microsoft Office Professional Plus 2010”

    InstallSource, ModifyPath and UninstallSring all show the Office 2010 GUID as
    {90140000-0011-0000-0000-0000000FF1CE}

     

    2.      Install VBScripting for Outlook.

     

    My commands to install VBscripting for Outlook are therefore:

     

    change user /install

     

    msiexec /i {90140000-0011-0000-0000-0000000FF1CE} ADDLOCAL=OutlookVBScript /qb

     

    change user /execute

     

    Note: After installing VBscripting for Outlook, “OutlookVBScript”at HKEY_CLASSES_ROOT\Installer\Features\00004109110000000000000000F01FEC changed its value from “OUTLOOKFiles” (where the box glyph at the beginning appears to be a minus or dash in the Registry editor) to “OUTLOOKFiles”.

     

    • Proposed as answer by TheDogMaster Friday, October 12, 2012 5:27 AM
    Monday, November 28, 2011 4:22 PM
  • I doubt it can help if user does not have administrator priviledges - like on most windows systems.
    Monday, April 02, 2012 1:35 PM
  • Thanks Blue Jay,

    I normally don't post these kind of Fixed It replies but for my combination of OS (2003 Server Std) and Office 2010 Std the problem and answer were quite obscure.

    I was actually geting the error message pop up twice when I opened the form and then the Outlook form would work OK anyway.

    Running the msiexec command with my registry key which turned out to be slightly different to your did the trick.

    Friday, October 12, 2012 5:32 AM
  • This is perfect thanks!  fixed my issue
    Thursday, June 12, 2014 9:12 PM
  • You fixed my issue. Thank you so much!!!
    Monday, August 04, 2014 2:29 PM