none
Excel 2007 will not open .XLS from a doubleclick, only file>>>open>>...

    Question

  • I have a user who has Office 2007. Her Excel will not open .xls files when she doubleclicks on them, be it on the desktop, in a folder or from outlook mail messages. However, when she maps to it with File >>> Open >>> dig down to file >>> x.Xls, then the file opens. What is causing the doubleclick not to work, and what can I do about it so it does?
    Thursday, June 17, 2010 5:04 PM

All replies

  • Hi,

     

    We can change the file association of the Excel file. Please right-click the Excel file and choose Properties. Click the Change button and choose Microsoft Office Excel. Also check the box before: Always use the selected program to open this kind of file.

     

    If the problem persists, try the methods below to resolve the issue:

     

    Method 1: Enable the Ignore Other Applications that use DDE feature

    ===================

    1.       Click the Office button an then click Excel Options. Excel displays the Excel Options dialog box.

    2.       Click Advanced at the left side of the dialog box.

    3.       In the General section, make sure the Ignore Other Applications that use Dynamic Data Exchange (DDE) check box is selected.

    4.       Click on OK.

     

    If you still cannot double-click on a workbook to open it, try these steps:

     

    Method 2:

    =================

    1.       Close Excel completely.

    2.       Open a My Computer window.

    3.       Choose Tool | Folder Options. You should see the Folder Options dialog box.

    Note: If you are Windows Vista, click Start > Search, type Folder Options and search it.

     

    4.       Make sure the File Types tab is displayed.

    (Note: This option is not available in Windows 7.)

    5.       In the list of registered file types, find and select the entry for XLS (Microsoft Excel Worksheet).

    6.       Depending on your version of Windows, click on either the Edit or the Advanced button. You should see the Edit File Type dialog box.

    7.       In the list of actions, choose Open.

    8.       Click the Edit button. Windows displays the Editing Action dialog box.

    9.       The Application Used to Perform Action box contains the actual command line used to start Word. Double-check the line to make sure there are no strange extra filenames at the end of the command line.

    10.   Make sure the Use DDE check box is selected, and that the DDE Message box is set to the following: [open("%1")]

    11.   Click on OK.

    12.   Close all the other open dialog boxes.

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Best Regards,

     

    Sally Tang

    • Marked as answer by Sally Tang Monday, June 21, 2010 4:11 AM
    • Unmarked as answer by The IT Sherpa Tuesday, July 06, 2010 3:36 PM
    Friday, June 18, 2010 6:55 AM
  • Here's the issue (it has compunded) with a little more background.

    User's machine is a vista machine with Office 2007 installed. Her settings were already set as you described in your post. 

    She is part of a domain, and has a shared drive (H:\) that connects to a Windows Server 2008 with Service pack 2. If I open a .xls file from her computer, then it opens the excel program and window, but the worksheet does not load (so I have the grey background, and no spreadsheet). This is with the aforementioned settings set as you recommend. However, if I open the same .xls file from the server, it opens in Excel 2007 just fine with compatibility mode.

    Then we had a new issue. Trying to click on a file to open it in this H: drive, I would get a file not found. Let's say the file was "doing the math.xls". Trying to open it would come pack with "doing the math.xlsx not found," and Excel would also kick errors from trying to open doing.xls, the.xls, and math.xls. Note it trying to find the .xls file as a .xlsx. I reinstalled office from add/remove programs and this issue went away. However, when I checked folder options on the H: drive from the Vista computer, At number six of option two, there was no advances button, only a repair button, because file types had "custom modifications." I clicked repair, and started having this new issue again.

     

    I can only assume this is a Office 2007/Vista/Server2008 combined issue. Thoughts?

    Monday, June 21, 2010 3:28 PM
  • Self bump seeking aid.
    Wednesday, June 23, 2010 6:35 PM
  • Here's the issue (it has compunded) with a little more background.

    User's machine is a vista machine with Office 2007 installed. Her settings were already set as you described in your post. 

    She is part of a domain, and has a shared drive (H:\) that connects to a Windows Server 2008 with Service pack 2. If I open a .xls file from her computer, then it opens the excel program and window, but the worksheet does not load (so I have the grey background, and no spreadsheet). This is with the aforementioned settings set as you recommend. However, if I open the same .xls file from the server, it opens in Excel 2007 just fine with compatibility mode.

    Then we had a new issue. Trying to click on a file to open it in this H: drive, I would get a file not found. Let's say the file was "doing the math.xls". Trying to open it would come pack with "doing the math.xlsx not found," and Excel would also kick errors from trying to open doing.xls, the.xls, and math.xls. Note it trying to find the .xls file as a .xlsx. I reinstalled office from add/remove programs and this issue went away. However, when I checked folder options on the H: drive from the Vista computer, At number six of option two, there was no advances button, only a repair button, because file types had "custom modifications." I clicked repair, and started having this new issue again.

     

    I can only assume this is a Office 2007/Vista/Server2008 combined issue. Thoughts

    Wednesday, June 23, 2010 6:35 PM
  • Hi,

     

    You can try to help her completely uninstall Office 2007 and then reinstall it.

     

    First, please go to Start > Control Panel > Programs and Features (Add/Remove Program Files), Locate the Office program and uninstall it.

     

    Then, you can try to manually uninstall Office 2007 by the steps below: 

     

    1. Download and install the Windows Installer Cleanup Utility.

    http://download.microsoft.com/download/E/9/D/E9D80355-7AB4-45B8-80E8-983A48D5E1BD/msicuu2.exe  

     

    2. After you install the Windows Installer CleanUp Utility, click Start  -> All Programs -> Windows Install Clean Up.

    3. Highlight Microsoft Office 2007 entry in the list and then click Remove. Quit the Utility.

     

    Note: If you have got any other old or redundant office entries such as Office 2003 or other Office standalone products, such as Visio in the list, please remove them together.

     

    4. Close all applications.

    5. Click the “Start” peal, in the Search box, type "regedit" (without the quotation marks) and press Enter.

    6. Expand the registry tree on the left pane and locate the following two registry subkeys:

     

    HKEY_CURRENT_USER\Software\Microsoft\Office

    HKEY_LOCAL_MACHINE\Software\Microsoft\Office

     

    7. Right-click on this registry subkey and click Delete to delete those keys.

    8. Open Windows Explorer, and then browse to the "C:\Program Files" folder

     

    If it exists, rename the "Microsoft Office" to "Microsoft Office OLD"

    If it exists, rename "OfficeUpdate" to "OfficeUpdateOLD"

    If it exists, rename "OfficeUpdate12" to "OfficeUpdate12OLD"

     

    9. Click Start, in the Search box, type "%Temp%" (without the quotation marks) and press Enter.

    10. Empty the Temp folder.

     

    Note: If some files can't be deleted, please skip them, which don't influence the result of the troubleshooting.

     

    11. Empty the Recycle Bin.

     

    12. Restart your computer.

     

    13. Try to reinstall Office 2007 again.

     

    Regards,

     

    Sally Tang

     

    • Proposed as answer by VBAToolsMVP Friday, November 16, 2012 9:10 AM
    Thursday, June 24, 2010 7:56 AM
  • The uninstall and reinstall did not help. Of note, after the reinstall, the administrator account has no problem accessing the xls files. The user's account (which has local admin and domain admin rights) still has the problem. The only differences of note I see are desktop themes, wallpaper, and the user has a ton of items on her desktop. Longshot, but would any of these cause the issue?
    Monday, June 28, 2010 2:40 PM
  • Same Issue here... but with some differences...

    Office 2007 XP Pro SP3... My personal desktop...

    file won't open by double click...

    Excel opens on the double click of the file but the file doesn't load.. Other Desktops with Win7 & Office 2007 load this file fine.. so I'm sure its not the server but the local machine.

    Could be :

    An Office Update that lost only part of association

    MY FIX

    DDE Settings (have a tweak to allow Separate window for each instance of an excel workbook)(basically this tweak) http://blog.drewery.net/2006/08/29/utilising-dual-monitors-with-microsoft-excel-2003/

     

    In my case the xlsx said "Restore" Instead of "Advanced"

    XLS Was fine but hadn't tested any xls files... guess I should have done that..LOL

    clicked Restore and it now works...

    Think its more related to the association not being perfectly happy even though its properly associated there is that RESTORE needing to be done to get all things happy again..

    Re-Install is a waste of time generally and doesn't resolve the issues 80% of the time... but I usually don't allow this much time to research a solution to such a minor issue either...

    Just usually would say re-image / Re-Install who machine after testing All Hardware / drives / memory for issues... (My Install is now almost a year old so I'm sure its due anyway!!!)

     

    Hopefully that little bit helps...

    • Marked as answer by Sally Tang Tuesday, July 13, 2010 8:17 AM
    • Unmarked as answer by The IT Sherpa Tuesday, July 13, 2010 8:32 PM
    Monday, July 12, 2010 3:20 PM
  •  

    no joy with any of the above

    i spent the morning trying to locate an answer for this across the interweb

    i have 3 xp workstation's i upgraded from office 2000 to 2007 this week

    i simply cannot grasp why 3 years after product release there still isnt a patch or solid solution to this

     

    Wednesday, November 24, 2010 12:07 PM
  • We are having the same issue at my office - shared Excel files are not opening. I don't get an error - just a grey screen where my spreadsheet should be. After about 10 or 20 minutes of trying to load it and closing and opening the document, sometimes it will finally open. Usually, it waits until I call the IT over to open for me. I have read some forums online that suggest it may be a firewall issue. That seems to fix my problem for now. Good luck, I have yet to find a solid solution. 

    We all recently upgraded to 2007 also, and that seems to be the common culprit here. 

    Wednesday, December 08, 2010 1:35 PM
  • One Windows XP system in our office has the same problem reported by others in this thread.  It started just a few days ago, having been noticed when the user tried to open an excel attachment in Lotus Notes.  I tried opening files from windows explorer and found the same problem;  Excel opens without opening the file.  I tried doing a repair and then an uninstall and reinstall.  Neither has worked.  When I tried opening an Excel attachment after the reinstall it gave an error message saying it couldn't find the file, something that hadn't happened before.

    Robert Szejn
    Tuesday, January 18, 2011 7:49 PM
  • Has anyone resolved this problem with Excel 2007 running on Windows 7 Pro (64)? This has become quite a pain. I've run repair, checked the DDE settings, checked file/program association, reinstalled Office 2007 (clean), disabled/enabled Add-Ins individually and we're still required to save the file loacally and open it from within Excel. Please help.
    Monday, March 07, 2011 6:25 PM
  • I am having the same problem. Windows XP, Excel 2007, and this started happening a couple days ago. The only thing I can think of that changed in that time span is that there was a Windows Update install...
    Thursday, March 17, 2011 4:29 PM
  • Same problem for me.

    Windows XP,

    Office 2007. 

    Problem currently occuring when I try to open a ".xls" file when I already have some other (.csv, .xlsx, or .xls) file open.

    Work around: Close all Excel windows.

    Double click the .xls file.  It opens quickly w/o any issue.

    Irritating.

    How to fix?

    Thursday, March 31, 2011 8:00 PM
  • I have the same issue with three computers.   All Hp Elitebooks, All Office 2010, OS win 7 Pro (32).

    I try to open a .xls from a website that our company frequents it opens Excel then gives me the Grey screen. I am pullin my hair out. Everytime I think I have a fix I get the Grey screen. Kinda like gettin the big Flippin Bird. The only way to get it to open is to save it and then File>Open> Etc. Etc. then all is well. Has there been any fixs for this yet?

    Sincerely,

    Goin bald fast  :)

    Thursday, May 12, 2011 8:07 PM
  • I have the same issue with three computers.   All Hp Elitebooks, All Office 2010, OS win 7 Pro (32).

    I try to open a .xls from a website that our company frequents it opens Excel then gives me the Grey screen. I am pullin my hair out. Everytime I think I have a fix I get the Grey screen. Kinda like gettin the big Flippin Bird. The only way to get it to open is to save it and then File>Open> Etc. Etc. then all is well. Has there been any fixs for this yet?

    Sincerely,

    Goin bald fast  :)


    My solution was to create new user profiles. It's a pain but took less time than all the research I did.
    Thursday, May 12, 2011 8:22 PM
  • I had the same issue here and was able to fix without creating new user profiles. In my case, I deleted the Excel registry keys for the user under: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Excel  <-- Close all Excel windows and delete this entire folder. The workbook opens OK after this. 

     

    Josh

    • Proposed as answer by santoshkevlani Sunday, January 29, 2012 1:21 PM
    Monday, June 06, 2011 8:28 PM
  • That's worked for me. Cheers.

     

    Bil

    Saturday, June 11, 2011 8:57 PM
  • I have searched, and searched, and searched across the internet for hours and hours. This solution WORKS, finally. Don't waste your time with adding the "%1" and messing with the DDE setting like you will read in most of the posts. This is a very simple and quick fix, and best of all IT WORKS!!!!!!!

     

     

    THANK YOU JOSH......

    Saturday, July 23, 2011 6:21 PM
  • I have this problem as well - any clues appreciated.

    Wednesday, August 10, 2011 8:17 AM
  • I have a user who has Office 2007. Her Excel will not open .xls files when she doubleclicks on them, be it on the desktop, in a folder or from outlook mail messages. However, when she maps to it with File >>> Open >>> dig down to file >>> x.Xls, then the file opens. What is causing the doubleclick not to work, and what can I do about it so it does?

    I also have this problem and would appreciate a fix.
    • Proposed as answer by Jeetu_007 Thursday, August 18, 2011 10:51 AM
    • Unproposed as answer by Jeetu_007 Thursday, August 18, 2011 10:52 AM
    Wednesday, August 10, 2011 8:50 AM
  • Thanks a lot SALLY. The procedure given by you is awesome.When i lost all the hopes.You came as a lifeline for me.

     

    YOU ROCK.....yipppeeeeeeeeeeeee  :-P

    Thursday, August 18, 2011 10:51 AM
  • Stop looking. Josh's solution works perfectly and can be done in less than a minute.

    I backed up the registry just in case (might take around a minute or so) and renamed the key from "..14.0\Excel" to "..14.0\Excel1". Once you open a file, the key gets recreated correctly and you can see what the changes are.

    Thanks JOSH

    • Proposed as answer by R_ul Wednesday, September 07, 2011 9:57 PM
    Wednesday, September 07, 2011 9:57 PM
  • Has anyone tried this one 2010?? I tried renaming the registry key and it recreated it but no worksheet at all.

    Currently using WinXP SP3 with Office 2010.

    Any help appreciated!!

    Saludos!

    Friday, September 23, 2011 10:53 PM
  • Your solution works great Sally! thank you!

    :)

    Thursday, November 17, 2011 7:33 AM
  • I tried your solutions, there is no Guarantee I did it right, And no dice. When I try the double click thing it says file is not a "win32 file."  I was able to open the document by "mapping" to it, if that is the right term. So at least i am not dead in the water.
    Thursday, December 08, 2011 7:17 PM
  • This worked for me.  Good post Josh.
    Friday, December 23, 2011 6:50 PM
  • Thank you Josh. 

    It worked perfectly for me as well. 

    Sunday, January 29, 2012 1:21 PM
  • Thanks Josh for your fix on the Excel issue.  I was getting ready remove and reinstall until I came to your solution.  What would have taken an hour, only took 2 mins.  The nice thing about delting that folder in the registry is it recreated itself once I opened Excel by double-clicking on a spreadsheet.

    Roy

    Tuesday, March 20, 2012 6:03 PM
  • Thanks Josh!

    Tuesday, April 24, 2012 3:50 PM
  • Josh,

    I see here that your solution works.......How exactly do you do this? Where do I find and delete these keys? I see the code but don't know where to go from there.....THX for any help you may give.

    Sunday, April 29, 2012 12:25 AM
  • Roy,

    I see here that your solution worked for you.......How exactly do you do this? Where do I find and delete these keys? I see the code but don't know where to go from there.....THX for any help you may give.

    Monday, April 30, 2012 3:11 AM
  • I see here that your solution worked for you.......How exactly do you do this? Where do I find and delete these keys? I see the code but don't know where to go from there.....THX for any help you may give.
    Monday, April 30, 2012 3:11 AM
  • I see here that your solution worked for you.......How exactly do you do this? Where do I find and delete these keys? I see the code but don't know where to go from there.....THX for any help you may give.

    Monday, April 30, 2012 3:11 AM
  • I see here that your solution worked for you.......How exactly do you do this? Where do I find and delete these keys? I see the code but don't know where to go from there.....THX for any help you may give.
    Monday, April 30, 2012 3:12 AM
  • I see here that your solution worked for you.......How exactly do you do this? Where do I find and delete these keys? I see the code but don't know where to go from there.....THX for any help you may give.
    Monday, April 30, 2012 3:12 AM
  • I had the same issue here and was able to fix without creating new user profiles. In my case, I deleted the Excel registry keys for the user under: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Excel  <-- Close all Excel windows and delete this entire folder. The workbook opens OK after this. 

     

    Josh

    this is a VERY quick and easy fix!!! thanks! 
    note that i had to delete the 'entire Excel' folder. (deleting the keys inside Excel folder wont do the trick)

    GL

    Monday, April 30, 2012 9:50 PM
  • I had the same issue here and was able to fix without creating new user profiles. In my case, I deleted the Excel registry keys for the user under: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Excel  <-- Close all Excel windows and delete this entire folder. The workbook opens OK after this. 

    Josh


    Thank you
    Very fast and it worke
    Wednesday, May 23, 2012 5:41 AM
  • Josh - you rock!  Kinda obvious really (suprised the MS sponsored person didnt know that trick!) but that is in hindsight....  Thanks mate.
    Monday, May 28, 2012 4:58 AM
  • That's the ticket. Thanks Josh!

    UPDATE: Josh's solution worked, but then Excel started to white screen regularly for up to 2 minutes after doing his solution. I tried detect and repair, no luck. I tried excel/unregserver then excel/regserver. When I did excel/regserver, I got a message  "One of your object libraries (stdole32.tlb) is missing or damaged. Please run setup to install it. Then I completely reinstalled Microsoft Office. This did not help. Then I ran system file checker and that seemed to find problematical system files, as it asked for the Windows XP CD. Hopefullly this will work.

    UPDATE 2: That did not work either. I should say that this is a restricted profile on XP that has the problem, not an Administrator account. No idea what to do now.

    UPDATE 3: I did  excel/unregserver then excel/regserver again, after running system file checker. This seems to have solved the problem.

    • Edited by numcrun Monday, July 16, 2012 11:42 PM More information
    Wednesday, July 04, 2012 11:05 PM
  • hi josh,

    I am using windows 7 and office 2010. I did the same thing but the problem persists. i also did the excel/unregserver and etc etc but nothing happened.

    have you any other solution for that.

    Thanks

    Arvind Chouhan

    Wednesday, October 17, 2012 5:44 AM
  • Josh has nailed it. Probably the registry entry is corrupt. Solution: delete the corrupt registry key.

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Excel 

    For me the Excel key was in

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Excel

    This is probably safe  to do if you are not a total newbie to registry keys. My machine is a corporte box and I can always get it reimaged if I screw it up. Here are some slightly more detailed instructions for those with a burning desire to get Excel working fast.

    1. Verify you have this problem: Excel spreadsheets no longer open when you double click them, instead Excel opens with a blank screen. I also got an error message.

    2. Close all Excel windows and files.

    3. Go to command mode. (This depends on your Start profile, but look for the "Run" link on the start screen. You can probably also do this from the "Search" box on the Start menu)    Type CMD in the box and press enter.  At the command prompt type "REGEDIT". A cautious person makes a backup copy of the registry at this time (Hint: Export the Registry-Google it, there are lots of tutorials).

    5. Look for the HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Excel  key and delete it.

    6. Exit and test

    Like I said, I found the Excel key in HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Excel so you may have to hunt around a little, depending on the MS OFfice installation history on your computer. I would delete the last one, if there was more than one but YMMV.

    This is not a file association issue. My HD is almost full so I think that is probably the cause of the corruption but there are lots of reasons a registry entry can get corrupted.

    LK


    • Edited by RiskAvoider Monday, December 17, 2012 5:11 AM corrected spelling
    Monday, December 17, 2012 5:05 AM
  • While I understand why this worked, as a general rule, I dislike brute force fixes like this, as they can have unintended side effects, similar to what numcrun experienced above.  I recently had this same issue occur and came across this post but after doing some additional testing, I was able to narrow it down to the "Options" key under HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Excel\Options.

    My Options key was set to 0x00000017.  When I either deleted that key (not recommended) or changed it to 0x00000057 (recommended), which is the value other users in my area had for that key, I was once again able to open Excel files by double-clicking.

    There is only a single bit difference between these values and clearing that bit is apparently what causes the problem.  I searched online to try to get a better understanding of the values for the Options key but was not able to find anything.  Nevertheless, correcting this single key is much safer than deleting the entire Excel branch and does not require you to reset any previous Excel defaults you may have had set.

    To keep whatever options you currently have and only set this one bit, convert your current value to binary, set the second bit (counting left to right; other people may count it differently so look at the example below), and convert it back to hex.  For example using the values I noted above:

    1. Converting 17 hex to binary = 0001 0111
    2. Setting the second bit = 0101 0111
    3. Converting that back to hex = 57

    Hope this helps!

    • Proposed as answer by teschste Friday, January 04, 2013 7:55 PM
    Friday, January 04, 2013 7:54 PM
  • So far People have created new User accounts and roughed up their Registry, Re-installed Office and Excel but did anyone actually figure out the real soultion to this Problem Yet I had the issue with one Account on a Win7 Pc with a 2.8Ghz Intel and 16gb Ram Not that my PC Specs matter. Anyway 1 out of 4 Accounts could not Open Word Documents via Double Click. Every time it would Error Out. The Issus is with Security Not the Registry or some Convuluted in-depth Coding STUFF. When your Error Message comes up you get the option to "Change how often these messages Apear"

    Change it!!!  DUH!!!

    Your current setting there is preventing Office from opening a file so if you make it a little more leiniant you've fixed the problem. Now I know I'm sounding Pompous but I went through this many times and found this solution by accident 4 times already after going crazy trying to totaly reprogram Windows in the process. This is one of those duh moment things you just have to remember Sometimes your own security settings will bite you in the Processor.


    • Edited by Mr.Jorge Sunday, September 22, 2013 10:46 AM
    • Proposed as answer by Mr.Jorge Sunday, September 22, 2013 10:47 AM
    Sunday, September 22, 2013 10:45 AM