none
Apply Watermarks across Section Breaks

    Question

  • Watermarks may be operating as designed, but is there anyway to default them to appear in all sections of a document.  If I create a custom text watermark, it appears on all pages, but if I create one, add it to the gallery, and then click to apply it appears only in the section where my cursor resides.  So if I am on page one where different first page is true, then the watermark does not even appear in the rest of section one.  I have to click the watermark on for every section of the document.  Yet, if I choose Remove Watermark, it is removed from every section. 

    I'd like to default the display to all sections.  Please advise.


    • Edited by orlandp Monday, January 30, 2012 12:27 AM
    Monday, January 30, 2012 12:26 AM

Answers

  • I created a macro called "copy watermark" to all pages/sections. 
    • Marked as answer by orlandp Thursday, May 03, 2012 8:45 PM
    Thursday, May 03, 2012 8:44 PM

All replies

  • Hi,

    What version of Word are you using?

    By default, watermarks will apply to all page in the document, unless you select option "Different first page" or "Link to Previous".

    You can try to remove watermark, and then re-add watermark test if it works.

    You may also reat this article:

    Insert a watermark or change a watermark.

    Best Regards.


    William Zhou

    TechNet Community Support

    • Proposed as answer by Leonid GanelineMVP Tuesday, January 31, 2012 8:59 PM
    • Unproposed as answer by orlandp Thursday, February 02, 2012 4:49 PM
    Tuesday, January 31, 2012 5:41 AM
    Moderator
  • Word 2010.  That is the issue.  If there are 2 headers (primary & different first page) in the document, the watermark only applies to the "header" containing the cursor.  Is there a way to display the watermark on all pages in a document containing a FirstPageHeader & Header without selecting the watermark twice?
    Thursday, February 02, 2012 4:52 PM
  • On 2012-02-02 17:52 (GMT+1), orlandp wrote:
    Word 2010.  That is the issue.  If there are 2 headers (primary & different first page) in the document, the watermark only applies to the "header" containing the cursor.  Is there a way to display the watermark on all pages in a document containing a FirstPageHeader & Header without selecting the watermark twice?



    Watermarks make use of the header; that is how they repeat. Therefore I don't see a way to change the behavior. Note that if you activate the header, select all (Ctrl+A), copy and paste into the “other” header, the watermark will be copied along with the rest of the header content.

    Stefan Blom, Microsoft Word MVP
    Thursday, February 02, 2012 7:33 PM
  • It's even easier than that.  Simply insert the cursor on a page using the other header and insert the watermark there.
    Thursday, February 02, 2012 9:40 PM
  • On 2012-02-02 22:40 (GMT+1), orlandp wrote:
    It's even easier than that.  Simply insert the cursor on a page using the other header and insert the watermark there.


    Of course, but let's assume that you don't remember which watermark was initially inserted; in such a case, it will be easier to copy an existing one.

    Stefan Blom, Microsoft Word MVP
    Thursday, February 02, 2012 10:38 PM
  • So if I can't remember what I just did 3 seconds ago, I shouldn't be using a computer.  :-)

    It doesn't make sense that the Remove Watermark option removes ALL watermarks across headers, but the Insert Watermark feature does not insert the watermark across all headers.

    Does anyone know if this can be easily remedied programmatically?


    • Edited by orlandp Friday, February 03, 2012 6:07 PM
    Friday, February 03, 2012 12:58 AM
  • On 2012-02-03 01:58 (GMT+1), orlandp wrote:

    <<So if I can't remember what I just did 3 seconds ago, I shouldn't be using a computer.  :-)>>

              
    :-)  Poor choice of words on my part. I was thinking of more complex cases where you have edited the watermark, for example, or added a custom one.
      
      

    <<It doesn't make sense that the Remove Watermark option removes ALL watermarks across headers, but the Insert Watermark feature does not insert the watermark across all headers.

    Does anyone know if this can be easily remedied programmatically?>>


       
       
    In a document with multiple unlinked headers, to delete a particular watermark, activate the header, select and delete the watermark. It wouldn't be hard to create a macro that does the same:

    ActiveDocument.Sections(1).Headers(wdHeaderFooterPrimary) _
    .Shapes(1).Delete

    In this simple example, it is assumed that the watermark to be deleted is in the primary header of section 1.

    Stefan Blom, Microsoft Word MVP

    Friday, February 03, 2012 7:11 PM
  • In the test I performed, it deleted all watermarks whether they headers were linked or not IF you selected the document.  That's why I question by inserting them is limited to linked headers.  I tried selecting the whole document and applying the watermark, but it inserts it in the first section only.

    Friday, February 03, 2012 11:20 PM
  • By chance do you have different odd and even headers & footers? If so put in temporary page breaks so you can see each header in the various sections.
    Kind Regards, Rich ... http://greatcirclelearning.com
    Saturday, February 04, 2012 3:46 AM
  • No, I do not.
    Tuesday, February 07, 2012 6:37 PM
  • this guy nailed it on the head

    http://help.lockergnome.com/office/Watermark-appears-section--ftopict1014978.html

    was having the same problem as you

    page 1 header different than page 2 and on's header

    using the built in functionality whenever i would add a watermark in one section, it would delete from the others.

    so i added the water mark to section 2.

    then went and selected the word art. copied it.

    scrolled up to section 1's header. pasted.

    now i have a consistent header across all pages

    Thursday, May 03, 2012 5:52 PM
  • I created a macro called "copy watermark" to all pages/sections. 
    • Marked as answer by orlandp Thursday, May 03, 2012 8:45 PM
    Thursday, May 03, 2012 8:44 PM
  • I had the same problem and found that the Custom Watermark option places the watermark in all headers (on all pages) even when the headers are different for first page, sections, and odd/even pages.

    Word 2010: Page Layout > Watermark > Custom Watermark > Text Watermark > select or enter text
    then select other options (Font, Size, Color, Layout, Semitransparent) > OK

    Wednesday, July 18, 2012 6:46 PM