none
Outlook 2007 public folder contact list not showing up in contacts

    Question

  •  

    ok, I have been dealing with this bug in outlook 2007 for about 3 months now.    click folder list expand public folders, right click on my public folder contact list, go to properties, go to outlook address book tab, then click checkbox to show as address book.   Ok.   So yes it shows up when I click "to"..to send a email, but it will not show up in my contacts list....here is the catch...sometimes I can get it to work but then after a few weeks or so, it will disappear.  totally random.   to get it to show up I have to do crazy stuff like check the check box, close outlook, open outlook uncheck close oulook, restart and so and so.....is there a fix for this bug.
    Wednesday, February 13, 2008 5:16 PM

All replies

  • good to see microsoft responds to these.....what a joke....I find answers quicker from google groups then this

     

    Wednesday, February 13, 2008 8:05 PM
  • I know what you mean...I'm on the web looking for an answer to a similar concern with MicroSuck...I never find it on one of their sites, tho. Good grief.

    Thursday, March 06, 2008 2:10 AM
  • Hello Technet ?   Can anybody help me with this ?   It is still happening.
    Monday, April 21, 2008 4:05 PM
  •  

    I am trying to fix this exact issue for a client as well. I can find no solution either...

    I guess MS doesnt have one as well.....

    If anyone gets a handle on this I would love to hear about it.

     

    Bman

    Tuesday, April 29, 2008 6:15 PM
  • All the suggestions I have found that claim to be a fix tell you to right-click on the Contacts folder, go to the Outlook Address Book tab, and then put a check in the "Use this...etc."  Trouble is I do not have an Outlook Address Book option in my Contacts folder's properties.  This is on Vista, with Outlook 2007.  What do I do?
    Sunday, May 04, 2008 12:12 AM
  • I have been trying to set up an Address Book in Outlook 2007 by the following,

    Outlook2007>Contacts>File>Folders>Prpoperties for Contacts>Outlok Address Book>

    Next is to check "Shw this folder as an email Address Book".

    BUT thsi box is grayed and cannlt be checked.This is not a problem in outlook 2003 but is in 2007.

    Dell spent 2 hours on the phone with me and could not fix the problem.

    Result I have no Address Book.

     

    Wednesday, May 21, 2008 4:28 AM
  • In "Account Settings" under "Address Book" check to see if the "Outlook Address Book" is listed.  If it is select the "Change" button.  If it is located there already, then then "Show this..." will be greyed out because it is already listed as a Outlook Address Book.  If the links get damaged due to changing of "PST" files, remove the "Contacts:..." from the "Change" list and reapply from either the "Contacts" properties of from the "Folders" Contacts properties.

     

    I have seen this behavior in past versions of Office (2k, 2k3) and this usually works.

    Wednesday, May 21, 2008 4:42 PM
  • Hi Dave,

     

    Let us know if you get a solution for this problem. Even my outlook does not check names from my address book. It does it from some cache file.... How can I turn it off from checking the cache file and actually checking my address book.

     

    anirban

     

    Thursday, May 22, 2008 11:39 AM
  •  

    Dave,

     

    I have had this problem too, but recently fixed it for multiple pc's. 

     

    1) If you pull open the contacts feature of Outlook 2007 you will notice there are several different address books listed.

    2) One of these address books has all of your contact information in it (the one not showing up when you click TO: in a new email message.)  You will also notice there is a "Contacts" folder with no contacts in it at all. 

    3) If you copy or move all of your contacts from the one that currently holds all of your contacts to the empty "Contacts" folder you will be able to see them when you go to send a new email message and click "To:"

     

    Hope this helps.

     

    PS.  I have not been able to have the same success with previous versions of Outlook.  It's just Outlook 2007.

     

    Andrew

    Tuesday, September 02, 2008 8:31 PM
  • I read some of the posts answering this and finally figured it out on my own, because the posts weren't clear to me. You go into Outlook "Contacts".  Right Click on the one that is not appearing in the "To:" of the email.  A pop-up box comes up. Click on "outlook Address Book".  Then make sure the box is highlighted, " Show this folder as an email Address Book".  Voila.  Problem solved.

    This happened to me a year ago, and I traveled around th internet, because I had this problem in Outlook XP as well as this one.  However, the solution was in a different place in Outlook 2007.
    Thursday, September 11, 2008 8:49 PM
  • Setup Outlook for use with the Exchange Public Address List

     

    1)     First Open Outlook and Click on the Folder view icon to see entire folder list available to you in Outlook.

     

    2)     Next scroll the Folder view window pane and open the Public folder plus sign and then click All Public Folders, then click once the Public Address List icon to highlight it. Right Click on this same list and choose 'Properties'.

     

    3)     Then Public Address List properties box opens. Select the 'Outlook Address Book' tab and check the 'Show this folder as an e-mail Address book' box and click OK.

     

    (NOTE: If this option is “Grayed Out” and cannot be selected. Please see the options to enable this feature at the end of this document. You will need to return to this step and continue.)

     

    4)     Close Outlook. Email or print to fax any document. Click on the "Address Book' button.

     

    5)      From the Address Book window, click the drop down button on the 'Show Names from the:' section and select the 'Public Address List' under the Outlook Address List section

     

    6)      Grayed Out Instructions:

     

    Outlook 2002, 2003, or 2007 Terminal Server Public Folder Address book availability for email setup instructions.

     

    Note that the ‘Show this folder as an e-mail Address book is “Grayed Out” and cannot be selected. Close this window and follow the below instructions.

     

    This will generally occur when using Outlook while logged into the Terminal Server .Click the Menu bar option Tools > Email Accounts > View/Change existing directories and address books, and Click ‘Next’ button.

     

    Click the “Add” button on the E-mail Account window to add a new address book.

     

    Click the Radio button on the ‘Additional Address Books’ Choice and click “Next’

     

    Highlight the Outlook Address book Choice and Click ‘Next’

     

    Outlook will have to be closed and restarted to enable access to the Public Folders Address books. Click ‘OK’

     

    Click ‘Finish” button and exit (Close) Outlook and restart Outlook.  Return to Step 2.

     

    Friday, October 31, 2008 6:58 PM
  • Cracked it!

    1. Make sure the 'Show this folder as an email address book' is ticked under the public folder contacts. (Right click properties on the public contacts, select properties, and click the 'outlook address book tab')

    2. Right click again on the public contacts and select 'add to favorites'.

    I have tested the above on a couple of machines but on one this didnt work on just one. To resolve this do the following:

    After selecting 'add to favorites' on the public contacts you will find that under the 'public folders' list a new folder is created called favorites.

    1. Right click on the contacts under the new favorites folder and select 'Properties'.
    2. Select the 'Administration tab'
    3. Click on the button that says: 'Add this folder to Contacts'

    I Hope this helps as this was driving me crazy

    Wednesday, November 05, 2008 10:36 AM
  • I found that a new contact saved would not show up in "To" in a new email unless it had a valid email address in the contact info. I created a "test" contact and not until I put xxxx@yyy.com in the "E-mail" section of the contact did it start showing up on the "To", "Contacts". Hope this helps.

    Wednesday, November 19, 2008 5:25 PM
  • Hello,

     

    Know this is a bit old post.  But as i just had the same problem, and no one here got a solution to why the favorit did not show up under the contacts.

    After digging a bit around, i found this page http://www.outlook-tips.net/howto/commandlines.htm

    /resetnavpane

    Clears and regenerates the Navigation Pane for the current profile. Removes all Shortcuts and Favorite Folders. Has the same effect as deleting profilename.xml in your user directory.

    Start Outlook with a switch > Start > Run > Outlook /resetnavpane

    It removed the previous ‘favorites’ and when added again, it now shows the other contacts.

     

    Cheers

    • Proposed as answer by Gavin.ADM Thursday, March 14, 2013 2:56 PM
    Thursday, January 29, 2009 2:16 PM
  • SETone you are my hero for the day.  The /resetnavpane did the trick for me.  Thank you.
    Saturday, February 14, 2009 12:25 AM
  • SETone, great suggestion!


    Diego Castelli
    Wednesday, October 07, 2009 2:47 PM
  • All the suggestions I have found that claim to be a fix tell you to right-click on the Contacts folder, go to the Outlook Address Book tab, and then put a check in the "Use this...etc."  Trouble is I do not have an Outlook Address Book option in my Contacts folder's properties.  This is on Vista, with Outlook 2007.  What do I do?

    Worked for me thanks :-)
    Thursday, October 15, 2009 3:16 PM
  • Old issue, but none of the proposed solutions had worked for me, and nothing I found anywhere on Google was helping.

    • Using Microsoft Outlook 2007
    • "Show this folder as an e-mail Address Book" is greyed out.
    • "Name of the address book:" is also greyed out.
    • Tools>Account Settings>Address Books. Outlook Address Book is mapped and remove is greyed out.
    • Attempting to add a new Outlook Address Book results in error "This account or directory type already exists and cannot be specified twice."
    • Hitting "Change" on "Outlook Address Book" shows zero items in the list.
    • The /resetnavpane option had no effect on the problem.
    • The user is using an Exchange Server account on our domain, with a Personal Folder mapped to a personal network drive mapped in a file server.
    • The computer was a brand new load and his profile was transfered using User State Migration Tool to the new system.

    I was able to solve this by deleting the outlook profile under Control Panel>Mail>Show Profiles, and then recreating the profile. It tried to bring up a dialog box to automatically configure the exchange account twice, which I cancelled both times.  After the second cancel, it asked if I was sure I wanted to create a profile without associating an email account, to which I said yes.  I then went back into the Mail Options and went to Email Accounts and manually configured the exchange account, ensuring Cached Exchange Mode was not checked.  I opened outlook back up and immediately went to Contacts and went to the properties of the Contacts List I wanted to use and the option was no longer greyed out.  I was able to set up the contacts list and it worked perfectly.

    • Edited by Solego Thursday, January 07, 2010 4:20 PM Added outlook version
    Thursday, January 07, 2010 4:20 PM
  • Thank you so much, you solved my contact problem!

    Sheila
    Saturday, February 06, 2010 10:06 PM
  • Finally.  I've been researching this for quite awhile.  The new profile answer is the only one that worked.  Thanks so much.
    Wednesday, February 10, 2010 7:42 PM
  • Hi,

    Usually this is happens with MS Exchange Account,

    Outlook contact list is not sync with exchange contact list.

    Reconfigure your exchange account and try.

    I fix the same many times.

      

     

     


    Monday, November 28, 2011 7:07 AM
  • What worked for me... some of it based on several suggestions in this thread, thank you all!

    Client on Exchange with Outlook 2007.

    Under Public Folders, right-click on the desired Contacts folder, and in Properties, added to the Outlook Address Book. (This had already been in place.)

    Then, under Public Folders, right-click on the Contacts folder, and click Add To Favorites. It will now appear in the Public Folders > Favorites folder. Drag and drop that icon onto the Outlook main Contacts navigation button. You should now see the Public Contacts folder in the Contacts area under My Contacts.

    I did try to drag and drop the actual Public Contacts folder the same way but it didn't work with that.

    Thanks, everyone!

    Thursday, March 29, 2012 10:38 PM
  • Even though this is a solution from 2008 it still seems to be the easiest way in 2013 to fix "links" broken in Outlook 2007 when you move or restore pst files and don't see your contact list displayed at the To... in a new mail message.  I  wonder why Microsoft never patched this problem.
    Wednesday, January 09, 2013 1:52 PM
  • ok.. your problem is not exactly as my problem but somewhat same. when you import contacts in outlook it show 'option' for mapping fields. if you not mapping field then sometimes it showing in contact list , i dont know whats the reason but i fix it by drag the left field to right box at appropriate matched field and its solve my problems.
    Monday, March 04, 2013 7:15 AM
  • You are a Gentleman, thank you - I spent quite a while looking at this for a customer and needless to say I was a little embarrased to find it was such an easy issue to fix....

    Thursday, March 14, 2013 2:57 PM