none
Can't overwrite Title with content enrichment

    Question

  • Hi guys,

    I set up my content enrichment web service, where I create custom titles to my indexed items.

    I output it to Title managed property with the proper configuration.

    For no reason, it doesn't overwrite it. When I output it to a different managed property (temptitle) there's no problem.

    Title is not set to Read Only, Mapping Disallowed,or Delete Disallowed (follow this for explanation).

    Any ideas?

    Amir

    Tuesday, January 01, 2013 2:02 PM

All replies

  • Hi Amir, 

    Probably your custom value for title is overwritten by mappings for Title property. I'm not sure in which order happens the mapping crawled properties and content enrichment callout, but maybe it's worth to try.

    To verify this idea - consider removing all mappings, reordering them or switching to "Include content from All ..."

    Friday, January 18, 2013 9:20 AM
  • Probably it's not the case with crawled property mappings, because according to my finding mapping actually occurs before enrichment.

    You might want to lower Diagnostic Logging level to Verbose for Search\Common Processing and Serach\Content Processing options. Probably this could help to understand what happens. (don't forget to switch back to default values after debugging)

    Friday, January 18, 2013 12:49 PM
  • Hi Alexey,

    You might want to take a look at my forum posting here: http://social.technet.microsoft.com/Forums/sharepoint/en-US/15311d8e-cc98-48a3-83d7-2034bad5a012/content-enrichment-updating-system-defined-managed-properties-author-department?forum=sharepointsearch

    I've run into the same issue with both 'Title' and 'Author' managed properties.   As per my forum posting, I logged a support ticket with Microsoft.  They've been able to reproduce the issue and I'm now waiting for them to confirm that it's by design or not.    Apparently there are three such properties but I'm not sure what the third is yet.

    Cheers
    Pete

    Wednesday, June 04, 2014 8:57 PM