none
Outlook 2013 + Gmail leads to many messages in drafts even after it is sent

    Question

  • I've added my Gmail to Outlook 2013 via IMAP. Now whenever I compose an email, if I let it wait for a while, it saves a copy to my IMAP drafts folder. However, when I send the message, the message gets sent but the message in the drafts folder still remains! Eventually this has let to my drafts folder being useless because it doesn't have just drafts - it's got a lot of work-in-progress emails that aren't drafts (i.e. too much noise in my drafts!)

    How can I setup Outlook so that when I send the email, it is cleared out of drafts?

    Wednesday, February 27, 2013 5:02 AM

Answers

  • That's might be the reason. Please set the minutes to 0 or disable the option to check if the behavior still remain. Cheers,
    Tony Chen
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Wednesday, March 06, 2013 3:12 AM

All replies

  • The relevant Settings is under File > Options > Mail Tab > Save messages section. Please check it.

    Cheers,
    Tony Chen
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Thursday, February 28, 2013 3:20 AM
  • Hi,

    Just checking in to see if the information was helpful. Please let us know if you would like further assistance.

    Cheers,
    Tony Chen
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Monday, March 04, 2013 1:23 AM
  • I checked it; but what is the reference to check it against?

    It looks like:

    "[check] Automatically save items that have not been sent after this many minutes: 3

    Save to this folder: Drafts"

    Tuesday, March 05, 2013 5:58 AM
  • That's might be the reason. Please set the minutes to 0 or disable the option to check if the behavior still remain. Cheers,
    Tony Chen
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Wednesday, March 06, 2013 3:12 AM
  • Hello, any update?

    Tony Chen

    Monday, March 11, 2013 2:17 AM
  • Hello Tony, I also have the common problem with getting drafts on my Gmail account even after a draft in Outlook is sent. 

    I've made the autosave setting change (disabled) that you suggest, but I'm concerned that no drafts at all will be saved when composing in Outlook.

    I tested by creating an email. Closing the email and saving a draft. Then going into Outlook drafts and sending it. The saved email is also saved on the gmail server, but the draft status is not updated with the IMAP server when the message is sent.

    I'd rather have to delete drafts that failed to have their status updated than have no drafts saved at all. This wasn't a problem under the previous version of Outlook.

    Wednesday, March 13, 2013 10:56 PM
  • Hi Tony and others,

    I have the same problem as I get a massive draft folder by the end of the day. Your proposed remedy will work by setting the 'auto-save' function to 0 minutes. However, this is a work-around, not a true solution as we need our draft folders to work correctly. So let's go back to leaving it enabled and changing the auto-save time period to something like 10 minutes or longer so it doesn't catch as many work-in-progress emails.

    Now, the problem that I think most of us are having is that after we send the email, the draft version of the entire email remains on the Gmail thread. In other words, if I post a reply to a single message (you send me an email and I'm responding to it) we will end up with 3 messages total in the thread. The first message will be the original message from you, the 2nd message will be the reply that has been sent by me, and the 3rd message will be an identical copy of the 2nd message except in draft form. This behavior is pretty consistent and occurs frequently.

    The link below references the same problem in his 'part A' of the question asked. His 2nd response is more descriptive and helpful as it pretty much hits the nail on the head in terms of what is going on. If you would like, I can probably reproduce the issue and take a screen shot for better description. EDIT: the website wouldn't let me post the full link so I will try again later. This is the name of the question asked: "Outlook 2013 - Gmail, message drafts and removing messages"

    Saturday, June 01, 2013 2:51 AM
  • Yeah, that's my thread.

    It's amazing that this obvious bug is still in Outlook 2013. It's crazy! Seems MS really does have some sort of battle with Google - why on earth do they need to aggravate customers of their Office suite is beyond me however. :(

    Monday, June 10, 2013 8:57 AM
  • It is a bug in Outlook - after a recent update its much better for me, but i still occasionally have drafts that never go away.


    Diane Poremsky [MVP - Outlook]
    Outlook & Exchange Solutions Center
    Outlook Tips
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Monday, June 10, 2013 3:43 PM
  • Hi Tony;

    Possibly useful to some as a band-aid, but not a solution.

    Unfortunately, this seems to be a bug that needs to be reported to the MS Dev team.

    Monday, September 09, 2013 2:56 PM
  • I just spent an hour looking for a solution to this.
    Wednesday, September 18, 2013 6:27 AM
  • Obviously this is a bug with no decent workaround. I too have a GMAIL account hooked to Outlook and it does save sent messages as draft messages.  And it does not delete them when they are sent.  Oulook is broken, it's an obvious severe bug and Microsoft could care less.
    Wednesday, October 09, 2013 1:50 AM
  • This is not just a G-mail bug.  I have the same problem using an IMAP account with pair.com. In recent weeks, I have had this problem and another issue since "upgrading" to Outlook 365.  The related problem is the inability to save deleted e-mails to the Inbox Trash Folder.  Does not work anymore.  Have to mark files to delete and then purge them.  Also, when moving an e-mail to another folder, the item is marked as deleted. This is all messed up and MS should fix this for all IMAP accounts.  OUTLOOK IS BROKEN,

    Friday, November 08, 2013 4:41 PM
  • i have the same problem i am using exchange email, also i am missing the amount of MB remaining in the progress bar below.

    prutal

    Saturday, November 09, 2013 2:17 PM

  • Hello,

    For you Google Apps users using the Google Apps Sync try disabling Drafts altogether.  Unfortunately Oulook Drafts will not Sync to GMail.  As noted here: 

    Drafts I save in Outlook don't sync to Gmail

    Unfortunately, Google Apps Sync doesn't synchronize email drafts with Gmail or other computers where you use Outlook. Please finish authoring your email using the same client where you started the draft.



    So long story short.  The best way to work with drafts and GMail using Outlook is to totally disable drafts from auto saving unless you like having 1000's of drafts to clean out.  You can always Save your drafts manually and this should work just fine.

    Tuesday, November 12, 2013 11:01 PM
  • Well... I've been dealing with this painful issue for a while and finally decided to investigate - resulting in finding this forum...   I agree that disabling auto-draft-save kinda defeats the purpose, since, as we all know, sometimes Outlook and/or Windows gives up and crashes/restarts... It happens...

    Some additional investigation led me to a mechanism that seems to be just the trick...

    office.microsoft.com/en-us/outlook-help/choose-which-imap-account-folders-appear-in-outlook-HP010355590.aspx

    HOWEVER, Outlook (or the IMAP functionality therein) has declared the 'Drafts' folder 'special', so won't permit unsubscribing...Grr.......

    Friday, April 18, 2014 8:16 AM
  • I have run into a similar bug where my auto-saved drafts are synching with Gmail and when I go to send, after modifications, Outlook tells me that the message has changed and can't be sent. 

    I finally found a workaround for Gmail that lets me auto-save the message but not synch the Drafts folder.

    While you can't unsubscribe from the Drafts folder in Outlook (special folder), you can configure Gmail to not included it in the IMAP synch process.

    - open Gmail

    - go to settings

    - click on the Labels tab

    - next to Drafts, uncheck "Show in IMAP"

    Now the Gmail Drafts folder will not be included in the IMAP synch. 

    Auto-save in Outlook will still save your draft email in the local Drafts folder, it just won't be synched with the Gmail server.  In addition, any online drafts that you are creating will not be synched back to Outlook.

    David

    Friday, June 13, 2014 1:43 PM
  • I've had an issue similar that when I begin a reply to an email and jump to another email as to reply to it before finishing the previous email, the draft acts like a pop3 email. I can delete it from Outlook as many times as I want, but it won't go away. It actually synchronizes with gmail and pops back up in the drafts folder. After researching and finding no answer and next having two drafts do this, I found out to try and pull the mailbox up through the browser. After accessing gmail through Chrome and deleting the drafts out, it finally synchronized properly and kept them out of Outlook. This only seems to happen with the drafts folder. I would consider this a workaround in my situation and would really like to know why it happens. Could be just a bug with Outlook 2013.
    Thursday, July 10, 2014 3:25 PM