none
OneNote Error: "Error occurred while attempting to sync this section or notebook."

    Question

  • We're working with OneNote, trying to edit Notebook in Office Web Apps in SharePoint 2010.

    When we make an edit to a Notebook saved in SharePoint, the changes aren't saved or sync'd to the Notebook in SharePoint. 

    09:07 OneNote in SharePoint 2010! (http://portal.company.com/sites/SiteName/) An error occurred while attempting to sync this section or notebook. (Error code: 0x8007009E) Click here to see help online about this error
    Has anyone seen this before? Thanks.
    Wednesday, December 08, 2010 10:44 PM

Answers

  • Hi,

     

    You can navigate to one such notebook and hit Shift-F9 - which will force a sync and sync should work from now on.

     

    Also you can create a new notebook and move your sections to it.

     

    To avoid the problem:

     

    1) Use a short name for the notebook

     

    2) Avoid using sections groups

     

    3) Use short names for sections

     

    4) Do not have too many sections

     

    It is not the "size" of the notebook that causes problem, it is the total size of the filenames stored on the server.

     

    Sincerely,

     

    Harry 

    • Marked as answer by Harry Yuan Thursday, December 16, 2010 7:10 AM
    Sunday, December 12, 2010 9:03 AM

All replies

  • Hi,

     

    You can navigate to one such notebook and hit Shift-F9 - which will force a sync and sync should work from now on.

     

    Also you can create a new notebook and move your sections to it.

     

    To avoid the problem:

     

    1) Use a short name for the notebook

     

    2) Avoid using sections groups

     

    3) Use short names for sections

     

    4) Do not have too many sections

     

    It is not the "size" of the notebook that causes problem, it is the total size of the filenames stored on the server.

     

    Sincerely,

     

    Harry 

    • Marked as answer by Harry Yuan Thursday, December 16, 2010 7:10 AM
    Sunday, December 12, 2010 9:03 AM
  • We also experience a similar problem.

    forcing a sync, as described in the above message, does not change anything - we continue to get the the following error:

    NoteBook Name (https://SharePointSite/Shared Documents/NoteBook Name/) The segment is already unlocked. (Error code: 0x8007009E)

    Thanks

    Sean


    Sean Sullivan
    Wednesday, January 26, 2011 7:32 PM
  • Yes - we get the same thing - can not figure out why
    Thursday, February 03, 2011 7:31 PM
  • OK i think i figured it out - Site Actions - Site settings - Site actions - Manage site Features 1 - is group list and tass (activated) ----- Next did you have onenote in a Doc Library or Documents (no folders in site - documents container)

    IE: Site Actions - Manage Content and structure - Site Settings Site Content and Structure is one note in a documents or in a library - i do not believe it will work in a Library structure template....  sort of the same thing with media web part not working in the lib template -  after doing above - my OneNote SYNC work's the lib template

    • Proposed as answer by cannonbear Friday, February 04, 2011 12:31 AM
    Friday, February 04, 2011 12:31 AM
  • I had the same problem with MOSS 2010. I was not able to sync a onenote notebook file to a standard document library.

    So i have created a new library and have chosen onenote document as the base template while creating and after that it works as expected.

    Hope it helps the others.


    Mirronelli
    Thursday, April 14, 2011 2:09 PM
  • Anyone able to resolve this syn error (0x8007009E)? Having this problem now. I have followed suggestions on this thread to no avail.

     

    Russ

    Tuesday, August 09, 2011 6:10 PM
  • I was getting the sync error and, while I'd call it more a workaround than a resolution, I am now able to successfully sync the notebook. As per Mirronelli's suggestion above I created a new library with OneNote document as the template type and was able to successfully replicate the notebook that refused to sync with multiple regular document libraries.

    On the same document libraries that were having the sync issue with OneNote I noticed an issue with the web OneNote. If I copied a OneNote file in to the document library I could open it, but if I tried to create a new section using the web OneNote after a few seconds it would come back with an "Error saving section " sectioname. Since I moved the OneNote documents to the new library I can't replicate the error. It looks like it may also be resolved by using a document library with OneNote document as the template type.

    Andrew


    Monday, September 05, 2011 2:17 AM
  • Hey Mike, I came across this error and the issue turned out to be a field in the document library being required.  Once all of the fields were unrequired, syncing worked fine.

    • Proposed as answer by Mr Phil Miller Friday, September 30, 2011 2:05 PM
    Wednesday, September 28, 2011 5:11 PM
  • LaShelle,

    Did you try filling in the required fields using the property editor? I was wondering if the problem was due to the fields being required at all or OneNote not prompting the user to fill them in.

    Thinking about it, when I created a new document library I also moved from "Require Documents be Checked Out" setting of Yes to a setting of No, so it may have been removing the checkout requirement or required fields that fixed my problem more than moving to a document library with OneNote template type.


    Andrew S. Martin
    Wednesday, September 28, 2011 7:12 PM
  • I was having all of these issues the Required Fields is what was actually holding me up at the end of it all.  I could not remove a required field setting, but I did set a default value for it. 

    That resolved all the problems I had with SharePoint 2010 and OneNote 2010.

    Friday, September 30, 2011 2:05 PM
  • Sorry late response, but I was suffering with this same issue and wasn't able to google for solution. Following advice from our helpdesk solved the issue for me:

    1. Go to library settings

    2. Select 'Versioning settings' under 'General settings'

    3. Select 'No' for setting 'Require documents to be checked out before they can be edited?'

    No brainer now, but I wasted some hours on this issue nevertheless.

    Monday, March 26, 2012 9:30 AM
  • Ville-Matti,

    I cannot figure out how to get to the "library settings". Any help greatly appreciated. Thanks.

    -Anil.

    Thursday, April 19, 2012 6:54 PM
  • I found that my folders on SkyDrive had brackets ([]) in the title. I removed them and this error was solved.

    Tuesday, July 17, 2012 9:44 PM
  • Anil ,

    Go to Site Libraries and Lists

    Select List item

    General Setting --> Versioning Settings

    - Sunny

    Tuesday, July 24, 2012 3:25 PM