none
What's wrong with Visio 2010

    Question

  • I am using Visio since about 15 years now and go back far beyond the time before MS bought that company.

    In the very very beginning Visio had problems with zooming and aligning lines to the grid. It made it almost impossible to work with. Luckily around 1997 all those problems were fixed.

    After installing Visio 2010 I have got all the same problems again. What does it help to move to a newer disputable GUI concept (which only slows one down), when the underlying basics are messed up? All my Figures are a mess now (again), nothing fits together anymore.

    While I found a way to convince Visio to zoom in precise steps (exactly 100%, exactly 200%, and so on), I found no way to draw precise on the grid.

    The zoom fix is bad enough, as I have to run manually a Macro each time I open a file.

    I would appreciate, if somebody could tell me, if there is a smart and elegant solution to my problems.

    Furthermore I would appreciate, if somebody of the developers or marketing guys could tell me, what they had in mind with this new concept.

     

    Sunday, September 26, 2010 12:28 AM

Answers

  • It appears that the horizontal spacing (vertical seems to snap as expected). I will submit the issue to development so they are aware of the issue and can consider fixing it in a service pack or product release.

     

    As a workaround, I suggest the following for workarounds that might make snapping to the grid better.

     

    >> Adjust Snap & Glue settings:

    1. On the View tab, in the Visual Aids group, click the Visual Aids Dialog Box Launcher.

    2. Click the Advanced tab.

    3. In the Snap strength section, adjust the Grid snap strength.

     

    >> Adjust Ruler and Grid settings:

    1. On the View tab, in the Show group, click the Visual Aids Dialog Box Launcher.

    2. You can change from the default “Fine” Grid spacing and ruler subdivisions to another setting or define the minimum spacing. These are adjusted based on zoom.

     

    ** this will have to be done for each axis separately

     

    >> Object sizes can be changed in the Size and Position window. Select the shape and go to View tab, in the Show group, click the “Task Panes” button and select “Size and Position”

     

    >> To answer the question about changing zoom levels, in the bottom right corner, click on the zoom percent sign on the bottom and a dialog box will appear to change the percentage


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thanks!
    Adrian
    Microsoft Online Community Support

    Wednesday, October 06, 2010 7:33 PM
    Answerer
  • It looks like development is aware of the zoom issue. The suggestion is to add the “zoom” command in a customized ribbon and adjust the zoom from there. To do so, right click on the ribbon and choose “Customize the Ribbon”.  From the “Choose commands from” dropdown, choose “All Commands”. Add a new tab and select the Zoom command and choose Add and OK.

    --------------------------

    To get a macro to run when a file is opened, he could create an add-in and let the “Load behavior” to “Load on demand”. Here is an article that has information about the issue.

    http://msdn.microsoft.com/en-us/library/aa201798(office.10).aspx


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thanks!
    Adrian
    Microsoft Online Community Support

    • Marked as answer by zabel1970 Wednesday, February 16, 2011 1:09 AM
    Tuesday, October 19, 2010 11:44 PM
    Answerer

All replies

  • I am not exactly sure what you are looking to do so please give me repro steps or more explanation. Snap and Glue settings can be controlled by going to Tools > Snap and Glue and under Advanced tab, you can change the Snap strength


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thanks!
    Adrian
    Microsoft Online Community Support

    Wednesday, September 29, 2010 7:47 PM
    Answerer
  • I also have a suspicion that something is wrong with snapping-to-grid in Visio 2010.

    I haven't had time to track down and isolate any problems, however. Whatever is wrong, it doesn't seem to be happening all the time. But I keep seeing shapes that *should* be, say, 1in x 1in, set via snapping, but upon closer inspection are 1.031in  x 1in. or something similar.

    Anybody else seeing problems in this area?


    Chris Roth Visio Guy (http://www.visguy.com)
    Monday, October 04, 2010 10:57 AM
  • It appears that the horizontal spacing (vertical seems to snap as expected). I will submit the issue to development so they are aware of the issue and can consider fixing it in a service pack or product release.

     

    As a workaround, I suggest the following for workarounds that might make snapping to the grid better.

     

    >> Adjust Snap & Glue settings:

    1. On the View tab, in the Visual Aids group, click the Visual Aids Dialog Box Launcher.

    2. Click the Advanced tab.

    3. In the Snap strength section, adjust the Grid snap strength.

     

    >> Adjust Ruler and Grid settings:

    1. On the View tab, in the Show group, click the Visual Aids Dialog Box Launcher.

    2. You can change from the default “Fine” Grid spacing and ruler subdivisions to another setting or define the minimum spacing. These are adjusted based on zoom.

     

    ** this will have to be done for each axis separately

     

    >> Object sizes can be changed in the Size and Position window. Select the shape and go to View tab, in the Show group, click the “Task Panes” button and select “Size and Position”

     

    >> To answer the question about changing zoom levels, in the bottom right corner, click on the zoom percent sign on the bottom and a dialog box will appear to change the percentage


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thanks!
    Adrian
    Microsoft Online Community Support

    Wednesday, October 06, 2010 7:33 PM
    Answerer
  • Thanks, Adrian!

    The workaround fixes the problem with the gird.

    Is there any smart solution to the Zoom issue (to get exactly the zoom level one selects)? It is not very elegant to run that macro manually.

    Currently I use the following (simple) macro:

    Sub Zoom()
    ThisDocument.ZoomBehavior = visZoomVisioExact
    End Sub

    Regards,

    Martin

     

     

    Friday, October 08, 2010 11:02 PM
  • Sorry, Adrian, saw only now, that you replied on the Zoom issue, too.

    The problem is, that exactly that is not working. Selecting 100% (e.g. using the radio buttons) gives me a 106% zoom. Going to 200% results in 212% and I get 53% instead of 50%.

    Even if I enter the percentage manually, I get the same results.

    Viso tries to automatically adjust the Zoom to the screen resolution / aspect ratio. I have this problem on 3 computer systems (2 running under W7, 1 running under Vista).

    The following simple macro (I am not much of a VB programmer) solves the issue, but it is burdensome to run it each time I open a file:

    Sub Zoom()
    ThisDocument.ZoomBehavior = visZoomVisioExact
    End Sub

    I did not find a way to run it automatically when opening a file, as it is possible for Word and Excel.

    Is there a setup or parameter file, in which I can change the ZoomBehaviour value?

     

    Regards,

    Martin

    Friday, October 08, 2010 11:11 PM
  • It looks like development is aware of the zoom issue. The suggestion is to add the “zoom” command in a customized ribbon and adjust the zoom from there. To do so, right click on the ribbon and choose “Customize the Ribbon”.  From the “Choose commands from” dropdown, choose “All Commands”. Add a new tab and select the Zoom command and choose Add and OK.

    --------------------------

    To get a macro to run when a file is opened, he could create an add-in and let the “Load behavior” to “Load on demand”. Here is an article that has information about the issue.

    http://msdn.microsoft.com/en-us/library/aa201798(office.10).aspx


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thanks!
    Adrian
    Microsoft Online Community Support

    • Marked as answer by zabel1970 Wednesday, February 16, 2011 1:09 AM
    Tuesday, October 19, 2010 11:44 PM
    Answerer
  • I just figured out that the problem exists only with drawings based on metric units. US units based drawings appear to zoom OK.

     

    Wednesday, February 16, 2011 1:13 AM
  • Hi all!

    Sorry, but I've tried the workaround related to the "Snap to Grid" function and it simply does not work.

    In previous versions (say, Visio 2007, for instance), just clicking the "Snap to Grid" button would produce the intended result. Scaling or moving objects would automatically "jump" to sizes or locations glued to the grid.

    Currently, nothing happens. I have even customized the ribbon, in order to have a "Snap to Grid" button [BTW... why on earth should they remove the most interesting tool buttons from the ribbon default settings...? :-( ].

    Now I have that button. But everytime I choose (click to select) any shape that I want to snap to the grid, that button is grayed out and does not work at all.

    Since the latest response to this post is almost one year old... can anyone tell me if there is a most recent solution, one that actually works??

    (I'm available to send printouts if needed)

     

    Thanks!

    Friday, January 13, 2012 12:16 PM
  • Hugh, you've inserted your text into the answer added by Adrian so it looks like Adrian wrote your texdt and you added nothing.


    -- Paul Herber, Sandrila Ltd. Engineering and software shapes for Visio - http://www.sandrila.co.uk/

    Tuesday, May 22, 2012 6:20 AM
  • Thanks for the heads up.  First time on this forum and was trying to put in a reply to Adrian.  Maybe I can just copy my rant as a reply?  I'll try anyway.  Is there a way to find out if MS is going to address this (horizontal connectors do not snap to the grid/ruler per my comments) or will MS just let the customers stew in their juices for years?
    Wednesday, May 30, 2012 11:17 AM
  • Is this the only answer to fix this?  I am fuming!!! I use "connectors" every day in my work when I do graphics for process units.  These connectors become flowpaths ("pipes") for process fluids.  In Visio 2010, connectors no longer snap to the grid or ruler whenever I create a new horizontal pipe or even adjust or attach to/intersect with an existing line.  The result of trying to draw a straight, horizontal connector along the grid is that the start-point and end-point of the line are on the grid but the rest of the connector is slightly offset from the grid line.  In other words, the connector becomes a very shallow, square "U". All of these flow lines have arrowheads showing direction.  As a result of this egregious programming error, arrowheads now point at 90 degrees to the actual flow direction because the arrowheads line up with the legs of the shallow "U".

    This creates a tremendous amount of work for me as I "fiddle" with handles and try to get the line to lay along the grid/ruler (which then corrects the arrowhead). I do not need to be spending time on every line I draw! Every drawing contains scores of lines.  Since the orientation of the vessels, etc. connected by lines can change, I have to go back and redo lines that have now "slipped off" a grid/ruler line. 

    SURELY, some genius at MS can fix this.  I do not need to be using macros or zoom settings, etc.  JUST FIX IT Microsoft and do it QUICK!!  MS has almost ruined this application for our company's use by not making the effort to repair such an obvious fault.  I think it might have something to do with programmers/designers not getting input from the "real world" and only relating to their cloistered world of geekdom.  As a side-note, the same attitude has ruined the Windows Phone and I plan to switch my personal, non-company phones, computers, "pads" to the "competition" (gag..which I said I would NEVER do unless a hot place froze over..must have frozen over).

    Wednesday, May 30, 2012 11:20 AM
  • Press Ctrl+Shift+i - it's an old combination since Visio 4.0 ;)
    Thursday, November 21, 2013 10:48 AM