none
Outlook 2010 - Email not removed from server

    Question

  • For some reason, Outlook 2010 will not remove the email from the ISP's mailbox when it is sucking the messages into Outlook.  I have two different mail servers; both accounts leave the messages on the server as well as the message in Outlook.  I have setup both accounts to use pop3 for the account type.

    I configured the mail accounts exactly as I did in Outlook 2007 and never seemed to have this issue, anyone heard of this?
    Thanks!
    noop

    Update: Just found out Outlook 2010 has the option checked by default to leave a copy of the messages on the servers for 14 days.  To disable this option, Click on the File Tab, Account Settings..., Account Settings.  Double click on your account, click More Settings button, Advanced Tab, Uncheck leave copy of messages on server.

    Tuesday, December 01, 2009 4:40 AM

All replies

  • thx i ll test it , it was big problem for me i hope it ll work.
    Monday, January 04, 2010 12:45 AM
  • No it dosn’t work no such box to uncheck it was in 2007

    Monday, January 04, 2010 4:03 PM
  • Can anyone advise on how to do this?  My emails are piling up on my server.  There is no such check box in the location mentioned above, which is the same as in the Help area.  Without this feature, Office 2010 will not be usable.
    Tuesday, January 05, 2010 6:46 PM
  • It appears this setting is only present for POP accounts, not IMAP.   What is the procedure to remove old messages from the server if you used the auto setup and it was created as IMAP?
    Tuesday, January 05, 2010 6:59 PM
  • My accounts all set themselves up automatically as IMAP/SMTP accounts and I don't have the option to remove old messages from the server either. It's causing me a big problem on the server, too.

    Microsoft HELP!!!!!!!!!!!!!!!!!!!!!!!
    • Proposed as answer by homebrews Thursday, February 11, 2010 8:49 PM
    Saturday, February 06, 2010 4:53 PM
  • IMAP is a server account, copies of messages are downloaded to outlook. You need to delete the messages in outlook then purge to delete them off the server.

    Autodiscovery uses IMAP if the mail provider publishes IMAP settings because this allows you to access the account from anywhere. If you want a POP3 account you need to create it yourself.


    Diane Poremsky [MVP - Outlook]
    Outlook Tips: http://www.outlook-tips.net/
    Outlook & Exchange Solutions Center: http://www.slipstick.com
    Saturday, February 06, 2010 7:00 PM
  • Click the Files tab, Account Settings, New on the eMail tab. Radio button Microsoft Exchange, Pop3 or Imap. On the next page the radio button on the bottom Manually configure server settings or additional server types. Click Next and then follow the bouncing ball.

    Hope this helps.
    Thursday, February 11, 2010 8:53 PM
  • In Outlook 2010 Click the File tab, Click Account Settings, Click on account settings again, Hightlight existing email account, click change, click more settings..., click Advanced tab, in Delivery section uncheck box "Leave a copy of message on the server.", click OK, click next, after test email has been sent click close, click finish.
    • Proposed as answer by screeno Thursday, May 31, 2012 7:39 AM
    Thursday, July 08, 2010 11:22 PM
  • Thank you, thank you thank you Mike.  I just got a new laptop with Windows 7 and office 2010.

    Both my server and local computer repair shop did not know how to rectify the mail problem.

    I followed your directions and they worked perfectly. Now I don't have to keep going on line

    to empty old mail form the server everyday! - C S T

    Sunday, August 15, 2010 9:55 PM
  • after clicking advanced tab, there is no "delivery" section....and no box to uncheck!

    Still stuck, please help....

    Also, can't change from imap back to pop....

    Friday, October 22, 2010 5:04 PM
  • after clicking advanced tab, there is no "delivery" section....and no box to uncheck!

    Still stuck, please help....

    Also, can't change from imap back to pop....


    What type of email account? You can only remove mail from the server if using POP3.

    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Friday, October 22, 2010 6:37 PM
  • Your USP should have been able to correct this issue.....I had the same problem, and this is what they did....

    At Outlook go to File.....account settings....click the email address.....click more settings......click advanced.....

    The bottom title is Delivery.....uncheck "leave a copy of message on the server"

    That will clear up your problem

     

     

    Wednesday, January 26, 2011 12:51 PM
  • I hate outlook 2010.

    If you have IMAP you cannot delete emails from server unless you delete from Outlook, but I can't do that for recordkeeping. So, you have to switch to POP, then it gives you the option of removing from the server.

    Once an email account is imap, you cannot change it to pop, except from deleting it. By deleting it, you lose all emails, all organized folders- everything. I had to do it, because my mailbox was full. POP will delete them off the server (but I must keep the history of emails locally), so I tried to switch to POP, but Outlook also automatically sends emails to confirm your account, so it didn't let me create a new pop account, because it tried to confirm and found the emails bounced because the mailbox was full. So, I had to figure out how to increase the limit in cpanel on the server, then go back and recreate the account, but I lost some emails in the process and the ones that were flagged to follow up, I have to go back in and find again. It also deleted all my sent mail, which I needed to keep. 

    All because Outlook doesn't let you switch from IMAP to POP.

     

     

    Thursday, January 27, 2011 5:37 PM
  • if you need to remove mail from the server but keep a copy, you can stay with imap and drag/move the messages you need to save to a local pst for archiving.

    Did you try disabling the option to test the account? That should have allowed you to create the pop account without erroring.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Thursday, January 27, 2011 8:25 PM
  • I have tried this on my version and there is no option to uncheck this.  Any other ideas where this may be?

     

    Thursday, April 07, 2011 7:35 PM
  • What type of email account do you have? The options vary with each account type.

    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Thursday, April 07, 2011 7:45 PM
  • It works as you describe it in the Update. Thanks a lot...
    Saturday, April 16, 2011 2:20 PM
  • Try clicking on file account settings and highlight the e mail account you want to change.
    Click on the change Tab at the top and select the more settings tab.
    Click advanced and remove the tick from: (Leave a copy of messages on the server).
    That should do it.
    Zane771
    • Proposed as answer by Zane771 Friday, May 13, 2011 4:43 PM
    Friday, May 13, 2011 4:42 PM
  • I'm having a similar problem. I have UNCHECKED the box in Office 2010 Outlook. Right after I uncheck the box and perform a "Send/Receive" it downloads the messages, however the next I check my email and perform a "Send/Receive" it downloads the messages BUT leaves them on the server. Is this a bug? Is there a fix?
    Wednesday, May 18, 2011 2:16 AM
  • i follow one of the feedback, delete IMAP acct and manually setup a POP3 acct.

    then it allow to an option if you want to save a copy at server, uncheck it, and everything go well.

    you won't having all incoming and outgoing mail choked up your server mailbox anymore.

     

    Tuesday, June 14, 2011 2:48 AM
  • thank you. I was going crazy trying to find this. Just followed your directions and found it right away. Thanks so much!!
    Monday, August 29, 2011 7:28 PM
  • if you need to remove mail from the server but keep a copy, you can stay with imap and drag/move the messages you need to save to a local pst for archiving.

    Did you try disabling the option to test the account? That should have allowed you to create the pop account without erroring.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Please help this Outlook Novice figure out how to find or create a pst.

    Brilliant L.E.D. Sign Solutions and Components, "Neon" LED Flex Tubing, Electronic Message Centers, Digital Billboards. No Account is Too Small to be Important!
    Friday, November 18, 2011 12:03 AM
  • Assuming Outlook 2010, File, Account Settings, Data Files tab. Click Add. Type in a name for the Pst file and click Ok. 

    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Friday, November 18, 2011 12:06 AM
  • What made them think we wanted this ridiculous feature?!
    Friday, January 13, 2012 4:16 PM
  • What made them think we wanted this ridiculous feature?!


    What rediculous feature are you talking about?

    Assuming you mean that Outlook leaves POP3 mail on the server for 14 days by default, it was much requested. If you don't want it, go to File, Account Settings, double click on the account then More Settings - it's on the Advanced tab. If you need one, a tutorial is at http://www.slipstick.com/outlook/email/to-leave-internet-messages-on-the-server/.

    IMAP, Hotmail Connector, and Exchange server are server-based accounts and the proper behavior is to leave mail on the server. If you don't like it, switch to POP3 and change the setting to leave mail on the server.

    When you use the auto-discover feature to set up your account and the mail provider published IMAP account configurations, Outlook will default to use IMAP. If you don't like it, configure the account manually.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Friday, January 13, 2012 5:15 PM
  • Doesn't work.  No such button. 
    Monday, January 23, 2012 10:45 PM
  • Which button don't you have? What type of email account do you use - IMAP, POP3, Exchange, Hotmail Connector? Remove from server (the topic of this post) is only available for POP3 accounts.

    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Monday, January 23, 2012 10:56 PM
  • For some reason the answer of

    "Delete your existing setup and lose all your emails then manually configure a new one" appears to be an acceptable answer to this problem.

    I would have thought the options of:

    1. Change the drop down from IMAP to POP3 and you will have acces to the delete feature, or

    2. Add the delete feature to IMAP anyway

    would have been simple (for the users) and logical.

    I have just had my PC crash and migrated to a new PC. I have 15 email accounts and I now discover this issue. What a waste of my time.

    As a software developer my self, I hate seeing features which expect the user to jump through hoops, especially if they are committed to a specific path without warning.

    Thursday, February 09, 2012 11:01 PM
  • You won't lose your existing email that is already downloaded - the pst is not deleted when you remove an account from your profile.

    2. If you mean you want an option in IMAP to delete it from the server after downloading, that defeats the purpose of using IMAP. You need to move mail out of the imap account to remove it from the server (or just delete it).



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Thursday, February 09, 2012 11:16 PM
  • I am having the same problen: after a while the box is checked again.

    Did you find a sollution?

    Wednesday, February 22, 2012 1:07 PM
  • I have made a new POP3 account on outlook and changed the settings, but now when I receive emails they will un-bold as a read email even when I haven't read them?  Anyone have this issue before, or any solutions?

    Thanks

    Thursday, February 23, 2012 7:57 PM
  • Using Outlook 2010 with an Exchange server and apparently using IMAP (I do not have the Leave-messages-on-the-server option on the famous Advanced tab).

    Just want to share my observation that when you use a rule (not manually) to move a message out of the Inbox to another folder or PST file, it will also be removed from the server. So you could define a rule that would simply move every incoming message to some sort of shadow inbox. This way your Inbox will be empty, the server will be empty too and you can still keep messages for reference. No need to switch to POP3.

    Hope this helps (me).

    Wednesday, April 04, 2012 12:35 PM
  • Yes, that works too... but why are you using IMAP with an Exchange mailbox? It should say what type of account you have in File, Account Settings - Email tab, to the left of the account name.

    If it says Microsoft Exchange, its not IMAP. When you use an Exchange mailbox, mail is always left on the server so you can access it from everywhere. (Just like IMAP, only better.)



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Wednesday, April 04, 2012 2:32 PM
  • In Outlook 2010 go to File...Options...Advanced . You will see a Send/Receive section. Click the Send/Receive button on the right.

    Select Edit, then select your account and click on Account Properties. Now select the advanced tab and you will see the "Leave on Server" setting.

    My Microsoft Core Infrastructure & Systems Management blog - blog.danovich.com.au

    • Proposed as answer by danovich_ Sunday, May 13, 2012 12:13 PM
    Sunday, May 13, 2012 12:13 PM
  • Was so excited getting mac office 2010. Last used office 2007. Set up outlook and has all the problems mentions in this forum. I don't have the options to  check off deleted messages from server. I have one account set up as a pop3 same problem. There is not a check box in the pop3 like you mentioned. I've tried all the helpful suggestions in this forum and I can't find or access any of this settings. When I look at the help sections, even the pictures on HOW TO the screen shots even look different. Nothing like the  Mac Office 2010.

    Twice trying to reset up the account all my messages disappeared. Just hoping nothing important

    Unfortunately, this email program is useless for me if this problem can not be solved. Is there a way to just delete oulook mail from office without going through the reinstall and possibly losing other information.

    I'll continue using imail, which I do like but I really did enjoy Outlook, put definately not this version.

    Tuesday, May 29, 2012 7:51 PM
  • Was so excited getting mac office 2010. Last used office 2007. Set up outlook and has all the problems mentions in this forum. I don't have the options to  check off deleted messages from server. I have one account set up as a pop3 same problem. There is not a check box in the pop3 like you mentioned. I've tried all the helpful suggestions in this forum and I can't find or access any of this settings. When I look at the help sections, even the pictures on HOW TO the screen shots even look different. Nothing like the  Mac Office 2010.

    Twice trying to reset up the account all my messages disappeared. Just hoping nothing important

    Unfortunately, this email program is useless for me if this problem can not be solved. Is there a way to just delete oulook mail from office without going through the reinstall and possibly losing other information.

    I'll continue using imail, which I do like but I really did enjoy Outlook, put definately not this version.

    This thread is about Windows Outlook 2010, not Mac's Outlook 2011, so dialogs will be different.

    What type of email account is setup in your Outlook? Leave on server is a POP3 only feature.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Tuesday, May 29, 2012 9:31 PM
  • In Outlook 2011, go to Tools, Accounts, sleect the POP3 account then click the advanced button at the bottom of the screen to change the leave on server settings.


    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Tuesday, May 29, 2012 9:57 PM
  • Just want to say that Mike Porch's reply way back on Thursday, July 08, 2010 11:22 PM is what did it for me!

    Lots of people are giving instructions on unchecking 'Leave a Copy of Messages on Server', and that is accurate, but the setting DOES NOT STICK, unless you follow Mikes spot-on advice, which is, AFTER unchecking the box, "click OK, click next, after test email has been sent click close, click finish".  There's the key... you must return to the dialog preceding where you unchecked the box, and send the test email as Mike instructed.

    HTH!



    Win7 ♦ Sandboxie ♦ VIPRE


    • Edited by screeno Thursday, May 31, 2012 7:38 AM
    Thursday, May 31, 2012 7:22 AM
  • I like using IMAP so I can use my phone as well. It works much better with IMAP than POP because I can delete and file with my phone. This feature really should be added to the IMAP so I can delete off the server if I want to. Can you explain what the pst is? Is that a solution to keeping it IMAP?
    • Edited by CV9692 Wednesday, June 27, 2012 10:23 PM
    Wednesday, June 27, 2012 10:22 PM
  • To keep a message but remove it from the IMAP server, you can indeed move it to a pst-file. You should already have a default one (since IMAP accounts can't Contacts, Calendar, Tasks, etc... folder) but you can also create one via File-> New-> Outlook Data File... (Outlook 2007 and previous) or New Items-> More Items-> Outlook Data File... (Outlook 2010)

    BTW: For future posts, always include your Outlook version.



    Robert Sparnaaij [MVP-Outlook]
    Outlook guides and more: HowTo-Outlook.com
    Outlook Quick Tips: MSOutlook.info

    Wednesday, June 27, 2012 10:53 PM
  • I like using IMAP so I can use my phone as well. It works much better with IMAP than POP because I can delete and file with my phone. This feature really should be added to the IMAP so I can delete off the server if I want to. Can you explain what the pst is? Is that a solution to keeping it IMAP?

    The purpose of IMAP leaving mail on the server is exactly the same reason why you like it- you can read it on your iphone or other computers and delete it off the server if you want to. When you do, the deletion is reflected in all computers and devices you use to read your mail.

    If you want to delete mail from the server and keep it in outlook, you need to move it to the local pst file.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Wednesday, June 27, 2012 10:57 PM
  • Hi Diane and all the others,

    I have the same problem but just with the "Remove from server after .... days".

    Running on Outlook 2010, 
    Windows 7, 
    configured POP mail account, 
    checked "leave a copy.....on the server", 
    checked "Remove from server after 14 days", 

    but the message stays on the server.
    If I uncheck "leave a copy", all my message are deleted, so the connection with the server is good but it does not seem to understand the deadline limit.

    Any tips on that ?

    Thursday, July 19, 2012 6:32 AM
  • First, did it ever work right with either 2010 or an earlier version of Outlook? Does it work if you delete from the server when deleted from Outlook? (Empty deleted folder to test) Do you know what software the server is using?



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Thursday, July 19, 2012 12:13 PM
  • Actually I had my email settings for POP3 accounts as:

    Leave message in server (checked)

          Keep for 14 days (unchecked)

          Delete from server when deleted from "Deleted Items" (checked)

    Now it would work for me only when I delete all the emails I have in the "Deleted Items" folder and then staying in the folder I click on the "Send/ Receive All Folders" button.  I checked it for my other accounts and it all worked fine.  Clicking the "Send/Receive All Folders" button did not work when I was on the Inbox folder or any other folder.

    I did not check if it works fine for emails that are already deleted in that folder previously but were still available on the server.  I am thinking it works only when I am in the Deleted Items folder.  Try it.

    Now for imap accounts an email is downloaded straight to Outlook once it is opened in Outlook and is not available even in webmail.  Thanks.

    Thursday, August 23, 2012 5:50 AM
  • Correct, you need to empty the deleted items folder, then on the next send and receive, Outlook updates the server.

    The IMAP behavior is not correct - unless you are using a 'hide read messages' view in webmail. IMAP syncs the mailbox with Outlook - the server mailbox is identical to what Outlook has, down to what is marked read (sorta like Exchange and Hotmail Connector, but email only).



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Thursday, August 23, 2012 2:35 PM
  • It Worked!! Thanks..

    • Proposed as answer by rodhuerta Tuesday, September 25, 2012 3:58 PM
    • Unproposed as answer by rodhuerta Tuesday, September 25, 2012 3:59 PM
    Tuesday, September 04, 2012 10:34 PM
  • Thanks Mike - this was the answer I needed. Some of my accounts were set to hold messages on the server - and some not.

    Thanks big time here.

    Tom L

    Thursday, January 03, 2013 8:13 PM
  • Mike,

    I followed each of your steps. Everything was fine until I got into the Advanced tab. BUT there is no Delivery section.

    Hmmm...

    Thanks anyhow.

    Terry Thomas
    Atlanta

    Sunday, April 14, 2013 7:28 AM
  • danovich:

    No there is no "Leave on Server" checkbox.

    My email comes from the Google Gmail server so is an IMAP account.

    The problem is that the Microsoft geeks know what all this IMAP stuff means but we great unwashed have no idea of the ins and outs. We just want to delete from the server. We don't give a damn if our account is IMAP or POP, we just want it to work!

    Where is Bill Gates when we need him???

    Sunday, April 14, 2013 7:43 AM
  • Thanks, it worked for me!
    Saturday, May 04, 2013 6:24 PM
  • it was silly default setting on MO 2010, im almost lost precious info on my email because my webmail out of capacity.

    thanks for info.

    Monday, May 13, 2013 10:02 AM
  • EXACTLY. Some common sense finally.

    Friday, July 05, 2013 1:17 PM
  • THanks to Diane and Mike,hopefully I have mine sorted. I'm going to use 2 accounts, IMAP when I'm travelling and want the server to keep the messages til I get home, and POP when I'm at home on my core PC. I just wish each new software package came with a "what has changed"...

    Friday, July 05, 2013 1:27 PM
  • Well, I'm sure that works for some version of Outlook, but not the 2010 version.  There's even a note at that tutorial site that states "The steps you need to follow to leave POP3 email on the server depends on your version of Outlook."

    There is no delivery box available in the 2010 version.  Any other ideas/solutions?  I'd prefer ones that work with Outlook 2010, however.

    Tuesday, December 10, 2013 7:46 PM
  • That would be POP3 and version 2010.
    Tuesday, December 10, 2013 7:47 PM
  • Same problem, different way to get there.  There is no "Leave on Server" setting.  I think it may exist depending on how the account got set up in the first place.  I don't see the option to "Leave on Server" and there are many others that don't see it either.
    Tuesday, December 10, 2013 7:58 PM
  • Same problem, different way to get there.  There is no "Leave on Server" setting.  I think it may exist depending on how the account got set up in the first place.  I don't see the option to "Leave on Server" and there are many others that don't see it either.
    Tuesday, December 10, 2013 7:59 PM