none
Modified date changes in Word 2010 without saving.

    Question

  • Some files (made in Word 2k) I open and get asked if I want to update the links. I answer no. When closing the file the modified date is set to today. After turning off "update links" in the settings, I am not asked anything but still the modified date is changed. This is a very undesired behavior. I would even consider it a bug .
    Friday, December 03, 2010 12:46 PM

Answers

  • The real issue is that it does not seem to be possible to stop Word from "updating" links to spreadsheets.  While it does not actually update the link if the option to update automatic links on open is unchecked, after opening a document containing a link to a spreadsheet and then attempting to close it without doing anything else, you will be asked if you want to save the changes to the document.

    -- Hope this helps.

    Doug Robbins - Word MVP,
    dkr[atsymbol]mvps[dot]org
    Posted via the Community Bridge

    "macropod" wrote in message news:fa4e20aa-f239-4847-b719-1b2989b54001@communitybridge.codeplex.com...

    I am not interested in the internal bookkeeping of Word. If I open a file to just read it, Word should not mess with the saved date under any circumstances.

    Hi victor,

    I understand well enough that you don't have any date-type fields in your document. My suggestion for using the SAVEDATE field was simply to obtain from Word it's interpretation of when the file was last saved.

    I fully agree that Word should not change the system 'modified' date if the file hasn't been changed. However, any such change is done by your system, not by Word itself. So, what OS are you using? Is it part of a network? Does your Word file include any macros? If so, have you checked whether any of those macros include code to save the file?

    -- Cheers

    macropod MS MVP - Word


    Doug Robbins - Word MVP dkr[atsymbol]mvps[dot]org
    Thursday, December 09, 2010 2:02 AM

All replies

  • The dates displayed by the CreateDate and SaveDate fields will not change. The latter however only if you do not save the document.

    -- Hope this helps.

    Doug Robbins - Word MVP,
    dkr[atsymbol]mvps[dot]org
    Posted via the Community Bridge

    "victor50" wrote in message news:376feddb-c5a8-4657-ae15-1aaa1940ef5c@communitybridge.codeplex.com...

    Some files (made in Word 2k) I open and get asked if I want to update the links. I answer no. When closing the file the modified date is set to today. After turning off "update links" in the settings, I am not asked anything but still the modified date is changed. This is a very undesired behavior. I would even consider it a bug .


    Doug Robbins - Word MVP dkr[atsymbol]mvps[dot]org
    Friday, December 03, 2010 9:56 PM
  • Sorry to say but you did not read my post very well. It was about the "modified date"  (windows/OS property) and I DID NOT SAVE THE FILE. Am I the only one on forums who thinks that more and more people do not care to read the question and just say something?
    Monday, December 06, 2010 6:40 PM
  • Hi victor,

    In your first post, you didn't say whether you had saved the file. Answering prompts when a document opens or changing the settings has no effect on the 'modified date' unless the file is re-saved. You can test whether the document was re-saved by inserting a SAVEDATE field - if the date & time returned by that field matches the system 'modified date', then clearly the file was saved on that date.


    Cheers

    macropod MS MVP - Word

    Monday, December 06, 2010 9:13 PM
  • I thought "closing the file" would be enough, otherwise the whole problem makes no sense because if I saved the file of course the saved date would be changed. I am not interested in the value of the "SAVEDATE" field and would be very surprised if that field would show the original saveddate while in windows explorer the date reported is the date the file was closed (NOT SAVED). In that case the bug would even be bigger. My idea of the bug: There is some "link" in the (Word 2K) doc-file that Word 2010 would like to update. Regardless of the state of the "update links" setting Word 2010 considers not updating as a choise, changing the file and without me saving the file it saves this "change" to disk.

    Monday, December 06, 2010 9:32 PM
  • Changing the "update links" setting has no effect on an open document's saved state - it is an application-level setting, not a document-level setting.
    Cheers

    macropod MS MVP - Word

    Monday, December 06, 2010 11:18 PM
  • I did read and understand your question.  The statement that I made deals with the issues that are significant.  The date displayed in Windows Explorer/OS Property is not significant.

    -- Hope this helps.

    Doug Robbins - Word MVP,
    dkr[atsymbol]mvps[dot]org
    Posted via the Community Bridge

    "victor50" wrote in message news:acb19435-f7f9-4965-ba46-f8abda2bbe40@communitybridge.codeplex.com...

    Sorry to say but you did not read my post very well. It was about the "modified date"  (windows/OS property) and I DID NOT SAVE THE FILE. Am I the only one on forums who thinks that more and more people do not care to read the question and just say something?


    Doug Robbins - Word MVP dkr[atsymbol]mvps[dot]org
    Tuesday, December 07, 2010 12:40 AM
  • I am not interested in the internal bookkeeping of Word. If I open a file to just read it, Word should not mess with the saved date under any circumstances. If there is any concrete action I can take to avoid this I will be glad to hear. Otherwise I would like this reported a bug to MS by any MPV or other person having enough blat to get it through.
    Tuesday, December 07, 2010 8:25 AM
  • This is not a bug. It is by design. The reason is that you have inserted a date field which shows the PC's system date. What you need to do is change those date fields for createdate fields - ALT+F9 change { DATE } or { TIME \@ "d MMM yyyy" } to { CREATEDATE \@ "d MMM yyyy" } then F9 and ALT+F9 - and change the date in your letterhead template so that future letters based on it show the correct dates. The switch  \@ "d MMM yyyy" may be different at your location.

    See http://www.gmayor.com/stop_automatic_date_update.htm



    <victor50> wrote in message news:43ce6be8-d9bc-4cfa-becf-1bb13a36378d@communitybridge.codeplex.com...

    I am not interested in the internal bookkeeping of Word. If I open a file to just read it, Word should not mess with the saved date under any circumstances. If there is any concrete action I can take to avoid this I will be glad to hear. Otherwise I would like this reported a bug to MS by any MPV or other person having enough blat to get it through.


    Graham Mayor - Word MVP
    www.gmayor.com
    Posted via the Communities Bridge
    http://communitybridge.codeplex.com/
    Tuesday, December 07, 2010 2:05 PM
  • This is getting a bit tiresome as you all refuse to read the post well enough. To be sure I just checked the document in question again and it contains a reference to an excel worksheet. It is this sheet-reference Word 2010 asks if I would like it updated (when the setting for automatic update is on) or does not mention anything if the setting is off. I don't want to have the file changed one bit. I just want to view it. Then close it. And when I look in windows explorer I don't want to see the date "last modified" changed to today.  IT DOES NOT CONTAIN ANY DATEFIELD AT ALL.  

    Getting a bit grumpy I suggest you MVP's all give back one medal and take a course "how to read word-problem posts". As for remarks about being "by design", this is standard response from god MS. A god makes no mistakes. Everything is by design.

    Tuesday, December 07, 2010 3:57 PM
  • If you open a file and read it and close it WITHOUT saving it, the date displayed by the { SAVEDATE } field in the document will not be changed.

    -- Hope this helps.

    Doug Robbins - Word MVP,
    dkr[atsymbol]mvps[dot]org
    Posted via the Community Bridge

    "victor50" wrote in message news:43ce6be8-d9bc-4cfa-becf-1bb13a36378d@communitybridge.codeplex.com...

    I am not interested in the internal bookkeeping of Word. If I open a file to just read it, Word should not mess with the saved date under any circumstances. If there is any concrete action I can take to avoid this I will be glad to hear. Otherwise I would like this reported a bug to MS by any MPV or other person having enough blat to get it through.


    Doug Robbins - Word MVP dkr[atsymbol]mvps[dot]org
    Tuesday, December 07, 2010 7:50 PM
  • And it was only in your fifth post that you mentioned that the file contained a link to an Excel spreadsheet.

    We are not mind readers.

    -- Hope this helps.

    Doug Robbins - Word MVP,
    dkr[atsymbol]mvps[dot]org
    Posted via the Community Bridge

    "victor50" wrote in message news:9a433fba-c91f-47cf-a6e5-ff508f88616a@communitybridge.codeplex.com...

    This is getting a bit tiresome as you all refuse to read the post well enough. To be sure I just checked the document in question again and it contains a reference to an excel worksheet. It is this sheet-reference Word 2010 asks if I would like it updated (when the setting for automatic update is on) or does not mention anything if the setting is off. I don't want to have the file changed one bit. I just want to view it. Then close it. And when I look in windows explorer I don't want to see the date "last modified" changed to today.  IT DOES NOT CONTAIN ANY DATEFIELD AT ALL.

    Getting a bit grumpy I suggest you MVP's all give back one medal and take a course "how to read word-problem posts". As for remarks about being "by design", this is standard response from god MS. A god makes no mistakes. Everything is by design.


    Doug Robbins - Word MVP dkr[atsymbol]mvps[dot]org
    Tuesday, December 07, 2010 9:33 PM
  • I am not interested in the internal bookkeeping of Word. If I open a file to just read it, Word should not mess with the saved date under any circumstances.

    Hi victor,

    I understand well enough that you don't have any date-type fields in your document. My suggestion for using the SAVEDATE field was simply to obtain from Word it's interpretation of when the file was last saved.

    I fully agree that Word should not change the system 'modified' date if the file hasn't been changed. However, any such change is done by your system, not by Word itself. So, what OS are you using? Is it part of a network? Does your Word file include any macros? If so, have you checked whether any of those macros include code to save the file?


    Cheers

    macropod MS MVP - Word

    Tuesday, December 07, 2010 9:57 PM
  • The real issue is that it does not seem to be possible to stop Word from "updating" links to spreadsheets.  While it does not actually update the link if the option to update automatic links on open is unchecked, after opening a document containing a link to a spreadsheet and then attempting to close it without doing anything else, you will be asked if you want to save the changes to the document.

    -- Hope this helps.

    Doug Robbins - Word MVP,
    dkr[atsymbol]mvps[dot]org
    Posted via the Community Bridge

    "macropod" wrote in message news:fa4e20aa-f239-4847-b719-1b2989b54001@communitybridge.codeplex.com...

    I am not interested in the internal bookkeeping of Word. If I open a file to just read it, Word should not mess with the saved date under any circumstances.

    Hi victor,

    I understand well enough that you don't have any date-type fields in your document. My suggestion for using the SAVEDATE field was simply to obtain from Word it's interpretation of when the file was last saved.

    I fully agree that Word should not change the system 'modified' date if the file hasn't been changed. However, any such change is done by your system, not by Word itself. So, what OS are you using? Is it part of a network? Does your Word file include any macros? If so, have you checked whether any of those macros include code to save the file?

    -- Cheers

    macropod MS MVP - Word


    Doug Robbins - Word MVP dkr[atsymbol]mvps[dot]org
    Thursday, December 09, 2010 2:02 AM
  • The real issue is that it does not seem to be possible to stop Word from "updating" links to spreadsheets.  While it does not actually update the link if the option to update automatic links on open is unchecked, after opening a document containing a link to a spreadsheet and then attempting to close it without doing anything else, you will be asked if you want to save the changes to the document.

    -- Hope this helps.

    Doug Robbins - Word MVP,

     

    If only it would ask! But it just closes the file without asking anything. As for hints that the OS (W7 64) would change the date without getting any instruction from the application (Word) to actually save changes: I find it very hard to believe and even a bigger bug.
    Thursday, December 09, 2010 9:08 AM
  • Hello Victor50,

    I realize that your post is old but I only saw it today as I too was frustrated with Office 2010 changing the "date modified" for Word docs and others.  IF you have still yet to resolve the matter I have found a check box which makes all the difference.   When you go to save a document, go to Options and find "Keep the last auto saved version if I close without saving"...it's the 3rd line item on the screen....Note, this becomes your default option unless you check the box again.

    Hope this is helpful.

     

     

    Monday, February 06, 2012 6:52 PM
  • Use that with caution - if you make some changes that are only meant to be temporary, or if you change your mind about making changes after the last save and close the document, you might be in for a nasty surprise.
    Cheers
    Paul Edstein
    [MS MVP - Word]
    Monday, February 06, 2012 10:04 PM
  • Did anyone figure this out and get a real answer?  We have a tremendous amount of documents created everyday and we are constantly opening prior Word docs to view and then close without saving.  It is important for us to keep the original date of a document if no changes have been made.  We cannot go backwards and make all these read only -- a pain you know where. 

    Is there not any options that you can select to make sure the modified date of a word document does not change unless you click on save or save as instead of just closing?

    Thank you for your help -- this is critical to our firm's procedures.

    Thursday, March 08, 2012 4:29 PM
  • I too would really like to know how I can fix this; it's critical to my work procedures as well.  I have to write several different drafts of documents, and being able to sort by date modified makes it easy to go back through them to track additions and deletions and so on.  Without date modified it's almost impossible, because as I'm sure you all know, once the numbering goes above 9, the sorting goes all to pieces.

    Can anyone help?

    Friday, March 30, 2012 5:01 AM
  • Word does not change the last-modified date used by the system or, for that matter, the last-accessed date. Those matters are managed by your operating system. Unless you either:
    • have an addin that saves the document behind the scenes; or
    • answer 'Save' to a prompt to save changes,
    Word doesn't do anything to the file that an operating system can legitimately interpret as a change to the last-modified date.

    For example, I have a Word document on my system that I last saved in January 2011. That document has links to an Excel Workbook. When I open the file, I am asked whether I want to update the links. If I answer yes, the links are updated. If I now close the file without saving the changes caused by updating the links, the last-modified date remains unchanged - January 2011. Amongst other things, this confirms what I posted on 6 & 7 December 2010 and invalidates Doug Robbins' post that has wrongly been marked as the answer.


    Cheers
    Paul Edstein
    [MS MVP - Word]

    Friday, March 30, 2012 6:26 AM
  • I realize this post is old, but in our company we are using Win7 and Word 2010 and are experiencing this exact issue. I am an IT support manager and the documents do not have any links to other documents and no auto-dates.  I have watched a person open a document and then immediately close it again without making any changes or any mouse movements, and the document modified date updates to the current date and time.  They are not even asked if they want to save the document - the date just updates. 

    As a very clumsy and temporary fix, I have the user exit Word and reload Word and then the behavior stops, but I'd like to know what glitch is causing this behavior.

    A post above from "Perserverance...." says to uncheck the "keep the last autosaved version if I close without saving" unchecked.  We do have that checked.  But again, no changes were made to this document to cause that autosave to kick in and the user was not in the document for more than 3 seconds.  Could this autosave option be causing the problem somehow.  Anybody discovered a fix for this problem yet?


    • Edited by jholehouse Monday, March 11, 2013 9:01 PM
    Monday, March 11, 2013 8:59 PM
  • As indicated in my last reply - the one immediately before your post - this is not a Word issue; it is something being done by your operating system.

    Cheers
    Paul Edstein
    [MS MVP - Word]

    Monday, March 11, 2013 9:15 PM
  • How have you ruled it out as a Word issue?  If my user exits Word and reloads Word, the behavior goes away.  I'm not saying that means Word is the culprit, but I'm not rebooting or resetting the OS in any way by just exiting the app.
    Tuesday, March 12, 2013 3:15 PM
  • How have you ruled it out as a Word issue?
    See my reply of Friday, March 30, 2012. There could be no clearer proof than that.

    Cheers
    Paul Edstein
    [MS MVP - Word]

    Wednesday, March 13, 2013 5:27 AM
  • We found the issue causing the edit date to update on documents without saving.  By the way, further testing after my last post proved it was also happening to PDFs.  It's a Daylight Saving Time glitch with the OS.  We researched our old tickets on this and the last time this problem occurred was the last time change.  The time just changed for us again this past weekend and bingo, the problem comes back.  We think we narrowed it down to computers that have not rebooted since the weekend DST switch.  Once a person reboots, the problem goes away and does not come back.  I know this doesn't pinpoint exact what is causing it in the OS, but I plan to next search some more on the Microsoft website to see what I can find.  Rebooting fixed our problems though.
    Wednesday, March 13, 2013 1:31 PM