none
Exch 2013 Forwarding Mail from local account to External SMTP user

    Question

  • New 2013 implementation... Two Servers (Front End and Back End) both running Exchange 2013.

    I am having trouble sending a local AD Exchange mailbox mail to external SMTP address.  I have tried several options.. I have created an "contact" as was required in previous versions.  I have created new AD accounts with external SMTP addresses, I have also attempted to use the scriptlet:

    Set-Mailbox -Identity "%AD-USER%" -DeliverToMailboxAndForward $true -ForwardingSMTPAddress externaluser@mail.com  (%AD-USER% was actual AD Username/mailbox) and externaluser@mail.com was actual receipient SMTP address (username@gmail.com)

    Local AD Mailbox receives the mail appropriately however I have enabled forwarding everyway I know how and nothing seems to work.  If I send mail straight from my account to the destination SMTP address, they get it; just not if it is sent to the local AD account then forwarded via -DeliverToMailboxAndForward command...

    Please help.. I have several users that I need to have their mail CC'd to an external SMTP address.. Previous versions of Exchange required a "Contact" to be created and then the mailbox forwarded to that contact, which had a SMPT mail address...

    Im not adverse to implementing via powershell if I can just get it to work... Any suggestions are greatly appreciated and needed.

    Wednesday, November 21, 2012 7:53 PM

All replies

  • Hi,

    I'd sugest you try with a mail contact. Hope it is helpful.


    Fiona Liao

    TechNet Community Support

    Thursday, November 22, 2012 2:39 AM
    Moderator
  • Hello,

    Is there any update? If the issue is resolved, please mark the answer accordingly. Thanks.


    Fiona Liao

    TechNet Community Support

    Wednesday, November 28, 2012 2:02 AM
    Moderator
  • I have tried.. If you read the entire post.. You will see there are / were mail contacts created and mail was forwarded...

    This is not an acceptable answer...

    Monday, December 10, 2012 4:18 AM
  • If I create a contact and then go to user mailbox and click on messaging features and enable mail flow details and then select "Enable Forwarding", I am prompted to select a mailbox or group to forward to, I then seelct Browse, and the system only displays "UserMailBox" options and NO contact info.

    This is the root of the problem, as no GUI is available to select a forwarding contact SMTP address.  Please advise further.

    • Proposed as answer by Riad63 Sunday, June 02, 2013 2:17 AM
    • Unproposed as answer by Riad63 Sunday, June 02, 2013 2:17 AM
    Monday, December 10, 2012 4:27 AM
  • In Exchange 2013 forwarding Mails to external Contacts is not possible using the GUI.

    Try this: (found at: http://www.techieshelp.com/exchange-2013-forward-email-to-external-contact/ )

    Exchange 2013 Powershell – Forward To External Contact

    First the command, then the description.

    Set-Mailbox -Identity "Allen" -DeliverToMailboxAndForward $true -ForwardingSMTPAddress allen@hotmail.com

    The command above will forward all emails from the mailbox “Allen” to Allen@hotmail.com and also leave a copy of the email in the Allen mailbox in Exchange 2013

    Set-Mailbox -Identity "Allen" -DeliverToMailboxAndForward $false -ForwardingSMTPAddress allen@hotmail.com

    The command above will STOP THE forward of all emails from the mailbox “Allen” to Allen@hotmail.com due to the $false command.

    • Proposed as answer by Don Le Chalks Thursday, December 20, 2012 5:18 PM
    Tuesday, December 11, 2012 2:29 PM
  • Have you tried setting the forwardingSMTPAddress to another local address?

    If that is beeing delivered, I suspect there is an issue with gmail dropping your e-mails as spam.

    The e-mail you are forwarding is not coming from the correct source if they use reverse lookup.


    stefan@xperta

    Tuesday, December 11, 2012 2:38 PM
  • The same problem at my side. We have only one Exchange server.

    Mail is not forwarded to gmail, hotmail and other domains.
    Send connector is exactly the same as in Exchange 2010. Reverse DNS is setup correctly.
    In Exchange 2010 this was not the problem.

    Thanks for help in advance!

    Monday, December 17, 2012 5:18 PM
  • I would like to add, that mail is not forwarded to external Mail server.

    I can't find records of external mail in TransportRoles/Logs/Hub/ProtocolLog/SmtpSend logs.

    Monday, December 17, 2012 9:35 PM
  • Here is what I have to do:

    1. Create a contact in the Exchange 2013 "Admin Center".
    2. If you want keep and forward, From Exchange Management Shell: Set-Mailbox -Identity "Allen" -DeliverToMailboxandforward $True -ForwardingSMTPAddress "allen@externaldomain.com" -ForwardingAddress "allen@externaldomain.com"
    2a. 2. If you want to forward only, From Exchange Management Shell: Set-Mailbox -Identity "Allen" -DeliverToMailboxandforward $False -ForwardingSMTPAddress "allen@externaldomain.com" -ForwardingAddress "allen@externaldomain.com"

    If you go back into the Admin Center and look at the properties of the Mail Flow, Forwarding, you will see your Contact listed.


    • Proposed as answer by TM Carter Wednesday, December 19, 2012 2:57 PM
    Monday, December 17, 2012 11:08 PM
  • This answer absolutely worked for me... THANK YOU...

    Im not certain why I could not get this to work previously, but after I reissued the commands below with the right "Alias" ID, Mail FWD is now working to external SMTP addresses. Many, Many Thanks to the community.. and tisk, tisk to MS for making something so straightforward so complicated and convulated :-) Merry Christmas to all and I certainly hope each person here has a prosperous New Year. Ty Carter

    "bwarwick98 wrote"

    Here is what I have to do:

    1. Create a contact in the Exchange 2013 "Admin Center".
    2. If you want keep and forward, From Exchange Management Shell: Set-Mailbox -Identity "Allen" -DeliverToMailboxandforward $True -ForwardingSMTPAddress "allen@externaldomain.com" -ForwardingAddress allen@externaldomain.com


    TM Carter

    Wednesday, December 19, 2012 3:03 PM
  • TM Carter - glad I could help.

    I just found out that if you uncheck the box "Enable Forwarding" in the Exchange Admin Center to stop the forwarding, it does not remove all of the Forwarding Addresses and the users email will be in limbo. If you used the above commands to enable Forwarding, issue this command to stop forwarding:

    From Exchange Management Shell: Set-Mailbox -Identity "Allen" -DeliverToMailboxandforward $False -ForwardingSMTPAddress $Null -ForwardingAddress $Null

    Brent


    Friday, December 28, 2012 3:04 PM
  • I realize I'm a little late to the party, but I must be missing a step here.  I did the full process described with no success.  The PowerShell command is executed with no feedback or confirmation.  I additionally get an error when the second "-ForwardingAddress" trigger is included.

    Couldn't find object allen@externaldomain.com. Please make sure that it was spelled correctly or specify a different
    object.
        + CategoryInfo          : NotSpecified: (:) [Set-Mailbox], ManagementObjectNotFoundException
        + FullyQualifiedErrorId : 25E622EF,Microsoft.Exchange.Management.RecipientTasks.SetMailbox
        + PSComputerName        : server.ad.domain.com

    Is there another piece of the puzzle that I don't have properly configured?  This is a single Exchange server in the simplest, generic configuration possible.

    I appreciate any leads and for the info provided in this thread thus far.  I am somewhat dumbfounded that such a simple operation is such a chore in Exchange 2013.

    Thursday, February 07, 2013 12:04 AM
  • I spent several hours on this but I found the perfect solution to forward to external and internal emails.

    In my case, I needed to forward to more the one external email (This applies to Exchange 2013):

    Here is how:

    Using the EAC,

    1) Make sure that ENABLE FORWARDING is unselected under the delivery options in mailbox features for your particular user.

    2) Create all the External Contacts you need to forward in the CONTACTS tab in RECIPIENTS.

    3) Create a group in the GROUPS tab, give it a meaningful Display name, and for ALIAS, make sure it is

    a name that does not exist in any mailbox. This name will make part of a new email for that group.

    You will need this email later to us in the SHELL for the last step.

    Further down, under members, click on the plus sign to add all the contacts you wish to forward. You might want to uncheck ADD GROUP OWNER AS MEMBER.

    Leave everything else with the defaults and click SAVE.

    4) After you save, go back and edit the same GROUP you just created and click on delivery management.

    Click the SENDERS INSIDE AND OUTSIDE OF MY ORGANIZATION radio so that any external emails are accepted.

    CLICK SAVE.

    Using the EXCHANGE SHELL enter the following command that will forward emails to that new group and keep

    a copy of the email in the mailbox.

    Substitute "user_to_forward_email" and "groupaliasemailaddress"

    with your information:

    Set-Mailbox  username_to_forward  -ForwardingAddress groupaliasemailaddress

    THIS WORKED PERFECT FOR ME

    Note that at this point  you cannot use the EAC to forward to groups.

    I don't know why but Microsoft should fix this

    unless there is something I don't know.

    HOPE THIS HELPS everyone out there looking for this type of scenario.

    Sunday, June 02, 2013 2:13 AM
  • I spent several hours on this but I found the perfect solution to forward to external and internal emails.

    In my case, I needed to forward to more the one external email (This applies to Exchange 2013):

    Here is how:

    Using the EAC,

    1) Make sure that ENABLE FORWARDING is unselected under the delivery options in mailbox features for your particular user.

    2) Create all the External Contacts you need to forward in the CONTACTS tab in RECIPIENTS.

    3) Create a group in the GROUPS tab, give it a meaningful Display name, and for ALIAS, make sure it is

    a name that does not exist in any mailbox. This name will make part of a new email for that group.

    You will need this email later to us in the SHELL for the last step.

    Further down, under members, click on the plus sign to add all the contacts you wish to forward. You might want to uncheck ADD GROUP OWNER AS MEMBER.

    Leave everything else with the defaults and click SAVE.

    4) After you save, go back and edit the same GROUP you just created and click on delivery management.

    Click the SENDERS INSIDE AND OUTSIDE OF MY ORGANIZATION radio so that any external emails are accepted.

    CLICK SAVE.

    Using the EXCHANGE SHELL enter the following command that will forward emails to that new group and keep

    a copy of the email in the mailbox.

    Substitute "user_to_forward_email" and "groupaliasemailaddress"

    with your information:

    Set-Mailbox  username_to_forward  -ForwardingAddress groupaliasemailaddress

    THIS WORKED PERFECT FOR ME

    Note that at this point  you cannot use the EAC to forward to groups.

    I don't know why but Microsoft should fix this

    unless there is something I don't know.

    HOPE THIS HELPS everyone out there looking for this type of scenario.

    Sunday, June 02, 2013 2:18 AM
  • This answer absolutely worked for me... THANK YOU...

    Im not certain why I could not get this to work previously, but after I reissued the commands below with the right "Alias" ID, Mail FWD is now working to external SMTP addresses. Many, Many Thanks to the community.. and tisk, tisk to MS for making something so straightforward so complicated and convulated :-) Merry Christmas to all and I certainly hope each person here has a prosperous New Year. Ty Carter

    "bwarwick98 wrote"

    Here is what I have to do:

    1. Create a contact in the Exchange 2013 "Admin Center".
    2. If you want keep and forward, From Exchange Management Shell: Set-Mailbox -Identity "Allen" -DeliverToMailboxandforward $True -ForwardingSMTPAddress "allen@externaldomain.com" -ForwardingAddress allen@externaldomain.com


    TM Carter

    I'll just comment for future reference.

    In the seccond step here: -ForwardingSMTPAddress is not relevant. The actual solution is to specify -ForwardingAddress (if you look at Get-Mailbox usename |fl - you'll see, that the -ForwardAddress is resoved to a domain object (rather than beeing a smtp address)). So, you'll need:

     1. Create a contact in the Exchange 2013 "Admin Center" (or Shell)

    2. Set-Mailbox -Identity "Allen" -DeliverToMailboxandforward $True -ForwardingAddress allen@externaldomain.com

    Friday, July 05, 2013 7:13 AM
  • Does anyone know what the commands would be for forwarding mail from a mail enabled public folder to an external email address.  I setup the contact, but I am not sure what the public folder command would look like to enable forwarding delivered to the public folder and to the external email address (contact).

    Thank you 


    Fred Zilz

    Wednesday, August 21, 2013 12:41 AM
  • Is there any update to get this working with EAC. I really really really hate powershell with ever fiber of my being - this may stun MS but I'm not alone.     People would all be sitting in front of a unix system lsing and greping all day if command scripts were better than GUI.       
    Wednesday, April 02, 2014 6:47 AM
  • Creating a mail contact for the forwarding is necessary.


    MCP-MCSA-MCSE-MCTS-MCITP-Exchange Server solutions consultant

    Saturday, May 31, 2014 9:48 AM