none
Outlook 2013 Inbox & Unread Mail Sync Counts

    Question

  • As per the image attached the 'Unread Mail Search Folder' is not updating the sync counts.

    My Inbox is zero yet the unread mail search folder is showing 71 unread emails in my inbox.

    I have tried creating a new 'Search Folder' and even the new search folder exhibits the same behaviour.

    The only way to get the count of the inbox to zero in the search folder is to expand the search folder tree and click each email individually to mark it as read.

    Office Professional Pro 2013 RTM x64 (via TechNet Subscription) connected to Exchange 2007 SP3 x64 with Rollup 8 installed.

    If anyone has some ideas to further troubleshoot this I would be glad to here said ideas.

    Thanks,

    Stephen Edgar

     


    Cheers, Stephen Edgar

    Tuesday, October 30, 2012 3:51 AM

All replies

  • Tested but I have no such behavior.(Windows 7 64 bit with Office Professional Pro 2013 RTM x32,  Exchange 2007)

    Can you reproduce it on another folder?

    Go to File > Account Setting > open your Exchange account > Adjust "Mail to keep online" to "All", restart Outlook to check the result.

    You may also create a new profile and re-setup Exchange account, Disable all of your AVG/Firewall, launch Outlook with the switch command-line "Outlook.exe /safe" to test it.

    Since there are several unread messages exist in your mailbox, if necessary, please try to mark them as read and then test the result in that situation.

    Feel free to post back. Thanks.

    Cheers,
    Tony Chen
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.


    Wednesday, October 31, 2012 2:06 AM
    Moderator
  • Hi,

    Just checking in to see if the information above was helpful. Please let us know if you would like further assistance.

    Cheers,
    Tony Chen
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Friday, November 02, 2012 9:58 AM
    Moderator
  • Can you reproduce it on another folder?

    No, only the Inbox.

    Go to File > Account Setting > open your Exchange account > Adjust "Mail to keep online" to "All", restart Outlook to check the result.

    'Offline Settings' I have 'Use cached Exchange Mode' checked to 'yes' and 'Mail to keep offline' set to 'All' (Previously I had this set to 24 months) and the same behaviour is still being seen.

    Since there are several unread messages exist in your mailbox, if necessary, please try to mark them as read and then test the result in that situation.

    If I 'read' or 'mark as read' an email in the Inbox it is NOT marked as read and remains 'unread' in the Inbox folder of the 'Unread Mail' search folder.

    If I 'read' or 'mark as read' an email from the 'Unread Mail' search folder the item in the Inbox is marked as 'read' and is what is expected behaviour though it can take up to 30 seconds for the item in the Inbox to be marked as read.

    You may also create a new profile and re-setup Exchange account, Disable all of your AVG/Firewall, launch Outlook with the switch command-line "Outlook.exe /safe" to test it.

    Created a new profile and the same behavior is still happening, one thing to note though is when I set up the profile I set 'Mail to keep offline' to '1 month' and everything worked as expected. Now that I have set this to 'All' it is back to the same behaviour in that the 'Inbox' & 'Unread Email Search Folder Inbox' counts do NOT stay in sync.

    Some more environment details

    Windows 8 Pro x64 with Media Center
    Microsoft Office Professional Plus 2013 x64
    Microsoft Windows Server R2 x64 with Exchange Server 2007 SP3 Rollup 8-v2 x64

    Exchange Mailbox Stats via Outlook x64

    Inbox 13,5346 Items 234,113 KB (Local) 376,804 KB (Remote)
    Total 3,860,558 KB (Local) 3,886,119 KB (Remote)
    RSS Folder 111,9352 KB (Local) 912,588 KB (server)

    Offline Folder (*.ost) Sizes

    .ost 4,658,504 KB (New Profile 4,788,808 KB (Previous Profile)

    Exchange Mailbox Stats via Exchange 2007 EMC

    Total Items 300,616
    Size 5,474,689 KB

    Exchange Mailbox Stats via PowerShell Get-MailBoxStatistics

    5,606,082,366 B (TotalItemSize)

    If there is any other info you need let me know, more than happy to test other ideas.

    Cheers,

    Stephen


    Cheers, Stephen Edgar

    Sunday, November 04, 2012 12:48 AM
  • I would confirm whether you restart Outlook after you change the set "Mail to keep offline". Based my test, this setting is even effected a few minutes after restarting Outlook. So, we need to wait a second to check the result.


    Cheers,
    Tony Chen
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Monday, November 05, 2012 5:19 AM
    Moderator
  • Yes, multiple restarts after making a change. Also recreated another Outlook profile from 'mail' in 'control panel' whilst Outlook was closed.

    Cheers, Stephen Edgar

    Tuesday, November 06, 2012 1:32 AM
  • Review your screenshot in initial post, your mailbox display name is Stephen Edgar but not displayname@domain.com. It isn't a Exchange account, is it? Or you've setup multiple account in one profile? Please detail it. I've received many reports about Outlook 2013 IMAP sync issue but I am not get the similar report for Exchange.

    Furthermore, is it always repro on your co-worker's machine? If it is a real Exchange mailbox, please try to move it to another data store to check if the issue still persists.


    Cheers,
    Tony Chen
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Tuesday, November 06, 2012 2:09 AM
    Moderator
  • It is 100% an Exchange account. There are NO other email accountssetup with this profile.

    Cheers, Stephen Edgar


    • Edited by Stephen Edgar Tuesday, November 06, 2012 2:27 AM Account clarification
    Tuesday, November 06, 2012 2:13 AM
  • As soon as the download for Outlook Configuration Analyzer Tool (OCAT 2.0.0.2) goes live (currently only 2.0 is available) I will run that and see what it has to say for itself about my Outlook profile/s.

    http://support.microsoft.com/kb/2659007

    http://www.microsoft.com/en-au/download/details.aspx?id=28806


    Cheers, Stephen Edgar

    Wednesday, November 07, 2012 10:22 PM
  • Further info...

    Tested with Exchange 2007 OWA (Outlook Web Access) and sync counts are correct eliminating any issues on the Exchange Server side.

    See https://twitter.com/MSFTExchange/status/266261198838833152

    Cheers, Stephen Edgar



    • Edited by Stephen Edgar Thursday, November 08, 2012 6:33 AM link
    Thursday, November 08, 2012 6:32 AM
  • It seems there is no unexpected behavior in OWA.

    Download MFCMAPI tool from http://www.microsoft.com/en-us/download/details.aspx?id=2953 and log onto your profile > Open your mailbox > Root Container > Search Root, Check the property value of PR_Content_Unread. What's the result?

    Tony Chen

    Thursday, November 08, 2012 7:37 AM
    Moderator
  • Property Name(s): PR_CONTENT_UNREAD, PidTagContentUnreadCount, ptagContentUnread
    Tag: 0x36030003
    Type: PT_LONG
    Value: 0
    Value (Alt): 0x0


    Cheers, Stephen Edgar

    Sunday, November 11, 2012 8:38 AM
  • I get the same, but not with the Exchange account.  I have 3 accounts set up - a direct Exchange connection (that works properly) and then two IMAP accounts against a Lotus Domino server.  These do not show me any unread messages until I click on the inbox and then a synchronisation happens.  In earlier Outlook versions, synchronisation was occurring all the time - I cannot find anywhere where I have a wrong setting.

    This is very annoying, and it would be great to find a solution.

    All the best,

    Clive Longbottom

    Thursday, December 06, 2012 3:41 PM
  • I can confirm this is an issue in Outlook 2013. I have multiple accounts and sync counts were fine in outlook 2010 after loading and working with 2013 for the past few weeks the unread counts are inaccurate.
    Monday, December 10, 2012 2:42 PM
  • I have the same problem - only in the Inbox.  Always says one unread, but nothing in my unread folder.  Cannot clear the unread by any means so far.  
    • Edited by gdghorn Tuesday, December 18, 2012 4:16 PM
    Tuesday, December 18, 2012 4:09 PM
  • Hi,

    I am having the same problem.

    An unread message in the inbox and 77 in a subfolder.

    I've tried selecting all messages and mark them as read and I have reset the message view to make sure there were no filters applied.

    I'm running Outlook 2013 (15.0.4420.1017) MSO (15.0.4433.1506) 32 bit on Windows 8 Pro 64 bit.
    I have na Exchange account and a few POP accounts.

    Friday, January 04, 2013 12:42 PM
  • Same Problem, Have had it since the day Outlook 2013 launched.

    1 Unread only in my inbox.

    Was hoping that there would be an update fixing it but so far no luck.

     
    Tuesday, January 08, 2013 7:21 AM
  • Same issue. Fresh install of Windows 8 x 64 and Office 2013.

    Single Exchange Account.

    Right now outlook is showing 2 unread emails in my inbox and there are 0 emails in my inbox.

    Very Annoying. I hope that Microsoft takes care of this issue soon.

    Has anyone found a work around to at least reset the counts?

    Tuesday, January 08, 2013 4:16 PM
  • Almost the same issue. Windows 8 pro 64 bit, and Outlook 2013 32 bit on a POP3 account.

    The unread mail folder is not updated when new mails arrive. The mails are in the inbox, but not in the Unread mail folder. Issue occurs when resuming PC from sleep. The issue is fixed when restarting Outlook.

    Tuesday, January 08, 2013 9:19 PM
  • I can confirm having a similar problem.  Outlook 2013 with Windows 8 Professional 64-bit on an Microsoft 365 exchange account.  My problem is that it shows unread messages, but when you click "unread" to only show unread messages in the list pain of emails it shows no unread emails.
    Friday, January 25, 2013 9:33 AM
  • The same problem here
    Friday, February 08, 2013 11:50 AM
  • I was having the same problem.  At the top of the Inbox, I clicked "Unread" (which is new to Outlook 2013, and different than the "Unread Mail" search folder).  It showed a message, something like, "There are more items on the server", and gave me a link to view the items.  When I clicked the link, no items appeared, but my unread mail indicator on my Inbox went away.  Success!

    Good luck...

    • Proposed as answer by Blue Yonder Monday, March 18, 2013 2:53 PM
    • Unproposed as answer by Stephen Edgar Tuesday, March 19, 2013 12:28 AM
    • Proposed as answer by robert_nsu Tuesday, April 09, 2013 10:49 PM
    • Unproposed as answer by Stephen Edgar Wednesday, April 10, 2013 4:12 AM
    Thursday, March 07, 2013 7:46 AM
  • Yes!!

    Worked for me.  I had two, then three, then four unread email items.  Once I clicked on the Unread selection as described it found them on the server and I was able to check them off.

    Thank You

    Monday, March 18, 2013 2:55 PM
  • This is a horrible "feature".  Why would anyone want anything left unsync'd with the server, let alone unread mail items.

    Edit: This workaround worked on every subfolder but not my inbox.  The inbox doesn't have that same "find more on the server" link.  Still a problem.

    Monday, March 18, 2013 6:46 PM
  • I was having the same problem.  At the top of the Inbox, I clicked "Unread" (which is new to Outlook 2013, and different than the "Unread Mail" search folder).  It showed a message, something like, "There are more items on the server", and gave me a link to view the items.  When I clicked the link, no items appeared, but my unread mail indicator on my Inbox went away.  Success!

    Good luck...


    I appreciate this as a 'work around' but by no means would I call this a solution.

    I have replied to a few others by direct email regarding this issue in that the problem went away for me as I no longer use my own local installation of Exchange Server 2007 as I am now using Office 365 'Hosted Exchange'.

    What I will say though is I most definitely have a 'related' bug in that Outlook 2013 does not get 'all' the email. I have an iPhone & iPad also connected to the same O365 account and ~3 messages per week are delivered to these devices but never arrive in Outlook 2013. I cannot find an exact 'rule' to reproduce this and just seems entirely random and not related 'junk' or mailbox rules.

    If I really want to make my life living nightmare I can enable 'Conversation' view in Outlook 2013 and then nothing is marked as 'read' from Outlook 2013 back to the Office 365 Exchange Server and ALL emails that I have read are marked as 'Unread' on the iDevices and I have to manually open each of those emails to mark them as read.

    When I use Outlook Web Access everything is perfect regarding 'Read/Unread' counts thus eliminating Exchange as the issue.

    Basically all of the issues I have had and still am having after migrating Exchange servers are related to how Outlook 2013 handles or rather doesn't handle read and unread messages correctly.

    Cheers,

    Stephen


    Cheers, Stephen Edgar

    Tuesday, March 19, 2013 12:42 AM
  • Exchange 2007

    Outlook 2013 same issue yet it is resolved when going to OWA and I find the suppected emails that are not sync with Outlook inbox or subfolders and mark them as unread in OWA and instantly they folder are updated on Outlook 2013.

    I hope a fix is availble soon.


    • Proposed as answer by RaymondLMCD Wednesday, March 27, 2013 8:28 PM
    • Edited by RaymondLMCD Wednesday, March 27, 2013 8:29 PM bad spelling
    • Unproposed as answer by Stephen Edgar Thursday, March 28, 2013 3:03 AM
    Wednesday, March 27, 2013 8:28 PM
  • Blue Yonder and Rovert_nsu, please keep in mind that there is a difference between a solution and a workaround. Mark's experience here posed as a workaround for him, but even if it did work on my system (which it did not) at best it's a workaround.

    Microsoft still needs to fix their code.  Later this month 365 Online is supposed to be upgrading my account to the latest OWA client and I'll report back to see if the problem is fixed with that, but I suspect that the problem is specific to Outlook 2013.

    Wednesday, April 10, 2013 9:23 AM
  • Just in case anyone from M$ is monitoring this and counting how many people have the same, or a very similar, problem - me too ...

    "Outlook 2013" x64 on "Windows 7" talking to "Exchange 2010", and in my case it's the "Jumk E-Mail" folder that's causing problems.  If I access the same "Exchange" mailbox from another machine with "Outlook 2010", it's fine; if I access the mailbox using "OWA", it's fine; if I access the mailbox using "Outlook 2013", it tells me there are 1138 items in my "Junk E-Mail" folder.

    There are no items in my "Junk E-Mail" folder ...

    If I click on the folder I get the "There are more items in this folder on the server" link (why? if there are more items on the server then bl**dy well synchronise them - what a moronic "feature" ...) and if I click on the link, "Outlook 2013" finally realises that there are no items in the folder, locally or on the server, and the "1138" count goes away.  Until the next time it talks to the "Exchange 2010" server, that is, at which point the "1138" count comes back again.

    This is really, really, annoying ...

    Monday, April 22, 2013 10:14 AM
  • I can confirm this issue with Exchange as only account in my profile.
    Wednesday, May 22, 2013 7:39 AM
  • I had the same issue, primarily with my RSS feeds. I had it showing (15) next to the folder of an empty feed. 

    On the Send/Receive tab, I clicked "Update Folder" (which is right next to Send/Receive All Folders), and this fixed the issue. 

    Saturday, May 25, 2013 12:37 AM
  • Hi,

    I have fixed it by

    1. File - Account settings - Select an email account that has issue

    2. Change...

    3. Offline Settings - Use Cached Exchange Mode -> uncheck

    4. Mail to keep offline -> All

    5. Restart the Outlook

    6. Mark all as Read on issued folder

    7. Reset the account settings as before then restart the Outlook

    When you can see the slow updating of any folders when you mark it as Read, but it clears the issue.

    Good luck!

    Thursday, June 27, 2013 8:17 PM
  • Worked !

    Go to File > Account Setting > open your Exchange account > Adjust "Mail to keep online" to "All", restart Outlook to check the result.

    • Proposed as answer by MRWarrenMC Tuesday, July 16, 2013 4:54 AM
    • Unproposed as answer by Stephen Edgar Tuesday, July 16, 2013 10:41 AM
    • Proposed as answer by Jerbo Tech Wednesday, August 07, 2013 5:49 PM
    • Unproposed as answer by Stephen Edgar Wednesday, August 07, 2013 11:00 PM
    • Proposed as answer by LeighWebber Wednesday, January 08, 2014 6:34 PM
    • Unproposed as answer by Stephen Edgar Wednesday, January 08, 2014 10:09 PM
    Tuesday, July 16, 2013 4:54 AM
  • Worked !

    Go to File > Account Setting > open your Exchange account > Adjust "Mail to keep online" to "All", restart Outlook to check the result.

    This solved the problem for me.  Thank you.
    Wednesday, August 07, 2013 5:50 PM
  • I'm using Exchange 2013 and outlook 2013.

    in unread tab few emails (10-20) are showing (greyed out as read) unread along with normal unread mails. even after days it's not clearing off from unread tab (still it's marked as read - grey text with out bold :) )

    In OWA and Exchange online every thing is fine. Since we are receiving apx.3000 mails a day i'm keeping only 1 months mails in offline mode (that feature also useless because the mentioned mailbox is shared with single user access- Its downloading everything from exchange).

    Any suggestions ?

    I'm going to try "MRWarrenMC" method today

    • Proposed as answer by tkeeth Friday, November 15, 2013 10:43 PM
    • Unproposed as answer by tkeeth Friday, November 15, 2013 10:43 PM
    Wednesday, November 06, 2013 1:29 PM
  • I did not see any additional unread items when clicking on "Unread" at the top of the Inbox.  However, after disabling Cache mode and restarting Outlook - I then did see 3 items when I clicked Unread at the top of the Inbox and was able to mark each read - clearing the unread item count next to the Inbox. I then re-enable cache mode and restarted again. So annoying to have to perform so many extra, and unnecessary steps, to get an accurate unread count next to the Inbox!


    ~alex

    Tuesday, November 26, 2013 4:06 PM
  • Thank you , it was helpful and it worked

    Regards

    Neha 

    Thursday, January 23, 2014 5:54 AM
  • Same issues here.

    Outlook 2013 SP1 with Exchange 2013 SP3 UR5. I think this began with UR5....

    Thursday, April 03, 2014 3:58 PM
  • Worked !

    Go to File > Account Setting > open your Exchange account > Adjust "Mail to keep online" to "All", restart Outlook to check the result.

    This solved the problem for me.  Thank you.
    Again, not a solution - this just means that a feature is broken - the offline caching feature.  Microsoft, please take note and fix this feature!  Some of us do not have unlimited hard drive space on our workstations.
    Friday, April 04, 2014 7:17 PM