none
Microsoft Office 2010 Professional - Problem - Will Not Auto-Open Downloaded Excel 2007 file!

    Question

  • Problem, see title.  If I save excel file and go Microsoft Office 2010 Pro and open file after opening excel it will open file but it will not open when downloaded as I did before I let windows process 51 updates to windows (new computer).  The error message I get is, "file is not a valid Win32 application".  My OS is Windows 7 Premium.

    Tuesday, October 25, 2011 5:37 PM

Answers

  • Here is the fix for this problem on Windows 7 and Office 2010- right click on an XLSX file, choose Open With.

    In the "Open with" window select the Browse button in the lower right

     

    Navigate to C:\Program Files (x86)\Microsoft Office\Office14\Excel.exe

    you should scroll down and see the Excel.exe application

    (Note - Do not navigate down the \Program Files\ path instead choose the \Program Files (x86) path)

     

    Bill Scala

    ScalableComputerServices.com


    Scalable Computer Services
    • Marked as answer by dwright77 Wednesday, November 30, 2011 4:12 PM
    Wednesday, November 30, 2011 3:43 PM

All replies

  • Hi,

    Please check the file association for the Excel files.

    This issue may caused by the association for Excel files is using "Excel 2010 Component" to open the files.

    If so, try change the file association to Excel.exe. This should fix your issue.


    Sincerely,

    Max Meng
    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    Thursday, October 27, 2011 2:02 PM
    Moderator
  • Thank you for the suggestion.  Where do I find Excel.exe in my system?  I don't see this to associate to.  Search can't find one?????

    Sincerely,

    Don Wright


    Don Wright
    Thursday, October 27, 2011 9:43 PM
  • Hi,

    To change the file association, right click on any Excel document, choose Open with.

    e.g.


    Sincerely,

    Max Meng
    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    Friday, October 28, 2011 2:15 AM
    Moderator
  • Hi,

    I right clicked on the excel document and chose "Open With".  My options were:

      1)  Microsoft Office 2010 (will not open file)

      2)  Microsoft Office 2010 Component (will not open file)

    or Choose Default Program then "browse".

    When I chose the default program, browse and select "other programs", I don't get a choice of Excel.exe.  I do get a choice of Microsoft Office 2010.  When I click on it, I get one choice, "Office14".  If I look at my desktop, I see Microsoft Office 2010, and the excel file (shortcut) but how can I make this file association to open the file?  If I click on this, it will not open file.


    Don Wright
    Tuesday, November 01, 2011 12:38 AM
  • Hi Don,

    Please try the following steps:

    Make sure the impacted computer is online.

    Go to Control Panel > Programs Programs and Features Uninstall a program.

    Select the Microsoft Office you installed. click Change and wait Change and Repair to run. Exit when complete.

    Click on any impacted Excel file, it should take a while to download more functionality via the web.

    After that, click on these Excel files to check the issue again.



    Sincerely,

    Max Meng
    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Tuesday, November 01, 2011 2:49 AM
    Moderator
  • Hi,   I tried to repair the Microsoft Office 2010 program as you suggested and it didn't work.  I'm still getting the same message.  Any other suggestions would be greatly appreciated!   I do appreciate your efforts.
    Don Wright
    Tuesday, November 01, 2011 11:00 PM
  • I have noticed that file types XLSX are affected by the file association problem,

    but not the XLSM files.  XLSM files open just fine and I checked the file association and it

    does connect to the proper file association but I have been unable so far to duplicate this for

    the XLSX files for the reasons mentioned above.  Any  futher suggestions?


    Don Wright
    Wednesday, November 09, 2011 3:07 AM
  • Any other suggestions???? or an I stuck???
    Don Wright
    Tuesday, November 22, 2011 8:30 PM
  • Hi Don,

    When you try to change the file association, by right click on any Excel document, choose Open with.

    Can you find Microsoft Application Virtualization DDE Launcher? If you can, try select it to open the files.



    Sincerely,

    Max Meng
    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Wednesday, November 23, 2011 8:45 AM
    Moderator
  • Hi Max,  Happy Thanksgiving!  I tried right clicking on an existing excel file and it did not offer the option of "Open with".  The only options were;  "open", "open a copy", "pin to list", "remove from list" and "clear unpinned workbooks".


    Don Wright
    Thursday, November 24, 2011 5:14 PM
  • Here is the fix for this problem on Windows 7 and Office 2010- right click on an XLSX file, choose Open With.

    In the "Open with" window select the Browse button in the lower right

     

    Navigate to C:\Program Files (x86)\Microsoft Office\Office14\Excel.exe

    you should scroll down and see the Excel.exe application

    (Note - Do not navigate down the \Program Files\ path instead choose the \Program Files (x86) path)

     

    Bill Scala

    ScalableComputerServices.com


    Scalable Computer Services
    • Marked as answer by dwright77 Wednesday, November 30, 2011 4:12 PM
    Wednesday, November 30, 2011 3:43 PM
  • Thanks  Bill!  PROBLEM SOLVED!!!!!!  2010 Microsoft Office Professional Plus (Excel) works perfectly now!   The key is to right click on an excel XLSX file while in Windows Explorer NOT FROM 2010 Microsoft Office Professional Plus (Excel).   If you right click on an excel XLSX file  from 2010 Microsoft Office Professional  Plus (Excel), "Open With" DOES NOT APPEAR!
    Don Wright
    • Edited by dwright77 Wednesday, November 30, 2011 6:57 PM
    Wednesday, November 30, 2011 4:12 PM
  • Thank you! I had so much so much trouble trying to find an answer to this problem!

     

    Thanks again, you've saved me a lot of time! :)

    Friday, January 20, 2012 10:29 PM
  • Thanks Bill Scala...i have solved the issue....
    Wednesday, September 19, 2012 8:50 AM