none
Unable to create a folder view with User-defined fields

    Question

  • Hello colleagues!

    Here is my problem. I have a custom form (based on IPM.Appointment class) published in public folder on exchange 2010 sp 1, client application - Outlook 2010. The form has a lot of User-Defined fields so I want to create a view to show those fields in a folder. I go to View menu -> Change view -> Manage views > New view. Then I go to "User-Defined Fields in Folder" but the list of fields is empty!! I tried adding my custom form to field chooser menu - it did not help my custom fields do not appear in the field chooser menu so I am unable to create a view that I need.

    Did anyone face the same problem ? What is a solution??


    Sergey

    Tuesday, March 06, 2012 11:19 AM

Answers

  • Hi,

    Are you using public folder account log on the Outlook client?

    Once you have the view created, using This folder, visible to everyone option:

    1. Right click on the public folder
    2. Choose Properties,
    3. Select the Administration tab.

    All of the views that were created using ‘this folder, visible to everyone’ will be listed in the dropdown. Select one of the views and now when anyone views the public folder, it will default to your chosen view.
    Note: you can’t prevent them from applying a new view to the folder, but they can’t change the default view for everyone without the proper permissions.

    More details refer to http://support.microsoft.com/kb/202186

    Tony Chen

    TechNet Community Support

    Thursday, March 08, 2012 7:43 AM
  • The solution that worked for me was the following:

    1. I added the public folder (which is based on ipm.appointment class) to favorites so now it is displayed in Calendar pane under public calendars group.
    2. I assigned the needed public form as default form for my personal calendar
    3. Created an item in a calendar using this form (not sure if it was necessary)
    4. Then in Manage views for my calendar folder I made a copy of List view and made it available in all calendar folders (checkbox)
    5. Went to Columns... setting and selected scope “User-defined fields in folder”. Now I finally saw all my custom fields. I created a view I needed for the form so I needed to publish it but Publish button was not available.
    6. So I selected the public folder (from Calendar pane) where I needed to publish my view, went to Manage views, selected the view created in step 3 and copied the view with checkbox “this folder, visible to everyone’”.
    7. Publish button appeared so I was able to publish the view and now it is available to all users of that public folder.

    P.S. I have a Russian interface so I am not sure if I translated all the Outlook specific terms 100% correct.


    Sergey

    • Marked as answer by Back2Base Friday, March 30, 2012 8:10 PM
    Friday, March 30, 2012 8:10 PM

All replies

  • Hi,

    Are you using public folder account log on the Outlook client?

    Once you have the view created, using This folder, visible to everyone option:

    1. Right click on the public folder
    2. Choose Properties,
    3. Select the Administration tab.

    All of the views that were created using ‘this folder, visible to everyone’ will be listed in the dropdown. Select one of the views and now when anyone views the public folder, it will default to your chosen view.
    Note: you can’t prevent them from applying a new view to the folder, but they can’t change the default view for everyone without the proper permissions.

    More details refer to http://support.microsoft.com/kb/202186

    Tony Chen

    TechNet Community Support

    Thursday, March 08, 2012 7:43 AM
  • The solution that worked for me was the following:

    1. I added the public folder (which is based on ipm.appointment class) to favorites so now it is displayed in Calendar pane under public calendars group.
    2. I assigned the needed public form as default form for my personal calendar
    3. Created an item in a calendar using this form (not sure if it was necessary)
    4. Then in Manage views for my calendar folder I made a copy of List view and made it available in all calendar folders (checkbox)
    5. Went to Columns... setting and selected scope “User-defined fields in folder”. Now I finally saw all my custom fields. I created a view I needed for the form so I needed to publish it but Publish button was not available.
    6. So I selected the public folder (from Calendar pane) where I needed to publish my view, went to Manage views, selected the view created in step 3 and copied the view with checkbox “this folder, visible to everyone’”.
    7. Publish button appeared so I was able to publish the view and now it is available to all users of that public folder.

    P.S. I have a Russian interface so I am not sure if I translated all the Outlook specific terms 100% correct.


    Sergey

    • Marked as answer by Back2Base Friday, March 30, 2012 8:10 PM
    Friday, March 30, 2012 8:10 PM