none
A communication error has occured. Please verify that you have connectivity to the Internet and try again. (0x80072EFD)

    Question

  • I am using Vista Home Premium 64 bit.
    Whenever I try to activate the Office Home and Business 2010 it displays "A communication error has occured. Please verify that you have connectivity to the Internet and try again. (0x80072EFD)" and does not allow to me activate the product even though my Internet is working and I can access other pages. I checked my firewalls and also looked up the support website but it does not help me to fix this. Help here
    • Moved by Ted WayMicrosoft employee Tuesday, February 09, 2010 9:38 PM Activation related (From:Microsoft Office 2010 Beta)
    • Moved by Siddharth Chavan Wednesday, April 28, 2010 10:39 AM Forum Consolidation (From:Microsoft Office 2010 Volume Activation (to be retired))
    Monday, January 11, 2010 8:29 AM

All replies

  • Having the same problem installing Office 2010 beta in Window 7. Communication error code 0x80072F8
    I have tried turning off firewall and anti-virus programs.

    Found dates were off! Corrected and download perfectly.
    • Proposed as answer by gjquigley Tuesday, February 09, 2010 7:24 AM
    Sunday, February 07, 2010 8:06 AM
  • I am having the same problem.  I use Windows XP Service Pack 3 though.  Exact same thing, though.
    Tuesday, February 09, 2010 6:55 AM
  • check your date on computer
    Tuesday, February 09, 2010 7:42 AM
  • The date is correct.  Time as well.
    Tuesday, February 09, 2010 7:43 AM
  • what do you mean by check dates on computer?
    Tuesday, February 09, 2010 7:44 AM
  • The actual date on your computer. Mine was off by a year! The time obviously can be off. I couldn't believe it when I saw it. Sorry if that doesn't fix it for you.
    Tuesday, February 09, 2010 9:14 PM
  • Double check your firewall settings.  I thought I had mine turned off but I forgot about Sygate being active.  As soon as I turned it off it activated in like 10 seconds.
    • Proposed as answer by tranquil_forest Tuesday, February 09, 2010 11:06 PM
    Tuesday, February 09, 2010 11:06 PM
  • The most likely cause is Internet explorer is disabled or unisnstalled If you got to file, INTERNET options and click the connections tab everything should be enabled you should be able to change settings because office uses internet explorer as the default INTERNET path, so without it the error will pop (0x80072EFD)meaning connection to IE is offline. Make sure you have IE 8 or later, If Firefox is connected to the INTERNET then its definitely IE 6,7,8 not working Wireless networks by default setup the Local area network using IE download nLite and remove IE and download a new version of IE my computer had IE connections tab disabled so i couldn't click anything and IE was always offline. This happens because a company can disable settings meaning only they can change INTERNET explorer settings so no matter which version you download theres nothing you can do but boot your OS all over again. FIREWALL ARE THE LEAST LIKELY CAUSE so dont bother disabling it because its just IE. TO solve this problem go to(IE) tools.Internet options,Connections tab, click on ,setup, near the INTERNET connections. change it to your networks default. sorry if this is confusing
    • Proposed as answer by Kazpa Thursday, May 06, 2010 10:45 AM
    Friday, April 16, 2010 5:33 AM
  • Thanks sid,

    Reset IE now runs like a charm.

     

    Thursday, May 06, 2010 10:46 AM
  • I have the same problem - I've tried via wireless networks and my LAN connection but it's always the same. I've reset Explorer as my default and the date is correct.

    When I go into internet options/connections and click set up to start a new connection, the wizard says I already have an internet connection using the LAN connection.

    Any ideas?

    Friday, November 12, 2010 11:59 PM