none
Compile Error in Hidden Module: This Workbook

    Question

  • Hi ,

    Today I installed the MS Office 2010 in to Windows XP PC. it installed the Windows XP Service pack 3 also. then when  I open Excel , it comes a Error message. Then it should go ahead with Press OK . that Error is there as per below.

    "Compile Error in Hidden Module: This Workbook.

    This Error commonly occurs when code is incompatible with the version, Platform , or architecture of the application. Click "HELP" for information on how to correct this Error"

     

     

    Please give any solution.

     

    Regards,

     

    COMDINI

     

    Monday, October 04, 2010 3:51 PM

Answers

  • Hi Comdini,

    Try to start Excel 2010 in safe mode [hold ctrl key while startup] to see if this error goes away. Sometimes, this error may be caused by some add-ins.

    If it works fine in this situation, try to disable add-ins in excel 2010.

    Click the File menu –> Options link –> Navigate to Add-Ins options.

    Excel 2010 Add-ins

    Select Disabled Items in the Manage dropdown and click the Go button. This would display the following Disabled Items window using which you can see and also re-enable the disabled add-in. You can select the ones you wish to re-enable and click the Enable button.

    image thumb89 How to enable a disabled add in in Excel 2010

    If it also doesn't work in safe mode, try to see this KB article about You receive a "Compile error in hidden module" error message when you start Word or Excel:

    http://support.microsoft.com/kb/307410

    Hope that helps.

     

    Tuesday, October 05, 2010 1:34 AM

All replies

  • Hi Comdini,

    Try to start Excel 2010 in safe mode [hold ctrl key while startup] to see if this error goes away. Sometimes, this error may be caused by some add-ins.

    If it works fine in this situation, try to disable add-ins in excel 2010.

    Click the File menu –> Options link –> Navigate to Add-Ins options.

    Excel 2010 Add-ins

    Select Disabled Items in the Manage dropdown and click the Go button. This would display the following Disabled Items window using which you can see and also re-enable the disabled add-in. You can select the ones you wish to re-enable and click the Enable button.

    image thumb89 How to enable a disabled add in in Excel 2010

    If it also doesn't work in safe mode, try to see this KB article about You receive a "Compile error in hidden module" error message when you start Word or Excel:

    http://support.microsoft.com/kb/307410

    Hope that helps.

     

    Tuesday, October 05, 2010 1:34 AM
  • Hi Jennifer,

     

    Thanks for your comments. I found the issue. That PC have installed 3rd Party PDF Editing Application that Nitro 5.4. Then I uninstalled & installed latest version. Problem solved.

     

    Regards,

    COMDINI


    Regards, COMDINI
    Saturday, October 16, 2010 4:27 AM
  • Hi COMDINI, My problem was also with Nitro 5.4. What I did to solve this problem was to delete this two files:

     

    C:\Documents and Settings\USER\Datos de programa\Microsoft\Excel\XLSTART\NitroPDF.xla

     

    C:\Documents and Settings\USER\Datos de programa\Microsoft\AddIns\NitroPDF.ppa

     

    Now works fine =D

     


    Tuesday, April 05, 2011 5:26 PM
  • Uninstalling Nitro PDF solved my issue as well. Thank You
    Monday, August 22, 2011 1:53 PM
  • Yup.  Uninstalled Nitro PDF Pro and problem solved.

    Monday, April 16, 2012 4:40 PM
  • The same error you can see when ConnonControls crash by windows UPG.

    I found that happens after KB2598039, KB2597112

    More about that on this page. (pl)


    Oskar Shon, Office System MVP

    Press if Helpful; Answer when a problem solved

    Monday, April 16, 2012 9:55 PM
  • In english, here is the fix...

    Excel shows a "compile error in hidden module: thisworkbook" when opened or closed.

    This error occurs because 2 excel files are corrupt.

    To stop the error from occurring:

    If in Windows XP open the following folder:
    C:\Documents and Settings\USERNAME\Application Data\Microsoft\Forms     where USERNAME is the current user


    If in Windows 7 open the following folder:
    C:\Users\USERNAME\AppData\Roaming\Microsoft\Forms     where USERNAME is the current user


    Once the folder is located, delete these 2 files

    ComctlLib.exd
    MSComctlLib.exd

    Excel should now open without the error message.

    Note: Excel will create 2 new files (with the same names) in the folder, but they will not be corrupted.

    Monday, April 23, 2012 5:04 PM
  • Hi:

    I'm running Vista x64 with Office 2007, and implemented the fix from srahoosier. I could only find the MSComctLib.exd file and deleted it. Restarted Excel and the compile error.... message with follow on error "cannot run the macro onload..." disappeared.

    Thanks. 


    Saturday, May 19, 2012 5:00 AM
  • thanks lot of.

    my problem is solve now.this trick is realy work.

    Monday, June 11, 2012 6:59 PM
  • Hi Mauricio Cortés,

    Same problem here and your solution worked.

    Thanks :)

    Best regards.

    Wednesday, June 20, 2012 2:32 PM
  • I tryed all the above but none worked.. still having the same problem. Any ideas?  (W7 - 64BIT - Office 2010 32bit)

    Tuesday, July 31, 2012 8:39 PM
  • Hey..

    Thanks for the comments and the answers. i also have the same problem and when i checked in the disabled add-ons , i found nothing. Is there any other reason for this issue. I have even tried installing a fresh copy of Office 2010 but still the same error retains .

    Is there a fix for this .. Am annoyed with this error...

    Any help is appreciated greatly !!

    Thanks in advance

    Aravind

    Sunday, September 30, 2012 5:23 AM
  • Hi guys,

    Thanks for suggestions. I uninstalled Nitro PDF, and this worked for me too...

    Tuesday, December 11, 2012 12:32 PM