none
Word 2010 Slow opening files on network share

    Question

  • Word 2010 and Excel 2010 on Windows 7 take several minutes to open a file on a Server 2008 network share . . unless you have done a login in last 30 (approx) minutes, or have been busy with Word or Excel in the last 30 minutes or so.  (Network Idle time seems to trigger the problem . . but its only probelm with Office 2010 with certain file types) 

    Relevant variables:
    This is problem with all Windows 7, Office 2010 workstations
    Not a problem with Windows 7, Office 2003 workstations.
    We only use .doc files for exporting files to customers  (not docx)
    Word can open .rtf files at any time without a problem.

    I can rename or delete a .doc or .xls file . . so its not "permissions".

    If user has done a full logoff and logon to network within the last 30 minutes then files open OK.   (30 minutes is a very rough guess . . it could be an hour)

    I have tried some registry hack to downgrade SMB version on server but that broke all network shares . . maybe I did it wrong.  that was a solution from some people on Technet for this problem posted earlier. 

     

     

     

     

     

     

     

     

    • Moved by Sally Tang Friday, July 16, 2010 6:52 AM (From:Office 2010 Setup and Deployment)
    Wednesday, July 14, 2010 3:47 PM

Answers

  • MANY MANY companies have had this issue with Windows 7 and Office 2007. I have the problem with Office 2010, because I skipped Offcie 2007 on our network.  I went back and tried again disabling SMB2 on Server 2008 and on the Windows 7 clients . . which was a soluton for others with this problem.

    Disabling SMB2 on the server and the client fixed this issue.   This problem has been around for a year and many people wonder, like I do why Microsoft has not fixed this problem.  (An internet search on this subject has many forums addressing the same problem)

    From Petri IT Knowledge base

    To disable SMB 2.0. You need to do so on both the "client" and the "server" operating systems. To disable SMB 2.0 for Windows Vista, Windows 7 or Windows Server 2008 systems that are the “client” systems run the following commands:

    sc config lanmanworkstation depend= bowser/mrxsmb10/nsi

    sc config mrxsmb20 start= disabled

    Note there's an extra " " (space) after the "=" sign.

    To enable back SMB 2.0 for Windows Vista or Windows Server 2008 systems that are the “client” systems run the following commands:

    sc config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi

    sc config mrxsmb20 start= auto

    Again, note there's an extra " " (space) after the "=" sign.

    In order to disable SMB 2.0 on the server-side computer, follow these steps:

    Warning!

    This document contains instructions for editing the registry. If you make any error while editing the registry, you can potentially cause Windows to fail or be unable to boot, requiring you to reinstall Windows. Edit the registry at your own risk. Always back up the registry before making any changes. If you do not feel comfortable editing the registry, do not attempt these instructions. Instead, seek the help of a trained computer specialist.

    1. Run "regedit" on Windows Server 2008 based computer.
    2. Expand and locate the sub tree as follows.

    HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

    1. Add a new REG_DWORD key with the name of "Smb2" (without quotation mark)

    Value name: Smb2

    Value type: REG_DWORD

    0 = disabled

    1 = enabled

    1. Set the value to 0 to disable SMB 2.0, or set it to 1 to re-enable SMB 2.0.
    2. Reboot the server.

     

    • Proposed as answer by Irish Chris Thursday, July 07, 2011 11:02 AM
    • Marked as answer by swb_mct Thursday, July 07, 2011 11:12 AM
    Saturday, August 07, 2010 2:30 PM

All replies

  • Hi,

     

    Thank you for using Office IT Pro General Discussions forum. 

     

    Before we go further, I would like to confirm if the performance issue with other types of documents, such as PowerPoint, Notepad?

    Also, does this performance issue occur when saving the Excel and Word files on another network share?

     

    Based on the current situation, this issue might be related to many factors, such as the network speed, software conflicts, viruses, etc.

     

    I suggest you scanning your computer and your network places for viruses.  

    Also, use another network share to test the results.

     

    At the same time, we might also try the suggestions to see if this issue is related to some hardware or software conflicts. Also, if you have installed some software or driver recently, please let me know.

     

    Suggestion 1: Test in Clean boot Mode

    ===============

    Let’s disable all startup items and third party services when booting. This method will help us determine if this issue is caused by a loading program or service. Please perform the following steps:

     

    1.       Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

    2.       Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3.       Click the "Startup" tab, click "Disable All" and click "OK".

     

    Then, restart the computer. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when Windows starts" box and click OK.

     

    Note: Temporarily disabling the Startup Group only prevents the startup programs from loading at startup. This should not affect the system or other programs. We may still manually run these programs later.

     

    What’s the result now?

      

    How to return from the Clean Boot state

    --------------------------

    After the troubleshooting, we can return from the clean boot state:

     

    1.       Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

    2.       On the "General" tab, click "Normal Startup - load all device drivers and services".

    3.       Click OK. Click Restart when you are prompted to restart your computer.

     

     

    Suggestion 2: Device Clean Boot

    ===================

    1.       Click the Start Button, in the Search or Run box, type "devmgmt.msc" (without quotation marks) in the Search bar and press Enter.

    2.       Expand "Sound, video and game controllers".

    3.       Right click on your sound card and then click "Properties".

    4.       In the dropdown menu of Device Usage, please choose "Do not use this device (disable)" and click OK.

    5.       Please use the same method to disable other non-essential hardware such as: internal modem, network card and CD-R drive. Please note some devices such as video adapters are not available to be disabled.

     

    Check the issue again. We can enable the features we disabled after the troubleshooting.

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Best Regards,

     

    Sally Tang

    • Marked as answer by Sally Tang Tuesday, July 20, 2010 4:32 AM
    • Unmarked as answer by David Wolters Wednesday, May 11, 2011 1:58 PM
    Friday, July 16, 2010 7:04 AM
  • MANY MANY companies have had this issue with Windows 7 and Office 2007. I have the problem with Office 2010, because I skipped Offcie 2007 on our network.  I went back and tried again disabling SMB2 on Server 2008 and on the Windows 7 clients . . which was a soluton for others with this problem.

    Disabling SMB2 on the server and the client fixed this issue.   This problem has been around for a year and many people wonder, like I do why Microsoft has not fixed this problem.  (An internet search on this subject has many forums addressing the same problem)

    From Petri IT Knowledge base

    To disable SMB 2.0. You need to do so on both the "client" and the "server" operating systems. To disable SMB 2.0 for Windows Vista, Windows 7 or Windows Server 2008 systems that are the “client” systems run the following commands:

    sc config lanmanworkstation depend= bowser/mrxsmb10/nsi

    sc config mrxsmb20 start= disabled

    Note there's an extra " " (space) after the "=" sign.

    To enable back SMB 2.0 for Windows Vista or Windows Server 2008 systems that are the “client” systems run the following commands:

    sc config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi

    sc config mrxsmb20 start= auto

    Again, note there's an extra " " (space) after the "=" sign.

    In order to disable SMB 2.0 on the server-side computer, follow these steps:

    Warning!

    This document contains instructions for editing the registry. If you make any error while editing the registry, you can potentially cause Windows to fail or be unable to boot, requiring you to reinstall Windows. Edit the registry at your own risk. Always back up the registry before making any changes. If you do not feel comfortable editing the registry, do not attempt these instructions. Instead, seek the help of a trained computer specialist.

    1. Run "regedit" on Windows Server 2008 based computer.
    2. Expand and locate the sub tree as follows.

    HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

    1. Add a new REG_DWORD key with the name of "Smb2" (without quotation mark)

    Value name: Smb2

    Value type: REG_DWORD

    0 = disabled

    1 = enabled

    1. Set the value to 0 to disable SMB 2.0, or set it to 1 to re-enable SMB 2.0.
    2. Reboot the server.

     

    • Proposed as answer by Irish Chris Thursday, July 07, 2011 11:02 AM
    • Marked as answer by swb_mct Thursday, July 07, 2011 11:12 AM
    Saturday, August 07, 2010 2:30 PM
  • I have a client that has recently upgraded all systems to Windows 7 and Office 2010. This client has also begun to complain about the Office 2010 applications hanging when attempting to access networked drives.

    While the SMB 2.0 fix was mentioned, I was not convinced that disabling SMB 2.0 was the best solution; so, I did a little digging. Turns out that Microsoft is at least aware of a similar issue regarding Office 2007. A search through the MSDN database turned up this: http://support.microsoft.com/kb/833041. Though Office 2010 is not specifically listed I have a feeling that the fix is similar.

    My guess is that the only change required will be to replace:

    "HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\Open Find"

    with:

     "HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Open Find"

    As I've just realized this applies to the Current User, I'll do a little searching through the registry and see if a Local Machine fix can't be applied instead.

    In any event, I'll be testing the solution within the next couple of days and post back with the results. This seems, to me, to be a cleaner solution to the problem. As the issue only affects Office products, shouldn't the fix as well?

     I may also decide to write a PowerShell script utilizing WMI objects in order to perform a remote fix without having to edit the registry manually on every machine. The result should be posted within a week if it's going to happen.

     

    Wednesday, August 25, 2010 6:20 AM
  • Bradford,

    I am having the same issues. Win7 machines with Office 2010 on a shared network drive the first Doc or Excel file is 2-4 minutes in opening. Server is SBS 2008. All our WinXP machines have no problem.

    I cannot find the reg key you specified in your post. There is no Open Find entry at all in Office 2010.

    Were you able to implement your findings and did it alleviate your Office issues?

    Thanks!

     

    PS..I am going to try the SMB2 disable on the server side.

    Friday, October 22, 2010 2:53 PM
  • I have been having this problem for months now with a client.  Brand new server and workstations, SBS 2008 and Win 7 Pro with Office 2010.  Seems to be when the first Word doc is opened it freezes, hangs, and if you close it and try to reopen it works fine. 

    Also happens when doing a search for a document (this is all via a network drive btw).

    Wednesday, October 27, 2010 1:03 AM
  • I'm having the same issues....opening Office documents on the network share (primarily Word), attaching files to e-mail in Outlook, etc.

    I'm running Windows 7 Pro 64-bit, and the server is SBS 2008.

    Does the single registry fix work above from Bradford, or should I try the SMB2 fix?

    Thanks!

    --Kent

    Friday, October 29, 2010 2:21 AM
  • Kent and the rest, I was reading another thread here in the Office IT Pro forums and someone from MSFT Adrian Pa I think is his name made a great post with some KB articles that provide SMB patches. The KB articles seem to describe the slow opening problem exactly or at least they described mine.

    Here's a link to his post from Oct 27 2010:

    http://social.technet.microsoft.com/Forums/en/officeitpro/thread/acf31929-bc71-4823-91df-d917fa919e63

    Here's a link to the KB article that he mentioned that looks as though it will fix my problem:

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;982860

    Wednesday, November 03, 2010 5:19 PM
  • Any luck with these fixes? I noticed this Thread was marked as answered - when it clearly was not - and then abandoned by the tech that first replied. 

    Did you get this fixed - same problems  - Office 2010 x32, Windows 2998R2, Win7x64

    Thanks

    SJMP

    Wednesday, May 11, 2011 12:15 PM
  • Any luck with these fixes? I noticed this Thread was marked as answered - when it clearly was not - and then abandoned by the tech that first replied. 

    Did you get this fixed - same problems  - Office 2010 x32, Windows 2998R2, Win7x64

    Thanks

    SJMP

    Hi SJMP,

    This worked for me, pretty much all the doc's were created with Office 2003.

    http://support.microsoft.com/kb/982860


    Thursday, May 12, 2011 4:08 AM
  • Thanks Daryl - But these Registry settings are already disabled on client/server. 

     

    Thanks - SJMP

    Thursday, May 12, 2011 2:40 PM
  • We are having similar problem!

     

    Win 7 32 Bit and 64 bit OS

    MS Office 2003

    Windows Server 2003 Network share

     

    It seems none of the solutions offered has worked for all!

     

    Thanks,

     

    Ashraf

     

     

    Wednesday, May 18, 2011 3:15 PM
  • I do remember at one point I had to reformat a computer and after that, it worked fine on that computer.  My client had all new Dell's with Office 2010 pre-installed.  After the reformat I installed all the software under the domain admin account and that computer opened files fine.  FYI
    Thursday, May 19, 2011 3:41 AM
  • office 2010 was not preinstalled. this is all machines, dell and lenovo, new and old. the only machines that are not having the problem is windows XP. formating would be a complete waste of time. 
    Thursday, May 19, 2011 1:31 PM
  • Hi swb_mct,

     

    We have Windows XP, Vista and 7 workstations (about 100), with all of Office 2003, 2007 and 2010 in production (various stages of migration), and the XP and Vista machines do not have this issue, nor do Win 7 with Office 2003.  But trying to open redirected/offline files stored on Server 2008 or 2008 R2 servers in Win 7 with Office 2007 or 2010 results in the issue you've described.

     

    Simply running the following on the Win 7 clients and restarting resolves the issue:

    sc config lanmanworkstation depend= bowser/mrxsmb10/nsi

    sc config mrxsmb20 start= disabled

    (after restarting you can check the SMB 2.0 service status by running "sc query mrxsmb20" - should be "stopped")

     

    I didn't have to implement the server-side registry edit, the issue is confirmed worked around.  I say work around because it's not a real fix, and I am also still flabbergasted that the issue has been known for at least two years now and MS have failed to release an update with a fix.  Frankly shocking and appalling.

     

    Thanks,

     

    Chris

    • Proposed as answer by HaydnWVN Tuesday, August 23, 2011 1:46 PM
    • Unproposed as answer by HaydnWVN Tuesday, August 23, 2011 1:46 PM
    Thursday, July 07, 2011 11:11 AM
  • Hi Chris,

    I got the similar issue. Most of workstation is Win7sp1 Office 2010sp1 work fine with Windows 2003 file server. But when I migrate their files to a new server Windows 2008r2SP1 then the problem start: if they save and save and save more than three times then then the messages saving.... stuck there forever and crash. The other lost mb for Access database and other for Excel "network path not found" and cannot save! But work for WinXP and Office 2007

    What should I do? Should I uncheck IPV6 protocol for server 2008? Or run your command to all Win7?

    I find out the problem is SEP11.6. I upgrade to 11.7 and it works fine
    • Proposed as answer by cp11111 Saturday, September 03, 2011 1:26 AM
    • Unproposed as answer by cp11111 Saturday, September 03, 2011 1:26 AM
    • Edited by cp11111 Thursday, September 08, 2011 3:01 AM
    Saturday, September 03, 2011 1:25 AM
  • CP11111 - can you share how you found out SEP11.6 was an issue?  I have this similar issue with one of my clients who runs Windows 7, Office 2010 and SBS 2008 R2, and they are full on SEP11.6.  If SEP11.7 does actually fix this, I will propose an upgrade as I have tried everything except turn off SMB 2.0 on the client as stated above.  I do not think or want to turn it off on the server.

     

    DG

    Friday, September 30, 2011 7:53 PM
  • I Had a similar issues and tried all of the above & more but nothing worked until I turned off
    the windows 2008 Firewall, now the share is really nippy :)

    NB: Our network firewall protects the win2008 system
    Friday, March 23, 2012 12:27 PM
  • Excel Slow to open on network drive.

     

    Fix:

    Disable SMB 2.0.

    You need to apply the fix (below) to both the "client" and the "server" operating systems.

     

    Client

    To disable SMB 2.0 for Windows Vista, Windows 7 or Windows systems that are the “client” systems run the following two commands:

    sc config lanmanworkstation depend= bowser/mrxsmb10/nsi

    sc config mrxsmb20 start= disabled

     

    Note there's an extra " " (space) after the "=" sign.

     

    Server

    Run "regedit" on Windows Server 2008 based computer.

    Expand and locate the sub tree as follows.

    HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

    Add a new REG_DWORD key with the name of "Smb2" (without quotation mark)

    Value name: Smb2

    Value type: REG_DWORD

    0 = disabled

     

    Set the value to 0 to disable SMB 2.0.

     

    Reboot the server.

     

    Issue is fixed

    Wednesday, May 08, 2013 3:46 AM