none
"Rows to repeat at top", in Page Setup/Sheet disabled in Excel 2010

    Question

  • I have read all of the postings on this question. I am having the same problem! However I do not see any solution. I see a lot of "I think's", or "try this'", but no clear cut-solution. Let me restate;

    I am running Excel 2010 in Office Professional:

    I want to print a long spread sheet and I would like the title row repeated on the top of each page. I specify the print area range. The first row is frozen, so that when I scroll through my work on screen, I can differentiate the column information by having the first row frozen. I want this to happen when I print this long document.

    I go to print and go to Page Setup. I select the "Sheet" tab. The Print address bar area is disabled (grayed), but my print range is there. Under "Print" Titles", both selections are disabled (grayed); "Rows to Repeat at Top" and Columns to Repeat at Left" are unavailable for selection. The address selection button on the right, of each of these three address range bars are also disabled (grayed).

    This worksheet is on my hard drive. It is the only worksheet in the file. When I click on the worksheet tab, it does not say "Ungroup Sheets" which means that sheets have never been grouped.

    I have been using Excel since Excel 95. I have done this many times in past versions, and it is a relatively simple procedure. Does any know why I can not access this feature in Excel 2010?

    Friday, November 30, 2012 3:37 PM

Answers

  • Hi

    By deault the option for settiing print area, rows to repeat and columns to repeat are greyed out if you display the Page Setup dialog via the Print option. "I go to print and go to Page Setup".

    I would suggest using the Print Titles button on the Page Layout tab in the ribbon to make the neessary changes.

    As you are a veteran of previous versions this greying out was the case if you activated Page Setup from the Print Preview options but not through File, Page Setup.  In the shuffling of the user interface from 2007 onwards,  File, Print is effectively the equivalent of the old Print Preview and the Page Setup options in the Page Layout tab the equivalent of the "old" File Page Setup. 

    Hope this helps


    G North MCT

    • Marked as answer by Harold1953 Friday, November 30, 2012 4:14 PM
    Friday, November 30, 2012 3:49 PM

All replies

  • Hi

    By deault the option for settiing print area, rows to repeat and columns to repeat are greyed out if you display the Page Setup dialog via the Print option. "I go to print and go to Page Setup".

    I would suggest using the Print Titles button on the Page Layout tab in the ribbon to make the neessary changes.

    As you are a veteran of previous versions this greying out was the case if you activated Page Setup from the Print Preview options but not through File, Page Setup.  In the shuffling of the user interface from 2007 onwards,  File, Print is effectively the equivalent of the old Print Preview and the Page Setup options in the Page Layout tab the equivalent of the "old" File Page Setup. 

    Hope this helps


    G North MCT

    • Marked as answer by Harold1953 Friday, November 30, 2012 4:14 PM
    Friday, November 30, 2012 3:49 PM
  • G North I see you have 8,175 points. You are being short changed. I have read many others who have tried to answer and offer a solution to this simple problem. They all used a lot of words, and said absolutely nothing. You used 132 words, and solved my problems. Thanks for your help!
    Friday, November 30, 2012 4:19 PM
  • Glad to help. (not here for the points)

    G North MCT

    Friday, November 30, 2012 4:22 PM
  • Hi,

    Thanks to both of you to share the helpful information to us. This will help the others who meet the same issue.


    Jaynet Zhang
    TechNet Community Support

    Tuesday, December 04, 2012 9:59 AM
  • Thanks,

    You saved my sanity (what's left of it.)

    Friday, May 03, 2013 1:42 PM
  • You could also save a Macro to do this and add a button that calls the macro. For example:

    Sub macro_Paginate_RepeatTitleRow()
    '
    ' macro_Paginate_RepeatTitleRow Macro
    ' Repeat title (first) row on all printed pages
    '
        Application.PrintCommunication = False
        With ActiveSheet.PageSetup
            .PrintTitleRows = "$1:$1"
        End With
        Application.PrintCommunication = True
    End Sub
    

    Friday, July 12, 2013 6:23 PM
  • I have always understood that glitch between accessing the Rows To Repeat via Print Preview and straight from the spreadsheet Menu.

    Today, it was greyed out via BOTH pathways and I cannot get the titles to print on a multi-page document.

    Any thoughts / ideas?

    Thanks

    Wednesday, January 15, 2014 8:14 PM
  • Here we are 15 months later and Microsoft Excel 2013 has the SAME ERROR

    If one chooses:

    1. Print Preview
    2. Page Setup
    3. Sheet

    Then the print area and print titles (Rows to repeat at top, columns to repeat at top) are all grayed out and cannot be selected.

    If, however, I choose the page layout bar and click print titles then everything works fine.

    Thanks for the solution!!!

    Friday, February 14, 2014 8:28 AM
  • Do you have multiple sheets highlighted?  I just had the exact same problem and when I chose only one sheet, it cleared it right up!
    Tuesday, March 11, 2014 2:57 PM
  • Dear Sir,

    It is enabled through the option Page Layout-->Print Titles.

    Please check this out......... and confirm...........

    Keshav

    Monday, April 07, 2014 6:24 AM
  • Awesome!  This helps!  Thank you.

    Wednesday, June 18, 2014 8:01 PM
  • Thank you very much. helped lot.
    Monday, July 07, 2014 9:06 AM
  • A+ response. Thanks!!
    Wednesday, July 16, 2014 6:58 PM
  • This worked.  Thanks Harold1953!
    Monday, August 04, 2014 9:07 PM
  • A note for anyone else that might encounter this problem. Be sure you don't have print preview open in another Excel window, or you'll have the same problem.

    I had two different spreadsheets open in two different Excel windows and I was trying to match up the page layout settings between them. I had to close the print preview on the first window before the fields would open up enabled on the second.

    Thursday, August 07, 2014 9:46 PM
  • I experienced the issue you described below and tried all of the solutions with no luck.

    But, if you close the MS Excel Application and re-launch it it will also fix this bug.


    Tuesday, August 12, 2014 4:33 PM
  • This is, to a degree. the solution to my problem. I had the File tab selected in another workbook. This saved the day :)
    Tuesday, August 26, 2014 11:26 AM