none
Outlook 2010 Indexing - fails to complete

    Question

  • I recently installed Office 2010 Professional on a Windows 7 Ultimate OS (running Office 32 bit on 64 bit machine) and I find that I nearly always have search problems in Outlook 2010 - message suggests that search is incomplete.  Number of items yet to be completed varies greatly and often the number goes up rather than down e.g. form 20K items to 200K items.  All this is occurring after a point where indexing was complete i.e. no message saying that indexing incomplete and all items searched for returned without a problem.  In an effort to complete indexing left machine on for 4 days - yet still incomplete - seems that indexing was complete at one stage but looks like it starts again. Is there a bug in indexing for Outlook 2010 on Windows 7 and, if so is there a fix please?

    • Moved by Jennifer ZhanModerator Wednesday, September 08, 2010 7:56 AM (From:Office 2010 Setup and Deployment)
    Tuesday, September 07, 2010 6:52 AM

All replies

  • Sadly I have to agree to this behaviour. :-(

    With Outlook 2007 I always had 'Advanced Find' as an open window (selected for whole mailbox). I was glad with OL2010, the instant search or suggestion for 'Look in all mail folders' if not found.

    But my experience is as Derek Sydney told. Certain results will not come up, messages I know for sure they are there. For Outlook/Exchange I sometimes even use the find from Outlook Web Acces to find something.

    My workaround is once per three/four weeks doing a rebuild of my Outlook and Archive PSTs. This took some hours with fewer response from my laptop. But afterwards I can find what I'm loooking for. And then, after one/two weeks I recognize that results are missing, items need to be indexing, and etcetera.

    BTW: Is it not possible for Outlook to force an INCREMENTAL search/update? Instead of building the whole index again?

     

    With the suggested approach of Microsft for Windows/Explorer AND Outlook to use (meta) data and not (nested) subfoldes the above mentioned problem is even more annoying! In previous versions I created hundred of folders, but with current Windows (7) and Outlook (2010) I rely heavily on - Instant - Search.

     

    Does other persons also have this same feeling? Has it something to do with the approach of Derek and me? Is it a shortcoming in the software? I'd like to read/hear!

     

    With kindly Dutch greetings,

    Arjan Vos, Logica


    VosAJM - Woerden (NL)
    Wednesday, September 08, 2010 8:27 AM
  • As an update - search in Outlook 2010 was working fine yesterday - i.e. no message saying indexing incomplete.  Turned the PC off last night and today started off saying 20K items to index and most recently has jumped to 200K items.  I have never had thses issues with Outlook 2007 on Windows 7 notebook PC so can only conclude that it is a Microsoft bug.  Microsoft support dest claim Outlook 2010 is out of 90 day warranty so any help is charageable - product downloaded 8th July 2010 so less than 90 days on my maths - typical Microsoft arrogance?
    Thursday, September 09, 2010 12:45 AM
  • In an effort to fix the problem I re-installed Office Professional 2010 but this did not resolve the problem.  Microsoft Office support have advised that I should uninstall Office 2010 again and then do an "In Place Upgrade" of my Wondows 7 64bit OS in the hope that this may fix the problem. Microsoft have warned that there are risks in trying tghis fix - may corrupt data.  For assistance on this exercise I was advised to contact the Dell support team (supplied PC) or the Microsoft OS team.  In short it seems that Microsoft know there is an issue with the 64 bit O/S but have no fix/patch.
    Tuesday, October 05, 2010 4:00 AM
  • For me a search in Outlook 2010 reveals no "no matches". I have rebuilt the index multiple times with no improvement. Search was working but is no longer. One forum I visited surmised it was conflict between Google and Outlook.
    Wednesday, November 03, 2010 3:07 PM
  • My problem with this was solved when my firm installed Windows7 (32bit) on the clients (previously XP :( ).
    Same counts for problem with Outlook not correctly shutting down.

    But this is already Windows7. Is it related to 64-bit as I don't have problems with my 32-bit?

    Rgds, Arjan
    VosAJM - Woerden (NL)
    Friday, November 19, 2010 8:52 AM
  • Derek, I have OL2010 on my Windows XP Pro machine and it's doing the same thing. Very frustrating. It seems to be perpetually indexing and I always get the "Search results may be incomplete" message. My machine is 32bit, so maybe the 64bit machine argument is not valid? I'd be impressed with 2010 if this problem were solved. Also, I have the same problem with contacting the mighty Microsoft, as I'm running a Trial version. I didn't want to pay the $40 charge to have a "chat" with them!
    Friday, February 18, 2011 3:03 AM
  • I have the exact same problem as Derek.  Search's dont work and it tell me the indexing isn't complete and the number of files it needs to index keeps going up.  I have Windows 7 64 bit.
    Thursday, February 24, 2011 12:26 AM
  • Same thing happens to me, very annoying and makes my PC slow.
    Tuesday, March 08, 2011 12:05 PM
  • As an update - search in Outlook 2010 was working fine yesterday - i.e. no message saying indexing incomplete.  Turned the PC off last night and today started off saying 20K items to index and most recently has jumped to 200K items.  I have never had thses issues with Outlook 2007 on Windows 7 notebook PC so can only conclude that it is a Microsoft bug.  Microsoft support dest claim Outlook 2010 is out of 90 day warranty so any help is charageable - product downloaded 8th July 2010 so less than 90 days on my maths - typical Microsoft arrogance?


    Who marked this as "answered"? Or is it because he accused the support department of arrogance?

    FYI: Shutting down your critics' technical questions on the forums is petty, childish, AND arrogant.

    Tuesday, April 12, 2011 8:56 PM
  • I also have this problem on Outlook 2010 with Windows 7 32 Bit.  Literally everyday I start my laptop Outlook will rebuild the index.  I have re-installed also and this has made no difference to the issue.
    • Proposed as answer by Peter Baird Thursday, April 21, 2011 4:30 PM
    Thursday, April 21, 2011 7:19 AM
  • I recently fixed the search failure in Outlook 2010 this way: I went to Control Panel>Programs and Features>highlight Microsoft Office and click Change which brings up a dialog box that gives options, including Repair. I clicked on this option and when the program finished running, half an hour later, my issue was solved...at least for the time being.
    Peter Cornelison
    Thursday, April 21, 2011 4:34 PM
  • Same issues with me.  It has been few weeks that I have been having this problem.  Every morning the number of items being indexed goes up.    I called MS on 92nd day and they wanted me to pay $45.  As always, an arrogant MS customer care representative answered my call. 

     

    Thursday, April 28, 2011 2:53 PM
  • Has anyone seen a hint of a solution in this matter?

    The issue is the same with me, Win7 x64 and Office 2010 32 Bit.
    Everytime i start Outlook after indexing has been completed the counter jumps up to 2800+.
    This number is fairly constant, but if you close outlook before the indexing is completed.
    The total will double and this behaviour is repleatable, local admin or GPO settings have no effect on this behaviour.

    Tuesday, July 12, 2011 12:27 PM
  • Did you try to run the repair recommended above by Peter Baird 4/21/11 4:34 p.m.? I'm not at the machine having the problem but, wondered if anyone else got the repair to work. I am using Office 2010 32 Bit on an XP OS. Have the same problem as everyone else. Have forestalled fixing it till we see what has worked. Only one reporting any success seems to be the one who ran repair.

    Tuesday, July 12, 2011 5:25 PM
  • I have don the repair, rebuilt the index, turned windows search on and off again.  Scanned the pst files, basically everything that is suggested.  None works.  I have another laptop, which is the same model and same programs and it works fine.  The bad part is its not working for the Boss.  There has to be a fix.  My next step is to wipe the laptop and reinstall everything.
    Friday, July 22, 2011 3:17 PM
  • I don't know if this has been answered as I don't know that it has, I was sent here from @MicrosoftHelps on Twitter and I want to know how to FORCE Search if I am having issues, instead of "waiting" and yet it doesn't seem like there IS an answer to this, if you rebuild the index, it will start from scratch and that's not "a fix."
    Tuesday, September 20, 2011 12:12 AM
  • It does not appear that a solution has been identified. It is not only annoying, but problematic. For the record I am running Win 7 Pro 32-bit, and I have the problem with Outlook 2007 (others in this thread are OL 2010). The suggestion to simply rebuild the index is nonsense - it never finishes. I started a rebuild on 9/8/11 and today (10/6/11) it has indexed ~168,000 items and reports that there are 37,400 to go. In the last 3 weeks the number left to index has only dropped by 15K. At this rate it MAY finish by Thanksgiving. I don't expect a solution until maybe there is a major service pack, and probably not even then. -mastman
    Thursday, October 06, 2011 4:28 PM
  • I dont know if it will make a difference to anybody but if you are the only user of a particular terminal, it might help to do the following:

    1. in outlook 2010 go to file --> options --> Search --> Indexing Options -->  Modify
    2. In Modify section in the top half of the window, go through each of the indexed items which are not related to your username and untick them.
    3. Rebuild index.

    Not sure if it will help only i cant see how indexing another users files while logged into your username would be of any use?

    Seems to have speeded up the indexing process for me at the moment at least.

    Microsoft are a little shoddy in this respect it would see,

    Thursday, October 20, 2011 9:49 AM
  • I am running Win7 enterprise x64 with Office 2010 SP1 X64. One behaviour that we need to take great care of with respect to outlook .OST file indexing is that Outlook needs to be running in order for the indexing to work. In my case, if i exit outlook, indexing is complete with about 55k items. However, as soon as I run outlook, the number of items jumps to about 150k. I left my machine idle overnight, the indexing completed and the search works just fine now.

     


    Warm Regards Ashutosh S Karkhanis, Director, Askari Infotech Private Limited, ashu.k@askari.co.in / http://www.askari.co.in INDIA: +91-20-65004721 / 24220388 USA : +1-619-591-8935
    Tuesday, October 25, 2011 7:23 AM
  • I have a Sony Vaio, Windows 7 Professioal, Outlook 2010 and I am experiencing the indexing nightmares that so many people in so many forums have spoken about. I have tried so many different possible fixes, but NO ONE has yet to solve this issue. Each time I reboot, the Indexing starts again. If you turn off Windows Search, you lose searching ability in Windows Explorer. If you turn off Windows Indexing, you wil be searching for a long time without the index if you have many items.

    Microsoft is very quiet about this issue, as usually happens when they make a change (adding Windows Search) to an operating system (Windows 7) without really testing it properly. If they actually tested it, and let it pass, then why are there hundreds of posts in many forums trying to solve this mess? Somebody at a higher level than local systems engineers should read these posts.

    Here is my solution to the problem --- if you eventually index every item in Outlook ---NEVER shutdown your PC, but keep it running. If you have a laptop, make it hibernate only. But DO NOT SHUT DOWN the PC, or you will find that upon reboot --- you will have Outlook indexing all your items, all over again.

    And... for those who try the "Files--Options--Search---Indexing Options -- Modify" and think they can select Outlook from the list --- that is not possible, So you cannot disable the indexing in Outlook 2010 as Microsoft describes.

    This never ending indexing issue is a problem that Microsoft needs to address --- use the code from Outlook 2007, where it worked just fine. 


    • Edited by TMucci Friday, January 06, 2012 2:54 AM
    Friday, January 06, 2012 2:50 AM
  • This sounds helpful, but why is it when solutions are posted it is impossible to follow because MS changes the damn locations so often? I go to Control Panel> Programs and there is no Office and no sign of any repair app.
    • Proposed as answer by D Evans851 Friday, July 20, 2012 2:20 PM
    • Unproposed as answer by D Evans851 Friday, July 20, 2012 2:20 PM
    Saturday, February 25, 2012 5:38 PM
  • I am running win7 64bit and Outlook 2010 64Bit the latter because I am also running the Exchange Management Tools.

    I have found the search function on this version of outlook, to be pathetic it is always breaking and failing to find things and has been reinstalled several times also I have reinstalled the OS on PC twice in an effort to fix this with no success. If i do a re-index it will find things for a bit perhaps a day or so and I have to do a manual re-index again. Generally the search function on the PC works well and I can find documents, directories and whatever quite easily.

    I do not see this problem on the 250 or so desktops that we manage which run the 32bit version of Outlook 2010. I could well be that some other piece of software on this PC could be conflicting but I am not getting any error messages to work with it is just that search does not find things that are there.

    Hope this helps


    • Edited by fernery Tuesday, February 28, 2012 2:36 PM
    Tuesday, February 28, 2012 2:35 PM
  • Thanks,

    Very frustrating last week when after a Windows Update, Outlook entered a endless do-loop indexing issue.  Took a long time to find this thread, but this immediately solved the problem at least for now.

    Friday, July 20, 2012 2:19 PM
  • Patrick, 

    Just completed Peter Baird's recommendation from above.  If you have not solve this yet this is a standard feature of MS Control Panel - Uninstall Programs function.  Right mouse click on MS office, select "change" versus uninstall, then select "Repair".  15-10 later and a reboot and you should be off and running. 

    • Proposed as answer by rickhardy3 Friday, October 26, 2012 3:14 AM
    Friday, July 20, 2012 2:24 PM
  • same problem, all i could do is search/indexing options/modify the index and stop using outlook 2010 , ie, uncheck the box for outlook 2010,, we run 2007  no issue on other machines,  i think it is something with the windows 7 as a conflict maybe ?  i can then search but the search tools is all greyed out. so i cannot narrow down the search. did MS ever come up with a fix?  if i do not do this it keeps on indexing for ever, then stops, then starts again.  lots of archiving to keep the search from going foever, 
    Friday, October 26, 2012 3:21 AM
  • I've spent hours trying to fix this.  Problem is all our IT customers have the same problem...

    Microsoft HELP!!! one of your updates has messed up Windows search indexing such that it keeps restarting from scratch every day and never stops.

    If one more person tells me to delete or rebuild my index I'll scream.

    B

    Thursday, January 24, 2013 5:59 PM
  • i have the same problem since few days. since i had to replace the hard disk on my VAIO Z135.. before that, i never had any problems to use this great indexing tool.

    not that it does not work on the new fresh install of windows and that i read your mails, i realise that when it works it is a great tool and 2/i don't know where is the problem. indexing and search was working fine until few days ago.

    sorry for not being helpful. i keep looking. i may use a ghost from my old config i try to reload on the new hard disk. not a fun thing to do nor an easy way to solve...Didier

    Tuesday, February 05, 2013 11:31 AM
  • You try re-creating the OST file (if cached mode is enabled)?
    Tuesday, April 02, 2013 3:20 PM
  • Did anyone find a resolution to this?

    NN

    Thursday, June 06, 2013 1:36 PM
  • Subject seems to have died? It's not just a Windows 7 problem, I have it with Windows 8.1. Outlook has been indexing for two weeks now and it went to zero and is busy going back up again. This is really poor performance from Microsoft if they can't fix it. I have to do manual searches for anything on Outlook.
    Thursday, December 05, 2013 2:27 PM
  • It is indeed astonishing. I am now also using 8.1. Nothing works to get the indexing behaving as it should. I finally removed Outlook from indexing altogether. The unindexed search is rather slow; however, at least I can find what I am looking for. The issue now is that the indexing does not seem to want to beyond about 12,000 files in my windows folders, meaning I have to use Google Desktop to search for files. Thank goodness for that, as it works well -- just not as convenient as it is not integrated. I will likely be trying Office 365; so we will see if this helps at all.  
    Saturday, December 14, 2013 5:27 PM
  • I have the same problem, started after I installed a Solid State HDD.

    Did anyone else upgrade their drive or running SSD?

    Wednesday, January 29, 2014 11:17 PM
  • I finally fixed this.

    Stop Windows Search service. Reboot.

    Open Outlook. Close.

    Restart Windows Search service. Reboot.

    Run new indexing overnight.


    • Edited by brokerhound Thursday, January 30, 2014 11:07 AM
    Thursday, January 30, 2014 11:04 AM
  • I manage a Windows/Exchange network and we've seen the search issue come up.  Most recently the search was failing firm-wide.  I did test repairing the MS Office files and, because of our network and the way it's set up, we stopped and started the index server.  While there was improvement with some clients the issue was not entirely resolved. 

    Our final step was to completely rebuild Outlook for each mailbox.  Although it shouldn't matter because all the indexing, as I understand it happens on Exchange, I've asked our clients to keep their PCs running, not locking, just leave Outlook open.   I'll report back with the results.

     

    Tuesday, February 25, 2014 12:23 AM
  • Indexing not working on an Exchange Network:  Follow up to my previous post.  The indexing on each mailbox worked.  Everyone is reporting their searches are complete.  Special thanks to Bill Sangston from Afinety for his help resolving this for our firm.

    I had all users keep their Outlook open during the process.  Not sure it mattered but it didn't hurt.

    The MS article is below which describes the overall process. That said, the proper command/context is .\ResetSearchIndex.ps1 -force –all which is run from the Exchange Management Shell. Simply copy the command and paste into the management shell, then press enter. The command will automatically delete/remove the old indexes and recreate them.

    http://technet.microsoft.com/en-us/library/aa995966(v=exchg.80).aspx

    Tuesday, February 25, 2014 10:09 PM
  • repairing the outlook client works for me thanks.

    Wednesday, April 30, 2014 6:44 PM
  • I had the same issues. Oulook PSTs are indexing forever in a closed loop and give no results (Outlook 2010 32bit with Win7 64bit). Here are my experiences after 3 days trial and error:

    • I renewed windows search index -> no change
    • I repaired Outlook 2010 -> no change
    • I have created a new outlook profile -> no change
    • I scanned all PST and OST with scanpst.exe -> no change
    • I unistalled windows search and reinstalled it (including manually deleting Registry Keys in HKLM) -> No change

    I have searched the whole Internet for any additional tip. Apparently in some cases the index error is persistent. My final step was: uninstall Office 2010, install Office 2013... reinstalling windows search... and it worked. Index of 60.000 elements in light-speed (below 2 hours) and the first time the message "0 elements left".

    Good luck to all others facing this error...


    Saturday, August 02, 2014 3:54 PM