none
Outlook 2010 reminders always on top

    Question

  • I just upgraded to Outlook 2010 x32 on Win 7 x64.  When reminders come up (from Tasks so far), the Reminder window is always on top.  Is there a way to change this behavior so if I click on another window it will be on top?

     

    Thanks!

    Sunday, June 06, 2010 1:13 AM

Answers

  • Don,

    A non-office workaround - but definitely geeky ;-) - would be to install a program (like http://www.thewonderfulicon.com/) that disables the 'Always on top' property of a specific window. I have not tested this on dialog boxes, though.


    - Thanks, Jinesh.
    • Marked as answer by Sally Tang Wednesday, June 09, 2010 12:52 AM
    Tuesday, June 08, 2010 12:54 PM

All replies

  • Does anyone have a thought on this, does it work this way on your desktop too? It's already driving me crazy as I use reminders from tasks to manage my day's work, so the task reminder window is up most of the day as I manage through my work. But sitting on top, "always on top", is an incredible nuisance.  Does anyone have any help?

     

    Thanks!

    Sunday, June 06, 2010 11:13 AM
  • Dear Don,

     

    We are unable to change the focus of the Outlook reminder window currently. If you do not want to see the reminder when you are working, you can uncheck the options in Outlook 2010: Click File > Options > Advanced, uncheck the check box before: show reminders.

     

    If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Best Regards,

     

    Sally Tang

    Monday, June 07, 2010 8:01 AM
  • Thank you for your reply Sally. 

    Turning off the display of the reminders isn't very helpful for me, as I want/need them there to address, I just don't want them to be forced on top of everything else for immediate attention, not able for any other window to be displayed on top of them.  That's so Windows 3.1 isn't it <g> After all, we are using a multitasking multi-application system, and for the UI to force something to be addressed that is not a catastrophic error, that's just an application function, is hardly a recommended user interface technique in anyone's book.

    I am not sure why this changed since Office 2007, but I hope the ability to change it back is reintroduced. I know some people want it on top, maybe an option could be added (although there are third party products that add this functionality, unfortunately there is no way that I found to turn off this obtrusive behavior).

    Please let others know my feedback if possible. Again, thanks for your help Sally.

    Monday, June 07, 2010 10:59 AM
  • Hi Don,

     

    I would like to explain that it was the intended design of Outlook 2007 that the Outlook reminders do not interrupt an application which has focus. Instead, reminders will only flash in the taskbar and produce the reminder sound. The reminders only pop up to the foreground when Outlook is the background.

     

    I have tested in Outlook 2010, and found that the behavior is the same as in Outlook 2007.

     

    So, if you are running Outlook, the reminder will pop up in the foreground. However, if you are running other programs and minimize Outlook to the taskbar, the reminders should not pop up to the foreground. It only flashes in the taskbar.

     

    Best Regards,

     

    Sally Tang

     

     

     

    • Proposed as answer by KinCaid76 Thursday, August 23, 2012 6:31 PM
    Tuesday, June 08, 2010 2:17 AM
  • That is true re: its behavior.

    However there is more to the story.  The difference is, if the Reminders Window is UP, and there are active reminders or appointments in there to be dismissed etc., it will stay in the foreground no matter what - it will usurp the desktop from any and every other window, staying on top of all of them. This is new to 2010 vs. 2007. So now you cannot leave that window up to review reminders, you have to minimize it and hopefully not forget about them.

    So the reminders Windows is MODAL.  Does that make sense?

    I don't know of any window that takes over the display any more like that - years ago the Windows Task Manager used to do it (Ctrl-Alt-Esc), but even it does not do it any more. It sure takes control of the desktop away from the user.

    In fact this appears to be in violation of Microsoft's own Windows User Interface Guidelines at

    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=e49820cb-954d-45ae-9cb3-1b9e8ea7fe8c

    "Modal dialog boxes require interaction, so use them for things that users must respond to before continuing with their task. Make sure the interruption is justified, such as for critical or infrequent, one-off tasks that require completion. Otherwise, consider modeless alternatives." - Reminders winodw acts just like a modal dialog box if it comes up, it must be dealt with.  Is it that critical?

    Just my .02.  I wish/hope it can change, it's very unusable in my work style.

    Thanks for listening!

     

     

    Tuesday, June 08, 2010 11:28 AM
  • Don,

    A non-office workaround - but definitely geeky ;-) - would be to install a program (like http://www.thewonderfulicon.com/) that disables the 'Always on top' property of a specific window. I have not tested this on dialog boxes, though.


    - Thanks, Jinesh.
    • Marked as answer by Sally Tang Wednesday, June 09, 2010 12:52 AM
    Tuesday, June 08, 2010 12:54 PM
  • I tried one of these utilities and it did not work on the Reminders dialog box - probably because it was a dialog, as it worked on other windows. Thanks for the suggestion though!
    Tuesday, June 08, 2010 1:06 PM
  • Sally why did you mark that as an answer? I tried that and it does not work on dialog boxes!
    Wednesday, June 09, 2010 1:10 AM
  • Hi Don,

     

    I am sorry for the delayed response. I performed much research on this issue but found no good method to change the focus on the Outlook reminder window. Jinesh’s workaround may be better at this time.

     

    Best Regards,

     

    Sally Tang

    Wednesday, June 09, 2010 9:03 AM
  • I was also very frustrated with this new reminder behavior, but I believe I found a potential solution.  Using the DeskPins application, a small piece of freeware that pins windows to the foreground, I set up an 'Autopin' assigment that automatically pins all reminder windows to the foreground.  Here are the steps I followed:

    1. Close Outlook

    2. Download and install DeskPins from http://users.forthnet.gr/pat/efotinis/programs/deskpins.html

    3. Launch DeskPins

    4. Right-click on the DeskPins icon in the taskbar tray and choose 'Options'

    5. Click on the 'Autopin' tab

    6. Click the 'Add' button

    7. I entered 'Reminders' for the Description field, '* Reminder' for the Title field, and '#32770' for the Class field

    8. Click on the 'OK' button

    When I opened Outlook and set up an appointment with a reminder, the window was automatically 'pinned' to the foreground in front of all other open windows.
    • Proposed as answer by splauber Tuesday, August 02, 2011 6:44 PM
    Sunday, June 27, 2010 7:24 AM
  • MS office developers are as always INSANE!!!! This has been an ongoing problem for years with office. WE NEED MS OFFICE POPUPS TO POP UP OVER OTHER TASKS! BUT IT NEEDS TO BE CONTROLABLE! I'M AT THIS SITE ONLY BECAUSE I'M WASTING TIME TRYING TO FIND A FREE POPUP REMINDER THAT POPS UP OVER OTHER TASKS SO I CAN SEE IT! MY $ 350 MS OFIICE 2007 CAN'T DO THIS SIMPLE AND OBVIOUSLY NEEDED TASK!!!! SO HOW DO THEY FIX IT IN 2010????? PUT THE POPUP ALWAYS ON TOP OF EVERYTHING!!!! ARE MONKEYS DESIGNING THIS???? OPEN OFFICE HERE I COME!!!!!!    
    Friday, July 02, 2010 1:17 AM
  • Why can't MS just have options: 1 Always on top off/on 2 Always on top for X number of mins, hrs.? Like Duh!!!! This is not rocket sience, it's lack of giving a @%#$ what customers want. MS style all the way!!! All changes must wait until next version.... SPEND MORE $$$ FOR GATES AND FRIENDS!!! I may seem rude but I've wasted hours and missed too many reminders to count due to office reminders being MINUMIZED where they are USELESS!!!! Sally your comment below is incorrect for office 2007. I run outlook everyday. All day and reminders never appear on top of anything. I know because I realize this every time I miss something important!  Excuse me while I install the freeware I found that can do this simple task (wow shouldn't office task manager be able to do this???!?!?!?!) 

    Friday, July 02, 2010 1:31 AM
  • Is there an answer to this yet? I read this whole thread and didn't find one. When I Google...

    microsoft outlook 2010 always on top reminders

    ...this thread is in the #1 spot<3

    Tuesday, July 06, 2010 9:55 PM
  • This does work.  It's a shame you have to use 3rd party software to display a reminder on top.  Why MS can't make it an option is beyond me.
    Tuesday, July 20, 2010 7:51 PM
  • Greetings,

    I've also been frustrated by this.  However, the Reminder window's behavior is inconsistent for me.  Most of the time, it behaves as I want, not always-on-top.  Occasionally, when a new reminder comes up, the window will become always-on-top, and will not return to normal unless I exit Outlook, reopen it, and wait for the reminders to appear again.  Usually they will return to normal at this point and not take over the desktop.  For me, the issue seems possibly less frustrating than it is for others here.  They may not have tried restarting Outlook, or that could be an impractical solution for their circumstances.

    Version is Office Professional Plus 2010, 14.0.4760.1000

    Thanks,

    Kevin

    Tuesday, July 27, 2010 3:44 AM
  • Greetings,

    I've also been frustrated by this.  However, the Reminder window's behavior is inconsistent for me.  Most of the time, it behaves as I want, not always-on-top.  Occasionally, when a new reminder comes up, the window will become always-on-top, and will not return to normal unless I exit Outlook, reopen it, and wait for the reminders to appear again.  Usually they will return to normal at this point and not take over the desktop.  For me, the issue seems possibly less frustrating than it is for others here.  They may not have tried restarting Outlook, or that could be an impractical solution for their circumstances.

    Version is Office Professional Plus 2010, 14.0.4760.1000

    Thanks,

    Kevin

    That's how it works for me as well. I wish it would just stay NOT forcing itself on top.  This thread is confusing because some seem to complain it is not on top, but I think having an app that forces its window on top until you address it is very unfriendly.It's ok if it pops up on top but then if I click on something else it should honor my desire.

    What's really maddening is that someone at MS took the time and effort to change this since Office 2007.  Better things to do...

    Tuesday, July 27, 2010 9:29 AM
  • I know, right? They keep changing the look and adding worthless features, and even more options placed in 20 different places, but no options for such a simple need. I think the notifications are worthless if they don't popup on top of everything, specially when techs use 20 programs at a time.
    Wednesday, July 28, 2010 7:27 PM
  • Alright ppl. Let's keep our cool here.  First off, MS has this functionality built in already, in a manner of speaking.  Yes, it would be of benefit to have an option that allows users to force reminders to the foreground, but remenber, many legacy applications, when in focus, do not allow this to happen.  Now, has anybody noticed that when Outlook 2007 is the foremost application, reminders do in fact inturupt what you are doing?  So what is the solution to this pesky issue?  Retrain yourselves to using Windows 7 the way it was designed to be used.  Windows 7 is not Windows XP, or 2000, etc.  Windows 7 has this Wonderful new feature.  Perhaps you have all heard of it?  It's called Windows Snap, where you have two applications in focus at the same time, each using half of you screen.  This does work, but not for every application.  There are legacy applications that take over the entire foreground because that is the way they were designed.  In these cases, there isn't anything that can be done about it, by MS, or anyone else.  MS would have to develope Windows to give there own applications priority over any other application.  In essence, making MS application work as part of the OS while all other apps run at the application layer.  This would be meet with screaming villagers, carrying pitchforks and scythes, wanting blood.  Anybody remenber U.S. vs. MS of the early 90's???  Give it a try and see for yourselves.  Just my two cents.
    Tuesday, August 03, 2010 6:56 PM
  • I thikn everyone needs to read the OP again the problem stated was

     

    the Reminder window is always on top

     

    This thread has been hijacked by people who want the reminders to be on top.  On my system reminder windwo is always on top like a system modal dialog, and nothing can get on top of it until all the reminders are addressed. For me this is new behavior in Outlook 2010 and very unwelcome. I am looking seriously to alternatives to OUtlook because this is just completely disruptive.

    Please keep the topic to this problem, as I hope to hear an aswer from Microsoft (but I doubt I will). Thanks!

    Tuesday, August 03, 2010 7:06 PM
  • I'd like to resurrect this thread.  There's been several months of patching, and I still have this problem.

    First, this thread is not about trying to make the reminders window always-on-top.  It's about making it STOP being always-on-top for those of us who have this issue.

    I have reminders popping up every day.  Two to four times per week, randomly, a reminder will pop up and cause the reminder window to become "always on top".  Sometimes it's a reminder adding itself to the reminder queue already displayed in the reminder window, and other times it's when there are no other active reminders.  This is obviously a bug.  It is not intentionally designed behavior.  If it were intentional, it would be consistent.

    I have a slight suspicion that it is related to what window and element has focus when the new reminder appears.  It may be when another window that tends to "get attention" by either popping up or flashing in the taskbar

    In case it helps, here is what I have running usually: Firefox (4 instances with total ~250 tabs), IE (4 tabbed instances), Yahoo Messenger, Pidgin messenger, Outlook 14, Onenote 14, Word 14, Excel 14, Notepad, Notepad++, Process Explorer (yes, always), GIMP, ESET Smart Security, Virtual Clone Drive (just sitting there not in use).  Windows 7 x64.

    (14 means 2010, the actual version number is 14.)

    Thursday, October 21, 2010 8:40 PM
  • I will cast my vote for making the reminder's behavior a selectable option.

    I have two screens; on one is a virtual machine where I do software development.  The other is for the host machine, where I do everything else.  When I am working on the VM, I don't usually see tiny movements on the host screen such as a briefly flashing taskbar icon.  I would set the option to "Reminders always on top" because their coming to the top would not interrupt my work on the VM, but would nonetheless get my attention.

    I wouldn't say the thread was "hijacked" by those of us who want reminders on top.  Both complaints speak to the fact that reminder behavior is not something we can choose.  It should be.

    Friday, November 19, 2010 4:23 PM
  • mjsagert, thanks for telling us about DeskPins.  Works perfectly!  However, I had to tinker with the title a bit. 

    I don't recall how previous versions of Outlook deal with the reminder window title, but Outlook 2010 makes it the count of reminders in the window.  So your title suggestion "Reminder" didn't work because my test appointment window was titled "1 Reminder".  If two reminders are displayed simultaneously, the title is "2 Reminders", and so forth.  So I tried it with wild cards, as "* Reminder*.  That worked for multiples, but the second wildcard couldn't deal with the case of no text at all ("1 Reminder" doesn't have an ending "s"), so it didn't work for one reminder.  Finally I settled on "* Reminde*", and all is well.

    Thank you!  Until Microsoft heeds our pleas, this will do. :)

    Friday, November 19, 2010 5:20 PM
  • My problem was that I wanted the reminders to pop up on the date/time of the event, because I couldn't see any flashing icon or hear any audible alert.  I solved that problem by going to this link:  http://www.ehow.com/how_6389912_fix-outlook-reminders.html  It is working for me; it will pop up when it is supposed to and then I can hide it, dismiss it, or whatever.  Please let me know if that works for you.
    Friday, December 10, 2010 3:51 PM
  • Hello Sally,

    My problem is the exact opposite of Don's.  I just switched to MS Office 2010, and I keep missing important alerts because they do not pop up in the foreground when I'm in other programs, which is 90% of the time.  I rely on this feature extensively and it has become a big problem for me. Is there any way to set it so that it pops up to the foreground, regardless of what program I'm in?

     

    Thanks
    Pam

    Wednesday, December 15, 2010 2:57 PM
  • See this thread for a possible workaround:

    http://social.answers.microsoft.com/Forums/en-US/outlookcontact/thread/a906bddd-96c7-4717-80a9-44f8241b18d7


    - Thanks, Jinesh.
    Thursday, January 06, 2011 12:17 PM
  • Does anyone know if Microsoft will ever fix the broken outlook reminders in Windows 7?
    Tuesday, January 25, 2011 1:21 PM
  • See this thread for a possible workaround:

    http://social.answers.microsoft.com/Forums/en-US/outlookcontact/thread/a906bddd-96c7-4717-80a9-44f8241b18d7


    - Thanks, Jinesh.

    This is a broken link
    Thursday, February 24, 2011 4:25 PM
  • Agreed, the 'normal behavior' is that in 2007 the notification box popped, to the foreground - you could take any action, but the when you clicked on another window for focus it came to the foreground over the reminder dialogue box.

    In 2010 the only change is that the dialogue box now remains in the foreground no matter what window is selected for focus - you cannot resize it either so even in my dual-monitor environment it's always in the way.

    While this is extremely annoying, you can simply minimize it to remove the issue and then the rest of the windows focus/foreground behavior is normal.  The next reminder that pops does open the dialogue box again, in front, and I cannot accuse the app of failing to remind me.  But, the way I work, I like being able to just click on a piece of the dialogue box and bring it to the foreground - cannot do that anymore - it's either always in the foreground or you have to minimize it.

    I am using Windows 7 professional 64-bit, and Office 2010.  I have multiple applications and instances of the same app open all the time - but I do no programming on this machine - the only 'shareware/freeware' app I use is RocketDock, which doesn't affect this and all the other applications play well in the sandbox.  I am also the unofficial 'apha' tester in the company as they say I can break anything through normal use if 'breakable.'

    It, of course, like any Windows program, has a bunch of buggy things that can affect you depending on what you use and do.  This is definitely is a change from Outlook 2007 - programming error in my opinion.  While I appreciate that others may want it on top all the time, because they'll forget something they've already been reminded of, that seems to be a personal organization/workflow issue, and not how (unscientific) 'most' people I deal with think or want this to work.  Having a switch for it would of course be nice.  Alot of freeware does - you can select 'always on top' or not - so do some of the 'big box' apps I use.

    Thursday, February 24, 2011 4:38 PM
  • Hello Hardrocker.  My problem is the oposite of this:

    "In 2010 the only change is that the dialogue box now remains in the foreground no matter what window is selected for focus". 

    My dialogue box will sometimes come to the foreground to remind me of an appointment, but most of the time it doesn't appear at all and I miss my appointments.

    Sally, or anyone else, is there a fix?


    Barbara Jean Bowden
    Thursday, February 24, 2011 5:04 PM
  • I've written a little utility to address this issue - Reminder Alerts.  A free beta version is available at http://www.moreproductivenow.com/reminder_alerts.htm .  It was inspired in particular by Diane Poremsky’s Outlook 2010 Reminders EMO article, and it displays reminders as alerts just above the system tray. Currently supports Outlook 2007 and 2010.
    Saturday, March 05, 2011 8:58 PM
  • It redirects me to http://answers.microsoft.com/en-us/office/forum/officeversion_other-outlook/outlook-meeting-reminders-and-communicator-ims-do/a906bddd-96c7-4717-80a9-44f8241b18d7?page=2

    Below given is the possible workaround I was referring to (which,btw, worked for me):

    I was also very frustrated with this new reminder behavior, but I believe I found a potential solution.  Using the DeskPins application, a small piece of freeware that pins windows to the foreground, I set up an 'Autopin' assigment that automatically pins all reminder windows to the foreground.  Here are the steps I followed:

    1. Close Outlook

    2. Download and install DeskPins from http://users.forthnet.gr/pat/efotinis/programs/deskpins.html

    3. Launch DeskPins

    4. Right-click on the DeskPins icon in the taskbar tray and choose 'Options'

    5. Click on the 'Autopin' tab

    6. Click the 'Add' button

    7. I entered 'Reminders' for the Description field, '* Reminder' for the Title field, and '#32770' for the Class field

    8. Click on the 'OK' button

    When I opened Outlook and set up an appointment with a reminder, the window was automatically 'pinned' to the foreground in front of all other open windows.

     


    - Thanks, Jinesh.
    Monday, March 07, 2011 9:32 AM
  • Hello Hardrocker.  My problem is the oposite of this:

    "In 2010 the only change is that the dialogue box now remains in the foreground no matter what window is selected for focus". 

    My dialogue box will sometimes come to the foreground to remind me of an appointment, but most of the time it doesn't appear at all and I miss my appointments.

    Sally, or anyone else, is there a fix?


    Barbara Jean Bowden


    Same here. I miss appointments because the reminder never pops-up...  Just a highlight in the system tray. Sometimes they do pop up though .... not sure what the difference is that make some reminders pop-up, and others not .... very frustrating.

     

    Also, if someone schedules a meeting with no reminder, it should still give it my default reminder setting of 2 hours so at least I get a notice.

    Friday, March 18, 2011 7:03 PM
  • As stated above, it extremely obvious that this feature should be configurable:

    1. Always on top
    2. On top for a user-specified amount of time
    3. Never on top (could be suggestion 2 set to zero time)
    4. With or without flashing in the Taskbar

    10 months later and there is no fix from MS - surely rather disappointing for all involved?

    Wednesday, April 06, 2011 3:29 AM
  • I am extremely disappointed.  Where are you when we really need you, Microsoft?   Is anyone even out there?    No one seems to give a rat's a...   This is depressing to the max.
    Barbara Jean Bowden
    Wednesday, April 06, 2011 1:36 PM
  • Hopefully the original poster already resolved this, but if someone else is having this problem give this a try:

    http://blogs.catapultsystems.com/mlist/archive/2011/04/24/outlook-2010-reminders-window-stuck-quote-always-on-top-quote.aspx

     


    • Proposed as answer by Nat J. Howry Saturday, July 02, 2011 4:44 PM
    Monday, April 25, 2011 1:12 AM
  • Sally, the problem that I - and I think some of the people who posted in this thread, and many people who have posted in many threads on many sites - have with the Outlook 2010 Reminders window, is that when Outlook decides to re-remind (typically, when the Reminders window is already open, and an existing or new reminder time arrives) OUTLOOK MAKES THE REMINDERS WINDOW **STEAL FOCUS**. This, regularly, results in the infuriating problem of typing in to the Reminders window instead of in to whatever other window just had its focus stolen away by the Reminders window. Outlook (or Windows 7) MUST be fixed to permit the user to specify that the Reminders window does NOT take FOCUS when a reminder (or re-reminder) occurs. Thank you, Jay Libove, CISSP, CIPP, CIPP/IT, CISM Windows 7 Ultimate 64-bit Outlook 2010 Professional Plus 32-bit
    Saturday, May 07, 2011 8:41 AM
  • Thanks, that fixed my issue with reminders always being on top in Outlook 2010.

     

    Wednesday, June 15, 2011 10:27 PM
  • Hopefully the original poster already resolved this, but if someone else is having this problem give this a try:

    http://blogs.catapultsystems.com/mlist/archive/2011/04/24/outlook-2010-reminders-window-stuck-quote-always-on-top-quote.aspx

     


    Thanks, Marty! This appears to be the fix.
    Saturday, July 02, 2011 4:44 PM
  • I actually need the reminders to pop up on top, they never do for me. Anyone have a solution for that?
    Tuesday, August 02, 2011 4:43 PM
  • Try a workaround given in the thread http://answers.microsoft.com/en-us/office/forum/officeversion_other-outlook/outlook-meeting-reminders-and-communicator-ims-do/a906bddd-96c7-4717-80a9-44f8241b18d7?page=2

    Below given is the possible workaround I was referring to (which,btw, worked for me):

    I was also very frustrated with this new reminder behavior, but I believe I found a potential solution.  Using the DeskPins application, a small piece of freeware that pins windows to the foreground, I set up an 'Autopin' assigment that automatically pins all reminder windows to the foreground.  Here are the steps I followed:

    1. Close Outlook

    2. Download and install DeskPins from http://users.forthnet.gr/pat/efotinis/programs/deskpins.html

    3. Launch DeskPins

    4. Right-click on the DeskPins icon in the taskbar tray and choose 'Options'

    5. Click on the 'Autopin' tab

    6. Click the 'Add' button

    7. I entered 'Reminders' for the Description field, '* Reminder' for the Title field, and '#32770' for the Class field

    8. Click on the 'OK' button

    When I opened Outlook and set up an appointment with a reminder, the window was automatically 'pinned' to the foreground in front of all other open windows.


    - Thanks, Jinesh.
    Wednesday, August 03, 2011 4:01 AM
  • My testing has shown that simply closing the Reminders window (by clicking the x in the upper right corner) instead of minimizing it or leaving it open under other windows will cause it to pop up again for the next reminder.

     

    I know that it’s annoying when Microsoft makes an interface change that requires us to change our work habits, but unfortunately, that’s what they’ve done with the issue of Reminders not popping up over active Windows. Installing Deskpins may work, but I'm not going to install a freeware utilty on a Remote Desktop Server that supports 40 users, so instead I'll just have to try to get them to change their behavior.

     

    If anyone has seen that Reminders, after being closed, do not pop back up, let me know because I haven't been able to reproduce that behavior.

    • Proposed as answer by Robert Waldrop Thursday, September 22, 2011 5:12 PM
    Friday, September 16, 2011 3:39 PM
  • BillG69, after reading the dozens and dozens of guesses, bitches and too difficult solutions, you have saved the day!  I also did the testing and got the same results you did. You wonder if MSFT really wanted to create distinct behaviors based on the position of the reminders window, but I can say it can't be a feature valued by Outlook users.  Again...thanks so much for taking the time to test and post your response.
    Thursday, September 22, 2011 5:17 PM
    1. Close Outlook
    2. Use Task Manager to wait for Outlook.exe to completely exit
    3. Use Regedit to rename or delete the window position registry value:

     

    • Key: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Options\Reminders\ 
    • Value Type: REG_BINARY 
    • Value Name: WindowPos

     

    The next time Outlook launches, the WindowPos value will get recreated and the Reminders window will no longer be stuck on top of the main window.
    Credit goes to this guy: http://blogs.catapultsystems.com/mlist/archive/2011/04/24/outlook-2010-reminders-window-stuck-quote-always-on-top-quote.aspx I just did the research and reposted as it worked for me :)


    • Edited by Doctor B in VA Friday, September 30, 2011 6:57 PM
    • Proposed as answer by SuperS16 Tuesday, June 12, 2012 8:31 PM
    Friday, September 30, 2011 6:57 PM
  • I am having the opposite problem. My calendar reminders do NOT appear on top, and I am missing meetings because of this. The reminders do come up, but they are buried underneath whatever document I am working on. Setting a sound for reminders is no help because my computer does not have sound. And it doesn't matter if I've minimized Outlook or not. Since it appears that it is the default for reminders to be on top, I wonder how I can reset it?
    Tuesday, October 11, 2011 6:29 PM
  • The workaround given below helps to 'pin' the reminder on top of all windows. It will not steal focus from other windows, just pins it on top.

    I was also very frustrated with this new reminder behavior, but I believe I found a potential solution.  Using the DeskPins application, a small piece of freeware that pins windows to the foreground, I set up an 'Autopin' assigment that automatically pins all reminder windows to the foreground.  Here are the steps I followed:

    1. Close Outlook

    2. Download and install DeskPins from http://users.forthnet.gr/pat/efotinis/programs/deskpins.html

    3. Launch DeskPins

    4. Right-click on the DeskPins icon in the taskbar tray and choose 'Options'

    5. Click on the 'Autopin' tab

    6. Click the 'Add' button

    7. I entered 'Reminders' for the Description field, '* Reminder' for the Title field, and '#32770' for the Class field

    8. Click on the 'OK' button

    When I opened Outlook and set up an appointment with a reminder, the window was automatically 'pinned' to the foreground in front of all other open windows.


    - Thanks, Jinesh.
    Wednesday, October 12, 2011 3:35 AM
  • That is extremely poot choice by Microsoft.  You have effectively killed the value of the reminder.  If I am using another application deeply involved in my work, I want to be interrupted by my remiders (that is their purpose!).  I have missed or been late to several important meetings and other tasks because the remider did not appear on the top.  The behavior in Outlook 2003 was much much better.  Why do you keep downgrading your apps and making them less functional for users?

     

    Please put on the list suggested new features for future version to have an option to have reminders pop-up and interrupt other applications.  (and while you are at it please also add the ability to flag for follow-up with date date for IMAP accounts - another feature missing from Outlook 2003).

    P.S. - Can I downgrade to Outlook 2003 without loosing all my data?  The features of Outlook 2003 seemed far superior.

     

    Wednesday, October 12, 2011 11:40 PM
  • Thank you Jinesh.

    Installing Deskpins worked for me.  I was missing out a lot on my tasks because of reminder that does not pop up on top of other windows. Much appreciate your help.

    Friday, October 14, 2011 1:47 AM
  • Hi Sally

     

    Can you te;; me how to get the Outlook reminder to be audible?

    Friday, November 18, 2011 4:46 PM
  • Hopefully the original poster already resolved this, but if someone else is having this problem give this a try:

    http://blogs.catapultsystems.com/mlist/archive/2011/04/24/outlook-2010-reminders-window-stuck-quote-always-on-top-quote.aspx

     



    This solved the issue for my Win7Ult-x64+Office2010 install.

    Thank you!

    Friday, November 25, 2011 7:35 PM
  • I was also very frustrated with this new reminder behavior, but I believe I found a potential solution.  Using the DeskPins application, a small piece of freeware that pins windows to the foreground, I set up an 'Autopin' assigment that automatically pins all reminder windows to the foreground.  Here are the steps I followed:
    1. Close Outlook
    2. Download and install DeskPins from http://users.forthnet.gr/pat/efotinis/programs/deskpins.html
    3. Launch DeskPins
    4. Right-click on the DeskPins icon in the taskbar tray and choose 'Options'
    5. Click on the 'Autopin' tab
    6. Click the 'Add' button
    7. I entered 'Reminders' for the Description field, '* Reminder' for the Title field, and '#32770' for the Class field
    8. Click on the 'OK' button
    When I opened Outlook and set up an appointment with a reminder, the window was automatically 'pinned' to the foreground in front of all other open windows.
    You definitely rock in my book
    Thursday, December 29, 2011 9:07 PM
  • http://users.forthnet.gr/pat/efotinis/programs/deskpins.html comes up with Not Found. Can anyone help? Thank you, JJ
    Monday, January 16, 2012 2:27 PM
  • If someone is still looking for this - http://office.microsoft.com/en-us/outlook-help/change-the-sound-played-for-reminders-HA010271158.aspx
    - Thanks, Jinesh.
    Tuesday, January 17, 2012 4:02 AM
  • I could find alternate download sources. Download only if you trust the sites.
    http://www.snapfiles.com/downloads/deskpins/dldeskpins.html
    http://deskpins.en.softonic.com/download
    - Thanks, Jinesh.
    Tuesday, January 17, 2012 4:05 AM
  • I agree with Barbara. This notification hiding problem is akin to me setting my morning alarm clock but turning the sound down, because "why would I want to be bothered while I'm sleeping? (note: severe sarcasm intended).

    Deskpin or other third-party applications might work for some, but what do the rest of us do if our company does not allow us to install third-party software on our computers?

    Shame on you, Microsoft for not giving control of this simple function back to the users.

    Barbara - your ehow article, unfortunately did not work for me (office 2010/windows 7). Bummer!

    Kari

    Friday, February 24, 2012 11:29 PM
  • Someone please tell Microsoft to change the reminder window so it is a balloon task bar popup in the lower right corner, will solve all the problems of stealing focus etc, then you have to click on it if you want to change things like postpone etc.

    Tuesday, May 15, 2012 11:55 PM
  • The /cleanreminders command line switch worked for me.  For more about command line switches and how to run them, see http://office.microsoft.com/en-us/outlook-help/command-line-switches-for-outlook-2010-HP010354956.aspx.

    What I find interesting is that this wasn't happening for me until just recently.  I had been using Windows 7 Enterprise with Outlook 2010, and the reminders were working just like I would expect.  Last week sometime, the reminders window started staying on top of other windows even when I would select a different window.  Very annoying.  I was thankful that the /cleanreminders command fixed it, or at least it seems to have done so.

    • Proposed as answer by IT Helper Thursday, August 16, 2012 9:24 PM
    Monday, June 18, 2012 2:38 PM
  • Thanks, Randall—this is the answer that people will be looking for!

    For those who need instructions (Windows Vista/Windows 7):

    1.  Press the Windows/Start button on your keyboard or taskbar.

    2.  Type in:  outlook /cleanreminders

    3.  Press Enter

    Outlook will launch and your Reminders window will no longer be stuck on top of all other windows when you click on another window/application to move the focus off of the Reminders window.  The Reminders window should still pop up in front of all other windows IF it's not already open.

    Don't forget everyone, the original question from Don (at the very top) was:

    "I just upgraded to Outlook 2010 x32 on Win 7 x64.  When reminders come up (from Tasks so far), the Reminder window is always on top.  Is there a way to change this behavior so if I click on another window it will be on top?"


    • Edited by IT Helper Thursday, August 16, 2012 9:59 PM
    Thursday, August 16, 2012 9:28 PM
  • Windows 7, Outlook 2010 and I have the opposite problem where reminders don't pop up to the foreground.  It's a serious issue since I'm missing meetings.  I cannot install unapproved 3rd party software.  Are there any Microsoft options available to me?

    Wednesday, January 16, 2013 7:14 PM
  • You made my day!

    The topic is very old, but still there seems to be no solution in Office itself.
    Your solution works like hell. Just like in the "old" Outlook2002 days!

    Remark: in point 7, the "Title" field is language specific! For my german Office 2010 version, I had to put in 'Erinnerung' to make it work. (The Asterisk and space before is not necessary)
    Thursday, July 25, 2013 7:13 AM
  • As Don said further below, many of us now live in a multi-tasking realm.  I need only a little piece of the Outlook Reminders box to be visible so that with one click I can check it.  As such, it needs to become mostly hidden when I click on any other application box.  I trust that Microsoft, whose products are great and which I've used for a long time, can craft an updates fix for this soon.  To have the Reminders Box always up front, in the way of everything else, is really annoying.  Thanks so much.
    Wednesday, December 11, 2013 2:14 PM
  • Thanks for the suggestion, Kevin.  Restarting Outlook did the trick for me as well.
    Wednesday, February 12, 2014 6:08 PM
  • It occurs to me that some people have the Outlook Reminder popping up in on top of all windows, and don't want it to do that.
    Then others want Outlook Reminders to pop up on top of all windows and it is not working.

    That means there has to be a setting/registry entry or something different between the two.

    It would help if each response included the OS version, IE version, Outlook Version, etc.

    Also some see this as a windows issue and others an outlook issue.

    Then a couple of you with the opposite taste for how reminders are handled, might be able to share more information and maybe find a solution.

    What do you think?

    Sunday, June 22, 2014 3:07 AM