none
Outlook 2007 error with underlying security system

    Question

  • I am using Outlook 2007 and receiving this error:

    An error occurred in the underlying security system. The supplied handle was invalid.

    i am using a smart card. So far a google and a technet search has turned nothing up. Any help would be great.

    Wednesday, August 10, 2011 9:40 PM

All replies

  • Hi

    Can you provide the below details?

    1. How outlook is configured. POP3 or Mapi connection

    2. what antivirus you are using?

    3. when you are getting this error message? while opening outlook or sending email or reading an encrypted email?

    4. did you find any information in the event viewer, related to this alert?

    Thursday, August 11, 2011 5:39 AM
  • Hello?

    Sincerely,

    Max Meng
    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Monday, August 15, 2011 4:57 AM
    Moderator
  • This is an issue that happens when Outlook or ActivClient has problems reading the certificates from your ID card. You most likely see this problem when attempting to send an email with an attachment, and send or open an encrypted email, all of which will require Outlook to have access to your published certificates. Open ActivClient, and if it takes forever to see them, or doesn't see your certificates at all there is an easy way to resolve this. Remove and re-insert your smart card into the reader. Re-open ActivClient and if it sees your certs right away, try resending the email, and it should go granted you have your certificates published properly.
    • Edited by Hom3Skill3t Thursday, March 01, 2012 5:49 PM fix
    • Proposed as answer by Hom3Skill3t Thursday, March 01, 2012 5:51 PM
    Thursday, March 01, 2012 5:48 PM