none
IMCEAMAILTO issue causing "Delivery has failed ...".

    Question

  • What started as a single user experiencing an issue sending emails to some addresses has started to become multiple users.

    In Outlook 2007, when a user does a reply to some emails the E-mail Type: changes from the normal SMTP to MAILTO and then when the user sends the email it is rejected because either Outlook or our Exchange server is adding @domain.local to the end of the recipient’s email address.

    This also happens with emails where the senders address is shown as a clickable option [mailto:persons.name@domain.co.uk].

    Email address has been changed to Persons.name@domain.co.uk for confidentiality reasons.

    Delivery has failed to these recipients or distribution lists:

     

    'Persons.name@domain.co.uk'
    A problem occurred during the delivery of this message. Microsoft Exchange will not try to redeliver this message for you. Please try resending this message later, or provide the following diagnostic text to your system administrator.

     

      _____  

    Sent by Microsoft Exchange Server 2007

     

    Diagnostic information for administrators:

     

    Generating server: mailserver.ourdomain.local

     

    IMCEAMAILTO-Persons+2Ename+40domain+2Eco+2Euk@ourdomain.local
    #550 5.4.4 ROUTING.NoNextHop; unable to route ##

     

    Original message headers:

     

    Received: from mailserver.ourdomain.local ([fe80::d597:2413:93ab:cf17]) by mailserver.ourdomain.local ([fe80::d597:2413:93ab:cf17%13]) with mapi; Thu, 14 Oct 2010 13:58:28 +0100
    Content-Type: application/ms-tnef; name="winmail.dat"
    Content-Transfer-Encoding: binary
    From: Internal User <Internal@ourdomain.co.uk>
    To: "'Persons.Name@domain.co.uk'"
                <IMCEAMAILTO-Persons+2Ename+40domain+2Eco+2Euk@ourdomain.local>
    Date: Thu, 14 Oct 2010 13:58:27 +0100
    Subject: email

    Thread-Topic: email

    Thread-Index: Actrn34QI8tEGRBCR/qQGIH5MxGgyA==
    Message-ID: <DC037DCA5E8D0F4585E53F80A5599ADC02339D6B5325@mailserver.ourdomain.local>
    Accept-Language: en-US, en-GB
    Content-Language: en-US
    X-MS-Has-Attach: yes
    X-MS-TNEF-Correlator: <DC037DCA5E8D0F4585E53F80A5599ADC02339D6B5325@mailserver.ourdomain.local>
    MIME-Version: 1.0

     

    Thursday, October 14, 2010 2:46 PM

Answers

  • Description of the Office Word 2007 hotfix package (wordconv-x-none.msp, word-x-none.msp): February 22, 2011:
    http://support.microsoft.com/kb/2475888/en-us?sd=rss&spid=11377
    • Consider the following scenario:
      • You receive an email message that contains a mailto hyperlink.
      • You use the mailto hyperlink to send an email message.
      In this scenario, you receive the non-delivery report (NDR).

    FINALLY POSTED!

    • Proposed as answer by Susan BradleyMVP Wednesday, February 23, 2011 5:16 PM
    • Marked as answer by Jexx Monday, February 28, 2011 8:14 PM
    Wednesday, February 23, 2011 5:16 PM
  • STATUS ON 12/13/2011

    HOTFIX HAS BEEN RELEASED

    **************************

    Assume that you create a document in Word 2010. When you type an email address inside the square brackets after the Mailto: header, the email address is displayed as an incorrect hyperlink. For example, you type abc@example.com inside the square brackets after the Mailto: header. In this situation, the email address is formatted as a [Mailto:abc@example.com] link. Additionally, when you click the link, the text "[Mailto:abc@example.com]" is inserted into the *To* box in Microsoft Outlook.

    http://support.microsoft.com/kb/2597052

    *****************************
    Please note it will not fix anything previously flipped.


    • Proposed as answer by -Dirk- Wednesday, December 14, 2011 8:10 AM
    • Edited by Susan BradleyMVP Monday, February 13, 2012 5:09 PM Bolding it to note hotfix release
    • Marked as answer by Jexx Friday, August 24, 2012 3:39 PM
    Tuesday, December 13, 2011 11:54 PM
  • I have identified the cause of the issue via the test server.

     

    This issue is caused by installing Security Update for Microsft Office Word 2007 (KB2344993) via windows update and can be resolved by removing this update.

     

     

    • Marked as answer by Jexx Friday, October 29, 2010 10:18 AM
    Friday, October 29, 2010 10:18 AM

All replies

  • On Thu, 14 Oct 2010 14:46:20 +0000, Jexx wrote:
     
    >What started as a single user experiencing an issue sending emails to some addresses has started to become multiple users.
    >
    >In Outlook 2007, when a user does a reply to some emails the E-mail Type: changes from the normal SMTP to MAILTO and then when the user sends the email it is rejected because either Outlook or our Exchange server is adding @domain.local to the end of the recipient?s email address.
    >
    >This also happens with emails where the senders address is shown as a clickable option [mailto:persons.name@domain.co.uk].
    >
    >Email address has been changed to Persons.name@domain.co.uk for confidentiality reasons.
    >
    >Delivery has failed to these recipients or distribution lists:
    >
    >
    >
    >'Persons.name@domain.co.uk' A problem occurred during the delivery of this message. Microsoft Exchange will not try to redeliver this message for you. Please try resending this message later, or provide the following diagnostic text to your system administrator.
     
    That 'Persons.name@domain.co.uk' is coming from either the mailbox's
    Contacts folder or an old PAB file. Remove the surrounding "'" from
    the address.
     
     
    >IMCEAMAILTO-Persons+2Ename+40domain+2Eco+2Euk@ourdomain.local #550 5.4.4 ROUTING.NoNextHop; unable to route ##
    >
    >
    >
    >Original message headers:
    >
    >
    >
    >"'Persons.Name@domain.co.uk'"
     
    The address is seen as a string, not an e-mail address. It has no
    <domain-part> so Exchange is adding its default domain to the address.
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Thursday, October 14, 2010 4:16 PM
  • Not that simple, the user has never emailed the person in question before so they are not in any address books or contact folders.

    The user is getting the email address from a received email by clicking reply or the HTML mailto in the email.

    Friday, October 15, 2010 10:19 AM
  • IMCEA encapsulation happens when the recipient can't be resolved to an SMTP address for some reason.

    http://technet.microsoft.com/en-us/library/bb430743(EXCHG.80).aspx

    In the message, the address is encapsulated as IMCEAMAILTO-Persons+2Ename+40domain+2Eco+2Euk@ourdomain.local

    persons.name@domain.co.uk is encapsulated in an @ourdomain.local address.  Is the user stamped with both a domain.co.uk and ourdomain.local SMTP address?

     

    J

    Friday, October 15, 2010 12:17 PM
  • Yes all of our users have both the user@domain.local and user@domain.co.uk addresses (if thats what you mean by stamped?).

    I'm trying to get a picture of when this all happens but as it is happening to users a and not me it can be quite difficult. But what I am seeing is that in some replies the external person's email address has [mailto:person@external.co.uk] next to it and if you use that it creates an email with [mailto:person@external.co.uk] in the To box, if you then move away it reformats it to person@external.co.uk (notice there is no 's around the address). If you right-click and select properties the E-mail Type is now MAILTO and not SMTP, if you send it then it will fail as it treats it as person@external.co.uk@mct.local

    Thanks for your assistance so far, I hope this turns out to be something simple...

    Edit:

    Log entries if any help?

    2010-10-15T14:49:43.123Z,fe80::d597:2413:93ab:cf17,mailserver.localdomain.local,fe80::d597:2413:93ab:cf17%13,mailserver,,,STOREDRIVER,RECEIVE,1969,<DC037DCA5E8D0F4585E53F80A5599ADC02339D6F2061@mailserver.localdomain.local>,IMCEAMAILTO-PMACKIE+40heathlambert+2Ecom@localdomain.local,,16347,3,,,subject,paul@ourdomain.co.uk,paul@ourdomain.co.uk,04I:
    2010-10-15T14:49:43.284Z,,,,mailserver,Journaling,,AGENT,RECEIVE,1970,<d0abf344-5889-4c88-8c51-d0a7d07af475@journal.report.generator>,Journal@ourdomain.co.uk,,17819,1,,1969,subject,MicrosoftExchange329e71ec88ae4615bbc36ab6ce41109e@ourdomain.co.uk,<>,
    2010-10-15T14:49:43.312Z,,,,mailserver,Failure,,DSN,DSN,1972,<28eb3003-b721-4f9b-8aaf-56fa0c2e9d90>,paul@ourdomain.co.uk;MicrosoftExchange329e71ec88ae4615bbc36ab6ce41109e@ourdomain.co.uk,,27043,2,,<DC037DCA5E8D0F4585E53F80A5599ADC02339D6F2061@mailserver.localdomain.local>,Undeliverable: subject,MicrosoftExchange329e71ec88ae4615bbc36ab6ce41109e@ourdomain.co.uk,<>,
    2010-10-15T14:49:43.312Z,,mailserver,,,,,ROUTING,FAIL,1969,<DC037DCA5E8D0F4585E53F80A5599ADC02339D6F2061@mailserver.localdomain.local>,IMCEAMAILTO-external+40person+2Ecom@localdomain.local,'550 5.4.4 ROUTING.NoNextHop; unable to route',16603,1,,<28eb3003-b721-4f9b-8aaf-56fa0c2e9d90>,subject,paul@ourdomain.co.uk,paul@ourdomain.co.uk,
    2010-10-15T14:49:43.319Z,,,,mailserver,,,ROUTING,EXPAND,1972,<28eb3003-b721-4f9b-8aaf-56fa0c2e9d90>,,'250 2.1.5 RESOLVER.MER.Suppressed; recipient suppressed',27043,0,MicrosoftExchange329e71ec88ae4615bbc36ab6ce41109e@ourdomain.co.uk,,Undeliverable: subject,MicrosoftExchange329e71ec88ae4615bbc36ab6ce41109e@ourdomain.co.uk,<>,

    Friday, October 15, 2010 3:43 PM
  • On Fri, 15 Oct 2010 10:19:38 +0000, Jexx wrote:
     
    >
    >
    >Not that simple, the user has never emailed the person in question before so they are not in any address books or contact folders.
    >
    >The user is getting the email address from a received email by clicking reply or the HTML mailto in the email.
     
    Ahhh . . . I took a closer look, this time at the address type that
    was encapsulated! You probably don't have an address type of "MAILTO"!
     
    IMCEAMAILTO-Persons+2Ename+40domain+2Eco+2Euk@ourdomain.local
     
    My guess is that the HTML anchor is badly constructed. "Mailto" is the
    scheme, but it shouldn't be part of the address. Check to see if the
    link is correct in the HMTL. May be it's "mailto:mailto:person@domain"
    instead of "mailto:person@domain"?
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Friday, October 15, 2010 4:39 PM
  • On Fri, 15 Oct 2010 15:43:02 +0000, Jexx wrote:
     
    >
    >
    >Yes all of our users have both the user@domain.local and user@domain.co.uk addresses (if thats what you mean by stamped?).
    >
    >I'm trying to get a picture of when this all happens but as it is happening to users a and not me it can be quite difficult. But what I am seeing is that in some replies the external person's email address has [mailto:person@external.co.uk] next to it and if you use that it creates an email with [mailto:person@external.co.uk]
     
    Ouch. The square brackets imply that the "mailto:" is the address type
    (e.g [FAX:<telephonenumber], or [X400:/o=....]). I'm pretty sure the
    HTML anchor tag is badly constructed.
     
    >in the To box, if you then move away it reformats it to person@external.co.uk (notice there is no 's around the address). If you right-click and select properties the E-mail Type is now MAILTO and not SMTP, if you send it then it will fail as it treats it as person@external.co.uk@mct.local
    >
    >Thanks for your assistance so far, I hope this turns out to be something simple...
     
    It's simple, I think, for you. It might be a problem for the person
    (or system) that built the HTML e-mail if that "mailto" tag is
    incorrectly constructed.
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Friday, October 15, 2010 4:45 PM
  • Thanks for the feedback.

    The issue appears on all replies and forwarded emails that we are sending and therfore must be an issue our end with Outlook or Exchange then? 

    For example if you sent me an email from your external email address and I replied to you, if I looked in my sent items at the email to you, when you hover over the email address it appears as mailto:[mailto:your@email.com]

    To me it looks like Exchange or Outlook do not support mailto, but I'm sure that's not the case so it must be a config issue some where?

    Monday, October 18, 2010 12:53 PM
  • On Mon, 18 Oct 2010 12:53:47 +0000, Jexx wrote:
     
    >
    >
    >Thanks for the feedback.
    >
    >The issue appears on all replies and forwarded emails that we are sending and therfore must be an issue our end with Outlook or Exchange then?
    >
    >For example if you sent me an email from your external email address and I replied to you, if I looked in my sent items at the email to you, when you hover over the email address it appears as mailto:[mailto:your@email.com]
     
    Well, that's just wrong. It should be "mailto:your@email.com". The
    absence of the "mailto" address space would lead the e-mail clinet to
    infer an address space of "[SMTP:your@email.com]".
     
    >To me it looks like Exchange or Outlook do not support mailto, but I'm sure that's not the case so it must be a config issue some where?
     
    "mailto:" as a scheme in a URI isn't the same as "[MAILTO:...]" in an
    e-mail address. Exchange and Outlook (and OWA, and Outlook mobile)
    handle them just fine. :-)
     
    The problem is certainly at your side of the processing, but I'd look
    at any processing of the message done by any Anti-Spam or Anti-Virus
    that may be altering the HTML tags, not at Exchange or Outlook.
     
    A message encoded in HTML would have an email address in an anchor tag
    like this:
     
     
    Note that there are no "square brackets" surrounding (in within) the
    address in the HREF tag.
     
    The "mailto" scheme is associated with some executable on your client
    machine (probably Outlook.exe). Clicking on the link sends the request
    to the associated application.
     
    The "[mailto:...]" address space would have to be associated with a
    "foreign connector" in your Exchange organization for it to work.
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Monday, October 18, 2010 3:23 PM
  • All our email is scanned externally and internally, but I don't see why Antivirus software would change email address/types when sending email and even if it did how I would know?
    The antivirus software would also only be check the outgoing message and not the copy saved in sent items.
    Below is an example of how the reply looks:

    From: Jexx [mailto:jexx@domain.co.uk]
    Sent: 09 August 2010 11:50
    To: Christopher

    Subject: Quote

    Monday, October 18, 2010 4:15 PM
  • If you are able to reproduce on the same email when replying, try disabling all outlook addins and replying. Open outlook in safe mode: outlook.exe /safe or reply using OWA. Also are you sure these email addresses were'nt mail enabled contact objects in the past?

     

    James Chong (MVP)
    MCITP | EA | EMA; MCSE | M+, S+
    Security+, Project+, ITIL
    msexchangetips.blogspot.com

     


    James Chong (MVP) MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    Monday, October 18, 2010 5:31 PM
  • On Mon, 18 Oct 2010 16:15:34 +0000, Jexx wrote:
     
    >All our email is scanned externally and internally, but I don't see why Antivirus software would change email address/types when sending email and even if it did how I would know?
     
    Because they can, and often do, try to disable certain HTML
    constructs.
     
    >The antivirus software would also only be check the outgoing message and not the copy saved in sent items. Below is an example of how the reply looks:
    >
    >
    >
    >From: Jexx [mailto:jexx@domain.co.uk] Sent: 09 August 2010 11:50 To: Christopher
     
    That's just wrong.
     
    So let's go back to the beginning. How does e-mail enter your
    organization from the Internet? Do external servers connect directly
    to your Exchange servers, or do they send it to an {external
    service|appliance|software running on your Exchange server}?
     
    Have you enabled pipeline tracing for a user and caotured the inbound
    e-mail as it arrives? Do you see that "square-bracketed" URI in the
    message?
     
    Forget looking at this stuff with an email client until you can look
    at the message the way it arrives.
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Monday, October 18, 2010 7:40 PM
  • On Mon, 18 Oct 2010 19:40:08 +0000, Rich Matheisen [MVP] wrote:
     
     
    >Below is an example of how the reply looks:
    >>>>From: Jexx [mailto:jexx@domain.co.uk] Sent: 09 August 2010 11:50 To: Christopher
     
    >That's just wrong.
     
    Sorry! That doesn't appear to be incorrect. What does is that the
    square brackets are being taken to be part of the address.
     
    This happens with OWA and Outlook? And it ony happens with
    HTML-formatted e-mail?
     
    I'd still like to know what the contents of the message is from the
    pipeline trace's "original" copy of the message.
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Monday, October 18, 2010 9:18 PM
  • Well I took a look at OWA and that does not create the hyperlinks for mailto:

    Comparing with my personal email account on my laptop I agree that for some reason it is including everything in the [ ] and not just the address between mailto: and ] as my laptop copy of Outlook does.

    This is running on Terminal Server so I will disable all plugins tonight and see if that makes a difference.

    Thanks for the advice so far, I'll report back with my findings.

    Tuesday, October 19, 2010 9:33 AM
  • Ok so I have disabled all addins and the antivirus software but it still does the same thing even on pure text emails. Although it only effects external email as the mailto: links are not created internally.

    The strange thing is that when I receive the emails on my personal machine with the same version of Outlook it does not create the mailto: links at all (not for any of the replies within the email, even though on the server it creates a link for them all)?

    There must be something in Outlook or a configuration setting relating to it that is causing it to create these links in the first place let alone doing it incorrectly?

    Is there a way to disable the use of custom e-mail types or is it possible to create a custom send connector that can handle these?

    The only thing I haven't tried is removing the addins completely which I'm reluctant to do as they are part of much larger installs which are key business systems.

     

    Tuesday, October 19, 2010 3:06 PM
  • On Tue, 19 Oct 2010 15:06:19 +0000, Jexx wrote:
     
    >
    >
    >Ok so I have disabled all addins and the antivirus software but it still does the same thing even on pure text emails. Although it only effects external email as the mailto: links are not created internally.
    >
    >The strange thing is that when I receive the emails on my personal machine with the same version of Outlook it does not create the mailto: links at all (not for any of the replies within the email, even though on the server it creates a link for them all)?
    >
    >There must be something in Outlook or a configuration setting relating to it that is causing it to create these links in the first place let alone doing it incorrectly?
    >
    >Is there a way to disable the use of custom e-mail types or is it possible to create a custom send connector that can handle these?
    >
    >The only thing I haven't tried is removing the addins completely which I'm reluctant to do as they are part of much larger installs which are key business systems.
     
    Try creating a new Outlook profile.
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Tuesday, October 19, 2010 8:50 PM
  • I have a client that is having an identical problem. It turns out the issue is indeed related to how the client (Outlook 2007) is handling the mail address. The problem only occurs when sending to certain mail addresses that he has previously corresponded with. If I delete the mail address from Outlook's "remembered" list of addresses, the problem does not occur. I've no idea why this is happening, but it is certainly an Outlook issue, not a server issue.

    Any thoughts as to what in Outlook is causing it would be appreciated. I have at least 2 people with the problem. Only started occurring after an earlier problem with the Exchange server, where the Exchange Transport service failed (I'm running Exchange 2007 SP3)
    • Marked as answer by Gen Lin Friday, October 22, 2010 2:36 AM
    • Unmarked as answer by Jexx Friday, October 22, 2010 9:11 AM
    Wednesday, October 20, 2010 3:52 PM
  • Deleted and let Outlook recreate the Outlook profile, deleted user profile, created a new user and all suffer the same issue.

    In response to Alan OC, that is how my issue first started, I assumed the user was copying and pasting the address into Outlook with 's in it. Further investigation showed it to be the mailto: links, once you use one it messes up any matching remembered email addresses.

    I never had the issue myself until I clicked on a mailto link and now the same thing happens to me (I have never used mailto links before in emails).

    Could this possibly be related to a corrupt Default User config?

    Friday, October 22, 2010 9:12 AM
  • On Fri, 22 Oct 2010 09:12:25 +0000, Jexx wrote:
     
    >Deleted and let Outlook recreate the Outlook profile, deleted user profile, created a new user and all suffer the same issue.
     
    Clear the outlook auto-complete cache. Before OL2010 that should be as
    easy as stoppig Outlook and renaming (or deleting) the .NK2 file.
    Outlook 2010 uses the "File | Options | Mail | Empty Auto-Complete
    List" to remove the list from the mailbox.
     
    >In response to Alan OC, that is how my issue first started, I assumed the user was copying and pasting the address into Outlook with 's in it. Further investigation showed it to be the mailto: links, once you use one it messes up any matching remembered email addresses.
    >
    >I never had the issue myself until I clicked on a mailto link and now the same thing happens to me (I have never used mailto links before in emails).
    >
    >Could this possibly be related to a corrupt Default User config?
     
    No, it just sounds like the address with the bogus address type needs
    to be removed from the auto-complete cache.
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Saturday, October 23, 2010 1:19 AM
  • Deleted the NK2 file which removed all the quick addresses but this did not have an effect of the mailto issue.
    Monday, October 25, 2010 7:46 AM
  • On Mon, 25 Oct 2010 07:46:26 +0000, Jexx wrote:
     
    >Deleted the NK2 file which removed all the quick addresses but this did not have an effect of the mailto issue.
     
    Does the problem follow you to another machine (assuming you don't
    have a roaming profile)? If it does then the address is in the mailbox
    somewhere.
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Monday, October 25, 2010 8:03 PM
  • As I have said this is on Terminal Services, so changing to another machine won't make any difference.

    I'm loading the an up to date copy of the SBS server to my test server tonight so I can check if a clean install of TS has the same issue.

    I'll report back my findings.

     

    A little detail about our setup:

    Server 2008 running: Terminal Services, MS Office, Advisor Office, Star Core and FileDirector (applications that effect Oulook listed only).

    SBS Server 2008: Exchange, SQL Server 2008 and a few other things.

    Monday, October 25, 2010 8:56 PM
  • On Mon, 25 Oct 2010 20:56:29 +0000, Jexx wrote:
     
    >As I have said this is on Terminal Services, so changing to another machine won't make any difference.
     
    Have you nuked your user profile on the TS?
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Tuesday, October 26, 2010 2:26 AM
  • I have identified the cause of the issue via the test server.

     

    This issue is caused by installing Security Update for Microsft Office Word 2007 (KB2344993) via windows update and can be resolved by removing this update.

     

     

    • Marked as answer by Jexx Friday, October 29, 2010 10:18 AM
    Friday, October 29, 2010 10:18 AM
  • Ok, that is a pretty important update, isn't it? I'd rather have it installed.

    I have had this problem before from time to time, but now it's bugging me almost every day.

    I think it happens when user copy-pastes an address in a "mailto:someone@something.com" form from somewhere to an outlook address field. The bad thing happens when Outlook(or Exchange?) automatically hides "mailto:" but keeps it somewhere in address properties (it sometimes even highlights the address with some greenish line) so user can not see the difference with a good address.

    Is there any way to make outlook automatically convert it from "mailto:" to "smtp:", or to make Exchange understand and process "mailto:" the same way as it processes "smtp:", or at least to prohibit outlook from hiding the poisonous "mailto:" part?

    // I have Exchange 2007 SP3sr0 and Outlook 2007 with all updates if it's matters.

    Friday, October 29, 2010 11:26 AM
  • The 'fix' I have listed is not ideal but it does stop the problem.

    It does however relate to a specific issue that it causes Outlook (technically Word within Outlook) to create mailto links within emails and does not relate to users copying and pasting email addresses or with email address internal or external users have placed within an email.

    Outlook handles mailto just fine, providing it is formatted correctly.

    The information will be passed to MS with the hope they will sort it out with a further fix.

    Friday, October 29, 2010 12:03 PM
  • Hi - we have now started to have this problem - does anyone have a solution - has there been a fix since KB2344993
    Tuesday, November 16, 2010 1:48 PM
  • I have seen no resolution to this issue yet and have had no assistance from Microsoft. In fact the only conversation I had with Microsoft involved them telling me "if you need to report a bug you need to post in the forums for a resolution" at which point I was directed back here again.

    Tuesday, November 16, 2010 3:04 PM
  • I've got a call into Microsoft as they are not aware of this.

    Can you ping me at susan-at-msmvps.com so I can ping you up with the support people as well?

    Tuesday, November 16, 2010 5:04 PM
  • I've also started seeing the same issue with a couple of users.  Have you heard any more from Microsoft?

    Thanks.

    Wednesday, November 17, 2010 9:49 PM
  • Still working on it.  ping me at susan-at-msmvps.com and I'll keep you in the loop.
    Wednesday, November 17, 2010 9:51 PM
  • Still working on it.  ping me at susan-at-msmvps.com and I'll keep you in the loop.


    Any solutions yet? One of my clients is having the same issue and i would rather not remove the update.

     

    Thanks :)

    Thursday, November 18, 2010 5:33 AM
  • Nothing yet.  MS dude has been in touch with one of my fellow MVP guys who can repro it, says he should be back with him probably in a day.

    Again, feel free to ping me at susan-at-msmvps.com, but I'll also post back when I have resolution.

    Thursday, November 18, 2010 5:37 AM
  • Nothing yet.  MS dude has been in touch with one of my fellow MVP guys who can repro it, says he should be back with him probably in a day.

    Again, feel free to ping me at susan-at-msmvps.com, but I'll also post back when I have resolution.


    Dear Susan,

    Do you any news about this topic?

    A client of us has the same problem.

    Thank you.

    Friday, November 19, 2010 1:52 PM
  • Still in investigation mode, it can be repro'd which is good.  As I said, ping me and I'll keep you directly in the loop.
    Friday, November 19, 2010 2:57 PM
  • I'm with the Help Desk at my company and we're seeing a few people with this issue but not everyone (we have over 1000 boxes).  Our updates gets pushed through scripting.  When I remove the security patch mentioned above, Outlook appears to work fine sending emails to external addresses.  I then reinstalled the security patch and guess what, it still worked fine.  But like I said, it is only affecting 3 out of 900 of our users.

     

    Hope this info helps.

    Friday, November 19, 2010 10:45 PM
  • Sorry but just to be clear you are saying that when you reinstall the patch mailto links do not appear?

    To be clear on this issue:

     

    The problem outlined in this post relates to the apperance of mailto hyperlinks in Outlook, if you are not seeing mailto hyperlinks in Outlook emails then this does not apply to you. You will only experience an issue if you use these mailto links which is why this issue appears to only effect a few people.

    Monday, November 22, 2010 9:12 AM
  • Hi

    Our users started reporting this last week - is there any workaround yet other than removing the patch?

    Thanks

     

    Monday, November 22, 2010 4:21 PM
  • Hope to know more today, hang loose.
    Monday, November 22, 2010 4:37 PM
  • You currently have two options:

    • Remove the security update.
    • Leave the update in place but inform your users that they are not to use mailto links in emails.

    If you are suffering from this issue please either subscribe to this thread or contact Susan Bradley as indicated. Either way you will receive a notification when this issue has been resolved by Microsoft.

    Monday, November 22, 2010 4:40 PM
  • Okay here's the skinny.  I don't see an immediate patch coming out for this.  Also I'm concerned that Microsoft sees this currently as a single call, not that a bunch of folks are impacted. 

    While there is a bug they are tracking on this Offug49462, short term there will only be info detailed in the security update that there's a side effect of this update.  No eta of when exactly that wording will be posted in the bulletin, but that certainly will be sooner than a patch fixing this.

    The trigger appears to be when you click on mailto links.

    You have two choices as I see it:

    1. uninstall the patch, and wait until I post back that there is an ultimate fix.  I don't see this coming out in a week or two honestly, so be aware that per my read on the situtation, this won't be resolved quickly with another patch.

    2. leave the security patch on, and as a workaround to ensure that you don't accidentally click on a mailto link and thus flip your email addresses and get NDRs to do the following:

    In Outlook:

    ·         Click Tools > Options

    ·         Click the Mail Format tab

    ·         Click Editor Options

    ·         Click Proofing

    ·         Click AutoCorrect Options

    ·         Click the AutoFormat Tab

    ·         Uncheck "Internet and network paths with hyperlinks"

    ·         Click OK, OK and OK

    Neither one is good, but it's all I have right now until something is coded up long term.

    So here's where you can do me a favor.  Call 1-800-Microsoft and explain to them you have an issue with a security update 2344993, say that you too are impacted by Offup49462 bug and tell them how many in your firm/office/school have been impacted.

    Like I said right now they only have one call on this issue, and I'd like to ensure they see more numbers of impacted people.

    Thanks.

    Susan-at-msmvps.com

    Tuesday, November 23, 2010 9:09 PM
  • Just logged a support case as this issue is effecting 1500 of my users and I'm getting about 400 non delivery email each day. The support case was free to log as it relates to a security patch.

    I will update as soon as I have more information.

    Regards

    Paul Blaxill

    Friday, November 26, 2010 8:07 AM
  • Susan

    Thanks for the post.  I just tried to call as you suggested and the tech told me I would need to send snail mail to report that my firm is experiencing the issue as well.  Please advise

    Thanks

    Jim 

    Thursday, December 02, 2010 6:57 PM
  • I've honestly heard people state every now and then that someone in support told them they'd have to mail Microsoft.  Each time I've been flabbergasted by the request.  I think these folks are thinking this is a normal code defect problem, not a security issue problem.

    If you have this person's contact info, I'd appreciate it.

    Thursday, December 02, 2010 7:33 PM
  • Sorry, I didn't take the support tech's name - I explained it very clearly and I know she understood.  She checked and verified the KB article and the bug number and read from a script after conferring with others I believe, to say that this type of report must be sent in via US Mail.

    I will report it to my TAM, and let her escalate.  Thanks for the response!

     

    Jim

    Thursday, December 02, 2010 7:38 PM
  • My case is logged and has been grouped with Susan. The engineer is waiting for an update from the case holders team.

    I'm in the UK and I understand the case team are in the US.

    When I logged the case I had to do so with a Contract ID but as soon as I pointed them to this thread the support case was given for free, seems like it would be worth giving Credit Card just to move beyond the support reception as it's given there will be no charge.

    Regards

    Paul

    Thursday, December 02, 2010 8:08 PM
  • I've just heard that Microsoft have closed my case because they have been unable to re-create the issue. Having show the engineer the problem first hand via Easy Assist, that really anoys me!!
    Monday, December 06, 2010 10:58 AM
  • Can you ping me with the Case info?
    Monday, December 06, 2010 3:07 PM
  • I have just sent an email to our TAM - hopefully she may be able to help us resurrect the issue.  I will keep you posted.

    Thanks

    Jim

    Monday, December 06, 2010 5:14 PM
  • This case is still open after a harsh email was sent. The engineer could recrate the issue in the lab, so could take it further.

    Interestingly, by removing the patch, removes the hyperlinking that was causing the problem but still, the auto complete cache is poisoned so this will be hard to correct overall. You have to delete the effected email addresses as well...

    Wednesday, December 08, 2010 8:59 AM
  • My TAM opened a case for us.  A tech emailed us and proposed the following:

    Issue Definition: When the user click on a mailto link with an e-mail and click on send on the new mail message windows , they receive an NDR

    Scope Agreement: Help ensure that we are able to send out e-mail without any NDR's

    I asked that the scope be expnded to how to create correct contacts using the mailto links functionality.

    What our temporary work around is right now - delete the mailto created contact from the NK2 file.  This is done by deleting the address in the To: field, and then creating a valid one by typing the address in manually and clciking the check names icon.  The user can then send email to that recipient. 

    This of course does not fix the underlying issue of not having the mailto functionality work.  If this becomes a bigger issue for us - does anyone know the location of the GPO that would help us Uncheck "Internet and network paths with hyperlinks" ( as described by Susan above) enterprise wide?

    Thanks

    Jim

     

    Wednesday, December 08, 2010 11:37 PM
  • I have just found this thread via Google.

    Exact same issue with a colleague - this is untested but I'm trying this.

    Right click the Addres in the To... field and go to properties and click the "Internet Type" button. (Outlook thought it was a custom type to send). Exchange was reporting a faillure: interpreting a waffle@something.sch.uk address as waffle@something.sch.uk@domain.local

    I'm not an email expert, but I'm hoping that Exchange will forward the SMTP email out as we don't answer for something.sch.uk.

    If it works I'll repost later with the result.

    Greg

     

    Thursday, December 09, 2010 8:36 AM
  • Greg,

    You should find that works, we're having the same issue as everyone else here. I've been using the same work around as you and had no comeback on that yet.

    Josh

    Thursday, December 09, 2010 11:06 AM
  • Greg

    Changing the internet type resolves the issue for that instance of the email only, so the next time that user emails that recipient the same thing will happen.  In my experience, the internet type will revert to MAILTO if the autocomplete nk2 entry is not deleted.

    In any event, it appears that it is important to report it to Susan Bradley and Microsoft because they need  to see it is affecting more than a few individuals.

     

    Thanks

    Jim

    Thursday, December 09, 2010 1:34 PM
  • Ok it seems that some clarification is needed for those that are unware of this issues scope:

    Users will not experience any issues until they use a mailto: link within an email, the mailto link must be in the header of a forwarded or replied message ie someone replies to or forwards a message to you and you click the mailto link in the header of a previous message within that email.

    Once the user clicks the mailto link a cached email address entrywill be generated or updated with an incorrect email type due to the malformed mailto: link. This and all further attempts to email said address will result in NDR.

    Removing the whole cache or just the single incorrect entry will resolve the issue until the mailto link is used again.

    Clicking a mailto link, right-clicking the email address in the new email, selecting Outlook properties, then changing the E-mail type to SMTP will allow the email to send correctly but only for that instance of using the mailto link.

     

    Therefore the practical options are:

    1. uninstall the patch, and wait until I post back that there is an ultimate fix.  I don't see this coming out in a week or two honestly, so be aware that per my read on the situtation, this won't be resolved quickly with another patch.

    2. leave the security patch on, and as a workaround to ensure that you don't accidentally click on a mailto link and thus flip your email addresses and get NDRs to do the following:

    In Outlook:

    ·         Click Tools > Options

    ·         Click the Mail Format tab

    ·         Click Editor Options

    ·         Click Proofing

    ·         Click AutoCorrect Options

    ·         Click the AutoFormat Tab

    ·         Uncheck "Internet and network paths with hyperlinks"

    ·         Click OK, OK and OK

    There does not appear to be a way to disable this via group policy apart from a registry edit which could have adverse effects.

    Thursday, December 09, 2010 2:01 PM
  • Hi all,

    Excellent Thread - our users are starting to report this, getting this same error message as well, they click a 'mailto:' translated external email address in a thread, and on the new message, in outlook 2007 it looks correct, however viewing the 'properties' of the resolved address indeed show the 'MAILTO' link instead of SMTP and they immediately get a bounce message.

    Noticed that WITH Patch 2344993 installed external addresses are hyperlinked with mailto addresses, that users can click on to send, however once backed this patch out, it removed the hyperlink capability - so users have to copy and paste plain text addresses - which will resolve and save correctly into the NK2 file.

    Oddly in my case, I 'sometimes' get an official microsoft bounce - with all the typical 2007 exchange header/footer info, and othertimes i simply get this:

    Your message did not reach some or all of the intended recipients.

     

          Subject:    test message

          Sent: 12/09/2010 1:53 PM

     

    The following recipient(s) cannot be reached:

     

          'whateveraddressis-makingthisup@yahoo.com' on 12/09/2010 1:53 PM

                None of your e-mail accounts could send to this recipient.

    And this is it! - I'm wondering if this is actually an error message from outlook instead of exchange (?)

    I first thought this was due to being in Cache Mode vs Online mode, as with a different account via 'online mode' i got the proper exchange bounce with full description. However this has since been proven not the case.

    Thursday, December 09, 2010 10:41 PM
  • So is there any fix now?
    Tuesday, December 21, 2010 3:18 PM
  • I'm also following this link.
    I've got the same issue, and it's driving me mad as postmaster for our domain.
    Please Microsoft, solve this issue asap!!

    Wednesday, December 22, 2010 3:18 PM
  • There is no change on the status of this issue.

    Mircosoft will not be attempting to rush a fix through as they have not had enough complaints.

     

    If you are experiencing this issue please raise a case with Microsoft. As per Susan's post:

    "Call 1-800-Microsoft and explain to them you have an issue with a security update 2344993, say that you too are impacted by Offup49462 bug and tell them how many in your firm/office/school have been impacted."

    Wednesday, December 22, 2010 3:42 PM
  • There is no change on the status of this issue.

    Mircosoft will not be attempting to rush a fix through as they have not had enough complaints.

     

    If you are experiencing this issue please raise a case with Microsoft. As per Susan's post:

    "Call 1-800-Microsoft and explain to them you have an issue with a security update 2344993, say that you too are impacted by Offup49462 bug and tell them how many in your firm/office/school have been impacted."


    So all the people here who are facing this problem just have bad luck?
    Just because there are not enough complaints?
    How many complaints does Microsoft need before taking action? 10+ 100+ 1000+ 10,000+ ??

    You've got to be kidding!! :(

    Thursday, December 23, 2010 8:46 AM
  • I have this exact issue over here.  So far it has only impacted 1 user but I expect it to impact more as time goes on.  Funny thing is, I don't have 2344993 installed on any of the app servers hosting Outlook (Citrix) but I do have the exact same problem others have described.  The user clicked the mail to link in the email and now is getting back:

     

    Diagnostic information for administrators:

    Generating server: exchangeCASserver.ourdomain.com

    IMCEAMAILTO-fname+2Elname+40correctdomain+2Ecom@ourdomain.com
    #550 5.4.4 ROUTING.NoNextHop; unable to route ##

    Original message headers:

    Received: from exchangeserver ([10.100.0.111]) by exchangeCASserver
     ([10.100.0.112]) with mapi; Thu, 23 Dec 2010 09:27:57 -0800
    Content-Type: application/ms-tnef; name="winmail.dat"
    Content-Transfer-Encoding: binary
    From: Sender Display Name <senderemailaddress>
    To: "'fname.lname@recipientdomain.com'"
        <IMCEAMAILTO-fname+2Elname+40recipientdomain+2Ecom@ourdomain.com>
    CC: Sender Display Name<senderemailaddress>
    Date: Thu, 23 Dec 2010 09:27:56 -0800
    Subject: Re: Complaint
    Thread-Topic: Re: Complaint
    Thread-Index: AcuixrzwyoG/pnfHTPKjfwEXbYN7PA==
    Message-ID: <obscured@server.ourdomain.com>
    Accept-Language: en-US
    Content-Language: en-US
    X-MS-Has-Attach: yes
    X-MS-TNEF-Correlator: <obscured@server.ourdomain.com>
    MIME-Version: 1.0

     

    I've already called MS to report this is affecting us (300+ users potentially)

    Thursday, December 23, 2010 8:24 PM
  • I just got word back from an "Outlook Senior Support Escalation Engineer" in response to our case opened on 12/08/10.  Her first email stated:

    "We are in the process of filing a bug for this issue.  Please keep in mind that this not guarantee that the issue will be addressed as a lot of factors come into play in this scenario. 

    Once the bug has been filed this case will be marked as a bug and non-decremented so you will not be charged for this issue.  This process may take some time, but I will let you know when the bug has officially been filed and then I will provide you with updates as I receive updates."

    I replied that this issue has already been given a bug reference number -  Offup49462 in Windows update 10-079 KB2344993 that should have been noted when we opened the case.

    She replied back:

    “Yes, that bug has been filed, and we are linking that bug.  There is another database that we file the official bug that will be sent to the Product Group in.   We do have several cases on this and currently I have three cases with this issue.  

    The bug is actually being filed on another case and I am waiting on that bug to be filed so that I can link your case to it as this increases our chances of getting this issue addressed.”

    I urge anyone who is experiencing this issue to please open a call with Microsoft and use the bug reference number -  Offup49462 in Windows update 10-079 KB2344993

    Thanks

    Jim

     

    Thursday, January 06, 2011 6:12 PM
  • I have a user who has hit this about 4 times now - we just got to digging through the items and discovered that it is the same issue described above. We'll probably be going to Microsoft and opening a ticket just to push it up on their radar

    Stacey Jenkins

    Friday, January 07, 2011 1:16 AM
  • Please do.
    Friday, January 07, 2011 4:44 AM
  • We got the same problem here too! Many complains by my email users. Come on Microsoft, will the fix come out january 11?

    Danny

    Friday, January 07, 2011 11:11 AM
  • Do not expect this out by January 11.  Please call Microsoft to ensure they understand the magnitude of people involved.
    Friday, January 07, 2011 4:57 PM
  • I also logged a call at Microsoft. Hope it will speed things up...
    It's really getting anoying now.

    Wednesday, January 12, 2011 3:52 PM
  • I've also logged a case with MS.
    Wednesday, January 12, 2011 7:26 PM
  • I've just been informed by the Technical Lead of the Outlook Team, Swanand Dalvi, that MS does not intend to fix this issue in Outlook 2007 or 2010, but it will probably be fixed in Outlook 2015.
    Wednesday, January 12, 2011 10:58 PM
  • Well they don't need to fix it in 2010 as it doesn't get broken there.

    Squeaky wheel gets fixed here.  Make sure people have called and set up cases.

    Wednesday, January 12, 2011 11:15 PM
  • I've just been informed by the Technical Lead of the Outlook Team, Swanand Dalvi, that MS does not intend to fix this issue in Outlook 2007 or 2010, but it will probably be fixed in Outlook 2015.


    I've logged a case yesterday, but I will not be satisfied with the answer you've got.
    Microsoft has a bug in an update which is confirmed here.
    So they need to fix it, and don't send us away with the message that it will be solved over 2 years !! (mad)

    Thursday, January 13, 2011 8:47 AM
  • I am also having the issue and will be logging a case shortly.

    I tried uninstalling the update but it still does not fix the problem.  How exactly am I supposed to get around this? 

    Thursday, January 13, 2011 3:44 PM
  • Dalvi told me that it is broken in 2010; we're not running it, so I didn't bring that up with him. I told him that it's not an issue of buying the latest version: we have SA on everything, so we already own the latest version. We have apps that are dependent on Outlook 2007, and are not certified with 2010 (or 2015) yet.

    I described the situation to him as this: customers purchased this product, and depend on certain functionality of it. MS broke the functionality through an update, but says they're not going to restore it. Whether breaking the product was accidental or intentional originally is irrelevant at this point; MS is intentionally not fixing what it broke.

    I actually expect that MS will fix it, and that Dalvi doesn't know what he's talking about. It just illustrates a lack of customer focus in MS's support organization.

    Thursday, January 13, 2011 5:08 PM
  • Hang loose and sit tight.  The issue is definitely being investigated still and is being worked on.  That said if you haven't called in, please do.  Like any organization that has resources, issues that have a bigger impact get more resources, so the more cases that are opened up, the better for everyone.
    Thursday, January 13, 2011 6:35 PM
  • I am also having this exact same issue with Outlook 2007.  It is reproduced every single time within Outlook 07.  This is happening with more and more users and need to see a fix for this.  I understand this is currently being investigated, but just wanted to express my concern and let it be known I have the same issue as a lot of other people and it would be very worth the while to release a patch for this.  

     

    Thursday, January 13, 2011 8:07 PM
  • You've called and set up a case right?
    Thursday, January 13, 2011 8:08 PM
  • Can you post the support number I need to call to setup the case?  I was on the Microsoft support website and only saw pay options.  

    Please let me know so I can get this case started to try to escalate this. 

    Thursday, January 13, 2011 8:23 PM
  • For information about Security updates, visit the Microsoft Virus Solution and Security Center for resources and tools to keep your PC safe and healthy. If you are having issues with installing the update itself, visit Support for Microsoft Update for resources and tools to keep your PC updated with the latest updates. 


    • Edited by Gavin-Zhang Monday, April 16, 2012 2:25 AM PCSafety center update
    Thursday, January 13, 2011 8:26 PM
  • I did call the number above and was on the phone with support for about an hour.  Basically, what I found out was already confirmed in this forum.  

    - This is affected by KB2344993.  

    - But removing the KB update completely takes away the MAILTO: feature all together (NOT A FIX!) 

    - Tried deleting the NK2 file, no help (tried telling him.)

    - Tried starting Outlook in Safe mode 

    - No help (No impact)

    The tried saying this has something to do with being an Exchange account.  I do not agree, I believe it is Outlook 2007 related with it using Word as the Email editor.  My case is closed now and mark unresolved.  

    You can change the Outlook properties to SMTP from MAIL TO after clicking on the MAIL TO link, but this really doesnt make any sense at all and is not  fix.  

    Would be willing to find out if there is a fix for this and will keep tabs on this forum.  

    My case # is 1146903628 if you would like to refer to it. 

    Thursday, January 13, 2011 10:32 PM
  • Any updates on this?

    One of my clients is experiencing the same problem.

    - Cleared the Autocomplete Cache

    - Checked and the KB2344993 update is not installed

    - When using message tracking on the Exchagne 2007 server, there are no traces of the messages

    Tuesday, January 18, 2011 3:36 PM
  • Experiencing the exact same problems as Jexx. Any updates?
    Monday, January 24, 2011 6:42 PM
  • Got the same issue, had one report of this a few days ago and thought it was the user and/or his Outlook install causing the problem, but when I had another user in a different office report the same issue I Googled the error and landed here. I'm in Australia, so what's the deal with submitting a support case here.... last I heard all support cases in ANZ were charged? Thanks
    Tuesday, January 25, 2011 3:56 AM
  • Issues with a security patch are a free call.

    It's in the product group now, I still would appreciate a call and body counts.

    Tuesday, January 25, 2011 5:07 AM

  • I've found that the options above didn't work for us as in unchecking the "Internet and network paths with hyperlinks", maybe I have a different issue?

    Anyway the resolution for me was that the email address contact in question had a settings format of "Outlook Rich Text" with an e-mail type of MailTo instead of E-mail type of SMTP and “Let Outlook decide the best sending format”. Once I changed those settings I was able to send a test message to the email address contact with the problem.

    So in Outlook right click the email address or name in the To field or go into Contacts and open up the contact and right click the email address and select Outlook Properties and change the E-mail type to SMTP and “Let Outlook decide the best sending format”.

    Hope this helps and hope MS release a fix for this ASAP

     

    Tuesday, January 25, 2011 10:54 AM
  • Confirming that I am also getting the issue.  This is related to a good 20,000+ users.  Multiple infrastructures that are seperate from each other. 

    Monday, January 31, 2011 9:58 AM
  • Just came across this today, can't believe this has been going on since October and Microsoft have no fix.

    Found a work-around, begin typing the problematic address in a new mail and hit delete to remove it. Close and launch a new mail and type the address again in full, it should go through this time.

     

    Not ideal but a quick fix until Microsoft can sort it out!


    Martin Golder - MCP, MCDST
    Tuesday, February 01, 2011 10:15 AM
  • I also found that workaround, and mail it to every user that's facing this problem, but it's not failproof.
    Unfortunately, sometimes this doesn't work either.
    In that case we ask the recipient (if known) to send an e-mail.
    When you reply on that mail, everything works fine.

    And I agree with you: It's going on for months now, and more and more people are facing this problems.
    But still no action from Microsoft.
    It can't be that hard to fix this imho.
    When you call support the only answer you'll get is: "They are working on it, please have some patience".

    It just seems that it hasn't any priority...

    Tuesday, February 01, 2011 10:23 AM
  • Hang loose guys a fix is still in the works.  I can't give you an ETA but I can tell you that it's now past the stage of proof to the stage of fix.
    Wednesday, February 02, 2011 4:54 AM
  • Susan,

     

    Any updates so far? Been following this thread for a while now as the number of staff experiencing the problem is increasing...

    Tuesday, February 08, 2011 1:36 AM
  • Keep watching.

    The product team are working on a fix, but I don't know of the ETA.  I'll report back as soon as I can.

    Tuesday, February 08, 2011 1:55 AM
  • Keep watching.

    The product team are working on a fix, but I don't know of the ETA.  I'll report back as soon as I can.


    I hope it will be asap...
    The errors are piling up, and it's almost impossible to send every user a mail with the workaround.

    Tuesday, February 08, 2011 7:42 AM
  • I also have been getting the exact same error message, BUT...  After trolling through our SMTP logs, it turns out that it's an error generated by POSTINI !!!  Postini is being used by one of our clients and for some reason, Postini is blocking our e-mail domain.  We have everything PERFECTLY configured and all SPF records, reverse DNS etc are exactly as they should be.  Also, we are not on ANY blacklists....

     

    So..  make sure this isn't the issue you are having.

    Tuesday, February 08, 2011 7:09 PM
  • My organization has just seen the first example of this issue. I opened a case this morning. I was just informed by Microsoft that the issue has been examined and that the Outlook Team has stated that it will be addressed in the February Cumulative update that is scheduled for the end of the month. I believe that will be on the 22nd.
    Tuesday, February 08, 2011 7:23 PM
  • No offense to Susan as she does a fantastic job for the community, but it's disappointing that someone from Microsoft has not jumped in here to provide the official word on what's going on given that this thread is huge and is obviously affecting more and more people. 

    Or am I on the wrong train and it's the job of MVP's to play a proxy role?

    Tuesday, February 08, 2011 9:44 PM
  • Any updates on this?

    One of my clients is experiencing the same problem.

    - Cleared the Autocomplete Cache

    - Checked and the KB2344993 update is not installed

    - When using message tracking on the Exchagne 2007 server, there are no traces of the messages


    I'm experiencing the same symptoms in my organisation. We've deployed to about 90 Pilot users and 2 of them have the symptoms above.

    From my perspective the KB2344993 is NOT the update which causes the issue, or there are multiple updates that cause it.

    Friday, February 11, 2011 3:38 AM
  • I'm having this issue with 2 employees as well and I have notified Microsoft.
    Friday, February 11, 2011 6:21 PM
  • Still no fix? My clients are getting frustrated...

    Wednesday, February 16, 2011 2:19 PM
  • My organization has just seen the first example of this issue. I opened a case this morning. I was just informed by Microsoft that the issue has been examined and that the Outlook Team has stated that it will be addressed in the February Cumulative update that is scheduled for the end of the month. I believe that will be on the 22nd.

    I posted this on the 8th ^  I believe it answers the question. Microsoft stated that a patch would be available on the 22nd.
    Wednesday, February 16, 2011 2:48 PM
  • Still no fix? My clients are getting frustrated...


    I'm wondering the same.
    And not only my clients are getting frustrated.
    With 2000+ recipients it's putting a lot of pressure on the daily bussiness.

    Wednesday, February 16, 2011 2:48 PM
  • I'm hoping end of the month.
    Wednesday, February 16, 2011 3:03 PM
  • Thanks Susan.

    Just had my first client with this issue.  I downloaded NK2Edit trial and changed the type from MAILTO to SMTP for the address with the issue and so far so good.  I didn't see the patch on their PC, but was under a bit of urgency to get it fixed so I may have missed it.  For what it's worth, Environment is Outlook 2010 / Exchange 2010 Win7/Server 2k8R2.  I have several clients around the city so if it comes up again i'll post more details.

    Thanks,
    keith


    Keith Copeland
    Thursday, February 17, 2011 5:10 AM
  • For Keith:

    I have the same environment (Outlook 2010/Exchange 2010/Win7/Server 2008 R2) with a user having this issue. However when I downloaded NK2Edit and ran it on my effected user's machine the "MAILTO" address type was not an option nor were any of the contacts listed as that type. What am I missing?

    Thanks,
    Terry

    Saturday, February 19, 2011 10:34 PM
  • This bug is only Outlook 2007 not Outlook 2010.  If you are seeing this issue with an Outlook 2010 then it's not the same as this thread.
    Saturday, February 19, 2011 10:35 PM
  • For Keith:

    I have the same environment (Outlook 2010/Exchange 2010/Win7/Server 2008 R2) with a user having this issue. However when I downloaded NK2Edit and ran it on my effected user's machine the "MAILTO" address type was not an option nor were any of the contacts listed as that type. What am I missing?

    Thanks,
    Terry

    NK2 files were removed in Outlook 2010.
    Saturday, February 19, 2011 10:46 PM
  • Description of the Office Word 2007 hotfix package (wordconv-x-none.msp, word-x-none.msp): February 22, 2011:
    http://support.microsoft.com/kb/2475888/en-us?sd=rss&spid=11377
    • Consider the following scenario:
      • You receive an email message that contains a mailto hyperlink.
      • You use the mailto hyperlink to send an email message.
      In this scenario, you receive the non-delivery report (NDR).

    FINALLY POSTED!

    • Proposed as answer by Susan BradleyMVP Wednesday, February 23, 2011 5:16 PM
    • Marked as answer by Jexx Monday, February 28, 2011 8:14 PM
    Wednesday, February 23, 2011 5:16 PM
  • Description of the Office Word 2007 hotfix package (wordconv-x-none.msp, word-x-none.msp): February 22, 2011:
    http://support.microsoft.com/kb/2475888/en-us?sd=rss&spid=11377
    • Consider the following scenario:
      • You receive an email message that contains a mailto hyperlink.
      • You use the mailto hyperlink to send an email message.
      In this scenario, you receive the non-delivery report (NDR).

    FINALLY POSTED!


    Thanks for the link Susan!

    Though I have downloaded and installed the hotfix on our test Citrix Server this morning and it hasn't made any difference :-(

    Has anyone else installed this yet?

    Thursday, February 24, 2011 9:44 AM
  • Hi Susan,

    Just installed the hotfix on a computer with the known issues.
    But unfortunately, the problem isn't solved.

    It's a XP SP3 machine with office 2007 connected to an Exchange 2007 environment.
    Mail is coming back instantly with an NDR.

    @Jetsada: As you see, it doesn't work for me, either.

    Thursday, February 24, 2011 10:01 AM
  • I haven't had a chance to test this yet.

    Have you cleared your NK2 file? I don't think this fix will correct any entries that are already wrong so you will need to clear the cache before testing.

    Please check the mailto: links in your new emails and see if they are still showing as:

    mailto:[mailto:joe.blogs@company.com]

     

    I will be installing this on my test server later and will confirm resolution then.

    Thursday, February 24, 2011 10:15 AM
  • Have you cleared your NK2 file? I don't think this fix will correct any entries that are already wrong so you will need to clear the cache before testing.


    Just tried that: No difference, instantly an NDR...
    Thursday, February 24, 2011 10:36 AM
  • Have you cleared your NK2 file? I don't think this fix will correct any entries that are already wrong so you will need to clear the cache before testing.


    Just tried that: No difference, instantly an NDR...


    Interestingly I've tried sending myself an email from my work address to my work address containing my hotmail.co.uk and gmail.com email addresses, clicked those and sent test emails from a server without the hotfix...both went fine. (Checking the link was MAILTO when hovering the mouse over)

    However, If you go in and manually select Custom Type from Outlook Properties for the email address, choose MAILTO it comes back with the NDR.

    As it hadn't affected many users anyway I'm going to sit on the hotfix for a while before applying it to the Citrix farm if it seems to be working ok now without the fix.

    Thursday, February 24, 2011 12:46 PM
  • I have been able to test the patch now and can confirm that the issue has been resolved.

     

    Please note: The patch does stop the creation of the mailto: links in Outlook but does not clear any bad entries from your NK2 file.

    Monday, February 28, 2011 8:17 PM
  • Very strange that the fix resolves your problems, it didn't work for me.
    As you can see 3 posts back, I did clear the .NK2 file, but that didn't resolve anything: Instant NDR.

    Tuesday, March 01, 2011 7:42 AM
  • Are you still seeing the mailto: links in the header of forwarded emails? As these have been removed for me now.

    Maybe the hotfix has not installed correctly, have you checked the file versions indicated in the hotfix KB article?

    Tuesday, March 01, 2011 11:30 AM
  • The hotfix is installed correctly, if I try to install it again, it says that all the files are updated already.
    Haven't checked the mailto: links yet, maybe I can check this.

    Tuesday, March 01, 2011 11:43 AM
  • Is this Hotfix supposed to fix the ability to send emails as MAILTO: , or is it just a fix to remove the hyperlink?

    What if a user cut and pastes the mailto information from the forwarded email?

     

    Tuesday, March 01, 2011 4:42 PM
  • This thread discussed a specific issue with mailto: links appearing in the header of forwarded and replied to emails. The hotfix has resolved this issue by returning things to thier original state before the security patch, which was that the mailto: infromation was shown but was not a clickable link.

     

    Typing or pasting mailto:person@company.com into the To... box does not work and to my knowledge never has.

     

    An email that contains a mailto: link that someone has added works perfectly fine and I have tested this to be the case.

    Tuesday, March 01, 2011 5:29 PM
  • Just one question:
    I've one test person, and I use the same mail from his Send items to test it over and over again.
    Should the fix resolve this as well?
    Or will the problem resist in that mail?

    Wednesday, March 02, 2011 9:11 AM
  • In my experience, any items that have already failed delivery can be resent.

     

    Open the email from Sent Items

    Other Actions --> Resend This Message...

    Double Click on the recipients email address in the To... field

    Click on the Internet type button to change the E-mail type to SMTP

    Click OK

    Send

    Wednesday, March 02, 2011 11:46 AM
  • I'm just adding to the list of users that are experiencing this issue.  I am calling MS to join the ranks.  If there are any MS personnel monitoring this thread, the response of "it will not be addressed in Office 2007 or 2010, only 2015" is not an acceptable response since Office 2007 a mainstream supported product until 4/10/2012.

     

     

    Monday, March 14, 2011 2:48 PM
  • No need to call. See my post for the hotfix for this.
    Monday, March 14, 2011 3:25 PM
  • I'm just adding to the list of users that are experiencing this issue.  I am calling MS to join the ranks.  If there are any MS personnel monitoring this thread, the response of "it will not be addressed in Office 2007 or 2010, only 2015" is not an acceptable response since Office 2007 a mainstream supported product until 4/10/2012.

     

     


    Description of the Office Word 2007 hotfix package (wordconv-x-none.msp, word-x-none.msp): February 22, 2011:
    http://support.microsoft.com/kb/2475888/en-us?sd=rss&spid=11377
    • Consider the following scenario:
      • You receive an email message that contains a mailto hyperlink.
      • You use the mailto hyperlink to send an email message.
      In this scenario, you receive the non-delivery report (NDR).

    Get that hotfix.

    Monday, March 14, 2011 3:26 PM
  • Has anybody already did a company wide roll-out of this hotfix?
    My testperson already deleted the messages, and there were no more issues.
    I'm looking for another guinea pig...

    • Proposed as answer by Dirubs Thursday, March 17, 2011 6:41 PM
    • Unproposed as answer by Dirubs Thursday, March 17, 2011 6:41 PM
    Thursday, March 17, 2011 2:20 PM
  • I was able to fix by simply deleting the saved e-mail entry in the .nk2 file and recreating it.  Just go in like your going to send a new e-mail and enter the first few letters of the person you are having the problem with in the to field and when its highlighted push the delete button.  Then type the correct e-mail address in the to field and click the check names button and it will re-add to the list with the correct e-mail address as smtp instead of mailto.  Problem solved.  We have the update installed on all machines this was affecting.
    Thursday, March 17, 2011 7:31 PM
  • So after you roll out the hotfix, you still have to do the trick with deleting the old recipient from the cache?
    I was hoping this wouldn't be nescessary...

    Friday, March 18, 2011 2:44 PM
  • Thanks for the hotfix. Unfortunately it is for x86 platforms only. We use WinXP x86 workstations and Win7 x64 platforms as well. Is there also a hotfix available for the x64 platform?
    Thursday, March 24, 2011 8:41 AM
  • I installed it on a Win7 x64 machine and it seems to have worked.
    Thursday, March 24, 2011 9:31 PM
  • Yes so do I, how's it going ?
    /* Server Support Specialist */
    Thursday, March 24, 2011 10:28 PM
  • ok, can now get the official response from http://support.microsoft.com/kb/2475888/en-us?sd=rss&spid=11377 which said like the following:
    Consider the following scenario:
    You receive an email message that contains a mailto hyperlink.
    You use the mailto hyperlink to send an email message.
    In this scenario, you receive the non-delivery report (NDR).
    but when I tried to install office-kb2475888-fullfile-x86-glb.exe it give me error that the product is not installed or not found ?
    i'm using Outlook 2007  (12.0.6550.5003) SP2 MSO (12.0.6545.5004)

    /* Server Support Specialist */
    Thursday, March 24, 2011 11:28 PM
  • This is a patch for office, therefore the x86 reference relates to the version of Office being 32bit not the version of windows.

    This patch runs on 32bit machines and 64bit machines and we have rolled out the patch to all of our users on mixed platforms and architectures without issues.

     

    Albert: Can you provide details of the OS you are installing on and are you installing on client or Terminal Server? (To be honest your probably better off starting a new thread.)

    Friday, March 25, 2011 10:49 AM
  • Anyone knows when this update will be released for WSUS ?

    Thanks, JvB

    Monday, March 28, 2011 8:16 AM
  • Jexx, just wanted to say thanks for posting all of this.  Been slamming my head against the wall for months trying to figure this out.  Finally knew enough about what was going on to perform a better search and came across this thread.

    While the hotfix says x86, it will run on x64 systems.  I just installed it on a Windows 7 x64 system and it went through just fine.

    As for WSUS, it probably will not be released.  Most likely, it will be bundled in an SP when it is distributed or addressed in a future update without letting anyone really know; kind of like sweeping it under the rug so no one knows what happened.  The hotfix page states that it is pretty much a case by case fix, which is why it is not readily available to the public unless you look for it.  This is also why the page stresses a test environment before distributing live.

    Wednesday, April 20, 2011 4:30 PM
  • @Jexx, I am installing this on Windows XP pro SP3 laptop with Office 2007 SP2
    /* Server Support Specialist */
    Wednesday, April 27, 2011 2:00 AM
  • Jexx, just wanted to say thanks for posting all of this.  Been slamming my head against the wall for months trying to figure this out.  Finally knew enough about what was going on to perform a better search and came across this thread.

    While the hotfix says x86, it will run on x64 systems.  I just installed it on a Windows 7 x64 system and it went through just fine.

    As for WSUS, it probably will not be released.  Most likely, it will be bundled in an SP when it is distributed or addressed in a future update without letting anyone really know; kind of like sweeping it under the rug so no one knows what happened.  The hotfix page states that it is pretty much a case by case fix, which is why it is not readily available to the public unless you look for it.  This is also why the page stresses a test environment before distributing live.


    Thanks le_goat but all credit should go to Susan Bradley who took management of the issue, without her help we would still be stuck.

    Glad to hear all went well for you and I agree with your view on WSUS.

     

    As stated before, this hotfix is for x86 versions of Word 2007 and supports both x86 and x64 versions of windows (XP,Vista and Win7).

    Wednesday, April 27, 2011 10:15 AM
  • Is there any possibility to get a .MSI file?
    Or another way to silent install the patch?

    I've tested the fix on some pilot users, and want to deploy the fix company wide.
    And I don't want the users to get all the questions.

    Wednesday, April 27, 2011 10:50 AM
  • ---------------------------
    Hotfix for Office (KB2475888)
    ---------------------------
    Usage:
    /extract:path, extracts the content of the package to the path folder
    /log[:path to log file], enables verbose logging for the update installation
    /lang:lcid, sets the user interface to the specified locale when multiple locales are available within the package
    /quiet, runs the package in silent mode
    /passive, runs the update without any interaction from the user
    /norestart, prevents prompting of user when reboot of machine is needed
    /forcerestart, forced restart of machine once update is complete
    /?, shows this help message
    ---------------------------
    OK  
    ---------------------------

    I guess /quiet /passive /norestart are the switches your after.
    Wednesday, April 27, 2011 10:57 AM
  • Oops, feeling a little stupid right now.
    Could have thought about that myself.

    Thanks anyway...

    Wednesday, April 27, 2011 10:59 AM
  • Sadly it appears that there may still be a problem, I have had more reports of this issue again today but on investigation it appears to be coming from tasks that contains e-mail in copy and pasted form.

    Neither my user or I have been able to create a task that appears the same way today, so I assume there is a specific method to this. But I thought I would see if anyone else has experienced this on a hotfixed machine while I am investigating.

    Thursday, May 26, 2011 10:22 AM
  • We have just started seeing this problem on an SBS2011 install with (obviously) Exchange 2010 & users on Office 2010. The Word 2007 fix is not going to work for us.
    Wednesday, June 08, 2011 7:46 PM
  • It's possible something else is the cause because I've seen no one report this issue with Office 2010.

    1. Did it just start occuring?

    2.  Did it just start after a security update?  If so which one?  Did you remove the update to test?

    You may need to call Microsoft because right now I'm not seeing anyone else report this from a 2010 system.

    Wednesday, June 08, 2011 7:50 PM
  • We are definitely seeing the same issue (identical symptoms even if the cause turns out to be different) under Outlook 2010.  Forwarded mails which include mailto links turn out to have malformed links, when you hover the mouse over the link it shows as mailto:mailto:myname@mydomain.co.uk  This has occurred for two users out of six - all are newly installed systems with no deliberate differences in configuration or settings.  Outlook is working against an external POP/SMTP server not Exchange.

     

    For now we have disabled the display of hotlinks in Outlook which prevents users inadvertently clicking on one of these mailto links.

    Thursday, July 07, 2011 9:54 AM
  • You will need to call Microsoft.  Posting here won't get a fix coded up.  They will need to be able to repro the issue and I'm not seeing any chatter that there's a major issue.
    Thursday, July 07, 2011 1:49 PM
  • I am seeing the issue on 1 site within terminal server running Outlook 2010, since we put SP1 in 1 day ago so I am not sure which update has caused this? Same symtoms as above "Forwarded mails which include mailto links turn out to have malformed links" We are running exchange
    • Proposed as answer by Lexdrak Tuesday, July 26, 2011 9:16 PM
    • Unproposed as answer by Lexdrak Tuesday, July 26, 2011 9:19 PM
    Thursday, July 21, 2011 3:18 AM
  • I have had the same problem, while replying some emails. The solution I found is to go to Options, empty the AutoComplete List and try again. It has worked so far. Sorry I can't give a more technical solution, but so far it works every time.
    Tuesday, July 26, 2011 9:18 PM
  • Lexdrak,

     

     This worked for me also.

     

    This issue occured on both a RDS and Non-RDS user both using Outlook 2010 as part of the Microsoft Office 2010 Standard suite. So it is certainly something with the Office suite corrupting the random e-mail addresses in Autocomplete for outlook.

     

     It appears to be intermittant, only effecting an e-mail address here or there but not all of them that autocomplete keeps in history. Like to figure it out what update or anything else that may have caused it.

    HapcoNT

     

     

    Wednesday, August 03, 2011 7:21 PM
  • This issue was resolvedfor me by deleting the "remembered Outlook address" 

    see http://support.microsoft.com/?kbid=287623

     

    SS

    Friday, August 05, 2011 12:53 PM
  • Do you guys have any idea what might be causing this same behavior on a exchange 2010 and outlook 2010?
    BEG
    Tuesday, August 23, 2011 11:25 AM
  • This tread is no longer being monitored, please create a new thread as you are experiencing a different issue.
    Tuesday, August 23, 2011 12:00 PM
  • That's a shame because I also have a client with exactly the same issue with Outlook 2010 (as I do myself when I had a check).

    Symptoms are identical - malformed mailto header and poisoned cache. I don't think this is a different issue at all. It could even be down to some common code.

    Baring in mind all the frustration of trying to get Microsoft to address this issue for 2007 and the fact it took them SIX MONTHS to fix this, I WON'T be reporting this or starting a new thread!

    Wednesday, September 07, 2011 10:56 PM
  • So if Microsoft can't repro it, we're not seeing it in the wild, exactly how do you expect a fix to be built?
    Wednesday, September 07, 2011 11:00 PM
  • I started to get users with this same issue this week with Office 2010 SP1. The problem stems to the email type (under Outlook properties for the problem email address) being set to MAILTO rather then SMTP. It can be fixed by setting the email type to SMTP by hitting the "Internet Type" button.

    I have also read that the problem stems to the ticked setting: File.. Options.. Mail.. Editor Options.. AutoCorrection Options.. Internet and network paths with hyperlinks (which needs to be unticked).

    However there doesn't appear to be a way to turn this off through GPO, Registry or with a hotfix. I've had two users with this same issue within the last day, and I want to get on top of it before it blows out, but at the moment it's not looking like I can deploy a fix to the organisation.

    Thursday, September 08, 2011 12:51 AM
  • I'm also starting to see this issue on 32-bit Office 2010 (Wwindows 7 32-bit) and 64-bit Office 2010 (Windows 7 64-bit)

    By opening up an email sent to me from an outside source (which includes an email I originally sent), and hovering over my email address in [] pre-pended with the mailto: I see mailto:[mailto:email@work.co.uk]

    If selected and sent it causes an NDR as it's clearly not correct.

     

    To solve this issue, the auto-complete email needs to be deleted. Then a contact with the correct email address needs to be created.

    Monday, September 12, 2011 9:10 AM
  • Delivery incomplete means that as the signal went out with the text the complete message was lost or part of it was not delivered.
    Revitaslim
    Monday, September 12, 2011 11:49 AM
  • Delivery incomplete means that as the signal went out with the text the complete message was lost or part of it was not delivered.
    Revitaslim

    We have a handfull of Office 2010 users that are experiencing this same problem now.  It appears that somehow the @ sign has been removed from the recipient address and when the system scans through and doesn'r find one it appends the senders domain name xxx.com to the end of the address (as if it were a local address). (this gathered from message tracking). in any case has anyone heard of a fix yet for Office 2010 (this mostly has focused on Office 2007). As there is no Nk2 file in Office 2010 it can be fixed (unfortunately one at a time) by going to contacts (suggested contacts - which appears to be the replacement for Nk2) and deleting the contact card, then manually typing in the correct address.
    Tuesday, September 13, 2011 7:18 PM
  • We had a similar issue come up on our side with the MS Exchange 2007 environment.

     

    We fixed issue by retyping name in the To: field.

    As the name was being entered (i.e. persons.name@domain.co.uk  started to populate), I clicked the Delete button...thus deleting the cached name. Once I typed the email address in its entirety, clicked Send.

    This resolved the issue.

    This was occurring from external emails coming into our secured environment.

    Also, you can try changing the email from HTML format, to Rich Text or Plain Text.

     

     

    Thank you

    Tuesday, September 13, 2011 11:08 PM
  • I've just got this happened today with one user on Outlook 2010, exchange 2003.

    seems like it thinks its an internal address. will get the user to try the suggested contacts list.

    Thursday, September 15, 2011 3:40 AM
  • We too have noticed this happening for one of our customers in the following environment:

    Terminal server running Server 2008R2

    Office 2010 32-bit (currently no Service pack)

    This issue however, is bizarely only affecting a single TS user. I can send an email to the contact from my admin account and from another user's account.

    I have tried creating a new Outlook profile and nuking the cached address entry for the affected user

    Monday, September 26, 2011 2:44 PM
  • We are also having this problem.


    Exchange 2007

    Office 2010

    Several Outlook Add-Ins

    Only hearing from a few users on this so far. Seems to have started a couple of weeks ago, perhaps.

    Tried sending plain text, deleting the address from the N2K file. No luck with either. Sending via OWA works just fine.

    Monday, September 26, 2011 11:38 PM
  • Hello,

    I think you will find that someone replied to an old message that has a recipient that has since been removed or renamed in your directory. 

    Every exchange object has a LegacyExchangeDN in the form of:

    /o=Your Org Name/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=recipient

    If you add the missing LegacyDN as an x500 address on the appropriate recipient the messages will get properly delivered.

    Incidently these are very difficult to get rid of as replies to messages will re-polute you nk2 files.

    Bill

    Monday, September 26, 2011 11:57 PM
  • We are having the same issue with Outlook 2010.
    Monday, October 03, 2011 4:15 PM

  • You will need to call Microsoft.  Posting here won't get a fix coded up.  They will need to be able to repro the issue and I'm not seeing any chatter that there's a major issue.

    I'm not a masochist and do not intend to call Microsoft, but I also have this problem. SBS 2011, Office 2010, Windows 7, everything up-to-date. Every workstation in my office has this issue.

    Click a blue mailto link and it comes up with [mailto:address@domain.com] which returns instantly with an NDR. Right-click the email, go to More Options | Outlook Properties, click the "Internet type" button to change E-mail type from MAILTO to SMTP and you are all set.

    This is a real hassle.

    Tuesday, October 04, 2011 3:31 PM
  • Jon please please please can I beg you since you do have repro of that many to call?  I'll set up a comp case, but truly n-o-t-h-i-n-g will happen unless a phone case is made.

    Please please please email me at susan-at-msmvps.com and I'll get one set up.

    Tuesday, October 04, 2011 3:44 PM
  • Jon please please please can I beg you since you do have repro of that many to call?  I'll set up a comp case, but truly n-o-t-h-i-n-g will happen unless a phone case is made.

    Please please please email me at susan-at-msmvps.com and I'll get one set up.

     

    Dear Susan,

     

    Seems like truly n-o-t-h-i-n-g is happening anyway for almost a year now.

    MS is most likely gonna give me the two options given in this thread in easy understandable lamer-terms, and probably charge me for it. 

     

    In short, everyone using mailto: links is having this problem.

    Opening a call won't fix broken software ma'am, with all due respect. If it did, it would have been fixed by now.  

    I also suspect this won't be fixed anytime soon, if ever, in the most current outlook builds. (outlook 2007 and 2010)

     

    Did I mention we're having the same problem?

    Well, you probably figured that one out by now.

    Thursday, October 06, 2011 3:27 PM
  • I see these issue too here on all my German Windows Systems under W7 + Outlook 2010 + Exchange 2007. It has nothing to do with cached mail info, it also happens when clicking the mailto:-link of a person I never have sent to before - and it has nothing to to with Terminal Servers.

    It is easy to reproduce - so I hope MSFT will fix it somedays.


    Viele Grüße Dirk
    Thursday, October 06, 2011 3:35 PM
  • Actually you are wrong.  Outlook 2007 has a hotfix out for this issue.  Outlook 2010 is the one that has not been investigated.

    Description of the Office Word 2007 hotfix package (wordconv-x-none.msp, word-x-none.msp): February 22, 2011:
    http://support.microsoft.com/kb/2475888/en-us?sd=rss&spid=11377

    • Consider the following scenario:
      • You receive an email message that contains a mailto hyperlink.
      • You use the mailto hyperlink to send an email message.
      In this scenario, you receive the non-delivery report (NDR).

    Get that hotfix for 2007.  If you are STILL seeing it after that hotfix on the 2007 platform, let me know.

    And no they will not charge for it because dude, I'm offering to open up a case ON YOUR BEHALF.  Opening up a call is the ONLY way that a fix will be coded up. 

    Did I mention again that I'm offering to set up a call for you?  For free?  With all due respect, the ONLY way that a fix will be found is by calling in with a case.  Not by posting here where engineers can't get repro info, but by calling in.

    susan-at-msmvps.com

    Email it.  Get a case.  Get it investigated. 

     

    Thursday, October 06, 2011 3:41 PM
  • Susan, I have nothing said about Outlook 2007 - I do not have Outlook 2007 running. I see it in Outlook 2010 as I write above.
    Viele Grüße Dirk
    Thursday, October 06, 2011 3:47 PM
  • I was responding to Tjoen.  So can I set up a case for you so it can be fixed?

    susan-at-msmvps.com

    Thursday, October 06, 2011 3:53 PM
  • Oh sorry, I found your reply to direct under my posting.

    If you now were responding to me ;-) - yes, you can set up a call if you want - that would be great!


    Viele Grüße Dirk
    Thursday, October 06, 2011 3:57 PM
  • Can you email me directly at susan-at-msmvps.com so I can set up a case?
    Thursday, October 06, 2011 4:08 PM
  • Incident title:
    Callback:IMCEAMAILTO issue causing "Delivery has failed
    Support request number:
    111100672376671

    111100608844822

    So far I only have two cases set up (thanks Dirk in this thread for being one of them).  The more cases that are set up, the more Microsoft will take notice. 

    Again, all I'm asking you to do is to send me an email and I will set up a free case for you.  Opening up a case is the only way that broken software gets fixed.

    My email is susan-at-msmvps.com

    The offer stands.  It's up to you.

    Thursday, October 06, 2011 8:10 PM
  • Thanks for your help Susan !

    Come on folks, lets create some cases!


    Viele Grüße Dirk
    Friday, October 07, 2011 7:46 AM
  • Hello,

    I believe I have this same issue - on a less than one week old exchange 2010 server. I will try deleting the NK2 files.

    I have replied to your address Susan so you can set up a case for me as well.

    Much appreciated!

     

    D

     


    DKSCRI
    Friday, October 07, 2011 4:59 PM
  • Two more set up

    111100762929043 and 111100762521363

    Friday, October 07, 2011 5:34 PM
  • MSFT Support has contacted me and we were able to reproduce it during a remote session. MSFT support will now try to reproduce it on their systems and will try to find a solution for it.
    Viele Grüße Dirk
    Monday, October 10, 2011 1:44 PM
  • Hi Susan, we've been having the same issue what details do you need to open another case?
    Monday, October 10, 2011 3:47 PM
  • Same issue here on a couple of PCs, I have sent you an email.
    Tuesday, October 11, 2011 7:16 PM
  • AT ALL:

    MSFT Support has confirmed me that this is an already known bug in Word 2010 and they were able to reproduce it on their systems. They are working on a hotfix for it, it will be available later this year, maybe not till end of 2011.

    Actual official work around: do not click this mailto: -link. Great.

    @Susan: Makes it sense to open more cases to push MSFT to publish a hotfix sooner?

    Unfortunatly there is no "auto-hotfix-update", so everybody need to look if that hotfix is published. I will get a link to a KB article about hotfix checking later today and will post it here.

    Thanks again Susan for your help!

    When I see that hotfix available I will post it here.

     

    EDIT:

    here's the link about all published Office 2010 hotfixes:
    http://support.microsoft.com/kb/2625547

     

     


    Viele Grüße Dirk




    • Proposed as answer by -Dirk- Wednesday, October 12, 2011 8:04 AM
    • Edited by -Dirk- Wednesday, October 12, 2011 8:17 AM
    Wednesday, October 12, 2011 8:04 AM
  • The hotfix for this issue is currently in testing, and will be a part of the Decemer 2011 Cumulative Update.  The article Dirk referenced above is the correct article to watch for the earliest notice of the release of the hotfix.  Once a KB article number is assigned to the CU, I will return here and post it for reference as well.

     

    Additional workarounds, while limited in their user friendliness are...

    • Right click on the address, and choose copy shortcut
    • Highlight the address, and copy/paste it into a new e-mail window manually

     


    RKeith - [MSFT]
    Tuesday, October 18, 2011 10:24 PM
  • There is one thing you also need to know:

    When you have clicked such a mailto:-link and tried to sent that mail, this wrong formatted address is stored in the Outlook auto-complete list (formally known as "nk2-files", now integrated in your message store). So even when you type thoses addresses later again manually, they will be "auto-corrected" by Outlook into the wrong formatted address - you mail will fail.

    I don't think the hotfix RKeith promised will also fix that, so everybody need to delete those wrong formated addresses in Outlook manually from the internal auto-complete list.


    Viele Grüße Dirk
    Wednesday, October 19, 2011 8:44 AM
  • Hi Susan, We have 350 users and a large percentage get the same issue with Outlook 2010 and MailTo addresses that have worked until our recent migration from Outlook 2003. I am not convinced this is an issue with Word 2010 however as we are still running Word 2003, unless the editor functionality within Outlook 2010 is using code shared with Word 2010? Anyway if you are still happy to open a case at no cost in order to help add some pressure I will send an email through to you. Regards, Gavin
    Friday, October 28, 2011 9:12 AM
  • Happening to a few of my users and some others in a sister organisation. markd at mvps.org Feel free to set up another case if you wish.
    Tuesday, November 08, 2011 6:34 AM
  • Sorry if I'm being dense - I've mostly just skimmed this thread and I need to get going on another job. I'm seeing this on a 2008R2 Terminal server with outlook 2010 and sbs2011 (exchange 2010) The problem has been fixed in outlook 2007 but there still a problem in 2010 correct? What is the status of the probem/fix in outlook/office 2010?
    Monday, November 21, 2011 8:46 PM
  • STATUS as of 11/21/2011 - awaiting hotfix for Outlook 2010 expected in the December Outlook update. Hang tight until then. Will post the link as soon as it goes live.
    Monday, November 21, 2011 8:54 PM
  • I don't know if this helps or not, but I just saw this behavior in a 2008R2 Terminal server, Outlook 2010, and Exchange 2007, but it was with a manually typed in address. The address does not exist in any addressbook, or recently used address lists. The user in question typed the email address into the to: field from a postit note. There were no whitespaces in the address. Once typed in, the address because underlined in a dashed green line. I opened properties on the address and saw that it had the display name and address correct, but that it was of type MAILTO. It does not happen on all addresses manually entered, but it does happen on some. Is there a reason that an address that has never been used and was typed in manually would resolve to type MAILTO?
    Tuesday, November 22, 2011 8:26 PM
  • First of all, is anyone else having problems with this Technet page? Takes forever to load and it usually crashes. Anyway, this doesn't fix the problem of the clicked email address, but you can remove it. The old NK2 editor can show you the MAILTO addresses, but the only way to fix it is to go into the Options > Send Messages and Empty Auto-Complete List. It's the only way we've been able to get users to send to these addresses.
    Wednesday, November 30, 2011 4:16 PM
  • Hi Suzan,

    Do you have any news? Need more name to open ms-case?

    I got the same issue under an Exchange 2003 with Outlook 2010 (fully updated) from a TS environnement in 2008 R2.

    Thanks

    Tuesday, December 13, 2011 8:06 PM
  • STATUS ON 12/13/2011

    HOTFIX HAS BEEN RELEASED

    **************************

    Assume that you create a document in Word 2010. When you type an email address inside the square brackets after the Mailto: header, the email address is displayed as an incorrect hyperlink. For example, you type abc@example.com inside the square brackets after the Mailto: header. In this situation, the email address is formatted as a [Mailto:abc@example.com] link. Additionally, when you click the link, the text "[Mailto:abc@example.com]" is inserted into the *To* box in Microsoft Outlook.

    http://support.microsoft.com/kb/2597052

    *****************************
    Please note it will not fix anything previously flipped.


    • Proposed as answer by -Dirk- Wednesday, December 14, 2011 8:10 AM
    • Edited by Susan BradleyMVP Monday, February 13, 2012 5:09 PM Bolding it to note hotfix release
    • Marked as answer by Jexx Friday, August 24, 2012 3:39 PM
    Tuesday, December 13, 2011 11:54 PM
  • YES This Hotfix solves the problem for me! Many thanks to Susan for all her help!!!
    Viele Grüße Dirk
    Wednesday, December 14, 2011 8:08 AM
  • Is there a similar hotfix available for outlook/office 2007?
    -- Jocelyn
    Wednesday, December 14, 2011 11:16 PM
  • Jocelyn the 2007 version was posted months and months ago

    ************************************************

    Description of the Office Word 2007 hotfix package (wordconv-x-none.msp, word-x-none.msp): February 22, 2011: 
    http://support.microsoft.com/kb/2475888/en-us?sd=rss&spid=11377 

    • Consider the following scenario:
      • You receive an email message that contains a mailto hyperlink.
      • You use the mailto hyperlink to send an email message.
      In this scenario, you receive the non-delivery report (NDR).

    ************************************************


    • Proposed as answer by Susan BradleyMVP Wednesday, December 14, 2011 11:59 PM
    • Edited by Susan BradleyMVP Monday, February 13, 2012 5:08 PM Bolding it for hotfix answer
    Wednesday, December 14, 2011 11:59 PM
  • Thanks Susan, I'll give it a try.
    Tuesday, December 20, 2011 1:14 AM
  • So I attempted to give it a try, the hotfix failed to install - 'There are no products affected by this package installed on this system' . This is on a 2k8R2 terminal server. with office 2010 professional plus.
    Wednesday, December 21, 2011 8:31 PM
  • If you asked for the 64bit hotfix, I'm guessing you have Office 2010 32bit installed, in which case install the 32bit hotfix.

    Bottom line request the version you don't think you need, and try installing that.

    This hotfix will indeed install.

    Wednesday, December 21, 2011 8:40 PM
  • After applying the hotfix on one of my servers. What do we need to do in terms of the user's outlook? Clear the auto-complete? Any other steps needed to be taken in the user's mailbox? This is for outlook 2010 32 bit on Windows 2003 enterprise 64 bit SP2. I tried clearing the entry and the autocomplete and the e-mail address with mailto still shows up as mailto when the user types the address in manually.
    Wednesday, January 11, 2012 4:39 PM
  • Does anyone know if there is a hotfix for this on Office 2003 please?
    Thursday, January 12, 2012 10:39 AM
  • Are you sure it's exactly the same issue?  I've never seen this issue being reported on a Outlook 2003 box.  Make sure you have all service packs as anything found in the past would be in a service pack by now.

    If you truly think it is, I think 2003 is in extended support time frame and this many years after the fact, they won't be coding up a fix.

    Thursday, January 12, 2012 5:04 PM