none
Outlook 2007 Spell Check Not Working

    Question

  • When starting a new email in Microsoft Outlook 2007 any word that is misspelled does not show up in spell checker. When pressing the spelling and grammar check it says spelling check complete. Does anyone have a solution to this problem?

    Monday, April 12, 2010 9:54 PM

All replies

  • When starting a new email in Microsoft Outlook 2007 any word that is misspelled does not show up in spell checker. When pressing the spelling and grammar check it says spelling check complete. Does anyone have a solution to this problem?

    I had the same problem. To fix, close Outlook and delete this registry folder:

    HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\Proofing Tools\1.0\Override

    This has happened on every install of Office 2010 so far.  Scenarios include these upgrades over the years - Office XP (2002) to 2003 to 2010, another is Office 2003 to 2007 to 2010.  I dunno if it's a 2003 to 2010 issue or not, but it appears so.

    Thursday, May 20, 2010 6:54 PM
  • Found this you could try it and see if it makes a diffrence:

    In Outlook 2007 my emails are not always automatically spell checked. Some time they are and sometime they aren't.

    When Outlook does indicate a misspelled word and I attempt to right click (to get a list of correct spellings) I usually get a Signatures option instead.

    How do I get spell check back all the time and get rid of this Signature option?

    Recreation Steps:
    Open New Mail with a default Signature
    Ctrl+A and Delete Signature
    Type some words
    Right click. You will get a Signature selection option not spell check option.

    "Basically, try moving you Signature down / delete it"  Seems that Outlook thinks that the whole email is a signature".  But im no expert on office! 


    Marc Darragh MCTS AdvDip. (IRE)
    Wednesday, February 09, 2011 7:36 PM
  • When starting a new email in Microsoft Outlook 2007 any word that is misspelled does not show up in spell checker. When pressing the spelling and grammar check it says spelling check complete. Does anyone have a solution to this problem?


    Outlook 2007 Not Spell Checking and possibly 2003

    1.      Start – run – regedit

    2.      Backup registry 1<sup>st</sup>.  File – Export

    3.      HKEY_CURRENT_USER

    4.      Software

    5.      Microsoft

    6.      Office ( Rename the whole Office Key to OfficeOLD )

    7.      Restart computer

    8.      Start Outlook ( You might have to setup client again ) as step number 6 disables Microsoft Office.

    This fix has worked for me after hours of trawling Technet and various websites looking for the problem where the steps above have not been documented. 

     

     


    Marc Darragh MCTS AdvDip. (IRE)
    Thursday, February 10, 2011 2:41 PM
  • dxtrb, this worked for me with Microsoft Outlook 2007, when I came here, spell check was not working in Outloook and Word, spell check in Outlook is working, but is still not working in Word 2007, any suggestions would be greatly appreciated.

    Thanks

    Bob

    Friday, October 21, 2011 11:48 PM
  • dxtrb - BRILLIANT...worked like a charm with Outlook 2007 running on Windows 7. Thanks!
    Thursday, December 08, 2011 9:52 PM
  • Marc,

    I was reluctant to try the solution you offered because of the statement "you might have to setup client again." The solution offered by dxtrb solved my spell checking issue.  However, I have another issue with Outlook 2007.  Whenever I open an attachment, it takes a while and, while waiting, it freezes the computer.  This never used to be the case.  I was wondering if your solution might handle this issue i'm having.

    Thanks in advance for any info you can provide...SRP

    Friday, December 16, 2011 10:04 PM
  • Could possibly handle the problem you are having but to be honest I would be unsure of this as I don't know exactly what the errors are.  take a look at the event veiwer to see if it can show the errors codes, in most case a quick search on here or on google could find a fix for you.

    Have you tried to run the office diagnostics program? and or create a new outlook profile?

    sometimes when an archive is over the 2gb mark it can have an effect on performance and could possibly make your machine freeze.


    Marc Darragh MCTS AdvDip. (IRE)
    Friday, December 23, 2011 1:17 PM
  • Thanks for the answer. Worked for me.
    Monday, January 16, 2012 8:24 PM
  • Tried this, however I don't see an override folder.  I do see 2 custom dictionaries though.
    Tuesday, June 26, 2012 3:06 AM
  • Thanks marc,

    I was tried with dxtrb solution, but i could not find the folder "override".

    This is worked for me.

    Anand

    Tuesday, February 05, 2013 7:41 AM