none
To free up disk space outlook express can compact messages

    Question

  • Hi there:

    I'm getting this error:

    to free up disk space outlook express can compact messages

    I did some research and this is associate to my windows Search Bar. The counter in the registry for Outlook Express, even when I dont use it, will increase and once it hits 100 will start displaying this error.

    Any help will be welcome.

     

    Thanks

    Thursday, May 13, 2010 2:58 PM

Answers

  • Based on my research, this error may occur even when Outlook Express is not in use on Windows XP, because Outlook Express is indexed by Windows Search. We can open Windows Indexing options and uncheck Outlook Express by the steps below:

    ==============

    1.       Click Start > Control Panel, and switch to classic view.

    2.       Click Indexing Options, and then click the Modify button.

    3.       Uncheck the checkbox before: Microsoft Outlook Express.

    4.       Click OK, and then click Close to save the settings.

     

    You can also refer to this blog about the steps: http://blog.lucidtechgroup.com/2009/03/outlook-express-to-free-up-disk-space.html

     

    If this problem persists, I would like to confirm if the error occurs when you start up the computer. If this is the situation, we can also disable the Outlook Express program from the startup menu by the steps below:

    ============

    1.       Right-click Start button, and choose Properties from popup menu.

    2.       Choose Start Menu tab.

    3.       Click "Classic Start Menu" radio button and choose the Customize button.

    4.       Click the Remove button.

    5.       Click on "Outlook Express" to highlight it.

    6.       Click Remove button.

     

    • Marked as answer by Sally Tang Wednesday, May 19, 2010 9:09 AM
    Friday, May 14, 2010 6:37 AM

All replies

  • It's not an error, it's a notification.  Have you tried letting Outlook Express compact messages?
    -B-
    http://www.officeforlawyers.com
    Author: The Lawyer's Guide to Microsoft Outlook
    Thursday, May 13, 2010 4:51 PM
  •  

    Hi there:

    I'm getting this error:

    to free up disk space outlook express can compact messages

    I did some research and this is associate to my windows Search Bar. The counter in the registry for Outlook Express, even when I dont use it, will increase and once it hits 100 will start displaying this error.

     

    To minimize the frequency of that use something other than OE  as your default News client (e.g. for .nws file creation and indexing).   Since this is posted in an Outlook forum I will assume that  .eml  creation is associated with that Mail client and not OE.  ; )

     

    Good luck

    Robert Aldwinckle
    ---

    Thursday, May 13, 2010 9:41 PM
  • Based on my research, this error may occur even when Outlook Express is not in use on Windows XP, because Outlook Express is indexed by Windows Search. We can open Windows Indexing options and uncheck Outlook Express by the steps below:

    ==============

    1.       Click Start > Control Panel, and switch to classic view.

    2.       Click Indexing Options, and then click the Modify button.

    3.       Uncheck the checkbox before: Microsoft Outlook Express.

    4.       Click OK, and then click Close to save the settings.

     

    You can also refer to this blog about the steps: http://blog.lucidtechgroup.com/2009/03/outlook-express-to-free-up-disk-space.html

     

    If this problem persists, I would like to confirm if the error occurs when you start up the computer. If this is the situation, we can also disable the Outlook Express program from the startup menu by the steps below:

    ============

    1.       Right-click Start button, and choose Properties from popup menu.

    2.       Choose Start Menu tab.

    3.       Click "Classic Start Menu" radio button and choose the Customize button.

    4.       Click the Remove button.

    5.       Click on "Outlook Express" to highlight it.

    6.       Click Remove button.

     

    • Marked as answer by Sally Tang Wednesday, May 19, 2010 9:09 AM
    Friday, May 14, 2010 6:37 AM
  • Why this issue has suddenly exploded in the past year?  It seems like everyone is having this problem, even if you use WindowsLiveMail, OutLook, or whatever is set as your default, and even if you have deleted all of your email, junkmails, and Deleted Box, the darn Outlook Express compacting pop-up keeps popping up.  Why does it continue to keep popping up when there are not even any emails to compact? 

    Plus, if you go ahead and let it compact, it just keeps popping up wanting to do it again several times a day.  That's just not right, and Microsoft needs to write a program to fix this problem, and put it in their Auto-Updates.

    Friday, May 21, 2010 12:01 AM
  • Can you resolve this issue by the steps above?

    Best Regards,

    Sally Tang

    Monday, May 24, 2010 6:31 AM
    • I did have indexing turned on at one time...I have now disabled indexing service.  I have uninstalled Outlook Express Windows Component.   I tried unchecking Indexing Options.  I removed Outlook Express from the Classic Start Menu.  Each reboot I get the same annoying error. 
    Thursday, June 03, 2010 4:04 PM
  • No. That's one of the reasons that I said Microsoft should make an update to fix this problem that SO many people have different systems and service packs.

    I have SP3.  Different people have different versions, and the instructions don't apply to all.  If Microsoft would put the fix in their update, they could fix this very annoying problem for all versions.  I know it is hurting Microsoft's sales. I know of 2 people that bought a Mac because they got tired of the compact message popup. I have not spoken to them since they got their Mac, but I'll bet they don't have the compact problem any longer.  

    It happens on every work station in our office now. We called out 2 different IT companies and their suggestion was to eliminate Express and just use Outlook.  I don't like Outlook, and that should NOT be the way to fix the problem.

    Why is Microsoft so dead set against not creating and putting a fix in Microsoft Update?

    Thursday, June 03, 2010 11:13 PM
  • I have uninstalled Outlook Express Windows Component.

    I removed Outlook Express from the Classic Start Menu.

    Neither of those things removes the msoe dll which is the cause of the symptom.

    However, changing the Indexing Options should have helped.   Are you sure that you disabled all the OE MIME filtered ones?   Have you tried installing  WLMail  and letting it take control of the relevant file types and protocols?   Otherwise the only other workaround that I can think of would be to change the permissions on the subkey which contains that compaction count value and then hope that Windows Search could never change it.


    Good luck

    Robert
    ---

    Saturday, June 05, 2010 6:34 PM
  • I don't have indexing options shown in Sp3.  I have changed and use WindowsLiveMail now, but my home computer still has the compacting popup several time, every time I use my desptop.

    I have changed the count to 0 on my bosses computer at work, but the compacting still pops up.  Two well known IT service companies have looked at the ones at my office, but they can't even fix it.

    Sunday, June 06, 2010 10:55 AM
  • I don't have indexing options shown in Sp3.  I have changed and use WindowsLiveMail now, but my home computer still has the compacting popup several time, every time I use my desptop.

    I have changed the count to 0 on my bosses computer at work, but the compacting still pops up.  Two well known IT service companies have looked at the ones at my office, but they can't even fix it.


    In XPsp3 IIRC Windows Search options are set using either a button on the far right of a search results window or using the Desktop search bar (e.g. via the Taskbar).   I haven't used XP for a while so these recollections are hazy.   E.g. in XP, WS is an add-on not integrated into the OS as it is in Vista or W7.

    Would you say that the frequency of the symptom is less since you have switched to WLMail?   Perhaps you still have associations and file types set which result in the OE .dll being used?   E.g. if you have not made WLMail the default for  .nws and .eml and Mailto:  you could see your symptom independently of WS simply by opening one of those files or just by entering mailto: somewhere (such as an IE Address bar).

    To try to get a better handle on the cause of the symptom now you could use Task Manager or Process Explorer (ProcExp) with the Go To Process command (or equivalent).   ProcExp would be preferred because then you could also look at the relevant thread and its stack to show how the msoe dll was being called.   ProcExp implements the same Go To Process functionality using a GUI, e.g. with its crossed-hairs button.

    Another diagnostic tool you could use if the symptom happens frequently enough is ProcMon.  E.g. that could show you exactly when and how the Compaction count variable was being updated not just when it had reached 100.   E.g. if you couldn't figure out from the context of the RegSetValue trace record where it was being done, ProcMon supposedly has some saved stack info in each of its trace records.


    Good luck

    Robert
    ---

    Sunday, June 06, 2010 3:33 PM
  • I had the same problem and tried to fix it using the suggested steps but it had no effect. I was successfully able to stop this error by simply un-installing windows search 4.0.
    Tuesday, August 24, 2010 1:16 PM
  • Ive had this problem for over a year myself.  It doens't matter if you go ahead and compact or not...it still asks to do it again in the next 20 minutes.  When you switch from one email account to another it asks over and over again.  It gets quite annoying.  It use to ask this and once you compacted you wouldn't see that again for quite a while.  Seems like someone from microsoft could answer this question.

    I have googled everything I can imagine and tried everything that others have suggested.  Still have the problem.

    Wednesday, March 23, 2011 6:05 PM
  • Just wanted to add my two cents worth, since it appears that this problem has still not been addressed by Microsoft. I've scoured various forums and support areas, and have tried everything. Uninstalled Outlook Express, and the popup keeps happening. Set the Compact Check Count to zero, but this is just a temporary fix since the counter keeps going until the popups happen again. Removed access to Outlook Express by all users- still get the popup. Went into indexing options and removed Outlook Express from indexing, and the popup still occurs. I thought I had finally found a working solution to this problem, which was to remove all the permissions for the msoe.dll file, since this was the file that was apparently causing the popup. After removing permissions for the file, even for system, the popups stopped. Finally.

    I thought I was done, but then Microsoft released update KB978542, which deals with security issues in Outlook Express. As a result of my deleting permissions for msoe.dll, the update couldn't apply itself. By re-enabling the permissions to the msoe.dll file, then installing the update, I can get the update to install. However, if I remove permissions again, the update needs to install again. Loads of fun, this.

    Now, instead of getting a ridiculous popup for a program I don't even use (all of our workstations use Outlook 2003), I get a reminder to update my system. Since it just sits in the systray I guess it's preferable to a popup, but it still seems like something Microsoft should address, especially given the volume of complaints I've found about the issue.


    Tuesday, March 29, 2011 7:07 PM
  • Update: I've finally found a solution that solves this problem for my particular situation. It appears that the cause of this whole mess was a program that was accessing the msoe.dll file in such a way to make the registry object "Compact Check Count" tick upwards from zero (once the count reaches 100, the popups start). In my case, it was Windows Search that was causing this, so I ran msconfig, removed Windows Search from the startup area, and examined the registry object to see the current count. Then, I entered the properties for the msoe.dll file, amended the security properties to allow permission propagation from the parent file, saved it, ran both Microsoft updates for Outlook Express, and restarted the computer.

    I confirmed that the "Compact Check Count" registry object did not change, so it appears my problem has been solved. For now. No popups, and updates installing normally. I hope this helps someone with this issue, as it was driving me absolutely nuts. Cheers.

    Wednesday, April 06, 2011 8:08 PM
  • Uninstalling Nero helped me stop this message box sometime back. It probably has a background indexing thread running that may trigger the counter when indexing msoe.dll. So, installing other programs could bring this nightmare back. Just wanted to share my experience.
    Tuesday, May 31, 2011 3:39 PM
  • Please, what are you talking about?

     

    There is no "indexing Options" or "Modify" button on the outlook express folder or in my Control Panel and I use Classic View. 

     

    and NOTHING seems to stop the insanity of this popup window that demands compacting messages. It's insane. Can you describe a better solution.

    I have XP Pro.

     

    Thank you.



    Thursday, June 02, 2011 1:43 AM
  • I've had this irritation on my XP Pro Laptop for a few months. I don't use Outlook Express or Outlook at all. Nothing to compress but pop-up recurrent even if I let it compress. Have tried all the suggestions except that posted by Lysandrus.

    On the basis that Microsoft are aware of this problem and could no doubt fix it if they wanted, I do wonder if their disinclination to do so may be part of the plan to drive people away from XP. They wouldn't deliberately allow this to be an adverse effect, for some users, from one of their updates - would they?

    Friday, August 26, 2011 10:01 AM
  •  

    One other thing you might want to try is to set the value of the following registry key to 0:

    HKEY_CURRENT_USER\Identities\{CLSID}\Software\Microsoft\Outlook Express\5.0\Compact Check

    Or check if you have the following .dlls on the machine and remove user's permissions on the respective files:

    C:\Program Files\Outlook Express\msoe.dll
    C:\Program Files\Outlook Express\msoeres.dll

    Please note that this solution offers no warranty and you should be doing this at your own risk.

    Friday, August 26, 2011 11:08 AM