none
Can't configure SharePoint Server 2010 after installation

    Question

  • After installing SQL Server 2008 R2 Enterprise, installing corresponding SharePoint Server 2010 Prerequisites and SharePoint Server 2010 Enterprise itself I now can't run the SharePoint configuration wizard:

    After I have started the SharePoint Server 2010 configuration wizard, it displays a message box about certain IIS services to be stopped when proceeding. Right after I have confirmed this message a new error message pops up, saying that the SharePoint Server 2010 configuration wizard cannot connect to SQL Server instance MSSQL$SharePoint .

    I guess that because I had installed SQL Server 2008 R2 Enterprise before installing SharePoint Server 2010, SharePoint Server 2010 setup chose to use the existing default instance.

    How can I tell the SharePoint Server 2010 configuration wizard to use the pre-installed SQL Server 2008 R2 Enterprise default instance?

    Thanks for enlightening me!

    Thursday, December 09, 2010 4:21 AM

Answers

  • Ok, I think I know what's going on.  You've installed SQL 2008 R2 on your box and chosen Standalone as the installation method.  This will default to installing SQL Express.  You might find you've got a SQL service that won't start due to R2 being on there already.  If you re-install SharePoint using "Server Farm" as the option when given, you'll be able to use the instance you've provisioned.


    PT_UK http://redmanta.co.uk/blog Twitter: @redmantauk MCTS:WSS,MOSS,2010 MCITP:2010
    Thursday, December 09, 2010 1:21 PM
  • I have now installed Active Directory Domain Services...

    Having this role activated it seems everything works fine now... (so far)

    Well it seems, attaching to an existing SQL Server 2008 is not supported without having a domain at hand.

    Tuesday, December 14, 2010 7:33 PM

All replies

  • Did you select Standalone at the installation prompt?  Is your SQL installation on the same box as SharePoint?  So far all you've done is install the binaries for SharePoint but it sounds as though you might have selected standalone and SQL Express has been installed.

    Failing that, If you need to you can configure the setup using the PowerShell command new-spconfigurationdatabase.

    New-SPConfigurationDatabase –DatabaseName “SharePoint2010_Config” –DatabaseServer “<db server>” –AdministrationContentDatabaseName “SharePoint2010_Admin_Content” –Passphrase (ConvertTo-SecureString “pass@word1” –AsPlaintext –Force) –FarmCredentials (Get-Credential)

    There's a blog detailing full steps here.


    PT_UK http://redmanta.co.uk/blog Twitter: @redmantauk MCTS:WSS,MOSS,2010 MCITP:2010
    Thursday, December 09, 2010 9:04 AM
  • Hi

    Please check the name of the SQL server instance you have created. Try creating an instance with the name SharePoint and then run the configuration wizard.

    • Proposed as answer by Naveed Mohammad Thursday, December 09, 2010 12:02 PM
    • Unproposed as answer by BetterToday Friday, December 10, 2010 1:28 PM
    Thursday, December 09, 2010 12:02 PM
  • Thanks for your replies.

    I have installed the default, nameless instance of SQL Server 2008 R2: "MSSQLSERVER". It's the only instance that's running on my machine.

    Next I have installed SharePoint as a Standalone installation.

    Thanks for the tip using PowerShell. However, before applying it I'd be very much interested in the reason/cause for this error. Do you perhaps know what's the cause for SharePoint installer not finding the current MSSQLSERVER instance? Why doesn't the installer ask me which SQL Server instance to use? Why can't I provide a user for SharePoint to use?

    Thursday, December 09, 2010 1:11 PM
  • Ok, I think I know what's going on.  You've installed SQL 2008 R2 on your box and chosen Standalone as the installation method.  This will default to installing SQL Express.  You might find you've got a SQL service that won't start due to R2 being on there already.  If you re-install SharePoint using "Server Farm" as the option when given, you'll be able to use the instance you've provisioned.


    PT_UK http://redmanta.co.uk/blog Twitter: @redmantauk MCTS:WSS,MOSS,2010 MCITP:2010
    Thursday, December 09, 2010 1:21 PM
  • Thanks PT,

    OK, I see. So I will perform a rollback on my VM to choose the other option now.

    You know, I'm more concerned in finding a flawless installation procedure than getting a remedy. I guess I will have to install SharePoint Server 2010 a couple of times in the future, and I don't want to run into the same problems over and over again.

     

    PS: I just checked the services on my machine. There is only one instance available, it's the default instance. No SQL Server Express edition had been installed on my machine.

    Thursday, December 09, 2010 1:58 PM
  • Even better, don't bother rolling back the VM, just remove SharePoint and re-install selecting the farm option.  When you run the configuration wizard you'll be able to specify your instance of SQL.
    PT_UK http://redmanta.co.uk/blog Twitter: @redmantauk MCTS:WSS,MOSS,2010 MCITP:2010
    Thursday, December 09, 2010 2:03 PM
  • Unfortunately it's too late for that already. I'm just booting my VM with only SQL Server 2008 R2 Enterprise installed...

    Green Smileys - Experiment

    If it's alright with you, I'll be right back after having SharePoint installed...

    Thursday, December 09, 2010 2:08 PM
  • See you in a minute :-p

    Don't forget to choose "Server Farm" & "Complete" when prompted.


    PT_UK http://redmanta.co.uk/blog Twitter: @redmantauk MCTS:WSS,MOSS,2010 MCITP:2010
    • Edited by Paul Turner _ Thursday, December 09, 2010 2:49 PM spelling
    Thursday, December 09, 2010 2:15 PM
  • Hmm... Seems this will take a little longer... This option doesn't allow local Workgroup users to be used to access SQL Server 2008 R2...

    I guess I will have to install AD DS first... and I guess I will have to re-install SQL Server 2008 R2 then. But I'm not sure yet.

     

    PS: You wouldn't know by accident of an option to persuade SharePoint Server 2010 Configuration Wizard to allow using local users for accessing SQL Server 2008 R2?

    Thursday, December 09, 2010 4:24 PM
  • OIC, it really is a standalone! There's some steps here which explain what you need to do if installing a standalone install without AD.
    PT_UK http://redmanta.co.uk/blog Twitter: @redmantauk MCTS:WSS,MOSS,2010 MCITP:2010
    Thursday, December 09, 2010 4:36 PM
  • Wow... I'm impressed... You, well, you seem know quite a bit about SharePoint... awesome...

    OK, I'll be right back... Twinker Smilie by GreenSmilies.com

    Thursday, December 09, 2010 5:10 PM
  • Nope, but I know a lot about google.
    PT_UK http://redmanta.co.uk/blog Twitter: @redmantauk MCTS:WSS,MOSS,2010 MCITP:2010
    Thursday, December 09, 2010 5:16 PM
  • Yeah, I usually do, too. But this time I wouldn't know which terms to search for... Thanks for taking the time.
    Thursday, December 09, 2010 5:40 PM
  • No problem, have you manged to progress?
    PT_UK http://redmanta.co.uk/blog Twitter: @redmantauk MCTS:WSS,MOSS,2010 MCITP:2010
    Thursday, December 09, 2010 5:45 PM
  • I'm still reading... That document did reference an MSDN article. A friend just called. Now I'm back on.
    Thursday, December 09, 2010 6:30 PM
  • I tried to execute that PowerShell cmdlet but it requires me to give a passphrase. I didn't come across something like a passphrase when installing SharePoint so far...
    Thursday, December 09, 2010 8:20 PM
  • A passphrase is generated by you when you install the farm.  It's asking you to create one, usually 8 characters I think upper/lowercase/numerical and special characters.  It's a way to ensure other servers can't be added to the farm without knowing the passphrase.  Pick a favourite and remember it for future use.
    PT_UK http://redmanta.co.uk/blog Twitter: @redmantauk MCTS:WSS,MOSS,2010 MCITP:2010
    Thursday, December 09, 2010 8:37 PM
  • Thanks, pt!

    I've just tried that and now I get the next obstacle: That PowerShell script is telling me that "The user is unknown":

    New-SPConfigurationDatabase : Der Benutzer ist nicht vorhanden.
    At line:1 position:28
    + New-SPConfigurationDatabase <<<<
        + CategoryInfo          : InvalidData: (Microsoft.Share...urationDatabase:
       SPCmdletNewSPConfigurationDatabase) [New-SPConfigurationDatabase], SPExcep
      tion
        + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletNewSPCon
       figurationDatabase

     

    What user? What for? What did I forget?

     

    I'm sorry that this is taking so long. I'm lost here... This is the first time I install SharePoint 2010.
    I've read the installation manual, but that doesn't seem to be sufficient....   Smilie by GreenSmilies.com

    Thursday, December 09, 2010 9:17 PM
  • Did you try configuring the sharepoint installation via the product and configuration wizard after the re-install?  The PowerShell command I gave you was before I knew you were installing without AD.


    PT_UK http://redmanta.co.uk/blog Twitter: @redmantauk MCTS:WSS,MOSS,2010 MCITP:2010
    Thursday, December 09, 2010 9:26 PM
  • No, I couldn't. That was my problem from the beginning.

    If I select Standalone, then the SharePoint Server 2010 Configuration Wizard doesn't start. If I select Create a Farm, on the other hand, I get an error message telling me that a local account can not be used to set up the database.

    Thursday, December 09, 2010 9:59 PM
  • OK, so if you now run the sharepoint powershell console and run the command

    New-SPConfigurationDatabase you will be prompted for your chosen database name, server name and the passphrase of your choosing. Once run check your sql and see if you have databases created.  If so you can then run the configuration wizard.


    PT_UK http://redmanta.co.uk/blog Twitter: @redmantauk MCTS:WSS,MOSS,2010 MCITP:2010
    Thursday, December 09, 2010 10:11 PM
  • OK... Yes, I've seen these databases have been created. So you suggest me to ignore the error message?

    I have rolled back my VM to the moment before I started the PowerShell script. I'm currently re-running it. It takes a few minutes... I'll keep you informed about the outcome.

    Thursday, December 09, 2010 10:24 PM
  • for now :-p

    So if you run the configuration wizard does it show you connected to a farm?


    PT_UK http://redmanta.co.uk/blog Twitter: @redmantauk MCTS:WSS,MOSS,2010 MCITP:2010
    Thursday, December 09, 2010 10:30 PM
  • Nope... It asks me whether I want to connect to a farm or start a new one. If I answer "Create a new farm" then it asks me to create a configuration database again, not accepting a local user account :(
    Thursday, December 09, 2010 10:35 PM
  • I think i'm missing something here..

    1. You installed SQL 2008 R2

    2. Installed SP2010 binaries

    3. You can run the command New-SPConfigurationDatabase and enter a new db name and passphrase etc

    4. You can see the databases created by the command

    5. You run the config wizard and you're not connected.

    Is that right?


    PT_UK http://redmanta.co.uk/blog Twitter: @redmantauk MCTS:WSS,MOSS,2010 MCITP:2010
    Thursday, December 09, 2010 10:42 PM
  • Would you mind giving me a second? I'm preparing a couple of screenshots that may enlighten the situation....
    Thursday, December 09, 2010 11:01 PM
  • Here we go... It took a while before I had taken it all, converted and uploaded it...

    Please follow this link to the video I have created (I leave it online till next weekend for others to follow).

    Unfortunately it's all German, I'm afraid. But I'm rather sure you will be able to guess the meaning of all the GUI texts.

    Friday, December 10, 2010 12:13 AM
  • Ok I couldn't see security details but i can see you have the db's created.  Is you're logged in account a DBO of those databases?  Also in the video, when you ran the configuration wizard again you selected the option to create a new farm again.   This is where you should select join an existing farm, enter the name of your sql server and it should detect the sharepoint_config db.
    PT_UK http://redmanta.co.uk/blog Twitter: @redmantauk MCTS:WSS,MOSS,2010 MCITP:2010
    Friday, December 10, 2010 1:25 AM
  • Good Morning ;)

    That doesn't seem to work, either:

    You are right: I am the DBO for those databases. After selecting "join existing farm" I can enter a DB server name. But clicking the "Query database names" button pops up an error message telling me that no configuration database could be found.

    Smilie by GreenSmilies.com

    Friday, December 10, 2010 12:17 PM
  • I can't see what's going on here.  At some point you've managed to successfully create a farm_config db and admincontent_db.  Can you delete those DB's and try again maybe?
    PT_UK http://redmanta.co.uk/blog Twitter: @redmantauk MCTS:WSS,MOSS,2010 MCITP:2010
    Friday, December 10, 2010 1:52 PM
  • Sure, just give me a minute or two...

    I'm very sorry for binding you to this issue so much. I honestly appreciate what you're doing.

    I wonder for how long this SharePoint Server 2010 GA is on the market alright...

    Friday, December 10, 2010 4:29 PM
  • Here's the result: It's the same:

    SharePoint Server 2010 fails to recognize configuration database when joining farm.


    It's basically saying that: "For given 'database server' no existing configuration database can be found. Select another 'database server'. "

     

    Do you believe it could be the dreaded "user does not exist" error when running the PowerShell script:

    SharePoint Server 2010 fails to create configuration database using SharePoint 2010 administration PowerShell.

    Friday, December 10, 2010 4:54 PM
  • I have now installed Active Directory Domain Services...

    Having this role activated it seems everything works fine now... (so far)

    Well it seems, attaching to an existing SQL Server 2008 is not supported without having a domain at hand.

    Tuesday, December 14, 2010 7:33 PM
  • Thats obviously the easiest way but annoying we may never resolve your original issue.


    PT_UK http://redmanta.co.uk/blog Twitter: @redmantauk MCTS:WSS,MOSS,2010 MCITP:2010
    Tuesday, December 14, 2010 8:44 PM
  • Hey Better Today & Paul,

    I'm trying to do this exact thing - Install SP SERVER 2010 on an AWS instance, and having problems with it.

    My problem exists when I install SP Server 2010, the product configuration fails.  I'm okay with doing the standalone install, and SharePoint should automatically install SQL Server Express with it.  So I'm unaware of the issue.

    Do you have any insight into that?  Or can you be more elaborate in the steps you took in activating the roles in Active Directory.

    Thanks,

    Helmut

    Saturday, March 31, 2012 11:45 PM
  • Hi Helmut,

    At exactly what point is the configuration failing?


    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Monday, April 02, 2012 7:34 AM
  • Paul,

    Thanks for the quick reply.

    I've done a few things since my last msg, including an Active Directory Installation.

    Now, when I'm creating a new server farm, I'm getting the following message:

    "Cannot connect to database master SQL server at SP2010.  The database might not exist, or the current user does not have permission to connect to it."

    Note, that I entered the Database server:  SP2010.

    -- Also, I'm looking for SP Server 2010 to install SQL Expess, and from what I see in the program files, it is there.

    Monday, April 02, 2012 10:16 AM
  • Hi Helmut,

    Not sure on your swl setup, (aliases etc if any) but try putting in your ServerName\InstanceName.  If you've allowed SharePoint to install SQL Express, it should be SP2010\SharePoint (providing SP2010 is the servername)


    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Monday, April 02, 2012 10:21 AM
  • Paul,

    What are you referring to with "swl setup, (aliases etc if any)"?

    I'm running the server on AWS EC2, so I'm not sure what the SeverName or Instance Name would be.  I believe they are one in the same.

    Monday, April 02, 2012 10:41 AM
  • Sorry,

    That was a typing error.  "SQL Setup"  Do you have SQL Management Studio installed or can you install it?  If everything has been done as "default" you might be able to put in ".\SharePoint" as the Server\Instance name when running the SharePoint config wizard.  Whatever "server name" you're putting in when configuring sharepoint, just append "\SharePoint" to the end and try again.


    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Monday, April 02, 2012 10:46 AM