none
Word and Excel show locked for editing by 'another user' when opened from File Explorer

Answers

  • Quote:

    There is a public blog on file locking issues (http://blogs.technet.com/b/the_microsoft_excel_support_team_blog/archive/2012/05/14/the-definitive-locked-file-post.aspx). I would suggest the following:

    If you are seeing problems where the file is locked when double clicking from Windows Explorer, but the files open up correctly when opened in Excel or Word, do the following:

    Turn off the Preview Pane, Details Pane and pop ups that show information about file and desktop items

    This is a problem that has been reported to affect Windows 7 clients only, not Windows XP. The problem here may have something to do with the Windows Explorer in Windows 7. We are currently investigating this further and will post more information as it is available.


    In a Windows Explorer window, do the following:

    1. Right click on the Start Button.
    2. Click 'Open Windows Explorer'.
    3. At the top left click Organize > Layout
    4. Uncheck Details Pane and Preview Pane.

    5. On a Windows menu, click on Tools > Folder Options. In the box that opens up, click on the View tab. Scroll down the list to “Show pop-up description for folder and desktop items” and clear the checkbox and then click OK.

    If you are seeing issues where the wrong user name is showing up, there is a known bug on that and a fix:

    In cases where the wrong user name is displayed in the file lock dialog

    Sometimes where it says 'another user' it has the name of someone that didn't open the file or it has no name at all. Just a big ' ' where a name ought to be. Fear not, there is a fix for this problem. The flavor depends on whether you have Excel 2010 or Excel 2007. The below KB Articles contain hotfixes that address several issues, not just the file locked issue. But in the dialog of the article you will see this as one of the problem descriptions:

    Assume that you have an .xls file that is protected by Information Rights Management (IRM) on a network share. When you open the file in Excel 2007, a File In Use dialog box appears. However, the dialog box does not display the correct name of the user who locked the file. Therefore, you cannot edit the file.

    Understand that these fixes don't make the File in Use dialog go away, they just correct the problem of showing bogus user name information on the dialog itself.

    Excel 2007 - http://support.microsoft.com/kb/2598133

    Excel 2010 - http://support.microsoft.com/kb/2598143


    Will Buffington
    Microsoft Excel Support


    Max Meng

    TechNet Community Support

    • Marked as answer by bhstang65 Friday, June 08, 2012 9:35 PM
    Wednesday, June 06, 2012 4:41 AM
    Moderator

All replies

  • Check if this will help:

    "Unexpected File Lock by <user>" saving or opening shared workbooks on network location

    http://blogs.technet.com/b/the_microsoft_excel_support_team_blog/archive/2012/01/18/quot-unexpected-file-lock-by-lt-user-gt-quot-saving-or-opening-shared-workbooks-on-network-location.aspx

     

    Sincerely,

    Max Meng
    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Thursday, May 31, 2012 3:11 AM
    Moderator
  • Thanks for the reply Max.  I viewed the post and the suggested fixes in 3 and 4 do not apply to our environment.  I added a comment to that post.
    Thursday, May 31, 2012 1:15 PM
  • I'll try to involve someone familiar with this topic to further look at this issue.

    Max Meng

    TechNet Community Support

    Monday, June 04, 2012 4:40 AM
    Moderator
  • Quote:

    There is a public blog on file locking issues (http://blogs.technet.com/b/the_microsoft_excel_support_team_blog/archive/2012/05/14/the-definitive-locked-file-post.aspx). I would suggest the following:

    If you are seeing problems where the file is locked when double clicking from Windows Explorer, but the files open up correctly when opened in Excel or Word, do the following:

    Turn off the Preview Pane, Details Pane and pop ups that show information about file and desktop items

    This is a problem that has been reported to affect Windows 7 clients only, not Windows XP. The problem here may have something to do with the Windows Explorer in Windows 7. We are currently investigating this further and will post more information as it is available.


    In a Windows Explorer window, do the following:

    1. Right click on the Start Button.
    2. Click 'Open Windows Explorer'.
    3. At the top left click Organize > Layout
    4. Uncheck Details Pane and Preview Pane.

    5. On a Windows menu, click on Tools > Folder Options. In the box that opens up, click on the View tab. Scroll down the list to “Show pop-up description for folder and desktop items” and clear the checkbox and then click OK.

    If you are seeing issues where the wrong user name is showing up, there is a known bug on that and a fix:

    In cases where the wrong user name is displayed in the file lock dialog

    Sometimes where it says 'another user' it has the name of someone that didn't open the file or it has no name at all. Just a big ' ' where a name ought to be. Fear not, there is a fix for this problem. The flavor depends on whether you have Excel 2010 or Excel 2007. The below KB Articles contain hotfixes that address several issues, not just the file locked issue. But in the dialog of the article you will see this as one of the problem descriptions:

    Assume that you have an .xls file that is protected by Information Rights Management (IRM) on a network share. When you open the file in Excel 2007, a File In Use dialog box appears. However, the dialog box does not display the correct name of the user who locked the file. Therefore, you cannot edit the file.

    Understand that these fixes don't make the File in Use dialog go away, they just correct the problem of showing bogus user name information on the dialog itself.

    Excel 2007 - http://support.microsoft.com/kb/2598133

    Excel 2010 - http://support.microsoft.com/kb/2598143


    Will Buffington
    Microsoft Excel Support


    Max Meng

    TechNet Community Support

    • Marked as answer by bhstang65 Friday, June 08, 2012 9:35 PM
    Wednesday, June 06, 2012 4:41 AM
    Moderator
  • Hi,

    Have you read my last reply?


    Max Meng

    TechNet Community Support

    Thursday, June 07, 2012 8:22 AM
    Moderator
  • Turning off Preview and Details pane did the trick.  I will be interested in the permenant fix when available.

    Thanks for the info. 

    Friday, June 08, 2012 9:37 PM
  • Turning off Preview and Details pane did the trick.  I will be interested in the permenant fix when available.

    Thanks for the info. 


    Nice, same here! Thanks for the tip.
    Thursday, December 13, 2012 12:54 PM
  • I needed to turn off Preview and Details Pane, as well as turning off "Show pop-up description for folder and desktop items", and that then allows these files to be opened with out the file locked message.

    This is a workaround though; not a fix.

    It's a bit of a pain this problem as I'm reluctant to deploy any more Windows 7 PCs until this is fixed properly.  The affected Win7 PCs are fully patched, so I look forward to a fix for this problem very soon.

    Monday, December 17, 2012 4:32 PM
  • I had the same issue. I was able to fix it after coming across this:

    http://answers.microsoft.com/en-us/office/forum/office_2007-excel/weird-file-in-use-error-opening-excel-2007-files/887e002d-1158-4a0b-9de8-931e473469d8

    I ran the registry fix from that forum and it is fixing all of the issues we have had with the same error. From what the forum says I think the user is locking the file for editing with the fist click, and when you try to open it with the second click you get the error.(a bug with Windows explorer/ Excel)

    I hope it works for you too.

    Jason


    Here is the regedit:

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
    "ShowInfoTip"=dword:00000000


    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Modules\GlobalSettings\Sizer]
    "PreviewPaneSizer"=hex:35,00,00,00,00,00,00,00,00,00,00,00,bd,02,00,00
    "ReadingPaneSizer"=hex:04,01,00,00,00,00,00,00,00,00,00,00,64,02,00,00


    • Proposed as answer by Under Zero Monday, March 18, 2013 9:37 PM
    • Edited by Under Zero Monday, March 18, 2013 9:39 PM
    Monday, March 18, 2013 9:37 PM
  • Hi All,

    I came across a similar issue, where Excel 2003 users were getting "File is locked by user " " ".

    It seemed to be down to a particular file rather than a general issue, and it was only when I investigated further that I found that the user had ticked the Privacy option!

    If you look in Tools / Options / Security tab and then tick the box for "Privacy Options", not only does it "remove personal information from file properties on save" but it's overly keen and won't tell you who's locking it out when the file's being shared!

    Hope this helps anyone else who comes across this issue!  :-)

    Thursday, November 28, 2013 12:38 PM
  • My company is using Excel 2010 and is current on all Office updates, but still experiencing the issue of wrong user name displayed in the file lock dialog box.  I tried installing the kb/2598143 update, but each Windows 7 system already had the update.  Any other suggestions? 
    Friday, December 27, 2013 3:41 PM
  • hi,

    To resolve this problem, run GPEDIT.MSC and navigate to Computer Configuration > Administrative Templates > Terminal Services and set the "Use temporary folders per session" to 'disabled'. This will prevent the environment variables from being modified and Office files should be able to save to the location you specify

    Thanks
    Jaison A
    http://infomoss.blogspot.in

    Thursday, April 03, 2014 9:57 AM