none
'Check Spelling As You Type' Does not Work in Word 2010

    Question

  • Hello,

    We have a 2008 R2 terminal server with Office 2010 installed.  We rolled out Office 2010 to the environment using the OCT.  In only Word, checking spelling as you type has a huge delay (approximately 45 seconds to 1 minute for each word).  We've checked all settings and have tried various fixes including disabling all add-ons, disabling contextual based spell check, ensuring all language and keyboard settings are in English...but none have helped.

    When starting Word with the /safe switch, this feature works perfectly.  Any ideas? 

    Thanks,

    Marcus

     

    Thursday, July 29, 2010 3:35 PM

All replies

  • Hi Marcus,

    If it works fine in safe mode, I think this issue is caused by add-ins.

    You mentioned you have tried to disable all add-ins, I guess you do this within COM Add-Ins under File->Options->Add-Ins, RIGHT?

    It is a way to disable COM Add-ins, that only works if these add-ins are referenced in HKCU( HKEY_CURRENT_USER\ SOFTWARE\Microsoft\Office\14.0\Word\Addins ); if they're in HKLM,  then you have to manually remove the key from HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\Word\Addins.

    The individual available add-ins are listed in the Addins subkeys. Within each Add-ins subkey is a property called LoadBehavior. This property has two possible values: 2 to disable or disconnect the add-in and 3 to enable the add-in.

    Hope it helps.

    Friday, July 30, 2010 7:06 AM
    Moderator
  • Hi Jennifer,

    Thanks for your response. 

    Corerct, we disabled the COM Add-ins via the options -> Add-ins menu and removed items that had load at start-up as behavior.

    Under HKCU, there is no key for add-ins under HKCU...\14.0\Word\Addins.  There is, however, a OneNote key under HKCU...\Office\Word\Addins and I've set LoadBehavior to '2' but it did not help.

    There are no type of addin keys under HKLM.

    Still at a loss - what's even weirder is another terminal server built as the same time in this environment that is nearly identical is not exhibiting this behavior. 

    Thank you for your assistance and any further ideas/troubleshooting tips would be appreciated. 

    Marcus

    Friday, July 30, 2010 7:36 PM
  • Anyone find an answer for this? we're experiencing similar issues in our environment using Word 2010

    Tuesday, November 08, 2011 6:20 PM
  • Anyone find an answer for this? we're experiencing similar issues in our environment using Word 2010
     
     
    Have you tried the suggestions made in this thread? There is certainly not a general issue with spellchecking in Word 2010.

    Stefan Blom, Microsoft Word MVP
    Tuesday, November 08, 2011 6:45 PM