none
cannot send email with microsoft outlook 2010 (64 bit) from Adobe ; outlook not recognised as default email client

    Question

  • Running windows 7 and outlook 2010 (64 bit) . Cannot send email from either Adobe Acrobat 9  or Adobe Readre 9 as outlook is not recognised by them as the default email client. Oulook is set up as default email client
    • Moved by Stephanie Perez [MSFT] Monday, October 04, 2010 8:49 PM (From:Microsoft Online Services Customer Portal)
    • Moved by Jennifer ZhanModerator Tuesday, October 05, 2010 2:05 AM (From:Office 2010 Setup and Deployment)
    Monday, October 04, 2010 3:18 PM

Answers

  • Turns out there is a workaround method. Microsoft had warned about 32 bit APIs not working with 64 bit office, but here's a fancy "trick". This will require a registry hack, so back up your registry before you try it. The object is to create a pseudo client, point it at some 32-bit dlls and let it talk to Outlook 2010' I got the info here:

    http://thedailyreviewer.com/outlook/view/cant-send-mail-from-32-bit-applications-office-2010-64-bit-r-104715645

     

    Run REGEDIT and goto:

     

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail]

    Right-click and create a new key called Outlook64Bridge

    Then right-click Outlook64Bridge and create two keys under it DLLPath and DLLPathEx

     

    Find the 32 bit version of the file MAPI32.dll and assign the whole qualified pathname to each key, mine were:

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Outlook64Bridge\DLLPath

    "D:\WINDOWS\system32\mapi32.dll"

    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Outlook64Bridge\DLLPathEx

    "D:\WINDOWS\system32\mapi32.dll"

     

    Then go back to the root key name and show the default client as Outlook64Bridge

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail

    "Outlook64Bridge"

     

    Works like a charm

     

     


    ---Mike
    Thursday, November 18, 2010 10:39 PM

All replies

  • Hi,

    Try to change program defaults. Set Outlook as default email program and Acrobat as default for .pdf files. Follow the links given below to set the default programs for your computer.

    Change which programs Windows uses by default

    http://windows.microsoft.com/en-us/windows7/Change-which-programs-Windows-uses-by-default

    Set Program Access and Computer Defaults: frequently asked questions

    http://windows.microsoft.com/en-US/windows7/Set-Program-Access-and-Computer-Defaults-frequently-asked-questions

    Also you can try to create a bookmark then delete it, and then Send PDF as email attachment to have a try.

     

    Hope that helps.

    Tuesday, October 05, 2010 2:31 AM
  • Doesn't help Outlook is already set as the default client is the places you refer to. The issue goes deeper something with how the MAPI funtionality has changed.
    Friday, October 15, 2010 5:15 PM
  • I have the same issue, but I am not sure of the problem. I have tried using a few other applications besides Acrobat and they also fail to find a MAPI client. I also changed the default from Outlook to Thunderbird and the system can't find Thunderbird either. I switched back and it still can't find Outlook. The error message says: --------------------------- Microsoft Office Outlook --------------------------- Either there is no default mail client or the current mail client cannot fulfill the messaging request. Please run Microsoft Outlook and set it as the default mail client. --------------------------- OK ---------------------------
    ---Mike
    • Proposed as answer by Praising Jesus Thursday, November 18, 2010 10:17 PM
    Thursday, November 18, 2010 9:48 PM
  • Turns out there is a workaround method. Microsoft had warned about 32 bit APIs not working with 64 bit office, but here's a fancy "trick". This will require a registry hack, so back up your registry before you try it. The object is to create a pseudo client, point it at some 32-bit dlls and let it talk to Outlook 2010' I got the info here:

    http://thedailyreviewer.com/outlook/view/cant-send-mail-from-32-bit-applications-office-2010-64-bit-r-104715645

     

    Run REGEDIT and goto:

     

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail]

    Right-click and create a new key called Outlook64Bridge

    Then right-click Outlook64Bridge and create two keys under it DLLPath and DLLPathEx

     

    Find the 32 bit version of the file MAPI32.dll and assign the whole qualified pathname to each key, mine were:

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Outlook64Bridge\DLLPath

    "D:\WINDOWS\system32\mapi32.dll"

    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Outlook64Bridge\DLLPathEx

    "D:\WINDOWS\system32\mapi32.dll"

     

    Then go back to the root key name and show the default client as Outlook64Bridge

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail

    "Outlook64Bridge"

     

    Works like a charm

     

     


    ---Mike
    Thursday, November 18, 2010 10:39 PM
  • Turns out there is a workaround method. Microsoft had warned about 32 bit APIs not working with 64 bit office, but here's a fancy "trick". This will require a registry hack, so back up your registry before you try it. The object is to create a pseudo client, point it at some 32-bit dlls and let it talk to Outlook 2010' I got the info here:

    http://thedailyreviewer.com/outlook/view/cant-send-mail-from-32-bit-applications-office-2010-64-bit-r-104715645

     

    Run REGEDIT and goto:

     

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail]

    Right-click and create a new key called Outlook64Bridge

    Then right-click Outlook64Bridge and create two keys under it DLLPath and DLLPathEx

     

    Find the 32 bit version of the file MAPI32.dll and assign the whole qualified pathname to each key, mine were:

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Outlook64Bridge\DLLPath

    "D:\WINDOWS\system32\mapi32.dll"

    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Outlook64Bridge\DLLPathEx

    "D:\WINDOWS\system32\mapi32.dll"

     

    Then go back to the root key name and show the default client as Outlook64Bridge

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail

    "Outlook64Bridge"

     

    Works like a charm

     

     


    ---Mike

     

    Thanks Mike - it does 'works like a charm'!!

    Took care of my problem that I had with Acrobat!

    Sunday, November 21, 2010 5:07 PM
  • Excellent instructions...It works flawlessly. I know how troublesome can be waiting for a 64bit mail client update from MS.

    Thanks!!!

    Saturday, December 04, 2010 12:11 AM
  • I've looked for WEEKS for a solution many of us are experiencing like this. THANK YOU for relaying this, Mike. It works great.

     

     

    Wednesday, December 08, 2010 9:21 PM
  • I couldn't get my Adobe Professional to automatically "call" Outlook 2010 (64-bit) which was very annoying...

     

    Thanks!!!!  This Rocks!!!

     

    Charles

    Thursday, December 23, 2010 10:10 PM
  • I having a bit of trouble, maybe im doing this wrong. Under the DLLpath & DLLpathex on the right what am i adding there, a string value, binary value, etc. or am i editing "(default)" already located under the new key.

    Also, same question below. What am i changing to "Outlook64bridge"

    Then go back to the root key name and show the default client as Outlook64Bridge

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail

    "Outlook64Bridge"

    Tuesday, December 28, 2010 11:13 AM
  • I having a bit of trouble, maybe im doing this wrong. Under the DLLpath & DLLpathex on the right what am i adding there, a string value, binary value, etc. or am i editing "(default)" already located under the new key.

    Also, same question below. What am i changing to "Outlook64bridge"

    Then go back to the root key name and show the default client as Outlook64Bridge

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail

    "Outlook64Bridge"

         For DLLpath and DLLPathex you should be adding strings. 

        You need to change the Default key for HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail to the string value "Outlook64Bridge".

    Saturday, January 01, 2011 1:40 AM
  • First of all, thank you very much for this post.  I really want to use Office 2010 64bit in my terminal server environment, which will hopefully run more efficiently.  

    I believe I'm having the same problem that ruirib is having. I was also a little unclear on the structure in the Outlook64Bridge folder.  I changed the default value of Mail to Outlook64Bridge. I created the Outlook64Bridge folder, under Mail. I then created two REG_SZ keys in the Outlook64Bridge folder, DLLPath and DLLPathEx.  I have tried both "C:\Windows\system32\mapi32.dll" and "C:\Windows\winsxs\x86_microsoft-windows-mapi_31bf3856ad364e35_6.1.7600.16385_none_ab2397727b134496\mapi32.dll" as the value of those keys.  I still have a problem running it.  I'm using Adobe Acrobat Pro 8.25, running on Windows Server 2008 R2 (Windows 7 basically), and Office 2010 64-bit.  When I go to click the envelope icon within adobe, the program crashes.  Do you think adobe 9 would work, or is it something about the registry keys?

    Jon Wooten

    System Administrator

    Wednesday, January 05, 2011 10:11 PM
  • Something else I should mention...if I don't have these registry keys in there, then I just get the message about not having a default mail client.  That was the original symptom.

     

    Jon Wooten

    Sys admin

    Wednesday, January 05, 2011 10:13 PM
  • Amazing! where were you until now? or better said, where was I?
    Wednesday, January 12, 2011 4:49 PM
  • I've got everthing setup as described.  However Acrobat is crashing with "Acrobat 9.0 has stopped working" error message.  Any ideas?

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Outlook64Bridge]

    "DLLPathEx"="c:\\Windows\\winsxs\\x86_microsoft-windows-mapi_31bf3856ad364e35_6.1.7600.16385_none_ab2397727b134496\\MAPI32.DLL"
    "DLLPath"="c:\\Windows\\winsxs\\x86_microsoft-windows-mapi_31bf3856ad364e35_6.1.7600.16385_none_ab2397727b134496\\MAPI32.DLL"

     

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail]
    @="Outlook64Bridge"

    Wednesday, January 19, 2011 7:02 PM
  • This works a treat - Many thanks!
    Tuesday, January 25, 2011 3:36 PM
  • How do I assign a pathname to a key?

    Friday, February 04, 2011 2:39 AM
  • Mike you are the best - Worked great!!!
    SANSTECH
    Thursday, March 17, 2011 7:16 PM
  • Worked perfectly.  Thank you.
    Friday, March 25, 2011 5:40 PM
  • This image may help you or others
    Monday, March 28, 2011 2:05 PM
  • Hi,

     

    Can anybody help me ? I can't get the fix to work. I've imported all the new keys into the registry but i still keep the error message no default mail client is setup ?

    I am using W7 64 bit with Office 2010 64-bit with Adobe Reader X:

     

    http://postimage.org/image/7mghhqp0/

    http://postimage.org/image/7o5odkys/

     

     

    What am i doing wrong ?

     

    thank you,

     

    Olivier

    Sunday, April 03, 2011 10:56 AM
  • I feel like there are some steps missing here.

    How do you create a path name in the registry? Please someone fiill in the blanks here?

     

    Friday, April 08, 2011 9:12 PM
  • Could you supply screen shots of your registry. Seems like there are missing steps? Exactly what type of keys need to be made to add a data path?

     

    Thanks.

    Friday, April 08, 2011 9:15 PM
  • Obviously this has not been tested by Microsoft as these suggestion do not work
    Monday, April 18, 2011 1:09 AM
  • I think it does work, granted I'm still working on getting this reg hack in through GPO, but Acrobat was crashing when it started Outlook, because outlook was asking if it should be the default email client.  I think acrobat can't handle the dialog.  After clicking yes it seems to work, but I have to test further to see if it sticks etc...
    SGS
    Thursday, April 28, 2011 9:00 PM
  • I have found that the regedit solution proposed above works very well.  I have CS3 sitting on Windows 7 Home Premium x64 with Office 2010 installed.  Although I did have to alter the instructions ever so slightly, see below...

    Run REGEDIT and goto: 

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail]

    Right-click and create a new key called Outlook64Bridge

    Then highlight the Outlook64Bridge in the tree view on the left and right click in the window to the right and create two strings called DLLPath and DLLPathEx.  Leave the (Default) string alone.

    Find the 32 bit version of the file MAPI32.dll and assign the whole qualified pathname to each strings data value, mine was:

    "C:\Windows\System32\mapi32.dll"

    Then go back to the root key name and show the default client as Outlook64Bridge 

    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail

    "Outlook64Bridge"

    I made sure to close out of Outlook and Adobe then I opened up a pdf and tried using both the Mail To icon and also tried using the Send To button on a fill in form and both succeeded.

    Wednesday, May 04, 2011 2:34 PM
  • Beautiful!!!! Works like a charm.
    Wednesday, June 15, 2011 6:01 PM
  • Sadly not working like a charm for me.

    I have made these reg changes however I can not get this fix to work. It must be users error on my end.  This is what I am looking like right now:

    I have the paths set in DLLPath/DLLPathEx to C:\Windows\System32\mapi32.dll (no "") and mail default has been set to Outlook64Bridge. I have restarted a few times but out of ideas. Any input on this subject would be good. I followed the above steps.

    Dathan

    Wednesday, June 15, 2011 9:42 PM
  • Does work like a charm!!  Thank you so much for the info and the fabulous detailed instructions.

     

    YOU ROCK!!!

    Thursday, June 16, 2011 3:01 PM
  • Worked perfectly until Acrobat update to 10.1. Now I cannot get it to work at all. Ideas?
    Monday, June 20, 2011 6:45 PM
  • Maybe it is not compatible with the following Adobe kb.

    This was updated 8 days ago.  Check if it is perhaps working without the hack with Acrobat 10.1?

    http://kb2.adobe.com/cps/882/cpsid_88296.html

     

    regards

    Tuesday, June 21, 2011 10:37 AM
  • Issue setting Office 2010 64bit as the default mail client was "partly" solved in my environment. After installing Office 2010 Service Pack 1, today 06/30, via Windows Update. I can now set Outlook as my default mail client. I can use the Send To -> Email recipient function via File Explorer that I could not use before.  I just tested sending a pdf file via the Adobe Reader X interface and  it still fails. Almost there.

    Thursday, June 30, 2011 12:42 PM
  • I have try above instruction, but did not work, so I try many combinatoin and finally has make it work. instead of use the mapi32.dll I change it to olmapi32.dll, (I copy the string from the DLLPathex of the "microsoft outlook" key, but use full path no "~") and also chage the defaul of [HKEY_LOCAL_USER\SOFTWARE\Clients\Mail] to Outlook64Bridge.

    Hope this work for others.

    • Proposed as answer by Bill Nguyen Friday, September 23, 2011 8:58 PM
    Thursday, June 30, 2011 8:16 PM
  • This is also no longer working for us with 7 SP1 x64, Office 2010 SP1 x64, and Reader 10.1. 

     

    Has anyone had success with this running the above setup? Seems like something the fix was doing broke in either the Office SP1 update or Adobe's 10.1 version (which supposedly includes a native 64bit PDMaker add-in). 

    Tuesday, July 05, 2011 6:51 PM
  • We have been trying to change the registry keys but it is still not working...

     

    we have a terminal server with office2010 and adobe acrobat reader 10.0.1 and no user can send a pdf by email from within adobe reader. they all have to "save as..." the pdf file and then attach manually the file. this is really anoying !!!

    can someone at microsoft or adobe keep this thread updated with an official feedback ?

     

    Steve


    Steve
    Wednesday, July 13, 2011 8:07 AM
  • Works with latest MS Office patches and Adobe Acrobat patches...

    HKLM is not the way to handle this...use HKCU instead.

    You need the whole key and subkeys from HKLM\Software\Clients\Mail\Microsoft Outlook.

    Based on what I have discovered:

    No Default E-mail Client is due to the way Adobe reads the default profile (it can't handle the space between Microsoft Outlook). Thus Outlook64Bridge is the profile to use.

    Adobe crashing is due to the lack of the remaining keys and subkeys...

    NOTE: if you use the Outlook64Bridge as the profile or anything but Microsoft Outlook, you will also need to uncheck the option in Outlook to check for the default mail client and set it to stop prompting the user. 


    Here is the code I used [Note: You should script this so it only does this on 64-Bit OSes with MS Office 2010 (64-Bit) and Adobe Acrobat or Adobe Creative Suite installed]
    REG COPY "HKLM\SOFTWARE\Clients\Mail\Microsoft Outlook" "HKCU\SOFTWARE\Clients\Mail\Outlook64Bridge" /s /f 2>&1>NUL:
    REG ADD "HKCU\SOFTWARE\Clients\Mail\Outlook64Bridge" /v "" /t REG_SZ /d "Outlook64Bridge" /f 2>&1>NUL:
    REG ADD "HKCU\SOFTWARE\Clients\Mail" /v "" /t REG_SZ /d "Outlook64Bridge" /f 2>&1>NUL:
    REG ADD "HKCU\SOFTWARE\Microsoft\Office\14.0\Outlook\Options\General" /v "Check Default Client" /t REG_DWORD /d "0" /f 2>&1>NUL:
    

    Good Luck!
    • Proposed as answer by ngraae Monday, August 22, 2011 1:30 PM
    Wednesday, August 10, 2011 3:52 PM
  • Works with latest MS Office patches and Adobe Acrobat patches...

    HKLM is not the way to handle this...use HKCU instead.

    You need the whole key and subkeys from HKLM\Software\Clients\Mail\Microsoft Outlook.

    Based on what I have discovered:

    No Default E-mail Client is due to the way Adobe reads the default profile (it can't handle the space between Microsoft Outlook). Thus Outlook64Bridge is the profile to use.

    Adobe crashing is due to the lack of the remaining keys and subkeys...

    NOTE: if you use the Outlook64Bridge as the profile or anything but Microsoft Outlook, you will also need to uncheck the option in Outlook to check for the default mail client and set it to stop prompting the user. 


    Here is the code I used [Note: You should script this so it only does this on 64-Bit OSes with MS Office 2010 (64-Bit) and Adobe Acrobat or Adobe Creative Suite installed]
    REG COPY "HKLM\SOFTWARE\Clients\Mail\Microsoft Outlook" "HKCU\SOFTWARE\Clients\Mail\Outlook64Bridge" /s /f 2>&1>NUL:
    REG ADD "HKCU\SOFTWARE\Clients\Mail\Outlook64Bridge" /v "" /t REG_SZ /d "Outlook64Bridge" /f 2>&1>NUL:
    REG ADD "HKCU\SOFTWARE\Clients\Mail" /v "" /t REG_SZ /d "Outlook64Bridge" /f 2>&1>NUL:
    REG ADD "HKCU\SOFTWARE\Microsoft\Office\14.0\Outlook\Options\General" /v "Check Default Client" /t REG_DWORD /d "0" /f 2>&1>NUL:
    

    Good Luck!

    This fix doesn't work in our domain environment.

    We are on Windows 7 64bit.
    We are running office 2010 64bit (with SP1).
    We are using Adobe Reader 10.1

    Does anyone have any suggestions?

    Thanks,
    Luc

    Friday, August 12, 2011 12:37 PM
  • I attempted to use the regedit solution, as outlined above, when I had Adobe Reader 9 installed, and it worked great.  As soon as I upgraded to Reader 10, the problem came back, even with the regedit edits still in place.  Is there a fix for Reader 10, or do I need to go back to 9?
    Friday, August 19, 2011 3:19 AM
  • Works beautifully!

    The old workaround based on HKLM ceased to function after Win7-64bit SP1 was loaded. 

    But this (essentially) same workaround based on HKCU works perfectly!!

    Monday, August 22, 2011 1:32 PM
  • Works with latest MS Office patches and Adobe Acrobat patches...

    HKLM is not the way to handle this...use HKCU instead.

    You need the whole key and subkeys from HKLM\Software\Clients\Mail\Microsoft Outlook.

    Based on what I have discovered:

    No Default E-mail Client is due to the way Adobe reads the default profile (it can't handle the space between Microsoft Outlook). Thus Outlook64Bridge is the profile to use.

    Adobe crashing is due to the lack of the remaining keys and subkeys...

    NOTE: if you use the Outlook64Bridge as the profile or anything but Microsoft Outlook, you will also need to uncheck the option in Outlook to check for the default mail client and set it to stop prompting the user. 


    Here is the code I used [Note: You should script this so it only does this on 64-Bit OSes with MS Office 2010 (64-Bit) and Adobe Acrobat or Adobe Creative Suite installed]
    REG COPY "HKLM\SOFTWARE\Clients\Mail\Microsoft Outlook" "HKCU\SOFTWARE\Clients\Mail\Outlook64Bridge" /s /f 2>&1>NUL:
    REG ADD "HKCU\SOFTWARE\Clients\Mail\Outlook64Bridge" /v "" /t REG_SZ /d "Outlook64Bridge" /f 2>&1>NUL:
    REG ADD "HKCU\SOFTWARE\Clients\Mail" /v "" /t REG_SZ /d "Outlook64Bridge" /f 2>&1>NUL:
    REG ADD "HKCU\SOFTWARE\Microsoft\Office\14.0\Outlook\Options\General" /v "Check Default Client" /t REG_DWORD /d "0" /f 2>&1>NUL:
    

    Good Luck!

    This fix doesn't work in our domain environment.

    We are on Windows 7 64bit.
    We are running office 2010 64bit (with SP1).
    We are using Adobe Reader 10.1

    Does anyone have any suggestions?

    Thanks,
    Luc

    Confirmed.

    Does NOT work with:
    Windows 7 64 bit (with SP1)
    Office 2010 64 bit (with SP1)
    Adobe Reader 10.1

     

     

    Tuesday, August 23, 2011 8:44 PM

  • Anyone else know how to get this to work with latest 64bit Windows and Office with all the latest patches?  I'm pretty sure it's possible with the right registry settings. ....[Note: You should script this so it only does this on 64-Bit OSes with MS Office 2010 (64-Bit) and Adobe Acrobat or Adobe Creative Suite installed]
    REG COPY "HKLM\SOFTWARE\Clients\Mail\Microsoft Outlook" "HKCU\SOFTWARE\Clients\Mail\Outlook64Bridge" /s /f 2>&1>NUL:
    REG ADD "HKCU\SOFTWARE\Clients\Mail\Outlook64Bridge" /v "" /t REG_SZ /d "Outlook64Bridge" /f 2>&1>NUL:
    REG ADD "HKCU\SOFTWARE\Clients\Mail" /v "" /t REG_SZ /d "Outlook64Bridge" /f 2>&1>NUL:
    REG ADD "HKCU\SOFTWARE\Microsoft\Office\14.0\Outlook\Options\General" /v "Check Default Client" /t REG_DWORD /d "0" /f 2>&1>NUL:
    
    Good Luck!

    This fix doesn't work in our domain environment.

    We are on Windows 7 64bit.
    We are running office 2010 64bit (with SP1).
    We are using Adobe Reader 10.1

    Does anyone have any suggestions?

    Thanks,
    Luc

    Confirmed.

    Does NOT work with:
    Windows 7 64 bit (with SP1)
    Office 2010 64 bit (with SP1)
    Adobe Reader 10.1

    Also confirmed.  I can also confirm the previous suggested method causes the adobe to crash as well (since 64bit Office 2010 SP1 update).  At least the problems and failed solutions are reproducible. 

    Anyone else know how to get this to work with latest 64bit Windows and Office with all the latest patches?  I'm pretty sure it's possible with the right registry settings.

    • Edited by mkanet2 Friday, September 23, 2011 3:45 PM
    Friday, September 23, 2011 3:44 PM
  • I have try above instruction, but did not work, so I try many combinatoin and finally has make it work. instead of use the mapi32.dll I change it to olmapi32.dll, (I copy the string from the DLLPathex of the "microsoft outlook" key, but use full path no "~") and also chage the defaul of [HKEY_LOCAL_USER\SOFTWARE\Clients\Mail] to Outlook64Bridge.

    Hope this work for others.

    This is the answer for me.

    It works on Windows 2008 R2, RDS mode! We have Adobe 9.x and MS Office 2010 64-bit installed.

    I tested successfully on the server itself and on couple RDS client sessions!

    The full path for DLLPath and DLLPathEx:

    C:\PROGRAM FILES\MICROSOFT OFFICE\Office14\OLMAPI32.DLL

     

    Thanks a lot, LTmoumimi!

    Bill

    Friday, September 23, 2011 9:01 PM
  • I faced the same problem and removing the hot key did not help.

    So, here is what remedied my 64 bit problem.

     

    1.   Back up your .pst files. There is a free automated backup program like Backup PST to help.

    2.   After the backup, uninstall the Office program through the Control Panel.

    3.   Use a disc cleanup program to eliminate all the registry errors.

    4.   Re-install Office.

     

    Outlook now operates just as it did the first time I installed the program.

    This should work for everyone.

     

    K9Dogman

    Wednesday, October 19, 2011 1:49 AM
  • It simply worked.  Thanks!

    Friday, October 28, 2011 3:14 PM
  • I have been struggling with this for a while with no success (until now).

    I tried all of the registry changes and MAPI32.DLL paths in HKLM and HKCU.  Nothing worked.  The closest I got was making Adobe Reader crash when I hit the submit button.

    We eventually tried to update Reader to the latest version (from 9.4.4 to 10.1.1).  We ripped out all of the added Outlook64Bridge stuff in the registry and....it works.

    I don't know if everyone else will have my success, but this was the only thing that worked for me.

    Win 7 64-bit Enterprise

    Adobe Reader 10.1.1

    Office/Outlook 2010 64-bit

    Thursday, November 03, 2011 2:16 PM
  • This fix worked for me with 64-bit Outlook and Acrobat X. Thanks Mike!
    • Proposed as answer by GrayRider Saturday, March 03, 2012 4:40 PM
    • Unproposed as answer by GrayRider Saturday, March 03, 2012 4:40 PM
    Tuesday, January 24, 2012 7:02 PM
  • Worked For Me:  Adobe Acrobat X Pro could not "share" created .pdf file via e-mail (would not open Outlook 2007 to attach or send e-mail.)  Would lock-up both Outlook and Adobe Acrobat X Pro.  I assumed that Outlook was not being detected as default e-mail program, although it is the only one I have installed following a clean install of Windows 7.  (Noted that within Outlook and from Windows 7, it was allegedly the default e-mail)  

    I know most of this thread concerned Office 2010 64-bit, but maybe my solution would apply.

    1.  In CONTROL PANEL/PROGRAMS, DEFAULT PROGRAMS, ASSOCIATE A FILE TYPE OR PROGRAM WITH A PROTOCOL, changed ".mapimail" from "No Extension or Protocol Selected" to instead point to "Microsoft Office Outlook" via "Change Program" box, to point to in my case to "C:\Program Files (x86)\Microsoft Office\Office12\Outlook"

    2.  Opened Registry Editor (REGEDIT), and after backing up Registry (I am always a chicken using that program), navigated to the following Registry Key:  HKEY Local Machine/Software/Clients/Mail, and deleted the keys for folders  "Microsoft Outlook" and "Windows Mail." (I didn't install or use the latter.) 

    3.  In CONTROL PANEL/PROGRAMS/PROGRAMS AND FEATURES/UNINSTALL A PROGRAM selected "Change" for "Microsoft Professional Plus 2007", which would then "re-build" the now missing Outlook registry keys deleted above. (At least for Outlook.)  (Also, I did not delete the installation files when I originally installed Office 2007, you may need your installation disc if you did.)

    4.  From within Adobe Acrobat X Pro, under "Help", selected "Repair Acrobat Installation."

    After that, I can attach .pdf files and share via e-mail from within Acrobat X, which opens Outlook 2007 and places the .pdf file as an attachment.  Works like it should do, and I am happy.

    Windows 7 64-bit, Adobe Acrobat X Pro, Microsoft Office 2007 32-bit. 

     

     

    Saturday, March 03, 2012 5:16 PM
  • Doesn't work for me.
    Friday, April 06, 2012 7:53 AM
  • Thanks for the solution.. It Worked like a CHARM...
    Wednesday, April 18, 2012 12:55 PM
  • Thanks, Works a treat.
    Friday, May 11, 2012 2:10 AM
  • Thanks a lot Mike! After struggling for a while, and nearly giving it up, took your advice, and it works perfectly for me...
    Monday, June 04, 2012 5:01 AM
  • Turns out there is a workaround method. Microsoft had warned about 32 bit APIs not working with 64 bit office, but here's a fancy "trick". This will require a registry hack, so back up your registry before you try it. The object is to create a pseudo client, point it at some 32-bit dlls and let it talk to Outlook 2010' I got the info here:

    http://thedailyreviewer.com/outlook/view/cant-send-mail-from-32-bit-applications-office-2010-64-bit-r-104715645

     

    Run REGEDIT and goto:

     

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail]

    Right-click and create a new key called Outlook64Bridge

    Then right-click Outlook64Bridge and create two keys under it DLLPath and DLLPathEx

     

    Find the 32 bit version of the file MAPI32.dll and assign the whole qualified pathname to each key, mine were:

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Outlook64Bridge\DLLPath

    "D:\WINDOWS\system32\mapi32.dll"

    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Outlook64Bridge\DLLPathEx

    "D:\WINDOWS\system32\mapi32.dll"

     

    Then go back to the root key name and show the default client as Outlook64Bridge

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail

    "Outlook64Bridge"

     

    Works like a charm

     

     


    ---Mike

    works for me like a charm

    but the istruction are not so clear.

    like another user reported create two stringo under Outlook64Bridge key.

    regards

    soldc

    Wednesday, June 13, 2012 8:07 AM
  • Step-by-Step fix method for people like myself:

    1. Search your computer for REGEDIT (Registry Editor) and run it.
    2. Go to: HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail
    3. Right-click on Mail > highlight New > click on Key and create a new key called Outlook64Bridge
    4. Then right-click Outlook64Bridge >  highlight New > click on Key and create one key called DLLPath; then create the second key called DLLPathEx
    5. Find the 32 bit version of the file MAPI32.dll (on my computer it is here: C:\WINDOWS\system32\mapi32.dll).
    6. Go back to REGEDIT and click on DLLPath > look to the right side of window and right-click on (Default) > click on Modify and type in (including quotation marks) "C:\WINDOWS\system32\mapi32.dll" > click OK. Repeat the same steps for DLLpathEx.
    7. Then go back to Mail and click on it > look to the right side and right-click on (Default) > click on Modify and type in (including quotation marks) "Outlook64Bridge" > click OK.

    You are done!



    Friday, July 20, 2012 1:09 PM
  • Works perfectly thanks Mike !

    PS for anyone out there trying this for the first time Kristof's directions simplify the matter.  However, I wish to add it is import to back up the entire registry first before making any changes as Mike implies.  Here's how under Windows 7 (earlier versions should be the same):

    At the very top of the Registry tree it will show COMPUTER.  Right click on this and choose EXPORT.  Then select a distinct location or create a new folder and call it Registry Backup.  (The Create new folder icon is to the right of the Save In drop down menu). Then save the REG file to this new location.  Note the location (the path) of where you save this REG file in case you need to import the whole registry prior to making any changes.  You can also launch System Restore and create a new Restore point and call it Mail Client Fix or whatever you like as an alternative.

    Friday, August 03, 2012 7:38 PM
  • that does not work for me :-(

    i have a customer with windows server 2008 64 bit, office 2010 64 bit ver. 14.0.6023.1000.

    In Adobe Acrobat Reader 10.1.4 it works,

    but the customer also uses adobe acrobat 9.1.0, and there it does not work. also in another application (special unpublic application) the mail-function does not work.

    in both cases instead of the outlook-windows the windows mail client with new account window popps up.

    i have tested the HKLM und the HKCU Keys without success, also i've tried changing the associated application for .mapimail which GreyRaider mentioned.

    But still no success :-(.

    I tried also a reboot (to be sure, that the changed registry-values will be read)

    i updated the adobe acrobat to 9.2.0 - but also this doesnt help :-(

    does anybody has any other idear what else could be done to solve the problem?


    • Edited by Comfine Monday, November 05, 2012 7:11 PM
    Monday, November 05, 2012 7:11 PM
  • Same for me - does not work
    Wednesday, November 07, 2012 7:05 PM
  • I think SP1 may break this work around fix and could be why it doesn't work for some people. I've just tried this on a fresh build with Office 2010 64bit w/ SP1, and it did not work.
    Tuesday, December 04, 2012 4:02 PM
  • I know this is old topic but for anyone that might still looking for the correct answer.

    Save this in a reg file then run it.

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook]
    @="Microsoft Outlook"
    "DLLPathEx"="C:\\PROGRA~1\\MICROS~1\\Office14\\OLMAPI32.DLL"
    "MSIComponentID"="{FF1D0740-D227-11D1-A4B0-006008AF820E}"
    "MSIInstallOnWTS"=dword:00000000
    "DLLPath"="mapi32.dll"
    "MSIOfficeLCID"=hex(7):4d,00,69,00,63,00,72,00,6f,00,73,00,6f,00,66,00,74,00,\
      5c,00,4f,00,66,00,66,00,69,00,63,00,65,00,5c,00,31,00,34,00,2e,00,30,00,5c,\
      00,43,00,6f,00,6d,00,6d,00,6f,00,6e,00,5c,00,4c,00,61,00,6e,00,67,00,75,00,\
      61,00,67,00,65,00,52,00,65,00,73,00,6f,00,75,00,72,00,63,00,65,00,73,00,00,\
      00,55,00,49,00,4c,00,61,00,6e,00,67,00,75,00,61,00,67,00,65,00,00,00,49,00,\
      6e,00,73,00,74,00,61,00,6c,00,6c,00,4c,00,61,00,6e,00,67,00,75,00,61,00,67,\
      00,65,00,00,00,00,00
    "MSIApplicationLCID"=hex(7):4d,00,69,00,63,00,72,00,6f,00,73,00,6f,00,66,00,74,\
      00,5c,00,4f,00,66,00,66,00,69,00,63,00,65,00,5c,00,31,00,34,00,2e,00,30,00,\
      5c,00,4f,00,75,00,74,00,6c,00,6f,00,6f,00,6b,00,00,00,4c,00,61,00,73,00,74,\
      00,55,00,49,00,4c,00,61,00,6e,00,67,00,75,00,61,00,67,00,65,00,00,00,00,00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Capabilities]
    "ApplicationDescription"="Microsoft Outlook 2010 provides an integrated solution to help you better manage your time and information, connect across boundaries, and remain safer and in control. This comprehensive information and time manager helps you organize and instantly search for the information you need. With Outlook 2010, you can securely share information with coworkers, friends, and family, no matter where they are located. Outlook 2010 makes it easier for you to prioritize and control your time, so you can focus on the things that matter most."

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Capabilities\FileAssociations]
    ".msg"="Outlook.File.msg.14"
    ".eml"="Outlook.File.eml.14"
    ".pst"="Outlook.File.pst.14"
    ".oft"="Outlook.File.oft.14"
    ".hol"="Outlook.File.hol.14"
    ".ics"="Outlook.File.ics.14"
    ".vcf"="Outlook.File.vcf.14"
    ".vcs"="Outlook.File.vcs.14"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Capabilities\StartMenu]
    "Mail"="Microsoft Outlook"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Capabilities\UrlAssociations]
    "mailto"="Outlook.URL.mailto.14"
    "stssync"="Outlook.URL.stssync.14"
    "webcal"="Outlook.URL.webcal.14"
    "webcals"="Outlook.URL.webcal.14"
    "feed"="Outlook.URL.feed.14"
    "outlookfeed"="Outlook.URL.feed.14"
    "outlookfeeds"="Outlook.URL.feed.14"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Envelope]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Envelope\CLSID]
    @="{0006F01A-0000-0000-C000-000000000046}"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Envelope\CurVer]
    @="Outlook.Envelope.14"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\InstallInfo]
    "ReinstallCommand"="C:\\PROGRA~1\\MICROS~1\\Office14\\OUTLOOK.EXE /spadreinstall"
    "HideIconsCommand"="C:\\PROGRA~1\\MICROS~1\\Office14\\OUTLOOK.EXE /spadhideicons"
    "ShowIconsCommand"="C:\\PROGRA~1\\MICROS~1\\Office14\\OUTLOOK.EXE /spadshowicons"
    "IconsVisible"=dword:00000001

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Protocols]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Protocols\mailto]
    @="URL:MailTo Protocol"
    "URL Protocol"=""
    "EditFlags"=hex:02,00,00,00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Protocols\mailto\DefaultIcon]
    @="C:\\PROGRA~1\\MICROS~1\\Office14\\OUTLOOK.EXE,-9403"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Protocols\mailto\shell]
    @="open"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Protocols\mailto\shell\open]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Protocols\mailto\shell\open\command]
    @="\"C:\\PROGRA~1\\MICROS~1\\Office14\\OUTLOOK.EXE\" -c IPM.Note /m \"%1\""

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Protocols\outlookfeed]
    @="URL:Outlook Add RSS Feed"
    "URL Protocol"=""

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Protocols\outlookfeed\DefaultIcon]
    @="C:\\PROGRA~1\\MICROS~1\\Office14\\OUTLOOK.EXE,-9403"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Protocols\outlookfeed\shell]
    @="open"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Protocols\outlookfeed\shell\open]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Protocols\outlookfeed\shell\open\command]
    @="\"C:\\PROGRA~1\\MICROS~1\\Office14\\OUTLOOK.EXE\" /share \"%1\""

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Protocols\outlookfeeds]
    @="URL:Outlook Add RSS Feed"
    "URL Protocol"=""

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Protocols\outlookfeeds\DefaultIcon]
    @="C:\\PROGRA~1\\MICROS~1\\Office14\\OUTLOOK.EXE,-9403"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Protocols\outlookfeeds\shell]
    @="open"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Protocols\outlookfeeds\shell\open]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Protocols\outlookfeeds\shell\open\command]
    @="\"C:\\PROGRA~1\\MICROS~1\\Office14\\OUTLOOK.EXE\" /share \"%1\""

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Protocols\stssync]
    @="URL:Outlook Add Sharepoint Folder"
    "URL Protocol"=""
    "ststypes"=hex(7):63,00,61,00,6c,00,65,00,6e,00,64,00,61,00,72,00,00,00,63,00,\
      6f,00,6e,00,74,00,61,00,63,00,74,00,73,00,00,00,64,00,6f,00,63,00,75,00,6d,\
      00,65,00,6e,00,74,00,73,00,00,00,74,00,61,00,73,00,6b,00,73,00,00,00,64,00,\
      69,00,73,00,63,00,75,00,73,00,73,00,69,00,6f,00,6e,00,73,00,00,00,00,00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Protocols\stssync\DefaultIcon]
    @="C:\\PROGRA~1\\MICROS~1\\Office14\\OUTLOOK.EXE,-9403"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Protocols\stssync\shell]
    @="open"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Protocols\stssync\shell\open]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\Protocols\stssync\shell\open\command]
    @="\"C:\\PROGRA~1\\MICROS~1\\Office14\\OUTLOOK.EXE\" /share \"%1\""

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\shell]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\shell\open]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\shell\open\command]
    @="\"C:\\PROGRA~1\\MICROS~1\\Office14\\OUTLOOK.EXE\" /recycle"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\shell\Properties]
    "MUIVerb"="Proper&ties"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\shell\Properties\command]
    @="rundll32.exe shell32.dll,Control_RunDLL \"C:\\PROGRA~1\\MICROS~1\\Office14\\MLCFG32.CPL\""

     

    Thursday, January 17, 2013 7:21 PM
  • The MSVCP100.dll is corrupt, or incomplete.. needs to have MS VS 2010 C++ Redists: X86  http://www.microsoft.com/en-us/download/details.aspx?id=5555 and x64 http://www.microsoft.com/en-us/download/details.aspx?id=14632  installed to work...

    The problem stems from Adobe Leveraging the Microsoft 2010 C++ Redist - (x86 and x64 needed in this case for the x64 office install) once you install the both the Adobe mail client "send mail" function will work. Adobe is looking for a file MSVCP100.dll (which doesn't exist or is corrupt -- when you don't have both redists installed). A huge BTW...FOXIT reader works either way... (but we don't want to use something other than ADOBE...)

    Wednesday, March 06, 2013 7:44 PM
  • Excellent,  Spent way too much time looking. Works great!
    Sunday, April 14, 2013 5:12 PM
  • Step-by-Step fix method for people like myself:

    1. Search your computer for REGEDIT (Registry Editor) and run it.
    2. Go to: HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail
    3. Right-click on Mail > highlight New > click on Key and create a new key called Outlook64Bridge
    4. Then right-click Outlook64Bridge >  highlight New > click on Key and create one key called DLLPath; then create the second key called DLLPathEx
    5. Find the 32 bit version of the file MAPI32.dll (on my computer it is here: C:\WINDOWS\system32\mapi32.dll).
    6. Go back to REGEDIT and click on DLLPath > look to the right side of window and right-click on (Default) > click on Modify and type in (including quotation marks) "C:\WINDOWS\system32\mapi32.dll" > click OK. Repeat the same steps for DLLpathEx.
    7. Then go back to Mail and click on it > look to the right side and right-click on (Default) > click on Modify and type in (including quotation marks) "Outlook64Bridge" > click OK.

    You are done!



    I am setting up an branch office with

        a) Microsoft Office 2013

        b) Adobe Reader 11.0.3

        c) Windows 7 Pro 64bit SP1 and all security updates as of today... June 8th, 2013

    and can report that using a combination of the above answers finally did the trick. It does work!

    Here is what I did:

    1) Follow PraisingJesus post and quoted Kristof Ok post for clarification to create the necessary Registry entries in HKLM.

    2) Duplicate the procedure using HKEY-CURRENT-USER, thus create registry keys under HKCU

    3) If you still need clarification or learn by pictures like I do, then grab the pics from ozeegers post as a guide to setting Outlook64bridge as default keys in both mail and the newly created keys.

    4) Bookmark this page, then reboot. You could try closing adobe and outlook programs, but best to reboot.

    5) Open Adobe Reader and no more annoying error message for me!

    Saturday, June 08, 2013 4:55 PM
  • I stumbled across the solution by pure accident. I tried everything listed below and to no avail nothing worked. I was having a secondary issue, this was every time I opened Outlook I would get a User Account notice asking if I wanted Outlook to make changes.

    Upon research to eliminate the annoying popup every time I opened Outlook I discovered the solution for both.

    >Right click Outlook

    >Click Properties

    > Uncheck, Compatible with and Administrator.

    No more annoying popup, and this also resulted in seamless emailing PDF's from Adobe 9, 10 and Foxit

    Monday, June 10, 2013 12:23 AM
  • Hi guys, 

    Just thought I would make this easier for everyone.

    After making a backup of your registry like suggested.

    Download the two files located here:

    http://dropcanvas.com/en28j

    All it is, is 2 registry files.

    The first one you do not need to change at all, but it will not work unless you run both of them.

    The second one does not need to be changed if your mapi32dll file is located @ "C:\\Windows\\System32\\mapi32.dll" . If is not located here then you need to make the adjustments.

    To make the adjusments just right click on the file and choose edit, after editing just hit save. Note that the back slashes are doubled.

    All that is left to do is double click on each file and accept the warning. This will install the keys in your system and things should work right away.


    • Proposed as answer by jag_cs Thursday, July 04, 2013 4:48 AM
    Thursday, July 04, 2013 4:47 AM