none
Word 2010 - "Connecting to printer" message when opening documents at Server 2008 R2 Terminal server

    Question

  • Our users experience sometimes the message "connecting to printer" while they open a document in Word 2010 (32-bit) on our Server 2008 R2 Terminal Server. This is behavior isn't consequent but random. The default printer in this environment is a Net2Printer-printerdriver (1.16) which redirects the print jobs (in PDF-format) to the local client's default printer. This feature works well. We don't want to change the default printer because this is the right one to use by our users.

    After a long seeking trip on the internet I've found the Microsoft hotfix KB974991 which can fix this issue for Word 2007. My question is, is this also usable for Word 2010 (32-bit) and if not, is there maybe another fix for the 2010 version available?

    Any other suggestions or workarounds are welcome!

    Friday, January 06, 2012 8:14 AM

Answers

  • We have found the solution for the problem! 

    Solution
    The printer driver Net2Printer RDP Client use for communication should be changed from 'Amyuni 2.x' to 'Net2Printer'. This will make the right default printer visible and prevent the "connecting to printer" message by opening, editing or closing Word 2010-documents.

    Thanks for the support!

    Thursday, January 19, 2012 2:52 PM

All replies

  • Hi,

    As my research,  Net2Printer uses a special virtual printer that sends the encapsulated print data in a printer-independent format to the receiving client.

    If it is correct and like your said local printer did not appear this issue, the problem might caused by Net2Printer drivers did not full compatibility with Word. If you agree, please contact Net2Printer support refer to Net2printer offical website.

    If you interested, I recommend to use "Send to OneNote 2010" as a workaround, Send a copy of content from almost any program to OneNote using the Send to OneNote virtual printer.

    "Microsoft OneNote 2010 Product Guide_Final"
    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=5829

    Best Regards.


    William Zhou CHN

    TechNet Community Support

    Tuesday, January 10, 2012 6:19 AM
  • Thanks for your research! In some cases when we use a local printer by testing the problem also occurs. Thereby we would like to serve our users they redirected printer as default.

    Word 2010 can't connect or communicate with the default printer at that moment and it gives the message "connecting to printer". As I said this isn't consequent, it can function well over a hundred times and then it goes wrong after a while.

    There is no option to prevent this check or communication from Word 2010 to the default printer?

     

     

    Monday, January 16, 2012 8:57 AM
  • Hi,

    Please change following options test if it works:

    Ÿ   Print proofs quickly

    Enable the Draft output option. When you use this option, the document prints with minimal formatting. Therefore, the document may print faster. This option is ideal for printing proofs.

    To enable the Draft output option, follow these steps. 

    Note Some printers may not support this option.

    1. Start Word.
    2. Click File, and then click Word Options.
    3. In the Word Options dialog box, click Advanced, and then scroll down to the Printing section.
    4. Click to select the Use draft quality check box, and then click OK.

    Ÿ   Use the background printing option that best fits your requirements

    When background printing is enabled, you can continue to work in Word while your document prints in the background. Background printing uses additional memory, and your document may print more slowly. 

    When background printing is disabled, your document prints faster. However you cannot work in Word until the print job is completed. If you do not have to continue to work in Word while your document prints, disable background printing to speed up printing. 

    To do this, follow these steps:

    1. Start Word.
    2. Click File, and then click Word Options.
    3. In the Word Options dialog box, click Advanced, and then scroll down to the Printing section.
    4. Click to clear the Print in background check box, and then click OK.

    Best regards


    William Zhou

    TechNet Community Support

    Tuesday, January 17, 2012 1:55 AM
  • We have found the solution for the problem! 

    Solution
    The printer driver Net2Printer RDP Client use for communication should be changed from 'Amyuni 2.x' to 'Net2Printer'. This will make the right default printer visible and prevent the "connecting to printer" message by opening, editing or closing Word 2010-documents.

    Thanks for the support!

    Thursday, January 19, 2012 2:52 PM
  • Hi,
    I’m glad to hear that you resolve this issue.
    Thank you for sharing your solutions and experience here. It will be very beneficial for other community members who have similar questions.
    Happy new year.

    William Zhou

    TechNet Community Support

    Friday, January 20, 2012 1:04 AM
  • I'm having a similar problem except instead of Word 2010, its Outlook 2010 saying "Connecting to Printer" and then my laptops are saying "Printer Offline". Everything is printing to my DC which is also my print server. It then is sending everything to my HP printers and Canon copiers. Any ideas?
    Monday, April 21, 2014 9:02 PM