none
How to import .NK2 file from O2K7 to O2K10

    Question

  • I setup a new PC with W7 (64-bit) and Office 2010 for a client. He is retiring an older computer with Office 2007.

    Apparently Outlook 2010 handles the autocomplete feature differently than the 2007 or earlier versions. I learned that from reading one of the KB articles (sorry, I didn't note the number). The user has a rather large .NK2 file that he wants to migrate over to the new PC with Outlook 2010. Can you advise me how to do that?

    Tuesday, June 22, 2010 9:28 PM

Answers

  • Hi,

    In outlook 2010, the .nk2 file is replaced by Suggested Contacts.

    To import .nk2 files into Outlook 2010, follow these steps:

    1. Make sure that the .nk2 file is in the following folder:
    %appdata%\Microsoft\Outlook

    Note The .nk2 file must have the same name as your current Outlook 2010 profile. By default, the profile name is "Outlook." To check the profile name, follow these steps:

    a. Click Start, and then click Control Panel.
    b. Double-click Mail.
    c. In the Mail Setup dialog box, click Show Profiles.

    2. Click Start, and then click Run.

    3. In the Open box, type outlook.exe /importnk2, and then click OK. This should import the .nk2 file into the Outlook 2010 profile.

    Note After you import the .nk2 file, the contents of the file are merged into the existing nickname cache that is currently stored in your mailbox.

    After the import is finished the .nk2 gets renamed with an . file name extension on the first start of Outlook 2010. Therefore, if you try to re-import the .nk2 file, remove the . file name extension.

    Wednesday, June 23, 2010 1:30 AM
    Moderator

All replies

  • Hi,

    In outlook 2010, the .nk2 file is replaced by Suggested Contacts.

    To import .nk2 files into Outlook 2010, follow these steps:

    1. Make sure that the .nk2 file is in the following folder:
    %appdata%\Microsoft\Outlook

    Note The .nk2 file must have the same name as your current Outlook 2010 profile. By default, the profile name is "Outlook." To check the profile name, follow these steps:

    a. Click Start, and then click Control Panel.
    b. Double-click Mail.
    c. In the Mail Setup dialog box, click Show Profiles.

    2. Click Start, and then click Run.

    3. In the Open box, type outlook.exe /importnk2, and then click OK. This should import the .nk2 file into the Outlook 2010 profile.

    Note After you import the .nk2 file, the contents of the file are merged into the existing nickname cache that is currently stored in your mailbox.

    After the import is finished the .nk2 gets renamed with an . file name extension on the first start of Outlook 2010. Therefore, if you try to re-import the .nk2 file, remove the . file name extension.

    Wednesday, June 23, 2010 1:30 AM
    Moderator
  • Dear Jennifer,

    It worked! Just to clarify, here are the steps that I followed:

    1. I verified the name of the Profile in the Control Panel. It was 'Outlook'

    2. I copied the OUTLOOK.NK2 file to the "users\<username>\AppData\Roaming\Microsoft\Outlook" folder.

    3. I then opened Outlook from the run command as: "OUTLOOK.EXE /importnk2". When I exited outlook, my NK2 file was renamed, OUTLOOK.NK2.OLD.

    Thanks for your help.

    • Proposed as answer by ian kerry Saturday, January 08, 2011 12:29 PM
    Wednesday, June 23, 2010 12:45 PM
  • Dear Jennifer,

    I have tried this repeatedly, but I can't seem to get it to work.  I have used different profile names, started from scratch, etc., but I still can't get the auto complete function to work in 2010.

     

    Can you please help?

     

    • Proposed as answer by Bebe-NC Wednesday, September 01, 2010 3:24 PM
    Wednesday, July 14, 2010 2:46 PM
  • I installed on an XP machine.  This thread is actually about installing on a Windows 7 OS.  I have found that this tool works sometimes, and other times - not!  I am truly at a loss to figure this one out. 

     

    Any sugestions??

    Wednesday, September 01, 2010 3:26 PM
  • Hi there,

    I'm not sure what I'm missing but I've pasted the nk2 file from my old XP machine into the  "users\<username>\AppData\Roaming\Microsoft\Outlook" location.  Then when  I try to run the command "OUTLOOK.EXE /importnk2" the command wont run.  Any suggestions?

    Thanks!

    Saturday, November 06, 2010 5:33 AM
  • Hi,

     

    Testing it in Windows 7 and Office 2010 shows that it does work from the RUN command as administrator but NOT from the search box in the start menu. I know this is months later but thought I would post anyway just in case it helps anyone stuck.

     

    Type in RUN into the search box or customize your start menu to show RUN as a selection then using it do the last step "outlook.exe /importnk2"

    Sunday, December 19, 2010 5:22 PM
  • Hi

    After much trial and error Jennifers solution worked for me - i am on win 07.

     

    Also it did work using the start/search box!

     

    cheers

     

    ian

    Saturday, January 08, 2011 12:32 PM
  • This didn't work for me. I copied the NK2 file from the old xp machine. It was named default or something other than the user name. I go to the new Windows 7 machine and copy that file to the folder. I renamed it Outlook.nk2 to see if that worked. Then when I type Outlook.exe/importnk2 I get an error like it can't find outlook. The exe is probably not named outlook.exe but I can't find the original.

    This is my bosses pc.

    Friday, February 18, 2011 5:20 PM
  • How to import NK2 file into Outlook 2010 on a Win7 Pro 32 BIT system.

    This is want I did to get it to work on the subject system

    1.       Copy NK2 file from old system to users\<username>\AppData\Roaming\Microsoft\Outlook

    2.       Renamed to new profile name

    3.       Go to Start/All Programs/Accessories and right mouse click on Command Prompt and select run as Administrator

    4.       Typed C:\program files\microsoft office\office14\outlook.exe /importnk2


    Owen Kittredge
    Saturday, March 12, 2011 8:11 PM
  • This doesnt work for me?? I have changed computor and got the new windows 7 and outlook 2010. Before I changed computor I saved the nk2 file on my email by sending it to my self. I have now followed the steps thats described here and no luck. Any advise? 
    Wednesday, March 16, 2011 10:06 AM
  • OK thanks for this setup, I have already Win 7 + Outlook 2010 too.

    We have in work all stuff on Outlook 2010 via exchange server.

    My problem is, when I imported nk2 file success, than close the Outlook and after new start the nicknames are out :( And than I must again import nk2 for session when is Outllook run. Where is problem please ? On the server site ? Outlook import nk2, but server doesnt recieve it ? or why ? Thanks for quicky reply ...

    Tuesday, March 22, 2011 8:50 AM
  • Thank you ever so much Owenmpk. Your instrcutions worked perfectly. All the suggestions on this page are not mentioning the last two steps which you suggested.

    Thanks,

    Simon

    Wednesday, May 25, 2011 4:31 PM
  • The thing to remember is to go to a RUN command not a search box.  Thanks for your help...
    Thursday, June 09, 2011 3:05 AM
  • Thanks!
    This worked, MAKE SURE that if you are running Windows 7 64bit version,  to change option 4 above to:
    "C:\Program Files (x86)\Microsoft Office\Office14\OUTLOOK.EXE /importnk2"
    Thursday, October 13, 2011 7:51 PM
  • Thanks, everyone.

    I used the above process on Windows 7 64bit, and although the import process seemed to work--the .old extension was added to the NK2 file--the auto-complete entries did not seem to be added. I exited and re-started Outlook 2010, but still no go. Some auto-complete entries were present (as had been the case before the import), but not some of my most often used ones.

    I appreciate any suggestions.

    Thanks

    Monday, November 14, 2011 11:30 PM
  • The Basic suggestions listed above and from MS have worked for me in the past, but I recently did a profile migration on the same workstation after I joined the system to a new SBS2011 domain using the same DOMAIN name as the old user profile. For some reason I was unable to /importnk2 the contact history cache.

    The issue was that in Windows 7, the user profile was NOT using the Roaming\Windows\OUTLOOK location of the NEW domain profile but in fact still using the OLD Roaming\Windows\OUTLOOK location for the existing user profile. Not sure what got messed up.

    Anyways, to remedy this I needed to locate what profile DATA file was being used, so I:

    a. Click Start, and then click Control Panel, then select  (User Accounts in WIN7)
    b. Double-click Mail.
    c. In the Mail Setup dialog box, click Show Profiles to confirm profile name (as been suggested)
    d. In the Mail Setup dialog box, click Data Files. Note the LOCATION of the profile under ROAMING\Windows\Outlook and THIS is where you will put the outlook.nk2 file

    After I put the outlook.nk2 file in the correct location, Presto, now it worked.

    Saturday, December 31, 2011 5:45 AM
  • >>1. Make sure that the .nk2 file is in the following folder:
    %appdata%\Microsoft\Outlook<<

    >>2. I copied the OUTLOOK.NK2 file to the "users\<username>\AppData\Roaming\Microsoft\Outlook" folder.<<

    For windows 7 step 2 was a solution to my case while step 1 is for windows XP and it didn't work in my case

    Thanks DHK2 for this tip that saved me couple of hours of troubleshooting and I was about to write a long thread and posted in a forum because I have exhausted all my resources and I couldn't find a solution till I found your your post in this forum.

     

     

    Sunday, January 22, 2012 12:39 AM
  • Wow, you don't know how you've saved me. It really worked.
    Wednesday, November 28, 2012 9:55 AM
  • Worked for me ... of course after a reboot

    Wednesday, December 04, 2013 7:04 PM