none
Excel 2010 SP2: file may have been changed by another user since you last saved it. In that case, what do you want to do?

    Question

  • Since installing the latest Service Pack for Office 2010 users, they are receiving the following message when saving an excel file that lives on a shared drive on our File server . . .

    "The file "Excel File Name" may have been changed by another user since you last saved it. In that case, what do you want to do?"

    The options are "Save a Copy or Overwrite Changes".  We only receive this message when saving the file a second time while it is still opened.  This wasn't occuring before implementing SP2.  I've read that this behavior was also present in other versions of office. 

    Is this something that was supposed to be implemented is SP2?  I did not see it mentioned in the Office 2010 SP2 release notes. 

     

    Friday, July 26, 2013 3:49 PM

Answers

  • Hi,

    Try the following steps:

    To resolve this issue in Excel, follow these steps:

    1.Click Start, click Run, type regedit, and then press ENTER.
    2.Locate and then click the following key:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\14.0\Excel\Options

    3.On the Edit menu, point to New, and then click DWORD Value.
    4.Type QFE_Saskatchewan for the name, and then press ENTER.
    5.Right-click the QFE_Saskatchewan entry, and then click Modify.
    6.In the Value box, type 2. When you type this value, Excel will always flush the file cache before the program obtains the time stamp. (This should resolve the problem most of the time.) Or, type 1 to have Excel disable the time stamp check and suppress the dialog in every case.

    Note We do not recommend disabling the time stamp check.
    7.Click OK to save the setting.


    Jaynet Zhang
    TechNet Community Support

    Saturday, July 27, 2013 7:07 AM

All replies

  • Hi,

    Try the following steps:

    To resolve this issue in Excel, follow these steps:

    1.Click Start, click Run, type regedit, and then press ENTER.
    2.Locate and then click the following key:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\14.0\Excel\Options

    3.On the Edit menu, point to New, and then click DWORD Value.
    4.Type QFE_Saskatchewan for the name, and then press ENTER.
    5.Right-click the QFE_Saskatchewan entry, and then click Modify.
    6.In the Value box, type 2. When you type this value, Excel will always flush the file cache before the program obtains the time stamp. (This should resolve the problem most of the time.) Or, type 1 to have Excel disable the time stamp check and suppress the dialog in every case.

    Note We do not recommend disabling the time stamp check.
    7.Click OK to save the setting.


    Jaynet Zhang
    TechNet Community Support

    Saturday, July 27, 2013 7:07 AM
  • Thanks.  This fix does work.  I've seen this fix in other forums.

    But what I want to know is if this behavior was supposed to be implemented with Office 2010 SP2 or if there is an underlying issue with the Service pack or our network environment.

    Any ideas?


    Pete Macias

    Tuesday, August 06, 2013 3:31 PM
  • Hello,
    The fix mentioned above did not work for me.  We ended up rolling back the patch with the following MS download here.
    http://www.microsoft.com/en-us/download/details.aspx?id=27131

    • Edited by DanielWertz Thursday, August 15, 2013 11:48 AM
    Thursday, August 15, 2013 11:47 AM
  • We noticed this issue after we applied the SP2 for Office 2010/Win7 Pro SP1 environment.  The registry fix did not work for me either.  Before we attempted to roll-back the update.  It was noted in another forum that this issue occurred on a spreadsheet that was created in the older .xls format and/or had macros. So in our case, we did a SAVE AS a .xlsx file on the affected spreadsheet and that seems to resolve the issues we are having.  
     
    • Proposed as answer by fwoconnor Monday, September 16, 2013 3:56 PM
    Tuesday, September 03, 2013 11:15 PM
  • This worked for me.

    Thank you Luis_P.

    Monday, September 16, 2013 3:57 PM
  • Problem still exists in my environment even if we convert the xls file to xlsx. 

    Does anyone know if Microsoft has acknowledge this as a bug and if they are working on a patch?


    Pete Macias

    Thursday, October 17, 2013 3:38 PM
  • I've been seeing this same issue, but with Excel 365 subscription and an Excel document on SkyDrive. Nobody else is using this document, yet I periodically will be told the file may have been changed by another user - even while in the middle of editing. I'll have the document open, make changes, save 2 or 3 times. The fourth time I save I'm told it may have been changed by another user. It makes no sense.
    Wednesday, December 18, 2013 1:30 PM